IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 6 December 2020   (all times are UTC)

00:44Tadaen_Sylverman has joined IRC (Tadaen_Sylverman!~TadaenSyl@69.9.29.70)
02:53vagrantc has left IRC (vagrantc!~vagrant@unaffiliated/vagrantc, Quit: leaving)
08:52ricotz has joined IRC (ricotz!~ricotz@ubuntu/member/ricotz)
10:08vsuojanen has left IRC (vsuojanen!~vsuojanen@ec2-3-21-130-219.us-east-2.compute.amazonaws.com, Quit: leaving)
10:14vsuojanen has joined IRC (vsuojanen!~vsuojanen@ec2-3-21-130-219.us-east-2.compute.amazonaws.com)
11:12Leo[m]4 has left IRC (Leo[m]4!leohwis@gateway/shell/matrix.org/x-essfhffsqvjnsegr, Ping timeout: 268 seconds)
11:12uumas has left IRC (uumas!uumaskapsi@gateway/shell/matrix.org/x-qkzvrorgxhmgfowy, Ping timeout: 268 seconds)
11:42Leo[m]4 has joined IRC (Leo[m]4!leohwis@gateway/shell/matrix.org/x-slpqrlsikpuzjtkv)
11:45uumas has joined IRC (uumas!uumaskapsi@gateway/shell/matrix.org/x-lnapvbhpcjqxqpsk)
13:12woernie has left IRC (woernie!~werner@pd9e8bc11.dip0.t-ipconnect.de, Ping timeout: 240 seconds)
13:13woernie has joined IRC (woernie!~werner@pd9e8bc11.dip0.t-ipconnect.de)
13:57adrianor1 has joined IRC (adrianor1!~adrianorg@201.22.230.145)
13:59adrianorg has left IRC (adrianorg!~adrianorg@186.215.20.62, Ping timeout: 246 seconds)
14:15adrianor1 is now known as adrianorg
14:16markit has joined IRC (markit!~marco@mail.ammdomus.it)
14:56adrianor1 has joined IRC (adrianor1!~adrianorg@177.156.228.234)
14:56adrianorg has left IRC (adrianorg!~adrianorg@201.22.230.145, Ping timeout: 260 seconds)
15:17adrianor1 is now known as adrianorg
15:30RaphGro has joined IRC (RaphGro!~raphgro@fedora/raphgro)
15:44adrianorg has left IRC (adrianorg!~adrianorg@177.156.228.234, Ping timeout: 240 seconds)
16:55eu^ftth-masked has joined IRC (eu^ftth-masked!05c79586@ftth-005-199-149-134.solcon.nl)
16:57
<eu^ftth-masked>
Hello, I have a question about LTSP19 on Ubuntu 20.04. Om 18.04 I had an empty 54.sh file with ldap authentication. I also had pam-mount to mount samba shares for each user (not the home dir). When I tried the same setup (starting with empty 54.sh) I found that auth-client-config was gone. I added LDAP to nsswitch.conf manually, and I can log in
16:57
with LDAP users just fine.
16:58
However, mounting smb shares from /etc/security/pam_mount.conf.xml doent work anymore
16:59
I used the exact same settings as I used om 18.04, and after I logged in with user "test1" the samba share wasnt mounted. But, when I did "su test1" (while already logged in from test1) the share did get mounted
17:00
Does anyone have any idea how to fix this?
17:18* alkisg will be around in 30'
17:20
<eu^ftth-masked>
Thank you
17:42
<alkisg>
eu^ftth-masked: ltsp runs `pam-auth-update` at boot, to install its pam script
17:42
It's the correct way to update pam files
17:42
If you do manual changes in pam, make sure they're NOT in the section that is managed by debian and pam-auth-update
17:43
Regarding the pam options of ltsp, see this comment: https://github.com/ltsp/ltsp/issues/338#issuecomment-735230997
17:43
It can go to primary/additional sections of pam, or not get installed at all
17:44
Now regarding samba and auth-client-config, I've no idea, never used them
17:45
Note that you should use an empty 54-pam, you can just set PAM_AUTH_TYPE="0" if you don't want pamltsp to get installed
17:45
*shouldn't
17:46
<eu^ftth-masked>
Ah, ok
17:46
<alkisg>
All these ^ are currently in the ltsp proposed ppa
17:46
Not in the stable ppa yet
17:46
<eu^ftth-masked>
empty 54.sh was the "best" way to do it back in 2019
17:46
<alkisg>
No, it was OMIT_FUNCTIONS
17:46
!ltsp.conf
17:46
<ltspbot>
ltsp.conf: Configuration file for LTSP: https://ltsp.org/man/ltsp.conf/
17:47
<alkisg>
Search for OMIT_FUNCTIONS there
17:51
<eu^ftth-masked>
I havent made any manual changes to the PAM files
17:51
And when I "su" to a user, the share gets mounted properly
17:51
but not when a user logs in via PXE
17:52
<alkisg>
cat /etc/pam.d/common-auth, in the booted client
17:52
Does that have pamltsp?
17:52
<eu^ftth-masked>
sec
17:58
No, it does not
17:59
<alkisg>
Then ltsp isn't involved in your pam settings. Do you want me to see with vnc?
17:59
!vnc-dide
17:59
<ltspbot>
vnc-dide: To share your screen with me, run this: sudo apt-get --yes install x11vnc; x11vnc -connect srv1-dide.ioa.sch.gr - this is a reverse connection, it doesn't need port forwarding etc.
18:00
<eu^ftth-masked>
Nope, LTSP is indeed not in the PAM files. But for some reason the PAM files get run _before_ a user logs in, and not afterwards (atleast so it seems)
18:01
As I can see s CIFS error before the login prompt (login failed, which is correct as the user hasnt logged in yet)
18:01
<alkisg>
The pam configuration is read and executed at the time that users authenticate or start a session
18:01
<eu^ftth-masked>
And running su also triggers it
18:02
but logging in doesn' t trigger it for some reason
18:02
<alkisg>
I think you just have misconfigured pam, unrelated to ltsp
18:03
<eu^ftth-masked>
Very strange, as I use the same settings as on 18.04, and it worked there
18:03
<alkisg>
Eh, software changes
18:05RaphGro has left IRC (RaphGro!~raphgro@fedora/raphgro, Quit: Please remember your own message. It'll be read as soon as possible.)
18:08
<eu^ftth-masked>
Ok, I just tested logging in with tty3 instead of the GUI on the LTSP client
18:08
and that also worked
18:08
<alkisg>
Other than installing itself in PAM, which you told it not to, LTSP doesn't do anything regarding logins
18:09
So if it works with tty but not with DM, then it's either a problem with home permissions, or just wrong pam settings
18:10
<eu^ftth-masked>
It tries to mount to /networkshares/sharename. The homefolder is mounted with NFS as FSTAB_HOME is ltsp.conf, and that works perfectly
18:11
So its not a home folder perm issue (Atleast not in TTY)
18:12
<alkisg>
OK, sorry I can't help as (1) it's not related to LTSP, and (2) I don't know about samba enough to help without (3) screen sharing; you could ask in #ubuntu though if noone else responds
18:13
<eu^ftth-masked>
I'll do a complete reinstall. Ill post back here in ~45 minutes if I found a solution
18:14
<alkisg>
OK
19:22
<eu^ftth-masked>
Hasn' t helped unfortunately
19:23
Using PAM_AUTH_TYPE="0" made no difference aswell
19:36
<alkisg>
But you already had remove ltsp from pam
19:36
ltsp isn't your issue here
21:00petitionynd has joined IRC (petitionynd!~Ozell@5.187.53.54)
21:00eu^ftth-masked has left IRC (eu^ftth-masked!05c79586@ftth-005-199-149-134.solcon.nl, Ping timeout: 245 seconds)
21:12petitionynd has left IRC (petitionynd!~Ozell@5.187.53.54, K-Lined)
21:43ricotz has left IRC (ricotz!~ricotz@ubuntu/member/ricotz, Quit: Leaving)
22:37Tadaen_Sylverman has left IRC (Tadaen_Sylverman!~TadaenSyl@69.9.29.70, Quit: Leaving)