IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 8 February 2017   (all times are UTC)

00:30vagrantc has left IRC (vagrantc!~vagrant@unaffiliated/vagrantc, Quit: leaving)
01:27Patrick__ has joined IRC (Patrick__!62723ff7@gateway/web/freenode/ip.98.114.63.247)
01:30lucascastro has joined IRC (lucascastro!~lucas@201.57.40.146)
01:31
<Patrick__>
Hello All! I've got an Edubuntu 12.04 server with LTSP which has been running for several years. We recently decided to add fat clients to the mix. Fat clients work fine with one exception. On dropdown menus, the whole menu is distorted (slanted) and is unusable. The rest of the screen is fine. I've seen it on drop down, tool tips, etc. This happens on fat clients and local apps. The machines are dell desktops with intel grap
01:31
We are up to date on patches and the intel drivers are current (for 12.04). Is there something else I can look into?
01:42lucascastro has left IRC (lucascastro!~lucas@201.57.40.146, Remote host closed the connection)
02:40lucascastro has joined IRC (lucascastro!~lucas@186.227.186.18)
02:42greenlight_ has joined IRC (greenlight_!~gre@de-2.serverip.co)
03:07Patrick__ has left IRC (Patrick__!62723ff7@gateway/web/freenode/ip.98.114.63.247, Ping timeout: 260 seconds)
03:59lucascastro has left IRC (lucascastro!~lucas@186.227.186.18, Remote host closed the connection)
05:13greenlight_ has left IRC (greenlight_!~gre@de-2.serverip.co, Ping timeout: 264 seconds)
05:19Freejack has left IRC (Freejack!~Freejack@unaffiliated/freejack, Ping timeout: 260 seconds)
05:37Freejack has joined IRC (Freejack!~Freejack@unaffiliated/freejack)
06:07Statler has joined IRC (Statler!~Georg@p579FEAB9.dip0.t-ipconnect.de)
06:57forum has joined IRC (forum!~Icedove@213-147-182-213.hdsl.highway.telekom.at)
07:11mikkel has joined IRC (mikkel!~mikkel@mail.dlvs.dk)
07:20forum has left IRC (forum!~Icedove@213-147-182-213.hdsl.highway.telekom.at, Remote host closed the connection)
07:40ricotz has joined IRC (ricotz!~ricotz@p5B2A9D9A.dip0.t-ipconnect.de)
07:40ricotz has joined IRC (ricotz!~ricotz@ubuntu/member/ricotz)
07:45adrianor1 has joined IRC (adrianor1!~adrianorg@177.18.175.107)
07:48adrianorg has left IRC (adrianorg!~adrianorg@177.18.177.128, Ping timeout: 264 seconds)
08:07sruli has left IRC (sruli!~sruli@82.152.117.29, Quit: Leaving.)
08:38forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
09:24Statler has left IRC (Statler!~Georg@p579FEAB9.dip0.t-ipconnect.de, Remote host closed the connection)
09:41lee_ has joined IRC (lee_!~lee@loathe.ms)
09:41lee_ is now known as Guest71032
09:43bitchecker_ has joined IRC (bitchecker_!~bitchecke@31.131.20.132)
09:44schlady_ has joined IRC (schlady_!~schlady@163.172.163.111)
09:44||cw2 has joined IRC (||cw2!~chrisw@unaffiliated/cw/x-1182934)
09:45schlady has left IRC (schlady!~schlady@163.172.163.111, *.net *.split)
09:45||cw has left IRC (||cw!~chrisw@unaffiliated/cw/x-1182934, *.net *.split)
09:45bitchecker has left IRC (bitchecker!~bitchecke@31.131.20.132, *.net *.split)
09:45lee has left IRC (lee!~lee@loathe.ms, *.net *.split)
09:49Statler has joined IRC (Statler!~Georg@mail.lohn24.de)
09:58markus_e92 has left IRC (markus_e92!~markus_e9@62-46-97-207.adsl.highway.telekom.at, Ping timeout: 240 seconds)
09:58gvy has joined IRC (gvy!~mike@altlinux/developer/mike)
10:00markus_e92 has joined IRC (markus_e92!~markus_e9@91-115-155-174.adsl.highway.telekom.at)
10:08forum1 has joined IRC (forum1!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
10:08forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
10:08forum1 is now known as forum
10:21adrianor1 is now known as adrianorg
10:22forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Quit: forum)
10:36forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
10:52
<vlt>
Hello :-) I installed Ubuntu 16.04, ubuntu-mate-desktop, ltsp-server and then ran ltsp-buil-client. My thin client boots via PXE, shows the X login screen but when I enter my user name and the correct password I get the login sccreen again after a few seconds of black. After a wrong password I get a "wrong password" message.
10:53
I tried to solve this without success by installing the package ldm-server.
10:53
Any idea what to try next?
10:56forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
10:57forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
11:05
<vlt>
Another problem: Since around v47 the Firefox browser becomes more and more unsuable. Scrolling down on a webpage results in 150 to 200 MB/s data transfer between the ltsp server and the client. This used to be ~500 kB/s.
11:06
After enabling the gfx.xrender setting (in FF) this drops to ~18 MB/s but this is still hardly acceptable.
11:07
What browser do you use in your setups?
11:08
Is there a Firefox fork that does this the old way (that used to just work for more than ten years!)?
11:17
vlt: You have to choose MATE session in the login screen settings ;-)
11:17
vlt: Thank you, this works!
11:26quinox has left IRC (quinox!~quinox@ghost.qtea.nl, Quit: :wq)
11:26quinox has joined IRC (quinox!~quinox@ghost.qtea.nl)
11:38forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
11:38quinox has left IRC (quinox!~quinox@ghost.qtea.nl, Quit: :wq)
11:39quinox has joined IRC (quinox!~quinox@ghost.qtea.nl)
11:39forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
12:13Faith has joined IRC (Faith!~paty_@unaffiliated/faith)
12:17
<ogra_>
vlt, do you have a desktop installed on your server ?
12:18
oh, yu got that part working already, sorry didnt see that on first sight
12:28lucascastro has joined IRC (lucascastro!~lucas@186.227.186.18)
12:36forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Ping timeout: 255 seconds)
12:38Patrick has joined IRC (Patrick!a7152a0c@gateway/web/freenode/ip.167.21.42.12)
12:38Patrick is now known as Guest21008
12:39forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
13:02
<vlt>
ogra_: Hi!
13:02
Yes, that part works.
13:03
The people in #firefox and #gfx both say that they won’t “fix” this performance problem for remote X setups.
13:04alkisg_web has joined IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238)
13:04
<vlt>
On my search for a solution I just discovered xrdp.
13:04
My first test seems to work great.
13:05
<alkisg_web>
You can find a few methods that use local caching and allow for faster scrolling
13:05
But you will never be able to fit uncompressed hd content in a gigabit network...
13:05
<ogra_>
or use FF completely as local app
13:05
<vlt>
How do I have to configure the LTSP login screen’s rdesktop backend to make that work?
13:06
<alkisg_web>
So in today's world with 1920x1080x32bpp displays, with 30 fps, which result in 2 gbps bandwidth, thin clients are not the way to go
13:06
End result is ==> buy fat clients :)
13:06
!cheap-client
13:06
<ltsp>
cheap-client: (#1) http://www.gearbest.com/tv-box-mini-pc/pp_343636.html, or (#2) https://www.aliexpress.com/store/product/New-arrival-Beelink-Pocket-Z83-Windows-10-Mini-PC-Z8300-64bit-1-84GHz-2GB-RAM-32GB/1871240_32640039781.html
13:06
<alkisg_web>
With less than 100 euros each...
13:06
For rdp, there's an xfreerdp screen script
13:06
SCREEN_07="xfreerdp params"
13:07
Start with SCREEN_07=xterm
13:07
Then, inside that xterm, find the xfreerdp command that works for you
13:07
Then put it in lts.conf instead of that xterm
13:07
<vlt>
alkisg_web: Thanks!
13:07
<alkisg_web>
np
13:08
<vlt>
Why "xfreerdp" instead of "rdesktop"?
13:08
<alkisg_web>
Both are supported
13:08
You can do SCREEN_07="rdesktop params"
13:08
xfreerdp was more maintained at the time that screen script was written
13:08
rdesktop wasn't
13:08
<vlt>
ok
13:08
<alkisg_web>
I'm not sure if any of them is currently actively maintained...
14:02forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
14:02forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
14:06
<vlt>
Hi! Any quick idea what ubuntu package I need to install into the chroot env if I don't get proper X resolution on some clients?
14:33alkisg_web has left IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238, Quit: Page closed)
14:55ben_roose has joined IRC (ben_roose!~roose@roose.cs.wichita.edu)
15:06pppingme has left IRC (pppingme!~pppingme@unaffiliated/pppingme, Ping timeout: 264 seconds)
15:09pppingme has joined IRC (pppingme!~pppingme@unaffiliated/pppingme)
15:17wolf has joined IRC (wolf!89940d65@gateway/web/freenode/ip.137.148.13.101)
15:17wolf is now known as Guest35657
15:19Guest35657 has left IRC (Guest35657!89940d65@gateway/web/freenode/ip.137.148.13.101, Client Quit)
15:19wolf_math has joined IRC (wolf_math!89940d65@gateway/web/freenode/ip.137.148.13.101)
15:20dtcrshr has joined IRC (dtcrshr!~datacrush@2801:88:f7a:100:240:a7ff:fe2d:d7c0)
15:20dtcrshr has joined IRC (dtcrshr!~datacrush@unaffiliated/datacrusher)
15:21
<vlt>
There seems to be at least an xserver-xorg-video-sis pkg installed in the working Ubuntu 12.04 chroot env. It is not available on 16.04.
15:34
What magic removes the non-*.pub files from chroot's /etc/ssh/ when builing the image (or mounting it in the client)?
15:34||cw2 is now known as ||cw
15:41
<vsuojanen>
vlt: there is with ltspserver a file /etc/ltsp/ltsp-update-image.excludes
15:46alkisg_web has joined IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238)
15:47
<alkisg_web>
!epoptes | echo vlt:
15:47
<ltsp>
vlt: epoptes: Epoptes is a computer lab administration and monitoring tool. It works on Ubuntu and Debian based labs with LTSP or non-LTSP servers, thin and fat clients, standalone workstations, NX clients etc. More info: http://www.epoptes.org
15:47
<alkisg_web>
vlt, use that instead of ssh
15:50
<vsuojanen>
vlt: i'm not so sure what you meant about the keys but also check /usr/sbin/ltsp-update-sshkeys. default only those keys known to server are exported. if this information is still valid for you
15:53
<vlt>
I need an ssh connection just now to fix my video hardware issues.
15:53
Or at least try to.
15:54
On our current 12.04 install every thin client's vga works just fine up to full hd.
15:54
On 16.04 something seems to be missing :-/
15:55
<vsuojanen>
is the ssh working now?
15:55
<vlt>
vsuojanen: I installed it manually on one running client. Works (for now.)
16:01
<vsuojanen>
isn't the ssh by default already installed for the clients
16:04wolf_math has left IRC (wolf_math!89940d65@gateway/web/freenode/ip.137.148.13.101, Ping timeout: 260 seconds)
16:14mikkel has left IRC (mikkel!~mikkel@mail.dlvs.dk, Quit: Leaving)
16:15
<alkisg_web>
vlt, epoptes allows you to have root access and also be able to copy/paste stuff and run xinit etc
16:16
vlt, what's the output of this, on 12.04 and on 16.04:
16:16
lspci -nn -k | grep -A 2 VGA
16:16
This will show your chipset and the driver in use
16:16
sis is very under-maintained, and was almost left out for 14.04 and 16.04,
16:17
but some user sent a patch and it barely got in, but only for a few selected sis chipsets
16:20
!precise
16:20
<ltsp>
I do not know about 'precise', but I do know about these similar topics: 'precise-i386'
16:20
<alkisg_web>
!precise-i386
16:20
<ltsp>
precise-i386: Ubuntu 12.04 compressed btrfs chroot to boot really old clients (non-pae, >=64MB RAM): http://ts.sch.gr/repo/livecd/images. You can find the image, a screenshot and a README there.
16:23
<vlt>
alkisg_web: Thanks for your great help!
16:25
"Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter" "Kernel modules: sisfb" (running 1920x1080 just fine on 12.04).
16:42forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Ping timeout: 260 seconds)
16:44forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
16:48||cw has left IRC (||cw!~chrisw@unaffiliated/cw/x-1182934, Quit: ZNC - http://znc.in)
16:54||cw has joined IRC (||cw!~chrisw@unaffiliated/cw/x-1182934)
16:56
<alkisg_web>
vlt: is that on 12.04? What is the output on 16.04? We are interested in the "Driver in use:" line, if it exists
16:57
The main bug report is there, I think : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-sis/+bug/1066464
16:58
They barely fixed a few of the segfaults for a few chipsets
17:03
<ogra_>
well, sis was gone after 2012
17:03
(the driver that is)
17:06forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
17:06forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
17:08
<alkisg_web>
http://packages.ubuntu.com/search?keywords=xserver-xorg-video-sis says that it's available for 14.04 but not for 16.04
17:11
And this is the answer from the ubuntu maintainer: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1625540
17:12
<ogra_>
yeah ... i meant SiS was gone from the market in 2012 ... they stopped producing garphics chips
17:12
there might still have been some updates to the driver after that but it is dead in the water now
17:18
<alkisg_web>
vlt, so, for those chipsets the latest chroot you can use that has the proper driver is 14.04.1. Or, you can build it yourself.
17:21gvy has left IRC (gvy!~mike@altlinux/developer/mike, Quit: Leaving)
17:30forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Remote host closed the connection)
17:30forum has joined IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at)
17:41
<vlt>
alkisg_web: There's no "driver in use" line. Neither on 12.04 nor on 16.04.
17:41
I think for now I'll just continue using the 12.04 machine to fire up the clients with a SCREEN_07 = "xfreerdp ..." line.
17:42
Then I'll try a 14.04 setup because two more years of support (for the cleints).
17:42
*ie
17:44
Maybe then we should begin to phase out the >70 existing HP ThinClients :-D
18:02
<alkisg_web>
vlt, then maybe you're missing the sis package in the chroot in 12.04
18:02
I don't think it comes preinstalled
18:02
<vlt>
alkisg_web: In 12.04 there _is_ the sis package and everything wors prefectly fine.
18:02
<alkisg_web>
Yes, replacing them with ultra slim fat clients would be a good idea...
18:02
vlt: a sis package without a sis line?
18:02
<vlt>
?
18:03
<alkisg_web>
You said there was no "driver in use" line in 12.04 too
18:03
<vlt>
alkisg_web: That's correct.
18:03
<alkisg_web>
Then you weren't really using the driver
18:03
<vlt>
alkisg_web: Maybe.
18:03
I'm trying to find out how this actually works.
18:04
And what causes our current 12.04 install to (just) work.
18:04
<alkisg_web>
Put /var/log/Xorg.7.log from a 12.04 booted client to pastebin...
18:04
Btw, you can use the 12.04 chroot with a 16.04 server
18:05
Or a 14.04 chroot with a 16.04 server etc
18:05
<vlt>
http://termbin.com/8jwv
18:06
alkisg_web: I know. But because of the poor firefox performance since a few months ago (ff v47 I guess) I need to find something else anyways.
18:07
xrdp on 16.04 seems to work great.
18:07
<alkisg_web>
It loads sis alright... maybe you need | grep -A 3 VGA, if there are more lines in the output, to see the "driver in use"
18:08
Anyway, time to go; have fun with those clients ;)
18:08
bb!
18:08alkisg_web has left IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238, Quit: Page closed)
18:11
<vlt>
There's absolutely no such line (driver in use) in the VGA section.
18:12
ogra_: Can you spot _why_ full hd resolution works on our 12.04 system? Xorg.7.log:
18:12
http://termbin.com/8jwv
18:31
<ogra_>
because it is the highest supported resolution of the attached CRT ?
18:31
no idea
18:32
85.156] (II) SIS(0): Using EDID range info for horizontal sync
18:32
[ 85.156] (II) SIS(0): Using EDID range info for vertical refresh
18:32
[ 85.156] (II) SIS(0): Printing DDC gathered Modelines:
18:32
[ 85.156] (II) SIS(0): Modeline "1920x1080"x0.0 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync (67.5 kHz)
18:33
that is the modeline the monitors EDID provides as the highest resolution ... and since the SiS driver can handle this it will be used
18:35PeperPots__ has left IRC (PeperPots__!sid1218@gateway/web/irccloud.com/x-mnoiltpytkyydtvq, Remote host closed the connection)
18:37cyberorg has left IRC (cyberorg!~cyberorg@opensuse/member/Cyberorg, Ping timeout: 258 seconds)
18:40
<vlt>
ogra_: Yeah but … why doesn’t this work when running 16.04 on that client machine?
18:40
Because the -sis pkg is not (available and) installed?
18:41
According to `lspci -nn -k` the -sis driver isn’t even used on 12.04 o_O
18:41
But I have no idea.
18:42
<ogra_>
right, it most likely uses some generic framebuffer driver
18:44cyberorg has joined IRC (cyberorg!~cyberorg@opensuse/member/Cyberorg)
18:49vagrantc has joined IRC (vagrantc!~vagrant@unaffiliated/vagrantc)
18:59lucascastro has left IRC (lucascastro!~lucas@186.227.186.18, Ping timeout: 264 seconds)
19:22alkisg_web has joined IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238)
19:22PeperPots__ has joined IRC (PeperPots__!sid1218@gateway/web/irccloud.com/x-kuaxcqpvmbpcmkmu)
19:22
<alkisg_web>
vlt: I remembered that sisfb isn't loaded by default in ubuntu 12.04, because it wasn't faster than the generic framebuffer, right
19:25Grembler has joined IRC (Grembler!~Ben@cpc87179-aztw31-2-0-cust6.18-1.cable.virginm.net)
19:36Faith has left IRC (Faith!~paty_@unaffiliated/faith, Quit: Leaving)
20:12ricotz has left IRC (ricotz!~ricotz@ubuntu/member/ricotz, Quit: Leaving)
20:21Statler has left IRC (Statler!~Georg@mail.lohn24.de, Remote host closed the connection)
20:23vagrantc has left IRC (vagrantc!~vagrant@unaffiliated/vagrantc, Quit: leaving)
20:36vagrantc has joined IRC (vagrantc!~vagrant@unaffiliated/vagrantc)
20:45forum has left IRC (forum!~Icedove@85-90-158-89.hdsl.highway.telekom.at, Quit: forum)
20:55alkisg_web has left IRC (alkisg_web!d4fb11ee@gateway/web/freenode/ip.212.251.17.238, Quit: Page closed)
21:12dtcrshr has left IRC (dtcrshr!~datacrush@unaffiliated/datacrusher, Remote host closed the connection)
21:40Grembler has left IRC (Grembler!~Ben@cpc87179-aztw31-2-0-cust6.18-1.cable.virginm.net, Ping timeout: 260 seconds)
22:26markit has joined IRC (markit!~marco@88-149-177-66.v4.ngi.it)
22:27
<markit>
hi, trying https://help.ubuntu.com/community/UbuntuLTSP/ltsp-pnp, stopped BEFORE "dns issues" since I rebooted but I've no more network manager running, probably something conflicts and stops it to work. Better use a static interface setup?
22:29
I've a single interface configuration and dnsmasq as proxy only (I've put a # on dhcp-range=192.168.67...)
22:30
better have a look tomorrow, too tired now... see you :)
22:30markit has left IRC (markit!~marco@88-149-177-66.v4.ngi.it, Client Quit)