IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 6 April 2010   (all times are UTC)

00:05nubae_ has quit IRC
00:06nubae has joined #ltsp
00:15
<johnny>
randomuser, delete it..
00:16
but do you really have x86_64 clients?
00:16
most people don't, that is why it defaults to i386
00:20try2free has quit IRC
00:23
<randomuser>
hey, hello
00:23
i do.
00:30alkisg has joined #ltsp
00:32Lns has quit IRC
00:34
<randomuser>
i see some mounts from /var/tmp/imgcreate-(foo) ; are these for ltsp?
00:34
<johnny>
probably.. i never loooked that closely..
00:34
and i don't know how fedora handles it on that side
00:34
whether it even uses nbd or not
00:35
<randomuser>
the k12linux wiki says to make sure the chroot isn't mounted before I erase it, but it doesnt describe how it mounts.
00:38
i can tell you that ltsp-vmclient fails on loadinf from tftp...
00:45Lns has joined #ltsp
00:47Selveste1 has quit IRC
01:13klausade has quit IRC
01:25Selveste1 has joined #ltsp
01:25ogra has quit IRC
01:35Selveste1_ has joined #ltsp
01:35Selveste1 has quit IRC
01:39Selveste1_ has quit IRC
01:42Selveste1_ has joined #ltsp
01:49Selveste1_ has quit IRC
01:51Selveste1_ has joined #ltsp
01:55Selveste1_ has quit IRC
01:57Selveste1_ has joined #ltsp
02:01leio has quit IRC
02:07Selveste1_ has quit IRC
02:09Selveste1_ has joined #ltsp
02:47highvoltage has quit IRC
02:49highvoltage has joined #ltsp
02:58Selveste1_ has quit IRC
03:04bobby_C has joined #ltsp
03:05Selveste1_ has joined #ltsp
03:12Selveste1__ has joined #ltsp
03:13Selveste1_ has quit IRC
03:53Selveste1__ has quit IRC
04:00Selveste1__ has joined #ltsp
04:01ogra__ has quit IRC
04:03ogra__ has joined #ltsp
04:13Selveste1___ has joined #ltsp
04:13Selveste1__ has quit IRC
04:27alkisg has quit IRC
04:38Selveste1___ has quit IRC
04:47bobby_C has quit IRC
04:57Lns has quit IRC
05:11alkisg has joined #ltsp
05:25nbtstatz has joined #ltsp
05:27
<nbtstatz>
Hello all, i need add a NIC module LTSP Client KERNEL, the module is r6040, What are the steps? any can help-me? I really must very necessary
05:30zamba has quit IRC
05:30zamba has joined #ltsp
05:51
<alkisg>
nbtstatz: do you mean something like this? https://help.ubuntu.com/community/UbuntuLTSP/AddingModules
05:57
<nbtstatz>
alkisg thanks for help, but my kernel dont have r6040 module to load! :(
05:57
<alkisg>
So it doesn't work in your OS in general? It isn't an LTSP problem?
05:57
Then I'd suggest asking in your distro channel, not in LTSP...
05:58
<nbtstatz>
alkisg thanks again, im asking in ubuntu channel too
05:58pmatulis has joined #ltsp
06:08hersonls has joined #ltsp
06:22
<nbtstatz>
alkisg now works, I THINK, i remove quiet and splash in pxelinux.0, but now Thinclient is stoping in
06:22
Load Essential drivers ........... OK
06:23alkisg has quit IRC
06:23
<nbtstatz>
Running /scripts/init-premount ..... OK
06:23
Mounting root file system
06:23
runnin /scripts/nfs-top OK
06:23
only Thin Client stop in boot, my vmware pxe-client works perfectly
06:43nubae has quit IRC
06:47scottmaccal has joined #ltsp
07:02nubae has joined #ltsp
07:25Dantix has joined #ltsp
07:26otavio has joined #ltsp
07:39mgariepy has joined #ltsp
07:48
<mgariepy>
good morning everyone !
07:50
<Dantix>
morning! I running ltsp4.2 and the clients runs rdesktop to show a windows application. Now I nned to redirect the rs232 port of client to be used by rdp session, what should be the advised configuraction.
07:53
<_UsUrPeR_>
morning all.
07:53
could somebody give me the nomenclature for LOCAL_APPS_EXTRAMOUNTS? I have the following line in lts.conf: LOCAL_APPS_EXTRAMOUNTS = /home/common
07:53
it doesn't seem to be mountint it though
07:53
err mounting
08:06bobby_C has joined #ltsp
08:09
<Dantix>
I'll refrase my question. Is it possible to use on a lptsp client the client's local serial port?
08:18
<cliebow>
Dantix, in 4.2 we could enable a serial mouse..
08:18
not sure about 5
08:22
<Dantix>
cliebow: in my case I need to use the serial port to connect a scale/balance
08:23
that uses rs232 to inform the weigths it measures.
08:34
<cliebow>
you'll have to get one of the gurus here to help..I am sure it is doable.
08:37
<Dantix>
anyway thanks
08:40Barbosa has quit IRC
08:49jammcq has joined #ltsp
08:58highvoltage has quit IRC
09:00
<cyberorg>
Dantix, use ltsp-localapps
09:00* cyberorg thinks cliebow is guru already :)
09:04sbalneav has joined #ltsp
09:04
<jammcq>
Scotty !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
09:06
<sbalneav>
Morning all!
09:06
jammcq!!!!!!!!!!!!!!!!!!!!!!!!
09:14highvoltage has joined #ltsp
09:26F-GT has quit IRC
09:26litlebuda has joined #ltsp
09:39F-GT has joined #ltsp
09:40
<johnny>
sbalneav, poke
09:41alkisg has joined #ltsp
09:41alkisg has joined #ltsp
09:41
<johnny>
sbalneav, i thought it would be interesting to see a mostly distro agnostic way to get packages installed in chroots, so i bugged the packagekit creator to take a look at it, he's got a branch going already
09:42
hopefully in the next round of distro releases we can create a .desktop file or shell script that just launches packagekit's gui , but in the chroot
09:51
<sbalneav>
Cool.
09:52
Another piece of good news: sayabon's back in debian unstable.
09:58rjune has joined #ltsp
10:00
<Dantix>
cyberorg: thanks, I'll check that
10:10
cyberorg: I've read about localapps, seems to me the way to run application on client. Did not found a clue of how to use it to get what I'm need.
10:11
<cyberorg>
install the software that requres serial port as localapp and run using ltsp-localapps yoursoftware
10:12
<Dantix>
my software is rdesktop, do you think this approach will work as well?
10:13
<vbundi>
yes
10:13
if rdesktop supports serial port forwarding, (which I believe it does) you'll get your local serial port on the windows machine
10:14
from 'man rdesktop' .... -r comport:<comport>=<device>,...
10:14
<Dantix>
fine!! I'm going to try right now..thanks
10:14
<vbundi>
Dantix: so you can do something like ltsp-localapps rdesktop -r comport:com1=/dev/ttys0
10:15highvoltage has quit IRC
10:16
<Dantix>
vbundi: thank you very much..
10:17
<vbundi>
Dantix: hah, don't thank me.. I was scratching my head until cyberorg suggested ltsp-localapps.... I'm going to get a coffee :P
10:18highvoltage has joined #ltsp
10:19leio has joined #ltsp
10:21runout has joined #ltsp
10:26rjune has quit IRC
10:27
<Dantix>
vbundi: :-D
10:28rjune has joined #ltsp
10:47Faithful has quit IRC
11:01Faithful has joined #ltsp
11:04staffencasa has joined #ltsp
11:13ludug3r0 has joined #ltsp
11:16
<ludug3r0>
alkisg: Can you tell me if you performed a safe-upgrade or a full-upgrade in your lucid? Previously I had problems running at ltsp at karmic with only safe-upgrade... I had to do a full-upgrade...
11:16
Maybe I shoul adjust the tutorials with my progress here...
11:16
<alkisg>
ludug3r0: I never upgrade, I always clean-install
11:16
<ludug3r0>
Ok... Thank you.
11:17
Should I upgrade just the ltsp package from the ppa? I'm gettng from stgraber as the tutorial I previously visited used his ppa...
11:18Dantix has left #ltsp
11:19
<alkisg>
After upgrading from karmic to lucid (or any other distro upgrade), building a new chroot is recommented
11:20
<ludug3r0>
I installed the lucid beta from scratch today.
11:20
<alkisg>
Erm, then what do you mean with safe-upgrade / full-upgrade?
11:21
<ludug3r0>
there are packages to update...
11:21
Some probably are services.. I had problems with update with karmic...
11:22
A fresh karmic install with the ltsp from stgraber did not work...
11:22
With aptitude safe-upgrade it didn't work also...
11:22
But with full-upgrade it was ok...
11:27
Well... I'm skipping everything related to updates for now...
11:27randomuser has quit IRC
11:30
<alkisg>
Ah, I've been dist-upgrading for many months now, it mostly worked fine except for 1-2 cases where the lucid repositories had problems
11:30
(sudo apt-get dist-upgrade)
11:30
<ludug3r0>
Ok.. dist-upgrade is equivalent to full-upgrade with aptitude
11:30
I will upgrade now.
11:52ogra has joined #ltsp
11:59ogra has quit IRC
11:59ogra has joined #ltsp
13:47jhutchins has quit IRC
13:49jhutchins has joined #ltsp
13:54nubae_ has joined #ltsp
13:56nubae has quit IRC
14:10runout has left #ltsp
14:28vagrantc has joined #ltsp
14:32ralth has joined #ltsp
14:33
<ralth>
Hello. Any suggestions on troubleshooting an "Error: failed to connect to NBD server" error on ubuntu lucid?
14:35
<alkisg>
ralth: is the nbd server actually running? sudo netstat -nap | grep 9572
14:37
<ralth>
alkisg: yes, it appears to be: "tcp 0 0 0.0.0.0:9572 0.0.0.0:* LISTEN 1129/inetd "
14:37
<vmlintu>
ralth: my favourite tool is wireshark / tshark and just dumping the network traffic
14:37
<alkisg>
Do you have another dhcp server running on your network? Can you upload your dhcpd.conf?
14:38
<vmlintu>
ralth: with it you see if there's actual traffic that gets blocked or if there are no packets at all
14:39
<ralth>
Here's dhcpd.conf: http://pastebin.com/TfnFz9Yg
14:39
no other dhcp server
14:42
<alkisg>
Uh sorry the port was 2000 not 9572
14:42
Can you mount the nbd image manually? nbd-client server-ip 2000 /dev/nbd0
14:42
(at the busybox prompt)
14:43
<ralth>
listening on 2000 as well
14:43
<alkisg>
(if you're not getting a busybox prompt, you can put break=premount in pxelinux.cfg/default)
14:43
<vmlintu>
ralth: do you see the client's dhcp request in daemon.log?
14:47
<ralth>
trying to mount manually gives an error as well: "Negotiation: Error: server closed connection"
14:49
From daemon.log: "nbd_server[1756]: Could not open exported file /opt/ltsp/images/amd64.img: No such file or directory"
14:50
<alkisg>
Did you run ltsp-build-client?
14:50
<ralth>
Why would it be trying to load the amd64 image?
14:50
I did, but for i386
14:50
<alkisg>
Edit your /etc/inetd.conf
14:50
and run sudo service openbsd-inetd restart
14:53scottmaccal has quit IRC
14:54
<ralth>
That fixed it!
14:54
Thanks a lot. Great support, as usual.
14:54
<alkisg>
np
14:56
<vagrantc>
yay. debian/squeeze will likely have ramzswap (a.k.a. compcache)
14:57ralth has left #ltsp
15:03
<dba>
vagrantc: not really; the tools are blocked in NEW.
15:07highvoltage has quit IRC
15:09
<vagrantc>
dba: i got the impression you didn't need the tools for basic useage...
15:14highvoltage has joined #ltsp
15:15cliebow has quit IRC
15:15
<dba>
vagrantc: true, but they are desirable anyway for most things.
15:16highvoltage has left #ltsp
15:17
<vagrantc>
dba: it is on my list of things in the new queue that do make me grumble a little *sigh*
15:18nbtstatz has quit IRC
15:40ogra__ has quit IRC
15:53ogra__ has joined #ltsp
15:55
<ludug3r0>
alkisg: Should I add the ppa even using lucid?
15:55
I'm having really strange behavior here... :\
15:55
<alkisg>
No need for it (yet)
15:55
What behavior?
15:56
<ludug3r0>
I removed quiet splash in the kernel...
15:56
To see what was happening here...
15:56
There are times the shell opens and others it does not...
15:56
<alkisg>
Any error messages?
15:57
<ludug3r0>
There are times I get "Staring LTSP [OK]"
15:57
No...
15:57
There are times I get "Starting LTSP" with no [OK].. It just hangs...
15:57
<alkisg>
Try also replacing "splash" with "nomodeset", it helps sometimes (plymouth still sucks :-/)
15:58
<ludug3r0>
I removed splash entirely...
15:58
<alkisg>
Yes, I meant where to put it
15:58
<ludug3r0>
Ahh.. do you want-me to put it now?
15:58
<alkisg>
The nomodeset, not the splash
15:58
<ludug3r0>
Ahhh... And there is times the "Starting LTSP" do not apear too...
15:58
<alkisg>
OK let me rephrase that, "insert the following kernel parameter: nomodeset"
15:59
<ludug3r0>
Ok.
15:59
Humm...
15:59
I setted now...
16:00
While i was setting... There are a lot of application timeouts...
16:00
restarting
16:00
<alkisg>
Application timeouts?! Where?
16:00
<ludug3r0>
Setting up the LSTP [OK]...
16:00
Waiting some more.
16:00
Just a minut..
16:00
I think the timeouts will come soon...
16:00
I had a lot in these last days...
16:01
Let me desccribe what I see in the screen now...
16:01
it configures the network.... I can ping the machine from here...
16:02
Ok.. I can't ping tis time...
16:02
There was a kernel error...
16:02
(rtl8180): cannot register devce
16:02
I wasn't having this problem before...
16:02
Let me try restart again.
16:03
Ok.. Waiting for the same problem to appear...
16:04
Well... Until now is ok... Let me keep explaining the boot...
16:05
Humm.... I can't ping the machine anymore... :\
16:05
Maybe some module problem....
16:06
Ok... I can ping it now....
16:06
It mount the root file system....
16:06
The goes to the /scripts/nfs-top
16:07
It says ndb0: unknown partition table
16:07
I think this is the problem...
16:07
Now there are a lot of timeouts...
16:09
root@ltsp:~# netstat -nap | grep 2000 tcp 0 0 0.0.0.0:2000 0.0.0.0:* LISTEN 908/inetd
16:09
<alkisg>
"unknown partition table" is not a problem, ignore that
16:09
<ludug3r0>
ok...
16:10
after this the only errors are these timeouts...
16:10
<alkisg>
What does it say exactly?
16:10
<ludug3r0>
There is a /script/nfs-bottom
16:10mgariepy has quit IRC
16:10
<ludug3r0>
No errors....
16:11
The Starting LTSP [OK]
16:11
<alkisg>
So you don't actually see the word "timeout", right?
16:11
<ludug3r0>
It hangs here...
16:11
And after 2 minutes I have something like...
16:12
[ 240.XXXXX] INFO: task rsyslogd:759 blocked for more than 120 seconds
16:12
<johnny>
does this sound like a bad network card? or bad cable?
16:12
or bad driver..
16:12
<ludug3r0>
[ 240.YYYYY] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables the message
16:13
Humm...
16:13hersonls has quit IRC
16:13
<johnny>
sounds like that to me
16:13
<alkisg>
Yeah a vbox client would probably help in testing this
16:13
<ludug3r0>
I wasn't having problem with this machine with ltsp from stgraber's ppa with karmic....
16:14
It was working perfect yesterday... The only problem was that I could log in juust six machines at a time... :\
16:14
<johnny>
the problem is proably the driver in the new kernel then
16:14
did you build a new chroot since?
16:14
<ludug3r0>
Humm..
16:14
I installed the lucid today...
16:14
<johnny>
you could try using the other chroot
16:14
<ludug3r0>
Than dist-upgraded it...
16:14
<johnny>
if you kept it
16:14
start over with a new chroot
16:14
<ludug3r0>
Then I used ltsp-build-client...
16:15
<johnny>
ah
16:15
well try the old one then :)
16:15
<ludug3r0>
It was a updated system..
16:15
But I can try to chroot and dowgrade the kernel there...
16:15
Or try if another machine boots here...
16:15
The problem is the irregular behavior..
16:15
let me try another machine...
16:17
Ok...
16:17
The other has setting up the ltsp client [ok]
16:17
than starting ltsp client [ok]
16:18
ctrl + f1 gives me a login shell...
16:18
ctrl + f2 should give me a shell.. I put SCREEN_02 = shell at the lts.conf
16:19
<alkisg>
Did you also put SCREEN_07=ldm?
16:19
<ludug3r0>
Yeah...
16:19
I tryed first without it..
16:19
Then putted it...
16:19
<alkisg>
So, are you able to login?
16:19
(in ldm)
16:19
<ludug3r0>
No...
16:20
I put any name (root, a valid user) then it hangs and theres no password line...
16:20
<alkisg>
Error messages? in auth.log on the server, or in ldm.log on the client?
16:20
Hmmm no password line?!
16:20
<ludug3r0>
I cant access ldm.log in the client...
16:21
The shell was suposed to open at SCREEN_02 but theres nothing there.
16:21
Let me see auth.log
16:21bobby_C has quit IRC
16:21
<alkisg>
Well if you didn't give a password there would be nothing there
16:22
<ludug3r0>
There was no request for a password. ;)
16:22
I couldn't give one.. :\
16:22
It seens to be a kernel problem...
16:23
Can you tell me the kernel you are running in your ltsp?
16:23
<alkisg>
linux-image-2.6.32-19-generic-pae
16:23
<ludug3r0>
Let me remove the ldm...
16:23
And remove the fatclient line...
16:24
<alkisg>
Remove ldm? How are you going to logon then?
16:24Lns has joined #ltsp
16:24
<ludug3r0>
I just want the shell to open now...
16:24
<alkisg>
Ah, from lts.conf, ok
16:24
<ludug3r0>
Yeah...
16:25
If I can get the shell up, I can try to use thinclients...
16:26
Ok... Machine #1 : same behavior... hungs when setting ltsp... even when it stats that it was ok...
16:26
Machine #2 I got a shell....
16:26
<alkisg>
Are you sure that the image was built OK?
16:26
Maybe you have a broken chroot... e.g. maybe the lucid repositories were inconsistent when you installed, and you're missing some packags
16:27
<ludug3r0>
Hummm...
16:27
Maybe...
16:27
I will try to chroot and see this now...
16:27
<alkisg>
Do keep the logs of ltsp-build-client (enable unlimited scrollback in the terminal and copy/paste them in a log file...)
16:29
<ludug3r0>
Hummm.
16:29
I was looking the entire process... There was noting that unusual there...
16:29
But I don't have this log to confirm...
16:29
Let me see...
16:31
Ok.. I don't have the log...
16:31
Just the sumarixed on at /var/log.. But it do not seens worthy
16:32
Ok....
16:32
I updated it...
16:32
Or at leat tryed...
16:32
There was not much to do there... Only remove two packages.
16:33
I'm doing a aptitude reinstall ltsp-client ltsp-client-core ltspfsd ltspfsd-core
16:34MaRX-Mode has quit IRC
16:34MaRX-Mode has joined #ltsp
16:35vmlintu has quit IRC
16:38vmlintu has joined #ltsp
16:52
<ludug3r0>
Yet the same... :(
16:52
Seens like a karma thing... :P
16:52
seems*
16:53
Whit thin client it hangs at the machine #2.... :\ I even don't get the shell anymore...
16:54
<alkisg>
Try with a vbox client to rule out any hardware/network related problems...
17:02
<ludug3r0>
alkisg: Do you know if there is problem runnig the ltsp-server inside a vmware server?
17:02
Before I was using if on a normal machine...
17:02
Ths is the main modification from yesterday to today.
17:12mgariepy has joined #ltsp
17:16
<alkisg>
ludug3r0: no idea
17:16
I'm using a vbox server sometimes with no problems, but I don't use vmware
17:17alkisg has quit IRC
17:17
<ludug3r0>
Ok.. I'm doing a dist-upgrade with apt-get now...
17:18
Strangely there was some packeges not detected by aptitude
17:18
samba related..
17:18
And a libwbclient... I find this one to be familiar..
17:18
Maybe this upgrade solve the problem.
17:19jammcq has quit IRC
17:53vagrantc has quit IRC
18:44Lns has quit IRC
18:53staffencasa has quit IRC
19:04mgariepy has quit IRC
19:06ludug3r0 has quit IRC
19:33pmatulis has quit IRC
20:01johnny has left #ltsp
20:02johnny has joined #ltsp
20:04tstafford has quit IRC
20:35try2free has joined #ltsp
20:41Lns has joined #ltsp
20:41try2free has left #ltsp
20:42litlebuda has quit IRC
20:58F-GT has quit IRC
21:14F-GT has joined #ltsp
21:19TheGuy has joined #ltsp
21:26vagrantc has joined #ltsp
22:11Guest3467 has joined #ltsp
22:12Guest3467 is now known as gpilotti
22:14Lns has quit IRC
22:26
<rjune>
http://testing.oriontechnologysolutions.com/
22:44johnny has quit IRC
23:25ogra__ has quit IRC
23:26ogra__ has joined #ltsp
23:37vagrantc has quit IRC