IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 9 January 2011   (all times are UTC)

00:43jd42 has quit IRC
00:55alkisg has quit IRC
01:08alkisg has joined #ltsp
01:27alkisg has quit IRC
01:32dr_data has quit IRC
01:39no_mind has joined #ltsp
01:39
<no_mind>
I am running ubuntu lucid as ltsp server. How do I install local apps ?
02:05
<muppis>
no_mind, you need install them to chroot and them define in lts.conf. Take a closer at here https://help.ubuntu.com/community/UbuntuLTSPKarmicLocalAppsFirefox
02:07
Applies almost all other apps also, as I've heard Google Chrome needs more adjustement than just installing.
02:22dlezcano has joined #ltsp
02:23dlezcano has quit IRC
02:26no_mind has quit IRC
03:09yanu has joined #ltsp
03:09yanu has joined #ltsp
03:11bobby_C has joined #ltsp
04:32komunista has joined #ltsp
05:09yanu has quit IRC
05:09RiXtEr has quit IRC
05:10Selveste1 has quit IRC
05:11Selveste1 has joined #ltsp
05:11yanu has joined #ltsp
05:11RiXtEr has joined #ltsp
05:21yanu_ has joined #ltsp
05:24bobby_C has quit IRC
06:29cyberorg has quit IRC
07:04artista_frustrad has quit IRC
07:18artista_frustrad has joined #ltsp
07:22artista_frustrad has quit IRC
07:25
<muppis>
How hard is get ldm work as locally installed? I'm still looking optimal solution to this oldie. Wiring is possible, but need to get some cable. For eth->wlan I got equipments, but booting is slow as he.. So if I could install that chroot locally and use wlan directly from client.
09:21ogra has joined #ltsp
09:21ogra has joined #ltsp
09:23jd42 has joined #ltsp
09:33klausade has quit IRC
09:59bobby_C has joined #ltsp
10:20artista_frustrad has joined #ltsp
10:42bobby_C has quit IRC
10:48alkisg has joined #ltsp
10:48alkisg has joined #ltsp
10:50shamino has quit IRC
10:54
<alkisg>
muppis: To speed up boot you can re-enable compression on the nbd image, it will help a lot.
10:54
It's also possible to put the whole image locally (I've even seen some ltsp .iso's in some university), but it requires some tweaking.
11:28shamino has joined #ltsp
11:56vagrantc has joined #ltsp
12:02vmlintu has joined #ltsp
12:55otavio_ has joined #ltsp
12:57otavio has quit IRC
13:17vagrantc has quit IRC
13:25
<muppis>
alkisg, I'm almost ready to do that tweaking Tried Xubuntu today on that machine and X just hangs. System itself responds, I can login tty1 and restart X.
13:30
Could that be so easy as just transfer chroot to loacl HDD, install kernel, fix booting and set variables needed by ltsp scripts?
14:05MorningSon has joined #ltsp
14:09vagrantc has joined #ltsp
14:12
<alkisg>
muppis: yes, if you tweak the initramfs AND initscripts wherever nbd is mentioned, you should be able to boot locally
14:12otavio_ has quit IRC
14:12
<alkisg>
Xubuntu hanged? Which graphics card? lspci -nn -k | grep -A 2 VGA
14:16bobby_C has joined #ltsp
14:19leio_ has joined #ltsp
14:19leio has quit IRC
14:36leio_ is now known as leio
15:24xavier_ has joined #ltsp
15:25xavier_ has quit IRC
15:26xavier_brochard has joined #ltsp
15:29komunista has quit IRC
15:31
<xavier_brochard>
hello, I have a problem with thincans clients unable to boot
15:32
they just download the nbi.img file and then nothing happened
15:32
other clients (old pc) works fine
15:36
<alkisg>
xavier_brochard: did you see my reply on the ML?
15:37
https://bugs.launchpad.net/ubuntu/+source/mknbi/+bug/487826
15:39
<xavier_brochard>
alkisg: your reply is not yet available for me. I've already read this bug report but I don't think it apply
15:39
<alkisg>
Why not? It states that nbi images don't work with recent ubuntu versions...
15:42
<xavier_brochard>
alkis: I'm not sure, this bug concerns etherboot
15:42
but the Artec's thincans use coreboot
15:43
<alkisg>
Do they work with pxelinux.0? Did you try to force-send it to them?
15:43
<xavier_brochard>
and they are working with elf based image on another install (Lenny)
15:43
<alkisg>
Hmmm ok, I don't know enough about the subject to be helpful
15:44
<xavier_brochard>
what do you mean by force-send?
15:44
<alkisg>
I've only used .nbi images years ago, before switching to gpxe/pxe
15:44
In dhcpd.conf there's an 'if' that decides to send either pxelinux.0 or nbi.img to the clients
15:45
I don't know if coreboot clients are able to boot with pxelinux.0, but you could easily try to remove that if
15:45
<xavier_brochard>
ok, totally forgot that, I try
15:50
alkisg: it works! many thanks - though I don't understand why it works on Lenny and not on UbuntuLucid
15:51
<alkisg>
xavier_brochard: please comment on that bug report, if coreboot products don't work with nbi images there's no reason to not put mknbi back
15:51
So that etherboot clients also work
15:51* alkisg uses neither etherboot or coreboot so can't help with that bug report
15:52
<xavier_brochard>
alkis: I wonder if the problem could be the size of the nbi.img?
15:52
I will try with a recent debian to compare
15:52
a,d then I will comment the bug report
15:55
well I've just goes out to see my thincans... it boot but it stay with the ubuntu progress bar, more debug to do!
15:56
<alkisg>
xavier_brochard: remove "quiet splash" from /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default to see any error messages
16:15klausade has joined #ltsp
16:22
<xavier_brochard>
alkisg: the current boot problem is with nbd ; it only affect the thincans
16:23
<alkisg>
xavier_brochard: so why your coreboot client didn't work?
16:25
<xavier_brochard>
The boot process start but stop on an nbd error which the various PC doesn't have.
16:25
looks like a Geode problem (Thincans use Geode)
16:26
<alkisg>
Ah, I read your message in the mailing and understood differently ("The Thincan clients download the nbi.img and then nothing happened.")
16:26
If it's an nbd problem, it can probably be worked around. What's the error message?
16:29
<xavier_brochard>
I've just solve the nbd error by disabling LDM_DIRECTX
16:29* vagrantc can't fathom that working
16:30
<xavier_brochard>
alkisg: but I can't login (I've setup a shell)
16:30
<alkisg>
You mean SCREEN_02=shell? Or in ldm?
16:31
For ldm, try ltsp-update-sshkeys && ltsp-update-image
16:31
<xavier_brochard>
SCREEN yes
16:31
<alkisg>
For SCREEN, you should already have a root shell, with no login prompt
16:32
I agree with vagrantc though, that LDM_DIRECTX shouldn't have anything to do with nbd errors
16:32
You might be experiencing random nbd errors, and it just happened to work this time
16:33
<xavier_brochard>
no, I only have tty=/dev/tty2 I can type anything, nothing happened (on the pc it is correct)
16:33
I didn't understood vagrant expression at first
16:34
I tried to removing LDM_DIRECTX because after a while, the screen changed with ssh errors
16:36
<alkisg>
What ethernet card do those clients have?
16:36
It sounds to me like you're having general networking problems, maybe because of the driver or some other component
16:36
That would explain the "random" errors you're seeing
16:38
<xavier_brochard>
Mmm. On the other ie, all my thincans here have problems bootng on Ubuntu, while working lke a charm on the old Lenny server
16:38
The card is a VIA VT6122 Gigabit
16:39
(card on the thincan)
16:41
I have a prompt now. But above there is a few "snd-malloc: invalid device type 0"
16:43
<alkisg>
Can you modify the kernel parameters for those clients? Or they're hardcoded inside nbi.img?
16:45
<vagrantc>
try squeeze? :)
16:45
<xavier_brochard>
vagrantc: squeeze freeze on my new server :-( (I prefer Debian)
16:46* alkisg was suspecting nbd-proxy, but yup, squeeze wouldn't have that problem at all :D
16:46
<xavier_brochard>
alkisg: yes I can pass ernel params with pxelinux.cfg
16:47
<alkisg>
xavier_brochard: er... I'm confused, are you using nbi or pxelinux?
16:48
When those clients boot, do they say "downloading nbi.img" or "downloading pxelinux.0"?
16:48
<xavier_brochard>
nbi doesn't work, I've forced pxelinux
16:49
<vagrantc>
xavier_brochard: hrm. you reported bugs?
16:50
<alkisg>
xavier_brochard: OK. So far I've seen such "random errors" in 2 cases, when there's a problem with the network driver or when there's a problem with nbd-proxy, you might want to temporarily disable the latter to see if it fixes your problems: https://bugs.launchpad.net/ltsp/+bug/589034
16:51
<xavier_brochard>
vagrantc: not yet. I'm investigating around the raid driver (dell perc)
16:53
<vagrantc>
xavier_brochard: it crashes? or is just missing the driver? a lot of things have moved into non-free firmware packages
16:57
<xavier_brochard>
it crash but install works fine, so it can be solved.
16:58
I've installed ubuntu temporarily. I will change to sqeeze later.
16:58
alkisg: thanks for the url, I will try
17:02zz_evil_root is now known as evil_root
17:08
<xavier_brochard>
alkisg: it works sometimes. It's allways stopped or very slow after running the init-bottom script
17:10alkisg has quit IRC
17:22yanu_ has quit IRC
17:23yanu has quit IRC
17:27
<xavier_brochard>
for the record: alkis solved my problem, the new ltsp_nbd version works well
17:30muppis has quit IRC
17:30muppis has joined #ltsp
17:30bobby_C has quit IRC
17:31vmlintu has quit IRC
17:32vmlintu has joined #ltsp
17:52ogra has quit IRC
17:52xavier_brochard has quit IRC
17:56ogra has joined #ltsp
17:56xavier_brochard has joined #ltsp
17:56ogra is now known as Guest61100
18:46alexqwesa has quit IRC
18:46xavier_brochard has left #ltsp
19:09alexqwesa has joined #ltsp
19:10artista_frustrad has quit IRC
19:21shawnp0wers has joined #ltsp
19:32sep has quit IRC
19:37F-GT has quit IRC
19:41evil_root is now known as zz_evil_root
19:42vagrantc has quit IRC
20:07johnny has joined #ltsp
20:11Lns has quit IRC
20:58shawnp0wers has quit IRC
21:12F-GT has joined #ltsp
21:25vagrantc has joined #ltsp
21:34artista_frustrad has joined #ltsp
21:40artista_frustrad has quit IRC
21:46MorningSon has quit IRC
21:53artista_frustrad has joined #ltsp
21:58artista_frustrad has quit IRC
22:11artista_frustrad has joined #ltsp
22:15artista_frustrad has quit IRC
22:28artista_frustrad has joined #ltsp
22:33artista_frustrad has quit IRC
23:15RiXtEr has quit IRC
23:24RiXtEr has joined #ltsp