IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 21 April 2010   (all times are UTC)

00:00ogra_cmpc has joined #ltsp
00:21alkisg has joined #ltsp
00:24japerry has joined #ltsp
00:31alkisg has quit IRC
00:33alkisg has joined #ltsp
00:38vagrantc has quit IRC
01:07cyberorg has quit IRC
01:18The_Code has quit IRC
01:28cyberorg has joined #ltsp
01:40japerry has quit IRC
01:41Faithful has quit IRC
01:52alkisg has quit IRC
01:55Faithful has joined #ltsp
01:56gnunux has joined #ltsp
01:57
<gnunux>
hi
02:02knipwim_ has joined #ltsp
02:04knipwim has quit IRC
02:29alkisg has joined #ltsp
03:09johnny has quit IRC
03:24bobby_C has joined #ltsp
03:42try2free has joined #ltsp
03:52try2free has left #ltsp
04:34davemir has joined #ltsp
04:54davemir has quit IRC
05:42mikkel has joined #ltsp
06:17alkisg has quit IRC
06:20pmatulis has joined #ltsp
06:50pasmen has joined #ltsp
07:04bobby_C has quit IRC
07:09michiel_e has joined #ltsp
07:15alkisg has joined #ltsp
07:44
<_UsUrPeR_>
sbalneav: ping?
07:54michiel_e has quit IRC
07:54ogra_ has joined #ltsp
07:55ogra has quit IRC
07:55ogra_ is now known as ogra
07:55ogra has joined #ltsp
07:59bobby_C has joined #ltsp
08:03Gadi has joined #ltsp
08:09evilx has joined #ltsp
08:16pasmen has quit IRC
08:37dragonbch has joined #ltsp
08:40
<dragonbch>
hello to all?
08:42
I've other little problem with tftp. the client pc say:
08:42
TFTP. . . . .
08:42
TFTP. .
08:42
PXE-E11: Opent timeout.
08:42
why? how I may resolve? pls!
08:49epaphus has joined #ltsp
08:50komunista has joined #ltsp
08:56
<komunista>
hi all
08:56shawnp0wers has joined #ltsp
08:59
<sbalneav>
_UsUrPeR_: Pong
08:59
Morning all
08:59
<_UsUrPeR_>
sbalneav: thanks. Gimme a bit :)
09:00
<sbalneav>
NP
09:03shawnp0wers has left #ltsp
09:13
<vbundi>
dragonbch: how is your system set up, 64bit, 2 nics or 1?
09:17
<dragonbch>
vbundi that?
09:17
<abeehc>
that!
09:20
<dragonbch>
mmm I speak little english sorry
09:20
<vbundi>
type uname -a
09:20
<dragonbch>
I've 32bit and 1 interface of net
09:20
<vbundi>
ok
09:20
<dragonbch>
Linux server 2.6.26-2-686 #1 SMP Thu Mar 26 01:08:11 UTC 2009 i686 GNU/Linux
09:20
<vbundi>
have you started your dhcp server?
09:21
<_UsUrPeR_>
sbalneav: after some experimentation with Sabayon, I have discovered the need to delete a user's /home/<user>/.local directory for some changes to profiles to take effect.
09:21
<vbundi>
_UsUrPeR_ ohh maybe thats why it didn't save changes for me yesterday
09:21
<_UsUrPeR_>
sbalneav: The removal of the .local directory is only required AFTER a user has already had a sabayon profile applied to the user
09:21
<dragonbch>
yes
09:22
<vbundi>
dragonbch: ps ax|grep dhcpd
09:22
<dragonbch>
whether, and to set the IP addresses correctly...
09:22
<vbundi>
ok
09:22munson has quit IRC
09:22
<dragonbch>
2574 ? Ss 0:01 /usr/sbin/dhcpd3 -q eth0
09:22
<_UsUrPeR_>
vbundi: indeed that may be why
09:23
<vbundi>
cool
09:24
<dragonbch>
look vbundi http://pastebin.com/CWLEFsxW
09:25
<vbundi>
_UsUrPeR_: my sabayon profile is created for a user, and I deleted the /home/user/.local directory... but my changes are not applied... (ie menu changes and wallpaper)
09:28
<sbalneav>
_UsUrPeR_: Well, the problem may be, we really shouldn't just WIPE the .local directory, as the user may have settings stored there that AREN'T being controlled by sabayon.
09:29
So, one supposes what we should do, is see what applications that use .local in the profile are, then wipe those .local directories, leaving the rest.
09:30
<_UsUrPeR_>
I concur. The .local changes I know are affected pertain to the panel options. I.E. applications, places, system
09:30
<sbalneav>
so, if the sabayon profile is storing .local/share/rythmbox, we shouldn't wipe the users .local/share/Empathy.
09:30
<vbundi>
sbalneav: why not take a copy of the .local directory for the user, have sabayon make changes to the files within, and then move them back
09:31
that way, only files that have been modified will be overwritten
09:31
<sbalneav>
sabayon does that now. It simply unpacks whatever is in .local in the profile.
09:32
the problem will be, if you have EXTRA stuff in your own .local, then that won't get cleared out.
09:32
<vbundi>
oh I didn't realize it was the extra stuff causing the problem
09:33
<sbalneav>
Well, we have a much bigger problem than that anyway that needs to get solved before Gnome 3 comes out.
09:33
gconf is disappearing, to be replaced by gsettings
09:34
which will work completely differently.
09:34
And so far, I haven't been able to confirm that gsetting will have the "clone" feature that sabayon uses from gconf to register a listener to track gconf changes.
09:35
So, it's entirely possible that sabayon may not work at all for gnome 3 :/
09:35
Unless they've either a) got that feature in there, or b) I can convince them to add it.
09:36
<vmlintu>
interesting, I've never even heard of gsettings before
09:36
<_UsUrPeR_>
another interesting issue I am experiencing: remember how I had described using a few simlinks in /etc/skel? When changes are made to any sabayon profile, the symlinked directories' ownership is changed to sabayon-admin:sabayon-admin
09:36
A simple change back to normal is all that's required
09:36
<sbalneav>
http://live.gnome.org/dconf
09:37CAN-o-SPAM has joined #ltsp
09:42pmatulis has quit IRC
09:45pmatulis has joined #ltsp
09:47dragonbch has left #ltsp
10:18staffencasa has joined #ltsp
10:26mikkel has quit IRC
10:33gnunux has quit IRC
10:47dragonbch has joined #ltsp
10:55
<dragonbch>
vbundi I had changed the dhcp
10:55
but is equal
10:55
:s
10:57
<alkisg>
dragonbch: is that a tftp server or a dhcp server?
10:57
<vbundi>
dragonbch: ahh, sorry that it didn't work for you... you have some non-standard things that I'm not really sure how to work with
10:57
<alkisg>
Is your tftp server running?
10:57
<dragonbch>
the same
10:57
ok thank vbundi
10:57
<alkisg>
*sorry I mean "a tftp server or a dhcp server PROBLEM"?
10:57
<dragonbch>
tftp
10:57
<alkisg>
Is your tftp server running?
10:57
invoke-rc.d tftpd-hpa status
10:58
or `netstat -nap | grep :69" - if it runs from inetd..
10:58
<dragonbch>
server:~# invoke-rc.d tftpd-hpa restart
10:58
Restarting HPA's tftpd: in.tftpdinvoke-rc.d: initscript tftpd-hpa, action "restart" failed.
10:58
server:~#
11:01
I've /etc/default/tftpd-hpa
11:01
#Defaults for tftpd-hpa
11:01
RUN_DAEMON="yes"
11:01
OPTIONS="-l -s /tftpboot"
11:02
<highvoltage>
hi, I need some help in determining whether an interface is up
11:02
<dragonbch>
this is my /etc/hosts.allow
11:02
nbdrootd: ALL: keepalive
11:02
bootpd 0.0.0.0. #Estoy permitiendo a la red de clase 192.168.74.
11:02
in.tftpd: 192.168.74. # tener acceso a mis servicios de transferencia de
11:02
portmap: 192.168.74.#archivos
11:02
<highvoltage>
at the moment I do an ifconfig for an interface and grep for "inet addr"
11:02
<dragonbch>
is good?
11:02
<highvoltage>
which works fine, the problem is that it breaks in other languages (like in french where it's "inet adr"
11:02
<vbundi>
sbalneav: changes that I am making with sbayon ('Administration > User profile Editor') are not being saved... I created a profile called 'users' and changed some gnome-menu things, logged out of 'sabayon-admin' and then hit edit again, and my changes are all gone
11:03
*sabayon even
11:04ogra has quit IRC
11:05ogra has joined #ltsp
11:07
<komunista>
highvoltage: try: LANG=C ifconfig ...
11:07
<highvoltage>
komunista: ah, nice one, I should've thought of that, thanks :)
11:10
<komunista>
I have non english locales too ;-)
11:12
<alkisg>
dragonbch: grep tftp /etc/inetd.conf
11:17slidesinger has joined #ltsp
11:31korcan has joined #ltsp
11:34japerry has joined #ltsp
11:37
<sbalneav>
vbundi: Which version of sabayon are you using?
11:38
<vbundi>
sbalneav: one sec
11:39
sbalneav: the one from the lucid repos I believe
11:40
<dragonbch>
alkisg
11:40
tftp dgram udp wait root /usr/sbin/in.tftpd /usr/sbin/in.tftpd -s /tftpboot
11:40
<vbundi>
sbalneav: if I added your ppa using apt-add-repository would it show in my /etc/apt/sources?
11:41
sbalneav: wait... went into the gnome 'software sources' app, I see that I have added your ppa for lucid main
11:53
sbalneav: sorry my bad.. I wasn't saving my profile, I was logging out.. doh... works properly :)
11:54thunsucker has joined #ltsp
11:58tstafford has quit IRC
11:59
<sbalneav>
vbundi: Well, the main one for lucid should be fine.
11:59
<vbundi>
yeah I see that I'm using the one from your ppa
11:59
<sbalneav>
off for lunch, back in a bit.
11:59
<alkisg>
dragonbch: ok, so you're using inetd, try `netstat -nap | grep :69` to see if tftp is running
12:04
<dragonbch>
netstat -nap | grep :69
12:04
udp6 0 0 :::69 :::* 2248/inetutils-inet
12:06
<alkisg>
And the file /tftpboot/ltsp/i386/pxelinux.0 is there?
12:07
(are you sure -s /tftpboot in inetd.conf is correct?)
12:10
<dragonbch>
ls /tftpboot/ltsp/i386
12:10
config-2.6.26-2-486 initrd.img-2.6.26-2-686 nbi.img-2.6.26-2-486 pxelinux.cfg vmlinuz-2.6.26-2-486
12:10
config-2.6.26-2-686 initrd.img-2.6.26-2-686.bak nbi.img-2.6.26-2-686 System.map-2.6.26-2-486 vmlinuz-2.6.26-2-686
12:10
initrd.img initrd.img.old nbi.img.old System.map-2.6.26-2-686 vmlinuz.old
12:10
initrd.img-2.6.26-2-486 nbi.img *pxelinux.0* vmlinuz
12:10
server:~#
12:10
all correct
12:13
tftp dgram udp wait root /usr/sbin/in.tftpd /usr/sbin/in.tftpd -s /tftpboot
12:17
<thunsucker>
dragonbch: pastebot!
12:17
pastbot!: dragonbch
12:17
lol bot died?
12:19
<dragonbch>
ok
12:23tstafford has joined #ltsp
12:30bulletxt has joined #ltsp
12:30
<bulletxt>
hi, has someone tried ltsp with ubuntu 10.04 pre releasE?
12:34slidesinger has quit IRC
12:36
<alkisg>
bulletxt: yes, many have tried it...
12:36
<bulletxt>
is it stable? I mean, I have to choose between ubuntu 9.10 and ubuntu 10.04 :) what should I go for?
12:37
<thunsucker>
bullext: go 10.04 but wait for the stable release
12:37
<bulletxt>
yea
12:37
<alkisg>
bulletxt: for production? or personal use? It's a little unstable for production, and I think it'll take some months for it to stabilize...
12:38
<bulletxt>
for production use alkisg
12:38
so you suggest to keep safe with 9.10?
12:38highvoltage has quit IRC
12:38
<bulletxt>
im actually afraid of 10.04 for all the backports they're doing
12:39
<alkisg>
I'm afraid of upstart breakage :)
12:39
<bulletxt>
:)
12:39
<alkisg>
(yesterday it was tftp, now it's mysql...)
12:40
<bulletxt>
mm.... I think I'll stay with 9.10 :)
12:40
<dragonbch>
I has remove, purge and install tftpd-hpa again but is same
12:40
<alkisg>
I think some weeks after the release, it'll stabilize enough...
12:40
<bulletxt>
yea maybe when they do the 6 month update, like around july
12:41
ill try todays current 10.04 image in a vm
12:42highvoltage has joined #ltsp
12:54komunista has quit IRC
12:58dragonbch has left #ltsp
13:01dragonbch has joined #ltsp
13:08thunsucker has left #ltsp
13:15alkisg has quit IRC
13:15alkisg has joined #ltsp
13:40alkisg has quit IRC
13:40alkisg has joined #ltsp
13:45
<bulletxt>
does ltsp somehow share some resources? for example if there 5 users logged all with firefox opened, does the server really consume firefox process 5 times?
13:47alkisg has quit IRC
13:49tstafford has quit IRC
13:53
<abeehc>
i'm not certain about ff; but openoffice does that in some respect i think
14:00tstafford has joined #ltsp
14:03dragonbch has left #ltsp
14:03japerry has quit IRC
14:05Lns has joined #ltsp
14:09
<_UsUrPeR_>
I am having some issues getting ltsp-update-sshkeys to work with ltsp-cluster in 10.04. Has anybody run into this yet?
14:10komunista has joined #ltsp
14:14
<Gadi>
_UsUrPeR_: ltsp-cluster hands out the ssh keys from the app server - you shouldn't need ssh-updatekeys
14:14
er, update-sshkeys
14:15
and by app server I mean control center
14:15
man, I should quit while Im ahead
14:15
<_UsUrPeR_>
ahh :)
14:15cliebow has joined #ltsp
14:15
<_UsUrPeR_>
ok, so if it's not properly handing out sshkeys, where should I be looking?
14:16
clients boot alright, they list that they are connected to the sundry test appservers, but it's apparent that sshkeys do not exist for the clients
14:16
<Gadi>
apparent how?
14:18
<_UsUrPeR_>
If I switch to a shell on the client (ctrl+alt+F2), when sshing to the the app server it's connected to, or the clusterserver, it states that the server is not in it's known hosts
14:18alkisg has joined #ltsp
14:18
<_UsUrPeR_>
which, in the past, indicated that the ssh keys did not exist
14:18
or were incorrect
14:18
<Gadi>
hmm...
14:19Lns has quit IRC
14:21
<Gadi>
is LDM_SERVER running anything on port 8001?
14:21
(it should be)
14:21
<_UsUrPeR_>
one second. lemme check
14:22
Gadi: http://pastebin.com/4KWZNDrD
14:23
that's the listing of what's running on 8001. ldm_server doesn't appear to be running at all
14:23
<Gadi>
that looks good
14:24
what do you get when you do:
14:24
echo "getkey" |nc -q-1 $LDM_SERVER
14:24
(obviously make sure you put the LDM_SERVER IP instead of the variable)
14:24Lns has joined #ltsp
14:25
<Gadi>
oops
14:25
and should be:
14:25
echo "getkey" |nc -q-1 $LDM_SERVER 8001
14:26
<_UsUrPeR_>
Gadi: nc seems to have a problem with something in there
14:28
<Gadi>
that could be your problem then
14:28
<_UsUrPeR_>
Gadi: http://pastebin.com/66qimLTH
14:29
<Gadi>
did you set LDM_SERVER?
14:29
LDM_SERVER=1.2.3.4
14:29
<_UsUrPeR_>
LDM_SERVER=%LOADBALANCER% according to the admin web site
14:30
<Gadi>
no, I mean for this test
14:30
do:
14:30
cho "getkey" |nc -q-1 1.2.3.4 8001
14:30
(where 1.2.3.4 = one of the test app servers)
14:31
<_UsUrPeR_>
AHH! ok, I see
14:31
no return
14:31
<Gadi>
that command should return an ssh key
14:32
<_UsUrPeR_>
Gadi: http://pastebin.com/CPRBqFsJ
14:32
no returns there from ssh keys.
14:37Kicer86 has joined #ltsp
14:37
<Gadi>
check ltsp-cluster -accountmanger to see if it is running and if the /etc/ltsp config file is ok
14:37
<_UsUrPeR_>
k
14:44
nothing weird in /etc/ltsp config files. both appservers are reporting in according to /var/log/ltsp-cluster0lbserver.log
14:44cliebow has quit IRC
14:44
<_UsUrPeR_>
Gadi: what is the ltsp-cluster -accountmanager? The only thing I am seeing is the ltsp-cluster-lbserver on the server
14:45
<Gadi>
are you looking at the app server?
14:45
I am talking about the app server
14:46
<_UsUrPeR_>
ahh
14:46
one moment
14:47
<Gadi>
each app server should have ltsp-cluster-accountmanager
14:48
<_UsUrPeR_>
ok, on the appserves, accountmanager is not running
14:49
and the config file in /etc/ltsp/accountmanager.conf has an entry for key=PUT_A_KEY_HERE
14:49
this it new :/
14:49dragonbch has joined #ltsp
14:49* _UsUrPeR_ puts a key there
14:50
<Gadi>
no no
14:50
leave it be
14:50
<_UsUrPeR_>
ok
14:50
<Gadi>
just restart the service
14:50
then, try getting a key with that getkey command
14:51
<_UsUrPeR_>
hmm
14:51
ok
14:51
seems to be running now
14:51
<dragonbch>
I managed to correctly configure the ltsp server, thanks you
14:51
alkisg, vbundi
14:52
<_UsUrPeR_>
hey! It's working now.
14:52
Gadi: thanks
14:52
<Gadi>
my pleasure
14:52* _UsUrPeR_ records for posterity
14:57pmatulis has quit IRC
14:59Kicer86 has quit IRC
14:59Lns has quit IRC
15:13dragonbch has left #ltsp
15:27alkisg has quit IRC
15:35ogra_cmpc has quit IRC
15:48ogra_cmpc has joined #ltsp
16:03japerry has joined #ltsp
16:03epaphus has quit IRC
16:10CAN-o-SPAM has quit IRC
16:38japerry has quit IRC
16:42komunista has quit IRC
16:45atkuepker has joined #ltsp
16:51japerry has joined #ltsp
17:04epaphus has joined #ltsp
17:07vagrantc has joined #ltsp
17:10Ahmuck has joined #ltsp
17:11
<Ahmuck>
hi hi. i'm considering running a vbox application window for a windows program. possible through ubuntu ltsp thin client? has anybody tried this?
17:16
<vbundi>
how many users do you want to access this vbox app
17:18
I don't see why it couldn't work for one user, but I've never tried it
17:18
<Ahmuck>
7 max
17:19
<vbundi>
ok so you'll be running 7 windows virtual machines... thats 7x256MB ram
17:20
plus licensing for 7 windows XP licenses to run this app
17:20
you'd be way better off running a Windows Terminal server and RDPing from your linux terminal sessions to it
17:25
I'm out for the night.. bye all
17:32
<Ahmuck>
no way to get the app to open without the vm?
17:32
open the app on demand and run from server?
18:12
<epaphus>
Hello all.. I have an ltsp image with firefox... as a local app... However when using it on a thin client... intermittently firefox loads some pages, and some it just gives "page cannobe displayed" error.. also when pages do load they load half way. Flash sometimes works, and sometimes it doesnt.
18:12
Running firefox from the server goes fine
18:12
anybody ever seen such thing?
18:24
nevermind.. its the dns resolver that screwed up
18:42staffencasa has quit IRC
18:45
<epaphus>
Hey guys, is it possible to specify more then one IP for DNS_SERVER In lts.conf ?
18:47
<vagrantc>
epaphus: should support multiple.
18:47
<epaphus>
vagrantc, what is the syntax? a space, a comma.. ive tried all that no luck
18:47
<vagrantc>
space
18:47
<epaphus>
vagrantc, if i do a space then... in my thin clients
18:48
/etc/resolv.conf turn out to be:
18:48
nameserver 1.1.1.1 2.2.2.2 <-- is that valid? two IPs on one line?
18:48atkuepker has quit IRC
18:48
<vagrantc>
epaphus: what's the exact line in lts.conf ?
18:48
no, that's not valid
18:49
<epaphus>
exact line is:
18:49
DNS_SERVER = 4.2.2.2
18:49
<vagrantc>
when you specify 2?
18:50
<epaphus>
DNS_SERVER = 4.2.2.2 208.67.222.220
18:50
<vagrantc>
epaphus: what distro?
18:50
<epaphus>
ubuntu 9.10
18:53
<vagrantc>
looking at the code, the only thing i can think would be it's treating it as a single parameter...
18:53
for n in $DNS_SERVER; do
18:53
echo "nameserver ${n}" >> /etc/resolv.conf
18:53
done
18:54
<epaphus>
vagrantc, ok.. those lines would go into lts.conf ?
18:54
<vagrantc>
no, that's the code that handles that variable.
18:54
i don't see how it would generate one line.
18:54
<epaphus>
ohh
18:55
vagrantc, iam going to try it again with a space. i must be doing something wrong
18:55
where is that code vagrantc ?
18:55
<vagrantc>
epaphus: try with and without "" in lts.conf ...
18:56
<epaphus>
DNS_SERVER = "4.2.2.2 208.67.222.220"
18:56
ok ill try that :)
18:56
<vagrantc>
epaphus: i.e. DNS_SERVER="1.2.3.4 5.6.7.8" as well as DNS_SERVER= 1.2.3.4 5.6.7.8
18:56
<epaphus>
thanks... ill try that...
19:01epaphus has quit IRC
19:04Ahmuck has left #ltsp
19:10bobby_C has quit IRC
19:13japerry has quit IRC
19:34vagrantc has quit IRC
19:40waldo323 has joined #ltsp
19:56Gadi has left #ltsp
19:57vmlintu has quit IRC
20:25pmatulis has joined #ltsp
20:27vagrantc has joined #ltsp
20:27knipwim has joined #ltsp
20:28pmatulis has quit IRC
20:30knipwim_ has quit IRC
20:41shinz has joined #ltsp
20:54waldo323 has quit IRC
21:04ogra_cmpc has quit IRC
21:06ogra_cmpc has joined #ltsp
21:29
<shinz>
hi..
21:29
need help here..
21:41jhutchins_lt has quit IRC
22:01shinz has quit IRC
22:29alkisg has joined #ltsp
22:56vagrantc has quit IRC
23:34vbundi_ has joined #ltsp
23:43vbundi_ has quit IRC
23:44alkisg has quit IRC