IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 12 January 2007   (all times are UTC)

00:01shogunx has quit IRC
00:05juhaj has left #ltsp
00:11shogunx has joined #ltsp
00:13shogunx has quit IRC
00:16ltspbot has joined #ltsp
00:17vagrantc has joined #ltsp
00:23shogunx has joined #ltsp
00:23pipedrea1 has joined #ltsp
00:27mistik1 has quit IRC
00:28pipedream has quit IRC
00:34pipedream has joined #ltsp
00:39wizzy has quit IRC
00:41vagrantc has quit IRC
00:43pipedrea2 has joined #ltsp
00:43pipedream has quit IRC
01:01pipedrea1 has quit IRC
01:01g333k_work has quit IRC
01:05jsgotangco has joined #ltsp
01:12jsgotangco has quit IRC
01:12pipedrea2 has quit IRC
01:12_rodrigo_ has quit IRC
01:12muh2000_ has quit IRC
01:12jamil has quit IRC
01:12robbie_ has quit IRC
01:12patrickb2 has quit IRC
01:12patrickb1 has quit IRC
01:12patrickb_ has quit IRC
01:12oh207 has quit IRC
01:12bronze__ has quit IRC
01:13jsgotangco has joined #ltsp
01:13pipedrea2 has joined #ltsp
01:13_rodrigo_ has joined #ltsp
01:13muh2000_ has joined #ltsp
01:13jamil has joined #ltsp
01:13robbie_ has joined #ltsp
01:13patrickb2 has joined #ltsp
01:13patrickb1 has joined #ltsp
01:13patrickb_ has joined #ltsp
01:13oh207 has joined #ltsp
01:13bronze__ has joined #ltsp
01:13muh2000_ has quit IRC
01:13muh2000_ has joined #ltsp
01:17ccherret1 has quit IRC
01:18ccherrett has joined #ltsp
02:30robbie__ has joined #ltsp
02:31robbie_ has quit IRC
03:39vanya has joined #ltsp
04:09robbie_ has joined #ltsp
04:11robbie__ has quit IRC
04:19patrickb2 has quit IRC
04:20Sp0oKeR has joined #ltsp
04:23CapRiCoRN^80 has joined #ltsp
04:38jsgotangco has quit IRC
04:45patrick_ has joined #ltsp
04:50patrick_ has quit IRC
04:50patrick_ has joined #ltsp
04:55patrick_ has quit IRC
04:58patrick_ has joined #ltsp
05:06MoL0ToV has joined #ltsp
05:08CapRiCoRN^80 has quit IRC
05:34xbow has joined #ltsp
05:37sep has quit IRC
05:37sep has joined #ltsp
05:48mascote has joined #ltsp
05:49robbie__ has joined #ltsp
05:49
<mascote>
hi
05:49
I need some help... I have a internet server (IP 192.168.0.200) and my LTSP server is other computer (192.168.0.203). When the internet server and the LTSP server are turn on the X login at the client is OK, but when the internet server is turn off the X login don't work, just show at the client a gray screen and a X(point of the mouse). Why its occours? What I have to change to correct this problem? Thanks a lot.
05:51robbie_ has quit IRC
05:52FernandoMM has joined #ltsp
06:05
<cliebow>
Mascote: what is xserver set to in lts.cconf?
06:06
sounds like xdmcp is not running on the ltsp server ot xserver is wrong in lts.conf
06:15jsgotangco has joined #ltsp
06:18budgee has quit IRC
06:29Envite has joined #ltsp
06:29
<Envite>
Hello all from Spain
06:29
Hola a todos desde España
06:45
<mascote>
hi cliebow
06:45
thanks your answer
06:45
I was out and came back now!
06:45jsgotangco has quit IRC
06:46
<mascote>
cliebow: the the xserver statement is auto ( XSERVER = auto )
06:47
cliebow: and the other statement is SERVER = 192.168.0.203
06:48patrick_ has quit IRC
06:50J45p3r_ has joined #ltsp
06:50patrick_ has joined #ltsp
06:52patrick_ has joined #ltsp
07:00
<mascote>
I need some help... I have a internet server (IP 192.168.0.200) and my LTSP server is other computer (192.168.0.203). When the internet server and the LTSP server are turn on the X login at the client is OK, but when the internet server is turn off the X login don't work, just show at the client a gray screen and a X(point of the mouse). Why its occours? What I have to change to correct this problem? Thanks a lot.
07:01
<jammcq>
you probably need to add your workstations to the /etc/hosts file
07:03g333k_work has joined #ltsp
07:06patrick_ has quit IRC
07:06patrick_ has joined #ltsp
07:06
<mascote>
jammcq: I already did this.
07:07jsgotangco has joined #ltsp
07:09patrick_ has quit IRC
07:10
<mascote>
jammcq: at the client, at text terminal, I whote "hostname -f" and the answer is: ws3
07:11
jammcq: in my /etc/hosts, at the LTSP Server, I have a line "192.168.0.3 ws3 ws3"
07:11
<jammcq>
mascote: that doesn't really tell us anything
07:11
you have 2 servers on your local network? a LTSP server and a web server?
07:11
<mascote>
jammcq: yes
07:12
<jammcq>
ok, the LTSP server has 1 or 2 network interfaces?
07:12
<mascote>
jammcq: 1
07:12
<jammcq>
and how about the web server?
07:13
<mascote>
jammcq: 2, one the internet link and another to local net
07:13
<jammcq>
ok, what distribution are you using on both servers?
07:13
<mascote>
jammcq: the LTSP and the Internet server are connect by a swicth
07:13
<jammcq>
are the workstations plugged into the same switch?
07:13
<mascote>
jammcq: yes
07:13
<jammcq>
what distro?
07:14
<mascote>
jammcq: LTSP=Red Hat EL4
07:14
<jammcq>
on both?
07:14
<mascote>
jammcq: Internet=Debian Sarge
07:14
<jammcq>
ok
07:14
hmm
07:14
what version of LTSP ?
07:15
<mascote>
jammcq: 4.2
07:15
I already use the LTSP from 3 years, from 3.4 version.
07:18
jammcq: I think the problem would be the dhcpd.conf, because the statement "options routers" was 192.168.0.200 (internet server) I changed to 192.168.0.203 (LTSP server), but the problem remain.
07:18
<jammcq>
the thin clients really don't need the 'routers'. a thin client ONLY talks to the LTSP server
07:18
<mascote>
jammcq: I just have 1 XDMCP server at my net, is the LTSP Server.
07:19
jammcq: ok, but I tried. ;-)
07:19
<jammcq>
what do you have in lts.conf, for 'SERVER' ?
07:19
<mascote>
jammcq: SERVER = 192.168.0.203
07:21
<jammcq>
ok, on the LTSP server, try running this:
07:21
tcpdump -i eth0 port 177
07:21
and then reboot one of the thin clients
07:24
<mascote>
[root@cpd3 etc]# tcpdump -i eth0 port 177
07:24
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
07:24
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
07:24
11:21:11.691663 IP ws3.1024 > cpd3.tum.com.br.xdmcp: UDP, length 7
07:24
11:21:11.795845 IP cpd3.tum.com.br.xdmcp > ws3.1024: UDP, length 59
07:24
11:21:15.624188 IP ws3.1024 > cpd3.tum.com.br.xdmcp: UDP, length 98
07:24
11:21:15.624387 IP cpd3.tum.com.br.xdmcp > ws3.1024: UDP, length 52
07:24
11:21:15.624687 IP ws3.1024 > cpd3.tum.com.br.xdmcp: UDP, length 29
07:24
<jammcq>
so, it's definately trying
07:24
<mascote>
jammcq: what?
07:24
<Envite>
I'm going home early today
07:24
bye all!
07:24
<jammcq>
that shows that ws3 is trying to connect to the server
07:25
ok, try running this:
07:25
<mascote>
jammcq: the client is connect.
07:25patrick_ has joined #ltsp
07:25
<jammcq>
did it work?
07:25
<mascote>
yes, because the internet server is on!
07:25
<jammcq>
oh
07:25
doh!
07:25
ok, when you get a chance, turn off the internet server, and run this:
07:25
<mascote>
I have to do this whithout the internet.
07:25
<jammcq>
tcpdump -s 1520 -w /tmp/tcpdump.out port 177
07:26
and while that's running, reboot ws3
07:26
and after 2 minutes, kill the tcpdump
07:26
<mascote>
jammcq: ok
07:26
<jammcq>
and email the /tmp/tcpdump.out file to jam@ltsp.org
07:26Envite has quit IRC
07:26
<jammcq>
I need to go eat my breakfast, and then drive to my office
07:26
but when I get the email from you, i'll take a look at it
07:27patrick_ has quit IRC
07:27cliebow_ has joined #ltsp
07:28budgee has joined #ltsp
07:28
<mascote>
jammcq: ok, thanks a lot.
07:28
<cliebow_>
mascote: solve it?
07:28
<mascote>
jammcq: I'm going to sent you a email with the file.
07:29
<jammcq>
ok, cool
07:29
<cliebow_>
what was the deal?
07:33
<mascote>
cliebow_: thanks, the jammcq is looking my problem, too.
07:33
cliebow_: not yet, problem persists.
07:33
<cliebow_>
mascote: well then you should consider yourself blessed
07:34
<mascote>
cliebow_: he he he
07:35
cliebow_: I love linux.
07:36
<cliebow_>
arrrgggh..my ltsp server just went down for no reason..nothing in the logs..just croakerd at 5 last night
07:39
<jammcq>
ok, gotta run to the office
07:39
see ya'll in a bit
07:39jammcq has quit IRC
07:46patrickb1 has quit IRC
07:46patrickb_ has quit IRC
07:47patrick_ has joined #ltsp
07:48g333k_work has quit IRC
07:49g333k_work has joined #ltsp
07:59
<mascote>
by
07:59
bye
07:59
thanks a lot.
07:59mascote has quit IRC
08:05torrya01 has quit IRC
08:08msinhore has joined #ltsp
08:08patrick_ has quit IRC
08:11jsgotangco has quit IRC
08:15jammcq has joined #ltsp
08:22
<pscheie>
jammcq: Does the ltsp kernel support Broadcom BCM4401 ethernet chips?
08:22
or rather, on my Dell laptop, I'm getting a kernel panic because it can't detect the ethernet chip
08:22
<jammcq>
umm, yeah, it has broadcom support. I think it's the tg3 module
08:23
<pscheie>
so I need to pass that as a kernel parameter for the client?
08:23
<jammcq>
yeah, prolly
08:29
<budgee>
jammcq: hey
08:30
jammcq: still not come right. think i might just shelve it and wait till it is release in XOrg 7.2 and then upgrade to LTSP 5
08:30
<jammcq>
hmm
08:45xbow has quit IRC
09:06ogra has quit IRC
09:08ogra has joined #ltsp
09:12Sp0oKeR has quit IRC
09:25ogra has quit IRC
09:36
<Snerf>
Got ltsp 4.2 and I am trying to get sound to work. I have a cmpci card, and I set that with SMODULE_01 = cmpci
09:36
but when my client boots up, it says that the cmpci module is not found, how do I add it?
09:38
<budgee>
What card is it for
09:39
<Snerf>
some weird name brand, bit it is cmpci compatable
09:39
<budgee>
snd-cmipci
09:39
Try that.
09:40
<Snerf>
any idea how I get that module tho, is there some way I need to install it?
09:40rxd has joined #ltsp
09:41rxd has quit IRC
09:44gentgeen__ has joined #ltsp
09:48
<budgee>
Snerf: sorry
09:48
Snerf: the module comes with my 4.2
09:48
you should have it?
09:52
<Snerf>
wel, its not there. is it part of one of the packages, cuz I didnt install them all\
09:53
thanks tho.. I'll see what I can do
09:55ogra has joined #ltsp
09:57Sp0oKeR has joined #ltsp
09:57FernandoMM has quit IRC
09:57FernandoMM has joined #ltsp
09:58jamil has quit IRC
10:02MoL0ToV has quit IRC
10:05Avatara has quit IRC
10:13mrlinux has joined #ltsp
10:14vykarian has joined #ltsp
10:21efra has joined #ltsp
10:21
<efra>
Morning everybody
10:22
<moquist>
cliebow_: Two dual-core xeons = 4 CPUs...sorta.
10:22
<cliebow_>
mornings
10:22
i saw the same thing on my trenton install
10:22
<moquist>
ogra: Ugh. How much trouble will the edsadmin licensing stuff be?
10:22* ogra woinders if vagrantc hides from him ...
10:22
<ogra>
moquist, upstream needs to add a note about the lgpl
10:23
or even the license directly
10:23
<cliebow_>
moquist: i feel like i missed a day..or something
10:24
<ogra>
Hi,
10:24
I've just rejected your edsadmin upload. It contains LGPL-ed files, but
10:24
there is no copy of the LGPL in the orig.tar.gz. Please fix and reupload.
10:24
- tfheen
10:24
moquist, ^^^^^^^
10:25
<vykarian>
morning
10:25
<ogra>
sadly i cant tweak the original source ... only the packaging, so upstream has to add the file
10:32FernandoMM has quit IRC
10:35patrick__ has joined #ltsp
10:43mathesis has joined #ltsp
10:48J45p3r_ has quit IRC
11:02patrick__ has quit IRC
11:08_rodrigo_ has quit IRC
11:08_rodrigo_ has joined #ltsp
11:44sepski has joined #ltsp
11:53alienBOB has left #ltsp
12:00vanya has quit IRC
12:20budgee has quit IRC
12:24Snerf has quit IRC
12:28FernandoMM has joined #ltsp
12:41
<g333k_work>
is ltsp 5 ready to use at production?
12:41
hello everybody, is ltsp 5 ready to use at production?
12:41
<ogra>
g333k_work, yes
12:42
in ubuntu edgy or debian etch
12:43
(not sure where the redhat port stands ...)
12:44Villarroel has joined #ltsp
12:48_rodrigo_ has quit IRC
12:49gigabytes has joined #ltsp
13:02
<g333k_work>
ogra, ok thanks
13:04Sp0oKeR has quit IRC
13:08vykarian has quit IRC
13:13mathesis has quit IRC
13:33
<g333k_work>
Hi, when running ltsp-build-client i receive this error about perl locales: http://pastebin.ca/314448 any clue?
13:34J45p3r_ has joined #ltsp
13:34
<ogra>
thats ok, dont worry
13:35
(the client doesnt set any locales, and doesnt need to ... )
13:39
<g333k_work>
ogra, really? after running ltsp-build-client my ltsp is supposed to be ready to go?
13:39
<ogra>
yep
13:40
if you followed the https://help.ubuntu.com/community/UbuntuLTSP/LTSPQuickInstall guide ...
13:40
<g333k_work>
ogra, yep... I'jm following this guide
13:41
<ogra>
good
13:41andresmujica has joined #ltsp
13:41
<g333k_work>
ogra, I'm really get used to ltspadmin, so its a big move for me
13:41
<ogra>
we'll have a gui in the near future ... (hopefully i have it ready for feisty (7.04) )
13:42
http://people.ubuntu.com/~ogra/LTSPManager/
13:42
some debian guy wanted to make a curses version of it ... so we might even have a nice commandline gui at some point if needed
13:44
<g333k_work>
ogra, wow! it sounds great
13:45* ogra will be afk now ... bbl
13:46
<Villarroel>
problemm, tftps says "in.tftpd: tftp: client does not accept options" it takes long time to load a configuration file and finally none is loaded.
13:48gigabytes has quit IRC
13:48mrlinux has quit IRC
13:56GiantPickle has quit IRC
13:57gigabytes has joined #ltsp
13:57GiantPickle has joined #ltsp
13:58Villarroel has left #ltsp
13:59andresmujica has left #ltsp
13:59andresmujica has joined #ltsp
14:00andresmujica has quit IRC
14:04J45p3r_ has quit IRC
14:05robbie_ has joined #ltsp
14:07andresmujica has joined #ltsp
14:07robbie__ has quit IRC
14:07andresmujica has quit IRC
14:08andresmujica has joined #ltsp
14:09andresmujica has joined #ltsp
14:15gigabytes has quit IRC
14:26Patina has quit IRC
14:26Patina has joined #ltsp
14:29
<g333k_work>
To use PXE botting with LTSP5, is the sam way of ltsp 4.2?
14:36muh2000_ has quit IRC
14:36
<g333k_work>
Maybe my question muts be: Is PXE booting avaiable for ltsp 5?
14:36muh2000_ has joined #ltsp
14:38
<sepski>
g333k_work, yes
14:39
<g333k_work>
sepski, can you help me to set it up?
14:41
<sepski>
what do you have problem with ?
14:42jammcq has quit IRC
14:43
<g333k_work>
sepski, I cant find the /tftpboot directory
14:43
sepski, I'm using tfptd-hpa
14:43
<sepski>
/var/lib/tftpboot
14:43
<g333k_work>
tftpd-hpa *
14:43
<sepski>
and i think atftpd is better
14:43
atlest i know it works since that's what i use
14:44
<g333k_work>
sepski, what should I put in the inet.conf file?
14:44
<sepski>
this is contents from my /etc/defaults/atftpd OPTIONS="--daemon --port 69 --tftpd-timeout 300 --retry-timeout 5 --no-multicast --maxthread 100 --verbose=5 /var/lib/tftpboot"
14:44
<g333k_work>
sepski, I use tftpd-hpa with ltsp 4.2 with no problems
14:45
<sepski>
dont know what tftpd-hpa would want
14:45
didn't say it woudn't work. only that i dont know it much
14:45
<g333k_work>
sepski, I'm talking about the file /etc/inetd.conf
14:46jammcq has joined #ltsp
14:46
<sepski>
mine say tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd --tftpd-timeout 300 --retry-timeout 5 --no-multicast --maxthread 100 --verbose=5 /var/lib/tftpboot
14:48gigabytes has joined #ltsp
14:48
<g333k_work>
sepski, ok thanks
14:51cliebow_ has quit IRC
14:52W^^harddd^^ has joined #ltsp
14:53mistik1 has joined #ltsp
14:53cliebow_ has joined #ltsp
14:57
<g333k_work>
sepski, can you paste your /etc/ltsp/dhcp.conf ?
14:58fxrsliberty has joined #ltsp
15:01
<sepski>
http://channels.debian.net/paste/5061
15:02
<W^^harddd^^>
i have some usb mouting issues to discuess
15:05
<g333k_work>
sepski, thanks
15:06
How do I tell ltsp to use another network interface?
15:06
ltsp 5 *
15:10
<sepski>
g333k, the dhcp config file contains the ip address of the interface that the client will try to pxeboot from, and the ip address it will try to nfs mount
15:10
and ofcouse the dhcp file will only serve the configured interface
15:16
<g333k_work>
sepski, because my server has two interfaces
15:16
<sepski>
so have mine. but i only run the dhcp server on the one where it should run
15:26efra is now known as efra_away
15:26* efra_away is away: I'm out to lunch | Sali a comer
15:26W^^harddd^^ has quit IRC
15:31arc_ has quit IRC
15:37fxrsliberty has quit IRC
15:42msinhore has quit IRC
15:46Egyptian[Home] has quit IRC
15:49cliebow_ has quit IRC
15:53Egyptian[Home] has joined #ltsp
15:53
<g333k_work>
I receive a error from the client whe booting says: "TFTP Error - File nor found"
15:53
I receive a error from the client whe booting says: "TFTP Error - File not found"
15:54
and in my dhcp I have this line: filename "/var/lib/tftpboot/ltsp/i386/pxelinux.0";
15:54
what is wrong?
15:56
<ogra>
why did you change the default dhcpd.conf ?
15:57
wipe the "/var/lib/tftpboot" from that line
15:57
<g333k_work>
ogra, ok
16:00
ogra, it booted... but never get the X windows....there is a line: (initramfs)
16:01gigabytes has quit IRC
16:01
<g333k_work>
ogra, /bin/sh: cant access tty; job control turned off
16:03
<ogra>
is there an nfs error somwhere above ?
16:03
if so , try rebooting the server to make sure nfs is started rigtht ... thats should solve it (unless you changed /etc/exports)
16:04
<g333k_work>
ogra, in /etc/exports I just have this line: /opt/ltsp *(ro,no_root_squash,async)
16:04
<ogra>
fine
16:04
just leave the defaults, the files are usually set up right ...
16:04
<g333k_work>
ogra, I think it must be /opt/ltsp/i386
16:04
<ogra>
no
16:04
<g333k_work>
or not?
16:04
ok
16:04FernandoMM has quit IRC
16:04
<g333k_work>
then whats the problem?
16:05
<ogra>
did you reboot the server ?
16:05FernandoMM has joined #ltsp
16:05
<g333k_work>
ogra, yep
16:05efra_away is now known as efra
16:05* efra is back (gone 00:39:23)
16:06
<ogra>
"ps ax|grep nfs" shows nfsd running ?
16:06
<g333k_work>
ogra, yep many
16:07
<ogra>
hmm
16:07
sudo mount localhost:/opt/ltsp/i386 /mnt
16:07
does that return without errors and mount the dir in /mnt ?
16:10
<g333k_work>
ogra, nop
16:10
ogra, there are many dirs mounted in /mnt
16:11
<ogra>
??
16:11
if you have already anything mounted there mout to anywhere else ...
16:11FernandoMM has quit IRC
16:11
<ogra>
we need to see if nfs works ...
16:12
did you change more stuff in the dhcp config ?
16:13
apart from the fliename option ?
16:13
<g333k_work>
ogra, I mean... after executing the line you told me, it mounted many dirs
16:13
<ogra>
ah, ok
16:13
the unmount /mnt again
16:13
*then
16:14
nfs seems fine, looks like your dhcpd config is broken
16:16
(the shipped file is usually fine)
16:17Patina has quit IRC
16:17Patina has joined #ltsp
16:21
<g333k_work>
ogra, I'm pointing the correct file right?
16:21
<ogra>
where ?
16:22
you mean the filename option ? yes, else you wouldnt see the initramfs loading until the busybox shell comes up
16:23
hos does your root-path option look like ?
16:23
*how
16:26
<g333k_work>
ogra, can you pastebin your .conf files for me?
16:27
<ogra>
http://paste.ubuntu-nl.org/1361/
16:27
(thats the unmodified default file btw ...)
16:30
oh207, indeed its not ...
16:30
ergh
16:30
replace "new" with i386
16:31
thats a change i made for a different kernel i tested ...
16:39
<g333k_work>
ogra, are you talking to me?
16:40
ogra, I got it,....
16:40
<ogra>
are any other people talking in here ? ;)
16:40
<jammcq>
not me
16:40
<ogra>
heh
16:41
<g333k_work>
ogra, why the subnet range is from 20 to 250?
16:41
<ogra>
jammcq, i wonder when vagrant will be around again i discovered some evil breakage he introduced ... i fixed it in ubuntu, but i think he wants it fixed in debian before they release etch
16:42
<sepski>
ogra, what was that ?
16:42
<ogra>
g333k_work, just beacues ... indeed you can use any range you like
16:42
sepski, ltsp-client-builder (the debian-installer part) has "--security-mirror none"
16:43
sepski, it was introduced by skole or debian-edu ... but i wonder if they ever tested it ...
16:43
<g333k_work>
ogra, my serve ip is 192.168.43.254, when I try to reload dhcpd i receive this error: /etc/ltsp/dhcpd.conf line 3: subnet 192.168.43.254 netmask 255.255.255.0: bad subnet number/mask combination
16:43
<ogra>
you end up with a line in your sources.list where the server name for security is set to nne ...
16:43
*none
16:43
<sepski>
ogra, we use that when installing from the cd when the security mirror is unavailable
16:44
<ogra>
well, it breaks ...
16:44
unless ubuntus apt is different to debians (which is very unlikely)
16:44
<sepski>
indeed.
16:44
im just builing a chroot from the etch ltsp now, checking in a minute
16:45
<ogra>
manage-mirror should either do a noop if thats set to none or we should drop it from the client-builder udeb
16:46
g333k_work, paste your /etc/ltsp/dhcpdconf anywhere ...
16:46
<g333k_work>
ogra, ok
16:46
<ogra>
/etc/ltsp/dhcpd.conf indeed
16:47
<g333k_work>
ogra, http://pastebin.ca/314640
16:47
ogra, I know..
16:48
<ogra>
subnet 192.168.43.254 ?
16:48
thats not a network address
16:48
change it to 192.168.43.0
16:49
also drop the group stuff for now ... make it look exactly like mine (apart from "new") with your ip address ...
16:50
if you got it running re-add the group stuff line by line to check whats breaking it ...
16:50
i dont think putting the filename inside the group statement is a good ised (i'm not sure though)
16:50
*ldea
16:51
*idea
16:51
(sigh)
16:51bobby_C has joined #ltsp
16:53
<ogra>
g333k_work, http://paste.ubuntu-nl.org/1364/
16:53
try that one ...
16:54markit has joined #ltsp
16:54jammcq has quit IRC
16:54
<markit>
forgive my ignorance, but would be possible have a thin client using wireless to connect to the server and boot?
16:55
<ogra>
no ...
16:55
<markit>
Imean, buy those low power boxes with PXE rom booting capability and
16:55
ah, no :(
16:55
<sepski>
ogra, we use --mirror file:///cdrom --security-mirror none and we only get a single line in sources.list that saies deb file:///cdrom etch main local
16:56
<ogra>
even though there is an image from ltsp 3.something with a handfull of wireless drivers included ... you can try it ... look on the ltsp wiki
16:56
<markit>
ogra: you were relplying to me?
16:56
ok, thanks
16:57
<ogra>
sepski, well, i get a security line as well, and it *only* happens if i run it in d-i (i.e. from the udeb) it doesnt happen if i run it manually in a installed system ...
16:57
sepski, oh, and when i tested my CDs the system was not connected to a network ...
16:57
both might influence it ...
16:58
<sepski>
ogra, probably becouse we preseed it somewhat d-i ltsp-client-builder/build-client-opts string --mirror file:///cdrom --security-mirror none --components main,local --accept-unsigned-packages --dist etch --late-packages sitesummary-client,debian-edu-artwork,debian-edu-artwork-usplash --debconf-seeds /usr/lib/debian-edu-install/defaults.ltsp-chroot
16:58
<ogra>
well ... did you test it directly from CD ?
16:59
while in d-i mode ?
16:59
<sepski>
ogra, i only tested our debian-edu installer.
16:59bobby_C has quit IRC
16:59
<sepski>
but i do that 2-3 times a day.. :]
16:59
<ogra>
actually i dont care much about it, i can fix it easily for ubuntu ... but you should check it twice to make sure it doesnt affect you as well
17:00
<sepski>
i'd prefer that we do it in the same way
17:00
to avoide needless seperation
17:00
<ogra>
i was just worried about your release ... i still have plenty of time to fix it before the next ubuntu release
17:00
<sepski>
ill test the etch cd's too
17:01
<ogra>
sepski, well, i'll just have my own manage-mirror plugin ... that wont do any harm and wont diverge us
17:01
(thats the reason we have separate plugin dirs ;) )
17:01
<sepski>
im not that familiar with the codebase im afraid
17:02
<ogra>
in any case i dont understand why you dont get the second entry ... there is no code in manage-mirror that would catch "none" as a keyword to avoid it adding that second line
17:02
<sepski>
i guess the udeb is not working too well without debian-edu's preseedings then.
17:03
<ogra>
well until i merged all your changes it worked flawless for three releases in ubuntu :)
17:03
it just started with the recent merges
17:03
<g333k_work>
whre is the lts.conf?
17:03
in ltsp 5?
17:04
<ogra>
its only used to override autodetection ...
17:04
<Egyptian[Home]>
g333k_work: find / -name lts.conf -print
17:04
<ogra>
so there is none by default
17:04
create one in /opt/ltsp/i386/etc if you think you need one
17:05
a list with valid values and an example file are in /opt/ltsp/i386/usr/share/doc/ltsp-client/examples/
17:05
<g333k_work>
what's new in ltsp 5?
17:05
ogra, ok I thought it was in another locatioon than ltsp4
17:06
<sepski>
ogra, i guess we wait for vagrant. is there a bug in debian BTS ?
17:06
<ogra>
no, but it uses slightly different values in some places, so take a look at the value list
17:07
sepski, nope i just discovered it during a 36h iso test run where i didnt sleep i was to tired and to lazy to file a bug ....
17:07
g333k_work, http://wiki.ltsp.org/twiki/bin/view/Ltsp/Ltsp5
17:08
g333k_work, ltsp5 is completely different to all former ltsp implementations
17:09cascade has joined #ltsp
17:09
<ogra>
and relies completely on distros implementing it (which didnt happen yet for others than ubuntu and debian)
17:09
<g333k_work>
ogra, I dont know if its time to move on to ltsp5 now... or stay in ltsp 4.2
17:09
<ogra>
redhat started a port but didnt show any success yet ... same for gentoo ....
17:09
suse isnt intrested in ltsp at all ...
17:10
<sepski>
g333k_work, works as a charm here :)
17:10
could spend some time on speeding up the booting time tho. but that goes for regular linux's too
17:10
<cliebow>
suse loses
17:10
<g333k_work>
sepski, what I use in ltsp4.2 is: local devices and I'm planning to use local applications
17:10
<ogra>
g333k_work, well, sbalneav switched his whole organization to edgy ltsp5 in october ... they use it in production for several hundret workplaces ...
17:11
<cliebow>
and edgy rocks!
17:11
<ogra>
and i know jammcq stared switching himself and his customers as well
17:11
<g333k_work>
ogra, wow!
17:11
<cliebow>
me too
17:11
<sepski>
local devices is much nicer in ltsp5 with ltspfs instead of the hackisly samba implementations
17:11
<g333k_work>
yep I'm using edgy here
17:12
<ogra>
sepski, well, its painful if you urgently want xdmcp ...
17:12
<g333k_work>
I'm using xfce (xubuntu), I installed student-control-panel to send messages to my clients, but the messages dont appear, why?
17:12
<ogra>
g333k_work, student-control-panel uses dbus ... i'm not sure xfce does
17:12
<g333k_work>
you must post the tricks for the old users of ltsp4.2, because ltsp5 is quite different
17:13
ogra, so how can I send popup messages to my clients using xfce?
17:13
<ogra>
sbalneav was working on rewriting a lot of the ltsp.org docs ... but then got new software in his organization which made probs ... he's fixing it since weeks
17:14
<g333k_work>
ok thats ok
17:14
<cliebow>
sbalneav is up to his ears
17:14
<ogra>
g333k_work, no idea ... its developed in gnome ... and i know it works in kde ... ask an xfce guy ...
17:14
<g333k_work>
is there any xfce guy here???
17:14
lol
17:15
<ogra>
g333k_work, there is a session script for s-c-p thats running a dbus listener in the users session ... if xfce doesnt use dbus it wont work
17:15
its /etc/X11/Xsession.d/80scp-client
17:20
<g333k_work>
ogra, xfce guys just told me that xfce do use dbus
17:20
<ogra>
right
17:20
then it should work
17:20
and you use xfce from a thin client ?
17:21
(it only works on thin clients)
17:21
<g333k_work>
ogra, my clients are desktop pcs, I think celeron without hard disk
17:22
<ogra>
it only works if you are logged in through an ltsp thin client via ldm ...
17:22
(beacuse its only designed for that purpose)
17:24
<g333k_work>
ogra, O come on! I really need to send popup messages to my clients, is there another way?
17:24
ogra, but I see my client... I can disconnect it
17:24cascade__ has quit IRC
17:25
<ogra>
try commenting the following lines
17:25
if not os.getenv('LTSP_CLIENT'):
17:25
sys.exit(0)
17:25
in /usr/bin/scp-client
17:25
<g333k_work>
ogra, where?
17:25
<ogra>
in /usr/bin/scp-client
17:26
<g333k_work>
ogra, let me try
17:26
<ogra>
that will start the dbus listener in every session ... regardless if its an ltsp session or not
17:27
hmm, wait ... can you check if zenity is installed ? the popup is shown by zenity ...
17:28
<g333k_work>
ogra, do I have to restart something?
17:28
<ogra>
no
17:28Egyptian[Home] has quit IRC
17:28
<g333k_work>
ogra, well it doesnt work then
17:28
:(
17:30
<ogra>
is zenity installed ?
17:30
<g333k_work>
ogra, noup
17:31
intalling...
17:31
<ogra>
great
17:31
tell it to cbx33 in #edubuntu, he maintains s-c-p :)
17:32
<g333k_work>
ogra, ok thanks
17:44markit has quit IRC
17:45
<g333k_work>
ogra, Can you help me setting up local applicantions on ltsp 4.2?
17:46
<ogra>
g333k_work, not tonight anymore ... for 4.2 there is docs on the wiki btw ...
18:25jammcq has joined #ltsp
18:26andresmujica has joined #ltsp
18:36sepski has quit IRC
18:54efra has quit IRC
18:57mistik1_ has joined #ltsp
19:00arc_ has joined #ltsp
19:07mistik1 has quit IRC
19:07mistik1_ is now known as mistik1
19:28arc_ has quit IRC
19:28
<g333k_work>
does anybody has experience running local applications in ltsp 4.2? actually firefox
19:33FernandoMM has joined #ltsp
19:34
<g333k_work>
oe maybe helping me to enable ssh access to a client?
19:47
<cliebow>
i can help maybe with ssh access..
19:57J45p3r has joined #ltsp
19:58
<mistik1>
jammcq: I have a strong feeling I will no longer need vmware in my toolbox
20:10andresmujica has left #ltsp
20:17
<jammcq>
mistik1: oh? did you find a new tool ?
20:17FernandoMM has quit IRC
20:30jsgotangco has joined #ltsp
20:31andresmujica has joined #ltsp
20:38PMantis has joined #ltsp
20:39
<jammcq>
PMantis: hey
20:40
<PMantis>
Hey jammcq
20:42
<cliebow>
ho
20:43
<jammcq>
hey chuckie
20:52J45p3r has quit IRC
21:00andresmujica has left #ltsp
21:04vagrantc has joined #ltsp
21:04andresmujica has joined #ltsp
21:47
<mistik1>
jammcq: qemu is growing up
21:48
I think I'll install ltsp on my laptop and play with it a bit
21:49
<jammcq>
cool
21:49
<mistik1>
I have been using qemu in a very stable fashion for about a week now
21:49
0.8.2 rocks
21:51muh2000_ has quit IRC
21:51muh2000_ has joined #ltsp
21:51muh2000_ is now known as muh2000
22:02
<andresmujica>
Hello there, to anyone interested in using FL_TeacherTool in ubuntu
22:02
http://www.seaq.com.co/linux/Fl_TeacherTool/
22:08PMantis has quit IRC
22:14andresmujica has left #ltsp
22:30
<moquist>
ogra: K. Hopefully Mark will be responsive. I'm guessing that his time will be the only issue; he seems friendly toward contributions and this is a small thing to ask.
22:30
ogra: (re edsadmin)
22:51krinns_ has quit IRC
23:03mathesis has joined #ltsp
23:04
<mathesis>
hi all
23:04
vagrantc: how are you vagrantc ?
23:04
*vagrantc: how are you ?
23:57mathesis has quit IRC