IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 17 October 2007   (all times are UTC)

00:06plamengr has joined #ltsp
00:52MagicStorm has quit IRC
01:14Amaranth has joined #ltsp
02:16PiousMinion has quit IRC
02:49Egyptian[Home] has quit IRC
03:04Amaranth has quit IRC
03:04Egyptian[Home] has joined #ltsp
03:12Avatara has joined #ltsp
03:18ogra has quit IRC
03:18ogra has joined #ltsp
03:36yopla has joined #ltsp
03:39
<yopla>
Hello, I'd like to modifiy ltsp 4.1 ppc initrd file. I can't find a way to mount it. gzip -dc says "premature end of file"....
03:52ari_stress has joined #ltsp
03:54
<ari_stress>
afternoon
04:00micha__ has joined #ltsp
04:07
<micha__>
hello. is it possibel to supsend and resume a session with LTSP5?
04:17Egyptian[Home] has quit IRC
04:18Egyptian[Home] has joined #ltsp
04:24
<ogra>
micha__, nope
04:25
(one could implement something like hibernate to swapfile though)
04:28apollo13 has joined #ltsp
04:29
<apollo13>
hi, what's the easiest way to connect from a running windows (xp) to a ltsp server (I would like to plac a icon on the users desktop, which he can click, and then a window with the new session would pop up like rdesktop).
04:31
<ari_stress>
you just answered your own question
04:33
<apollo13>
lol? can mstsc connect to an ltsp server?
04:34
<ari_stress>
you can use tightvnc, realvnc
04:34otavio has quit IRC
04:34
<apollo13>
then I would need an vncserver, I just need a windows tool, which can execute a xdmcp chooser...
04:35
something like mstsc for ltsp...
04:36
<ari_stress>
setting up a vncserver is very simple
04:36
<rcy>
you dont need a chooser on the windows side if you are using vnc
04:37
but that is the other option, to install an xserver in windows
04:37
<apollo13>
If I set up a vncserver then all the user would see the same screen and not their environment?
04:37
<ari_stress>
apollo13: no, they will have their own env. we can set it in the vncserver
04:38
<apollo13>
ari_stress: hmm, can you provide a link with an example?
04:39
<ari_stress>
wait a sec
04:39
<apollo13>
thx
04:39
<ari_stress>
what distro do you use?
04:39
<apollo13>
debian
04:40
<ari_stress>
ok
04:40
http://ubuntuforums.org/showthread.php?t=122402
04:42
<apollo13>
thx, btw if I don't use vnc, xming would be a good choice, or?
04:43
<ari_stress>
i don't know xming
04:44
<apollo13>
okay thx
04:44apollo13 has quit IRC
04:49Amaranth has joined #ltsp
04:57micha__ has quit IRC
05:07mrcin has joined #ltsp
05:09burnerx has joined #ltsp
05:11yopla has quit IRC
05:17ogra has quit IRC
05:17ogra1 has joined #ltsp
05:18mrcin has quit IRC
05:22ogra1 is now known as ogra
05:42ari_stress has quit IRC
05:45makghosh has joined #ltsp
05:59fox2k has joined #ltsp
06:00fox2k has quit IRC
06:01fox2k has joined #ltsp
06:02fox2k has joined #ltsp
06:03Guaraldo has joined #ltsp
06:06spectra has quit IRC
06:15twinprism has quit IRC
06:32makghosh has left #ltsp
06:35otavio has joined #ltsp
06:36mikkel has joined #ltsp
06:37fernando110 has quit IRC
06:56Guaraldo has quit IRC
06:57Guaraldo has joined #ltsp
07:16fernando110 has joined #ltsp
07:22muh2000_ has joined #ltsp
07:35muh2000 has quit IRC
07:50Avatara has quit IRC
07:56Guarald1 has joined #ltsp
07:56Guaraldo has quit IRC
07:56Guarald1 has quit IRC
07:57Guaraldo has joined #ltsp
08:09
<sbalneav>
Morning all
08:31Clown-MG has joined #ltsp
08:31rjune_ has quit IRC
08:39
<highvoltage>
morning sbalneav
08:39
sbalneav: what is the version of LTSP in gutsy? 5.1?
08:39
<ogra>
5.0.39
08:52bails has joined #ltsp
08:53
<bails>
greetings from the UK, a small question
08:53spectra has joined #ltsp
08:54
<bails>
I have installed ltsp5 on debian unstable, everything is working fine with local devs, pulseaudio except my lts.conf settings do not seem to be parsed, is it still /opr/ltsp/i386/etc/lts.conf or has it been moved somewhere else?
08:55
^ /opt
08:55
<ogra>
in debian its stll there
08:55
<sbalneav>
bails: Are you setting values by hostname, ip address, or mac address?
08:56
<bails>
hmm i have set X to 640x480 and 8 bit colour depth but X still shows 1024x768 @ 16bit
08:56
sbalneav, I have a [Default] and [mac] sections
08:58
<sbalneav>
bails: Can you paste your lts.conf to the pastebot?
08:58
!pastebot
08:58
<ltspbot>
sbalneav: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
08:59
<bails>
!pastebot [Default]
08:59
SERVER = 192.168.0.1
08:59
XSERVER = i810
08:59
X_MODE_0 = 640x480
08:59
X_COLOR_DEPTH = 8
08:59
<ltspbot>
bails: Error: "pastebot" is not a valid command.
08:59
<bails>
LOCALDEV = True
08:59
SOUND = True
08:59
SOUND_DAEMON = pulse
09:00
NBD_SWAP = True
09:00
<sbalneav>
no not here
09:00
<bails>
SYSLOG_HOST = server
09:00
XKBLAYOUT = gb
09:00
X_MOUSE_PROTOCOL = "IMPS/2"
09:00
X_MOUSE_DEVICE = "/dev/psaux"
09:00
<sbalneav>
stop
09:00
<bails>
X_MOUSE_RESOLUTION = 400
09:00
X_MOUSE_BUTTONS = 5
09:00
X_ZAxisMapping = "4 5"
09:00
[00:02:a5:56:2b:0d]
09:00
XSERVER = i810
09:00
X_MODE_0 = 640x480
09:00
X_COLOR_DEPTH = 8
09:00
LOCALDEV = True
09:00
<ogra>
ARGH
09:00
<bails>
SOUND = True
09:00
SOUND_DAEMON = pulse
09:00
NBD_SWAP = True
09:00
<ogra>
!pastebot
09:00
<bails>
SYSLOG_HOST = server
09:00
<ltspbot>
ogra: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
09:00
<bails>
XKBLAYOUT = gb
09:00
#SCREEN_07 = startx
09:00
oops
09:00
I was actually trying to follow your instructions
09:00
so its not !pastebot then ?
09:00
<sbalneav>
Read what the text says
09:01
<bails>
ah ok so sorry
09:01
<ltsppbot>
"bails" pasted "lts.conf" (29 lines) at http://pastebot.ltsp.org/333
09:03
<ogra>
LOCALDEV, SOUND_DAEMON and SOUND are just the deaults ... you can drop them
09:03
<bails>
k
09:03
<ogra>
SYSLOG_HOST is useless (default to the bootserver)
09:03
<bails>
K done
09:04
<ogra>
thats only duplicating the defaults though and wont do any harm
09:04
(apart from making it less readable)
09:05
i can actually not see anything thats wrong ...
09:05
is your SERVER different from the bootserver ?
09:05
<bails>
nope its 192.168.0.1
09:05
<ogra>
else drop that as well, (not needed, defaults to bootserver)
09:06
<bails>
K
09:06
<ogra>
did you try to use the intel driver instead of the i810 one ?
09:07
<bails>
is there a page/wiki entry for ALL of the available stanzas for lts.conf in ltsp5 ?
09:07
which driver might taht be?
09:08
<ogra>
intel
09:08
just replace i810 in your file
09:08
<bails>
K i'kll give it a go
09:09
<ogra>
i810 usually needs 915resolution installed to change resoutions
09:09
its unlikely debian installs that in the thin client root
09:09
(we dont in ubuntu, and i'm not aware vagrant changed it when he imported the code)
09:09
the intel driver should switch resolutions just fine
09:11
<bails>
still no luck
09:11rjune_ has joined #ltsp
09:12
<ogra>
any error messages during boot ?
09:18
<bails>
none atall and it still doesnt go 640x480
09:19
but if i leave "XSERVER_0 = " i iget parse error online 4
09:19plamengr has left #ltsp
09:19
<bails>
so it is at least parsing lts.conf
09:20
<ogra>
it works in ubuntu, so i'm not sure whats wrong there
09:20
<bails>
read X_MODE_0 ^
09:21
hmm hey-ho i'll carry on trying things out
09:22
<ogra>
can you set size with vesa as Xserver ?
09:24Clown-MG has quit IRC
09:25
<bails>
haha well in the console X DRIVER still appears as "intel"
09:26
so i guess no is the answer
09:26
is there anyway of dumping the XConfig to a file?
09:26Clown-MG has joined #ltsp
09:27
<bails>
and i assume it is /etc/X11/xorg.conf on the client?
09:34
it is ^ if i log in then ctl+alt+F2 change driver to "vesa" in /etc/X11/xorg.conf then log out it picks it up
09:34
but not on boot
09:35
<ogra>
the modes in that file end at 640x480 ?
09:36
<bails>
they do
09:37
<ogra>
and neither with intel nor i810 it works even if you manually put them in the Driver section there ?
09:37
<bails>
is the XF86CONFIG_FILE still honoured?
09:37
<ogra>
its X_CONF now by default, but that old variable will still work, yes
09:37
<bails>
OK I'll try to do it like that then
09:38
<ogra>
you said unstable ....
09:38
which version of ltsp-server ?
09:38
i think it was added in ubuntu arund 5.0.30 or so
09:38
<bails>
the one from: deb http://pkg-ltsp.alioth.debian.org/debian etch-ltsp-backports main
09:38
<ogra>
thats not unstable
09:39
that are backports ... the packages in unstable are likely quite different
09:39
<bails>
ah sorry the server is sid/lenny
09:39
<ogra>
then you should use sids or lennys packages
09:39
not the backports for etch
09:40
<bails>
well i hate to say it but i couldnt find them
09:41
although looking at http://pkg-ltsp.alioth.debian.org/debian i can now
09:42
<ogra>
hmm, i would have expected them in the sid repo
09:42
but i dont know when and what debian pulls from ubuntu so it might be not in sid ...
09:46
<bails>
also X_CONF = doesnt appear to work :(
09:46
<ogra>
well, the edgy packages are pretty old (even the backported ones)
09:46
use XF86CONFIG
09:47
err
09:47
XF86CONFIG_FILE
09:47
<bails>
ok CF*^CONFIG_FILE semms to work properly thanks
09:48
<ogra>
err
09:48
s/edgy/etch/ :)
09:48
to closely named
09:48
<bails>
^ XF86CONFIG_FILE
09:49
next problem i need to add a local script
09:49
<ogra>
to run on boot ?
09:49
<bails>
can i still do a RC_FILE =
09:49
<ogra>
use rc.local or the RC_FILE variable in lts.conf
09:49
<bails>
yeh on boot to alsactl restore
09:50
<ogra>
aww, doesnt debian set that to 80% by default as ubuntu does ?
09:50
<bails>
sure does but it mutes my headphones, this is for a voip suite
09:51
<ogra>
(note that with the alsa sound all gstreamer controls should just work)
09:51
even though ...
09:51
i'm not sure the debian packages use the alsa emulation
09:52
(but oyu had pulse in the lts.conf so it should)
09:59ogra has quit IRC
10:01Clown-MG- has joined #ltsp
10:04muh2000_ has quit IRC
10:05MagicStorm has joined #ltsp
10:07bails has left #ltsp
10:10K_O-Gnom has joined #ltsp
10:11ogra has joined #ltsp
10:12Clown-MG has quit IRC
10:16krishna has joined #ltsp
10:21elisboa has quit IRC
10:22elisboa has joined #ltsp
10:32muh2000 has joined #ltsp
10:49ogra has quit IRC
10:50burnerx has quit IRC
10:51ogra has joined #ltsp
11:03fernando110 has quit IRC
11:10cyberorg has quit IRC
11:10fernando110 has joined #ltsp
11:13cyberorg has joined #ltsp
11:14Clown-MG- is now known as Clown-MG
11:17staffencasa has joined #ltsp
11:21slidesinger has joined #ltsp
11:27slidesinger has left #ltsp
11:28mohamed_ has joined #ltsp
11:29mohamed_ has left #ltsp
11:34krishna has quit IRC
11:39
<gonzaloaf_work>
hi, I'm using ltsp 4.2 and I boot all my clients using PXE and turn on them using WOL, the problem is that I have bought new PCs with a different mainboard, and now they dont turn on when I send the magic packet, I have read that is a kernel issue, what kernel do I have to modify in order to solve that? the ltsp kernel?
11:47muh2000_ has joined #ltsp
11:59Gadi has joined #ltsp
12:02muh2000 has quit IRC
12:17
<Guaraldo>
!s
12:17
<ltspbot>
Guaraldo: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
12:22
<Guaraldo>
!pastebot
12:22
<ltspbot>
Guaraldo: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
12:30MagicStorm has quit IRC
13:03
<lns>
are there any Ubuntu specific docs out there to move to PulseAudio? All I can find is that Novell documentation.
13:03
(in ltsp)
13:04
<ogra>
lns, no, there arent
13:04
feel free to ask though :)
13:04
<lns>
ogra, feel free to ask?
13:05
<ogra>
about the implementation
13:05
<lns>
ok...well i dunno how well i'll do since i'm not on-site, but i've had a pretty big issue with feisty/ltsp5 and moving to pulseaudio using this (seemingly pretty good) doc: http://developer.novell.com/wiki/index.php/Feisty/HOWTO:_PulseAudio
13:06
my server is running feisty/amd64 and i have i386 clients
13:06
<ogra>
pulse is the default in feisty
13:06
<lns>
at one site, it's worked fine - except, of course, for flash sound
13:06
ogra, hmm.
13:06
<ogra>
there is absolutely nothing you need to do
13:06
its even enabled by default :)
13:06
<lns>
even if you upgraded from dapper?
13:07
<ogra>
if you follow the suggestion to rebuild the clint env, yes
13:07
*client
13:07fernando110 has quit IRC
13:07
<lns>
i'm sure i've done that since upgrading to feisty... hmm!
13:08
<ogra>
https://wiki.ubuntu.com/EdubuntuLTSPUpgradeNotes
13:08
hmm, we should make that general ... not edubuntu specific
13:08
<lns>
well ok, i guess i just (still) can't get flash sound to work then. I've tried a bunch of things, including the revolutionlinux package, but it still seems to be not passing through to the clients.
13:09
ogra, that would be nice...after a while of installing/supporting ltsp, its still hard to find central documentation =)
13:09
<ogra>
https://help.ubuntu.com/community/EdubuntuFAQ#head-9eab8b3fa984d1b72c777b67a5bb557646e5946b
13:09
lns, since gutsy your best bet is to install the edubuntu-docs package. that brings excellent ltsp docs :)
13:10
its not in feisty though (we're working on getting a recent html versin up before the gutsy release though)
13:10
<lns>
ogra, awesome =) I look forward to tomorrow! ;)
13:11
<ogra>
check the link above for flash sound
13:11
<lns>
ogra, will the libflashsupport_1.0~2219-1_i386.deb work on amd64 with i386 libraries on it?
13:11
<ogra>
flash has a bug that makes networked sound break
13:11
no
13:11
<lns>
see that's my hangup
13:11
<ogra>
but there is a source package for it as well i think
13:12
<lns>
i remember trying to compile it and it gave some cryptic error...let me try and recreate it
13:12
thank you for the insight btw.. =) I'm sure you guys are flooded for tomorrow!
13:12
<ogra>
slightly ...
13:13
<lns>
you know i think it'd be cool for canonical to hire support ppl to man chans like this ;)
13:13
<ogra>
the last two weeks were hard ... the later it gets the better it gets :)
13:13vagrantc has joined #ltsp
13:13
<lns>
oh cool
13:13
what's up vagrantc
13:13
<vagrantc>
hi
13:13
<ogra>
hey vagrantc
13:16paul0 has joined #ltsp
13:16
<paul0>
hi there
13:16
i'm setting up my first ltsp system
13:16vagrantc has quit IRC
13:17
<paul0>
i was trying out some things, and i've noticed that isn't possible to run videos, that's normal?
13:18
<lns>
paul0, what videos?
13:18
and what app?
13:18
<paul0>
totem
13:18
i've tried to run an divx video
13:19
i tried with vlc too, but didn't work
13:19bobby_C has joined #ltsp
13:19
<lns>
paul0, did you install the right codecs?
13:20
<paul0>
yup
13:20
i could see the video in the ltsp server
13:20
but i couldn't see in the client
13:22
lns, is it possible to see videos in ltsp clients?
13:22
<lns>
ogra, i can't really decypher all this stuff..sorry about the chars too, this is what i try to do when "make"ing the libflashsupport code: http://pastebin.ca/740083
13:23
paul0, weird...
13:23
that's beyond my "expertise" (which is none at all) ;)
13:23
if it works on the server but not the client at all...it should be pulling from the same stuff i would think (minus sound maybe)
13:24
<paul0>
sound works fine
13:24
i was listening to di.fm radio in one ltsp client, very nice
13:25
even without video, ltsp is awsome =)
13:25
i mean, without playing divx videos
13:35MagicStorm has joined #ltsp
13:42fernando110 has joined #ltsp
13:43
<lns>
ogra (or anyone who's gone through this already), is there anything you can suggest to get libflashsupport source to compile correctly on AMD64? I guess I'm missing some header files, but I'm not sure what to do. http://pastebin.ca/740083
13:44
if I can get this going, I have 3 computer labs that would thank me over and over again...
13:49paul0 has quit IRC
13:51
<lns>
i'm beginning to think that i'm just dumb and need to install some dev packages... :)
14:04
argh
14:16Clown-MG has quit IRC
14:27slidesinger has joined #ltsp
14:40mikkel has quit IRC
14:41MagicStorm has quit IRC
14:43
<lns>
ok, now that I've installed linux-headers, build-essential, libssl-dev, libpulse-dev and libesd0-dev, I get the following errors when trying to compile libflashsupport.c (amd64 arch):
14:43
flashsupport.c:502: warning: cast from pointer to integer of different size
14:43
and again on line 514 and 544
14:44
any ideas?
14:48
<Guaraldo>
lns: warnings normaly are just warnings... not errors...
14:48
<lns>
Guaraldo, right - but in the makefile it treats warnings as errors
14:48
and it craps out...
14:49
i'm not entirely comfortable changing that, unless i get confirmation from someone who knows this specific error (and its context) is a moot point
14:54vagrantc has joined #ltsp
14:56makghosh has joined #ltsp
14:57cliebow_ has quit IRC
14:57Gadi has left #ltsp
14:58makghosh has left #ltsp
14:59Guaraldo has left #ltsp
15:04muh2000_ has quit IRC
15:16
<lns>
Does anyone have any suggestions on how to keep track of customizations/modifications to the LTSP chroot if they need to re-build it?
15:20
<vagrantc>
package them ?
15:20
<lns>
vagrantc, i don't follow
15:23
<vagrantc>
lns: make a package, and install it in your LTSP chroot ?
15:24
<lns>
vagrantc, hmm..interesting idea!
15:26K_O-Gnom has quit IRC
15:28vagrantc has quit IRC
15:31slidesinger has quit IRC
16:08muh2000 has joined #ltsp
16:12
<warren>
https://bugzilla.redhat.com/show_bug.cgi?id=336721 XDMCP segfaults gdmgreeter (libkeymouselistener)
16:13
Apparently this has been an issue in upstream GNOME for a while now. Did any of the other distros find a solution?
16:15fox2k has quit IRC
16:17
<joebaker>
warren: I know that there can be problems with GDM when you turn on "Accessibility" modes (In the 7.04 version of Ubuntu iirc.
16:18
<warren>
joebaker, this is a different bug from that
16:47robbie has joined #ltsp
17:19bobby_C has quit IRC
17:20Elive_user has joined #ltsp
17:22
<Elive_user>
I'm new tothe irc but longtime ltsp user with a problem. Anyone here?
17:24
I have a fresh 4.2 install which only allows the first client to logon.
17:26
exit
17:28J45p3r has joined #ltsp
17:33Elive_user has quit IRC
17:36jammcq has joined #ltsp
17:36
<jammcq>
hey all
17:37libmandan has joined #ltsp
17:40
<libmandan>
I have a fresh 4.2 install with this problem. Only one client can run firefox at a time. Any help?
17:40
<jammcq>
are you using unique user ids ?
17:40
<libmandan>
Yes. they are net1, net2, etc
17:40
<jammcq>
with unique home dirs ?
17:41
<libmandan>
Yes.
17:41
<jammcq>
what happens when the 2nd user tries to run ff ?
17:41
<libmandan>
Nothing. The screen remains blank.
17:41
<jammcq>
odd
17:42
how much ram in the server?
17:42
<libmandan>
2Gigs
17:42
<jammcq>
hmm
17:42
what distro?
17:42
<libmandan>
Debian etch. I have 9 servers running 4.1 with no problems.
17:43
<jammcq>
hmm
17:43
<libmandan>
Feel like I've missed something painfully obvious.
17:43
<jammcq>
so if net1 logs out, then can net2 run ff with no probs?
17:44
<libmandan>
Yes
17:48ogra has quit IRC
17:49
<libmandan>
One app I've noticed when doing ps -Unetx is dbus-launch and dbus-daemon. These don't appear on my 4.1 servers
17:49
<jammcq>
what happens if you try to launch firefox from an xterm window?
17:51
<libmandan>
I'm offsite now but I can connet and giv it a try...momento
17:53
Iget this error: The program 'firefox-bin' received an X Window System error.
17:53
This probably reflects a bug in the program.
17:54
Also, firefox here is really iceweasel.
17:57
If I use "firefox --sync" ff will launch.
18:11
Going to sleep on it and look at things in th emorning. Thanks for taking the time.
18:11
exit
18:11libmandan has quit IRC
18:22libmandan has joined #ltsp
18:22* libmandan is away: eZzzz
18:22Egyptian[Home] has quit IRC
18:28
<lns>
alright guys here's an interesting one
18:28
https://help.ubuntu.com/community/UbuntuLTSP/ResolveRamIssues - I created this page after implementing the fix described in it
18:29
I have two different kinds of thin clients at my labs - NeoWare e100's and older Compaq iPaq workstations.
18:29
the iPaqs will not, with the modified /opt/ltsp/i386/etc/ltsp/screen.d/ldm script, launch LDM.
18:30
The error is: "Fatal server error: xf86MapVidMem: Could not mmap framebuffer (random mem addresses) (Cannot allocate memory)
18:30
The neoware clients, however, boot up fine.
18:32
Any ideas?
18:34libmandan has quit IRC
18:41dubinsky has joined #LTSP
18:42dubinsky has left #LTSP
18:53
<lns>
hey, is NBD_SWAP a valid lts.conf entry? if so, is it the same/different as USE_NBD_SWAP ?
18:54
I can't find plain old NBD_SWAP in the docs at all
19:23staffencasa has quit IRC
19:58cliebow has joined #ltsp
20:02cliebow has quit IRC
20:18J45p3r has left #ltsp
21:12ccherret1 has joined #ltsp
21:13ccherrett has quit IRC
21:15ltspbot has joined #ltsp
21:21ltspbot has joined #ltsp
21:30ltspbot has joined #ltsp
21:38captain_magnus_ has quit IRC
21:39captain_magnus has joined #ltsp
21:54spectra has quit IRC
22:40boog has joined #ltsp
22:42boog has quit IRC
22:56Joris_ has joined #ltsp
23:09vagrantc has joined #ltsp
23:13Joris has quit IRC
23:42plamengr has joined #ltsp