IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 9 December 2010   (all times are UTC)

00:35alkisg has quit IRC
00:40F-GT has quit IRC
00:56daya has quit IRC
00:56F-GT has joined #ltsp
01:02evil_root is now known as zz_evil_root
01:26Kicer86 has joined #ltsp
01:41alkisg has joined #ltsp
01:51alkisg has quit IRC
01:53alkisg has joined #ltsp
02:24dobber has joined #ltsp
02:44gorkhaan has joined #ltsp
02:47alexqwesa has quit IRC
02:48bobby_C has joined #ltsp
02:49alexqwesa has joined #ltsp
02:52map7_ has joined #ltsp
03:09Da-Geek has joined #ltsp
03:12Gremble has joined #ltsp
03:39litlebuda has joined #ltsp
04:38litlebuda has quit IRC
04:48ogra_ac has quit IRC
04:49ogra_ac has joined #ltsp
04:55alkisg has quit IRC
04:58ogra_ac has quit IRC
04:59ogra has quit IRC
04:59ogra_ac has joined #ltsp
05:01ogra_ac has joined #ltsp
05:09ogra_ac is now known as ogra
05:09ogra has joined #ltsp
05:12ogra has quit IRC
05:12ogra has joined #ltsp
05:13ogra is now known as Guest42462
05:15Guest42462 has quit IRC
05:18ogra- has joined #ltsp
05:20ogra_ has joined #ltsp
05:21ogra_ has joined #ltsp
05:23ogra_ has joined #ltsp
05:24ogra_ has joined #ltsp
05:26ogra_ has quit IRC
05:26ogra_ has joined #ltsp
05:27ogra_ has quit IRC
05:28ogra_ has joined #ltsp
05:28ogra_ has joined #ltsp
05:30ogra_ has quit IRC
05:31ogra_ has joined #ltsp
05:31ogra_ has quit IRC
05:32ogra_ has joined #ltsp
05:40ogra_ has quit IRC
05:40ogra_ has joined #ltsp
05:46ogra_ has quit IRC
05:46ogra_ has joined #ltsp
05:46ogra_ is now known as ogra
05:47ogra has joined #ltsp
06:05map7_ has quit IRC
06:50Trixboxer has joined #ltsp
06:58Gremble has quit IRC
07:19MorningSon has joined #ltsp
07:23litlebuda has joined #ltsp
07:23MorningSon has quit IRC
07:24litlebuda has quit IRC
07:45mgariepy has joined #ltsp
07:45
<mgariepy>
good morning everyone
08:29zz_evil_root is now known as evil_root
08:30alkisg has joined #ltsp
08:39evil_root is now known as zz_evil_root
08:45primeministerp has quit IRC
08:47primeministerp has joined #ltsp
09:00
<highvoltage>
good morning mgariepy
09:11Pweg has joined #ltsp
09:21al3 has joined #ltsp
09:32m4xx_ has joined #ltsp
09:32
<m4xx_>
i'm trying to set up a ltsp thinclient environment. mostly everything is working fine but when trying to use crossover or wine the application freezes when it shows a dialog box. at first i thought it may be the emulator but i'm not sure that it is on the account that both emulators freeze in the exact same spot.
09:36m4xx_ has quit IRC
09:46Pweggle has joined #ltsp
09:47Pweg has quit IRC
09:58Kicer86 has quit IRC
10:37cliebow has joined #ltsp
10:57dobber has quit IRC
11:29komunista has joined #ltsp
12:06m4xx_ has joined #ltsp
12:10
<m4xx_>
i'm trying to set up a ltsp/thinclient environment. All the built in stuff works great, however when i open a windows app using both crossover or wine and it displays a dialog box teh whole screen freezes. I'm really not sure what's going on. I love what i've seen so far and would really like to get this to work.
12:15
the strange thing is everything works just fine when i use a local session, but if i use one of the thinclients is when it freezes
12:15
<alkisg>
Distro/version?
12:16
<m4xx_>
edubuntu 10.10
12:16
<alkisg>
Do you have anything in your lts.conf?
12:16
<m4xx_>
everything is default except for ip's
12:16
<alkisg>
So you don't have an lts.conf?
12:16
<m4xx_>
no sir
12:16
<alkisg>
(by default there is none)
12:16
OK
12:16
How much RAM on the thin client?
12:16
<m4xx_>
500MB i believe
12:17
<alkisg>
And you're using it as a thin client, no localapps, no fat clients or other fancy stuff, right?
12:17
<m4xx_>
nothing at all
12:17
just the server and 1 thinclient
12:17
<alkisg>
Are you trying to run a specific app, or does it happen with any app?
12:17
E.g. the wine notepad?
12:17
<m4xx_>
hp t5145
12:18
is the type of thinclient i have
12:18
i can try notepad if you would like
12:18
<alkisg>
Ah, does that have openchrome?
12:18
<m4xx_>
no sir
12:18
<alkisg>
Try this:
12:18
<m4xx_>
it has no local apps
12:18
<alkisg>
!localxterm
12:18
<ltspbot>
alkisg: "localxterm" :: while sitting on a thin client, open a gnome terminal. In that, run: ltsp-localapps xterm. An xterm will open. That xterm runs locally, so any commands you enter there are executed directly on the client.
12:18
<alkisg>
On a localxterm, run: lspci -nn -k | grep -A 2 VGA
12:18
What do you get?
12:18
<m4xx_>
would that be after the pxe boot or befor?
12:19mgariepy has quit IRC
12:19
<alkisg>
After you login
12:19
<m4xx_>
like a local session or the remote session
12:19
<alkisg>
A remote session
12:19
Ah
12:19
Any would do
12:19
If you have a local session, then run it there
12:19
I just want to see the graphics card and the driver used
12:19
<m4xx_>
i was going to say i cant do that locally
12:19
ok on second please
12:19
*one
12:22
when i do that it shows the servers video card
12:22
oh
12:22
i'm sorry i didnt see the other part
12:22
one second
12:25
http://pastebin.ca/2014956
12:26
brb
12:26
back
12:26
<alkisg>
Right so it has a chrome card, that's why I was saying about openchrome
12:27* alkisg hates those graphics cards :(
12:27
<m4xx_>
sorry, i thought you were talking about the browser :x
12:28
do you think this is the source of my problem?
12:28
<alkisg>
On the thin client, on a normal gnome-terminal, what do you get with: ps -e | grep compiz
12:28
?
12:28
<m4xx_>
nothing
12:29
<alkisg>
And with: ps -e | grep metacity
12:29
?
12:29
A line?
12:29
<m4xx_>
yes hold i will paste
12:29
<alkisg>
No no need
12:29
Try opening /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default
12:29vagrantc has joined #ltsp
12:30
<alkisg>
In there, put "nomodeset" right next to "quiet splash"
12:30
<m4xx_>
i can do that from the server correct?
12:30
<alkisg>
Reboot the client, and try running: wine notepad
12:30
Yes
12:31
<m4xx_>
fyi, i can already open an app
12:32
it's when it shows a dialog box or something similar. not sure if you ever used rsa's securid app. the actuall program loads but when i got to menu>select token and the dialog shows is when it freeze. i can open ms office 2007 fine and modify the default document.
12:33
logging in now
12:34
<alkisg>
Ah, that's why I asked above about (08:18:39 PM) alkisg: Are you trying to run a specific app, or does it happen with any app?
12:34
I thought that was with *any* wine app
12:34
So that specific application runs on the server but hangs on the thin client?
12:35
<m4xx_>
pretty much
12:35
notepad opened fine
12:35
was able to open the save as dialog just fine
12:35
tried the rsa securid software again and again it froze.
12:36
<alkisg>
And that software runs on the server without hanging?
12:36
<m4xx_>
yes sir
12:36
runs great
12:37
<alkisg>
Try this:
12:37
sudo gedit /var/lib/tftpboot/ltsp/i386/lts.conf
12:37
In there, put:
12:37
[Default]
12:37
LDM_DIRECTX=True
12:37
Then reboot the client and try again launching the software
12:39zz_evil_root is now known as evil_root
12:39
<evil_root>
morning alkisg
12:39
<alkisg>
Hello
12:39
<m4xx_>
loggin in now
12:40
same
12:44
<alkisg>
Check also ~/.xsession-errors for that user
12:44
Other than those, no idea...
12:48Da-Geek has quit IRC
12:49
<m4xx_>
http://pastebin.ca/2014981
12:50Trixboxer has quit IRC
12:53
<m4xx_>
alkisg: does any give you any ideas?
12:55
<alkisg>
Nope. If you have another client handy, I'd try with a client that has a different graphics card, to ensure that it's a driver/wine issue.
12:56
<m4xx_>
it's the only thinclient i have, can i use another computer with pxe?
12:56
<alkisg>
Sure, any computer will do
12:56
Even if it doesn't have pxe :)
12:57* vagrantc tries a pocket calculator
13:08
<alkisg>
For managing fat clients in the future, I'm thinking the following scenario: the user installs any distro in a vbox normally, without using ltsp-build-client. He adds apps with synaptic, uses sabayon to specify preferences etc etc. Nothing related to ltsp so far.
13:08
Then he installs ltsp-client inside the image. And finally he calls a special version of "ltsp-update-image-vbox" script which uses vdfuse to mount the vbox disk and then squashfs'es it into /opt/ltsp/images/i386.img.
13:08
For that to work, the ltsp-client initramfs + initscripts should be smart enough to just exit if the chroot is booted locally (i.e. from within the vbox image).
13:08
Would anyone mind if some code snippets were added in this direction?
13:09
<m4xx_>
i'm trying to pxe boot using this netbook and it says invalid card number. how else can i test this?
13:09
vnc viewer?
13:10
<alkisg>
Invalid card number? Maybe it's missing a module... No, vnc won't do.
13:10
https://help.ubuntu.com/community/UbuntuLTSP/AddingModules
13:11
<vagrantc>
alkisg: why not use ltsp-build-client?
13:11
<alkisg>
vagrantc: just because there's no need for it in that scenario
13:11
The OS will be inside the vbox disk
13:11
<vagrantc>
alkisg: ok, then... why use virtualbox?
13:11
<alkisg>
To have GUI access to the chroot
13:12
<vagrantc>
hmmm
13:12
basically so you don't have to understand what you're doing?
13:12
<alkisg>
Teachers know how to use GUIs but not console
13:12
So I'm thinking it'll be an alternative way for them to manage a chroot
13:12
E.g. how can one use sabayon in an ltsp chroot now?
13:13
Or gconf-editor? Or synaptic? Etc etc..
13:13
<vagrantc>
hrm.
13:13
<alkisg>
The same snippets could be used if one decides to have a normal workstation as a "chroot template"
13:13
I.e. not to have a vbox image, but a standalone PC, and use that as the chroot
13:14
I don't think more that 10-20 lines will be needed...
13:25mgariepy has joined #ltsp
13:41mistik1 has quit IRC
14:06
<m4xx_>
alkisg how else can i test this if not vnc? would it be possible to test using a windows box?
14:07
<alkisg>
m4xx_: with another pc...
14:07
Since it's already running on the server, I don't think vnc/windows will be helpful
14:07
<m4xx_>
all the other pc's i try all fail to pxe boot
14:07
<alkisg>
...but another thin client that only has a graphics driver different would tell you it's indeed a driver problem
14:07
!gpxe
14:07
<ltspbot>
alkisg: "gpxe" :: the successor to etherboot (http://etherboot.org). To download bootable floppy, cd, usb, kernel etc images, visit http://rom-o-matic.net/
14:07
<m4xx_>
i tried a netbook and an emachines
14:08
<alkisg>
Instead of pxe booting you can use gpxe ^^^
14:13cliebow has quit IRC
14:16
<vagrantc>
or apparently, ipxe... ugh.
14:17
<alkisg>
No rom-o-matic for ipxe yet ;)
14:22m4xx_ has quit IRC
14:22alkisg has quit IRC
14:42_UsUrPeR_ has quit IRC
14:47cliebow has joined #ltsp
14:58_UsUrPeR_ has joined #ltsp
14:59m4xx_ has joined #ltsp
14:59
<m4xx_>
i've tried to boot using that disk on 3 different computers, not one of them worked =[
15:02
i've tried to boot via nic pxe on 2 different computers, neither worked.
15:11cliebow has quit IRC
15:15* _UsUrPeR_ surveys his surroundings
15:16
<_UsUrPeR_>
m4xx_: what disk?
15:16
<m4xx_>
etherboot
15:17
<_UsUrPeR_>
woof
15:17
by "disk" do you mean 3.5" floppy?
15:22mgariepy has quit IRC
15:45
<m4xx_>
no i'm using the is and burned it to a cd
15:46
actually i did get it to bood from one nic's pxe but the screen was up side down some how
15:51Pacifica has joined #ltsp
16:19cliebow has joined #ltsp
16:20ogra has quit IRC
16:20alkisg has joined #ltsp
16:21ogra has joined #ltsp
16:21ogra is now known as Guest74620
16:25gorkhaan has quit IRC
16:26Guest74620 has quit IRC
16:27ogra_ has joined #ltsp
16:31ogra_ has quit IRC
16:32ogra_ has joined #ltsp
16:39m4xx_ has quit IRC
16:42gorkhaan has joined #ltsp
16:55alkisg has quit IRC
17:14bobby_C has quit IRC
17:21ogra_ is now known as ogra
17:21ogra has joined #ltsp
17:23mistik1 has joined #ltsp
17:23mistik1 has joined #ltsp
17:27komunista has quit IRC
17:35
<evil_root>
for anyone wondering, ltsp-cluster = awesome
17:48
<AndyGraybeal>
bice
17:48
nice
18:01Pweggle has quit IRC
18:15* cliebow stgraber!!!!!!
18:20staffencasa has quit IRC
18:28evil_root is now known as zz_evil_root
18:29johnny has joined #ltsp
18:48
<stgraber>
cliebow !!!
19:27vagrantc has quit IRC
19:46cliebow has quit IRC
19:55petre has joined #ltsp
19:55
<petre>
evening all
20:37pmatulis has quit IRC
20:37pmatulis has joined #ltsp
20:40
<highvoltage>
hey petre
21:02
<petre>
so, I installed Ubuntu 10.4 & LTSP using the alternate install CD
21:02
server has two nics, and while ifconfig shows them both up, I can't get a client to boot.
21:03
I've got tcpdump running on eth1, but I don't see any packets coming in when the client broadcasts a request for an IP address.
21:04
I've verified the cable is good, the switch works. I'm stumped.
21:04
The nic for eth1 is gigabit, and the switch has two gbit ports and 24 100Mb ports.
21:05
At first I was just using a 100Mb switch, as I'm just testing at this point.
21:06
But when the client wouldn't boot, I changed to the switch with the gbit port in case the card was not negotiating its speed down to 100Mb.
21:06
Anyone have any suggestions?
21:27petre has quit IRC
21:36daya has joined #ltsp
21:37robbie has joined #ltsp
21:38robbie is now known as robbie72
22:15johnny has left #ltsp
22:17robbie72 has quit IRC
23:01johnny has joined #ltsp
23:15sol326 has joined #ltsp
23:15
<sol326>
Does LTSP have dual screen ability??
23:20robbie72 has joined #ltsp
23:31alkisg has joined #ltsp