IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 27 March 2007   (all times are UTC)

00:38plamengr has joined #ltsp
00:48haz has joined #ltsp
00:51
<haz>
can anyone tell me whether or not i should be using xfs with my ltsp 4.2 setup? I am right now, but I don't really understand why :)
00:51
and it has a very annoying habit of leaving all these dead child processes around, when it clones itself it doesn't seem to cleanup the old procs
00:52
this is on debian testing
01:05
hmm actually i could be wrong, if the client limit is set to 10 does that mean i should see 10 child xfs processes? from the man page i thought that meant that a single process would handle 10 connections and then clone itself
01:06
anyway, i ask all this because i'm trying to get asian fonts to display on my thin-clients
01:18MoL0ToV has joined #ltsp
02:06haz has quit IRC
02:56|jon| has joined #ltsp
02:58|jon| has quit IRC
03:05tsw_ has joined #ltsp
03:06tsw has quit IRC
03:27vanya has joined #ltsp
04:09zald has quit IRC
04:38amit1 has joined #LTSP
04:40
<amit1>
problem: while trying to boot form lancard ERROE: TFTP cannot not connect
04:41
ERROR
04:41
any body ..?
04:45Maxou has left #ltsp
04:49spectra has joined #ltsp
04:53vanya has quit IRC
04:56ogra has quit IRC
05:15vanya has joined #ltsp
05:26ccherrett has quit IRC
05:26ccherrett has joined #ltsp
05:28Avatara has joined #ltsp
05:35ogra has joined #ltsp
05:37fordox has joined #ltsp
05:55klausade has quit IRC
05:55daya has joined #ltsp
05:56
<daya>
hi all
05:56
I am having problem in implemetig it
05:57
Xserver fail, press anykey to continue
06:00BadMagic has quit IRC
06:01BadMagic has joined #ltsp
06:03
<daya>
why no one here this big channle
06:12IRCzito has joined #ltsp
06:14
<cliebow>
its breakfast time...im boking it for school..bbiaab
06:14Shingoshi has quit IRC
06:15
<cliebow>
dya:lay out your prob so all can see...4.2 or 5? what type video card? what distro on server?
06:16Shingoshi has joined #ltsp
06:53jammcq has quit IRC
06:53daya has left #ltsp
06:55gigabytes has joined #ltsp
06:56gigabytes has quit IRC
07:18vanya has quit IRC
07:19vanya has joined #ltsp
07:20cliebow_ has joined #ltsp
07:21
<cliebow_>
ltspbot learn js asLumiere!!!!!!!!
07:21
<ltspbot>
cliebow_: (learn [<channel>] <key> as <value>) -- Associates <key> with <value>. <channel> is only necessary if the message isn't sent on the channel itself. The word 'as' is necessary to separate the key from the value. It can be changed to another word via the learnSeparator registry value.
07:21
<cliebow_>
ltspbot learn js as Lumiere!!!!!!!!
07:21
<ltspbot>
cliebow_: The operation succeeded.
07:22
<cliebow_>
ltspbot learn j as jammcq!!!!!!!!!!!!
07:22
<ltspbot>
cliebow_: The operation succeeded.
07:28IRCzito has left #ltsp
07:33amit1 has quit IRC
07:51bricode has joined #ltsp
07:59tiagovaz has joined #ltsp
08:01Arauto has joined #ltsp
08:18sbalneav has joined #ltsp
08:18plamengr has quit IRC
08:18
<sbalneav>
Morning all
08:19
<ogra>
!sbalneav
08:19
<ltspbot>
ogra: "sbalneav" is Scotty !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
08:19plamengr has joined #ltsp
08:19
<ogra>
:)
08:19
<sbalneav>
Morning ogra!
08:20
Hey, what's the "recommended" way to load apps from the second CD?
08:20
<ogra>
pop it in :)
08:20RiXtEr has joined #ltsp
08:20
<sbalneav>
Did a bunch of testing on Edubuntu last night, I only came up with one minor problem, which I think is a udev issue.
08:21
This one machine I installed on doesn't have a built in sound card, so I use a USB sound card (SoundBlaster NX)
08:21
The problem was: it didn't create the device at /dev/dsp, but rather, /dev/dsp1
08:21
<ogra>
hmm
08:21
<sbalneav>
so, sound wouldn't work at all.
08:21
<ogra>
weird
08:21
<bricode>
sbalneav: What's the weather like these days in the 'peg?
08:22
<sbalneav>
Added an extra udev rule in the links section to create a symlink from /dev/dsp1 to /dev/dsp, bingo
08:22
everything OK
08:22
<ogra>
are you sure there is absolutely nothing builtin ?
08:22
<sbalneav>
Yep, double, triple, and quad checked. Thats what I thought it was.
08:22
<ogra>
it shouldnt add the 1 if no dsp is there
08:22
<sbalneav>
nothing showed up in dmesg, and there was only the one card in /dev/snd
08:23
yep. But there appears to be no actual rules regarding sound cards in /etc/udev/rules.d that I could find, so I don't even know how it handles that.
08:23
<ogra>
weird, make sure to file a bug ... someone with soound or udev knowledge should look at it
08:23
<sbalneav>
bricode: thawing, and flooding my basement :(
08:24
Well, not yet, if I keep on top of it.
08:24
<bricode>
sbalneav: Lame. I'm headed out there on Thurs. for one of my dad's talks.
08:24
<ogra>
what do you all have with your basements atm ?
08:24
<sbalneav>
Well, it's a window well that's filling up.
08:24
Hopefully today will be better. I'm taking a risk, and showed up for work. I'll go home at lunch and check it.
08:25
ogra: ok, I'll file a bug-a-wug
08:25
<ogra>
good :)
08:25
didnt jammcq also have issues with his basement ?
08:26
<sbalneav>
Don't think so.
08:30jammcq has joined #ltsp
08:31
<sh3mh4mf0r4sh>
ogra: have a question about edubuntu
08:31
r u there>
08:31
?
08:32
well... anyway.. shoot a question 4 * #ltsp
08:34
i installed 2 weeks ago edubuntu .. now not have problem with devices. but the system is very slowly .. as slowly as stay blocked ... i'm talkin of server 3ghz with 2 g ram and the clients p4 2.6ghz with 256 ram but. have the network mounted in the hub layer to 10mb/s
08:34
is the network physically the problem?
08:35
oh! and are 15 clients
08:35
so have always 3 or 4 clients sessions blocked
08:35
have to make crtl+zlt+backspace
08:35
and run an script i made to resolve
08:36
killing all process of $client_blocked
08:36
and re-logging to can go..
08:36
<ogra>
10Mbit isnt enough ...
08:36
<sh3mh4mf0r4sh>
but occurs many times
08:36
yes i c
08:36
here my work
08:36
buy now switches
08:36
to 100mb/s
08:36
to can try fix the problem
08:37
but my point of view is this
08:37
is the network the problem
08:37
because
08:37
when i installed
08:37
<sbalneav>
Yeah, hubs are bad enough, because X is a very chatty protocol, and sends out LOTS of small packets.
08:37
<sh3mh4mf0r4sh>
4.2 with debian etch
08:37
<sbalneav>
a 10 meg hub is going to be even worse
08:37
<sh3mh4mf0r4sh>
okok.. but look this
08:37
check this..
08:37
1st time have 4.2 in debian etch
08:37
i just installed a base system
08:37
and iso
08:37
with same layer
08:38
and the clients
08:38
go more fastley
08:38
my fear
08:38
is ..
08:38
buy this switches.. and the problem stay continues
08:38
<neuralis>
sh3mh4mf0r4sh: please write more than a few words per line, it's highly annoying this way
08:38
<sh3mh4mf0r4sh>
neuralis: ok.. sorry
08:39
<sbalneav>
sh3mh4mf0r4sh: If you still have the problem after you buy switches, then we'll help you to fix it.
08:40
<sh3mh4mf0r4sh>
uhm. ok .. is a good point. but what you can said me when i has the version 4.2 ...in that moment have some problems with pen drives with ountend and other thins.. so have to upgrade with this solution (edubuntu).. but now appears this
08:41
is obviuslly the networks stay fater because all the system mov in the net
08:41
but is strange.. how before run more rapidlly as now.
08:41
i guess.. because edubuntu have many packages...
08:42
<ogra>
what kind of desktop did you use on the debian system ?
08:42
<sh3mh4mf0r4sh>
well edubuntu by default show gnome
08:42
ahh
08:42
sorry
08:42
in debian use same
08:42
gnome gnome
08:42
<ogra>
a gnome desktop ?
08:42
<sh3mh4mf0r4sh>
yes
08:45
so? .. making a conference .. or have any idea.. my boss askme all days. if i have solution for this.. (anyway the swith is going to buy) but while??
08:59McDutchie has quit IRC
09:15randall_nowan has quit IRC
09:36vagrantc has joined #ltsp
09:47ogra has quit IRC
09:49Avatara has quit IRC
09:49Avatara has joined #ltsp
09:52arowanaj_ has joined #ltsp
09:53
<arowanaj_>
Hi!
10:00ogra has joined #ltsp
10:06MoL0ToV has quit IRC
10:18Dorphalsig has joined #ltsp
10:18
<Dorphalsig>
Hello =)
10:18
has anybody tried running ltsp on a mac?
10:19oh207 has quit IRC
10:20
<vagrantc>
Dorphalsig: i know it's been done ...
10:21bjohnson has joined #ltsp
10:24
<Dorphalsig>
yeah I just found an article about thta
10:24
although I believe its old, because its in the sf.net site
10:34efra has joined #ltsp
10:38RiXtEr has quit IRC
10:47vanya has quit IRC
10:54
<cliebow_>
Dorphalsig, i do some with Macintosh
10:59
<sh3mh4mf0r4sh>
ok... have a switch 100mbs for the clients... let c.. how clients survive now :)
10:59jammcq has quit IRC
11:05bjohnson has quit IRC
11:11Avatara has quit IRC
11:14Avatara has joined #ltsp
11:15petre has joined #ltsp
11:15
<petre>
morning all
11:17
<cliebow_>
hey!
11:17
<petre>
hey chuck!
11:18
<cliebow_>
how goes it all?
11:20
<petre>
I inherited a Mac Powerbook G3. It's got a built-in ethernet port. Can these netboot?
11:20jammcq has joined #ltsp
11:20
<cliebow_>
!j
11:20
<ltspbot>
cliebow_: "j" is (#1) jammcq!!!!!!!!!!!!!!!, or (#2) jstraw!!!!!!!!!!!!!!!!!!!!!!!!, or (#3) jammcq!!!!!!!!!!!!
11:21
<jammcq>
knucklehead
11:21
<cliebow_>
Heh!
11:21
Lumiere keeps messing with my head
11:24
<Avatara>
if your mac network adapter supports PXE and you kernel and LTSP enviroment compiled for PPC arch - why not <petre> I inherited a Mac Powerbook G3. It's got a built-in ethernet port. Can these netboot?
11:24
<cliebow_>
sure
11:26
<petre>
my k12ltsp 5 server supports ppc machines, as I've run them on it before
11:26
but I haven't had any macs for a while
11:26
with this g3, how do I get it to netboot? I tried holding down the N key during boot but it didn't do anything
11:27
<Avatara>
read manual for this book
11:28
<cliebow_>
petre:if you check that escurity-mode=none in opfw
11:28
petre: you can hold cmd-option-o-f at chime and boot to opfw
11:28
<petre>
lemme try that...
11:28
<cliebow_>
then type boot enet:ipofserver
11:29
<petre>
is cmd=apple key?
11:29
<cliebow_>
err..
11:29
yeah
11:30
you will need options in dhcpd.conf to wake it up..got that piece?
11:31
<petre>
which options?
11:32
stuff like 'filename "yaboot"'?
11:33
<ltsppbot>
"cliebow" pasted "authoritative; subnet 192.168." (34 lines) at http://pastebot.ltsp.org/75
11:34
<cliebow_>
this kind of stuff..the wierdvedndor-encapsulated--> stuff
11:35
<petre>
yeah, I think I've got all that, courtesy of Eric
11:36
<cliebow_>
there Are some machines that dont seem to responfd to n key..but cant be started from opfw
11:36
<petre>
hmm, can't seem to get the opfw to kick in
11:36
<cliebow_>
and later set to automagically use those boot parameters
11:37
maybe it is old enough it has no firmware?
11:38
<petre>
well, it's only got 32MB RAM, OS 9; not sure about the processor
11:40
<cliebow_>
you are stuck with option then of a chubby client..which is not really an option since no one has ever worked out the details for g3
11:42
<petre>
so, a g3 is not a g3 is not a g3?
11:43
<cliebow_>
yeah..
11:43
i dont know at what point they started woith opfw
11:45
<petre>
looks like some time after this g3 was made
11:46
I found a web page that says the version of opfw can be found under the Apple menu
11:47
then under Apple System Profiler; there's supposed to be a 'Boot ROM version' listed, but I don't have one
11:47
:-(
11:47
CPU is 233mhz
11:48
<cliebow_>
SOL then..i always used mklinux booter for the nubus machines..it wouldnt work on g3..and i had just one g3..so did not mess around thrying to make yaboot work on early g3 for chubby client use
11:50
<petre>
I wonder if an older version of ydl would work on this, at least the point of starting X
11:52
<cliebow_>
i did have ydl running on an old g3..it is what i used to tweak the ppc kernel
11:52
<petre>
what version of ydl?
11:52
<cliebow_>
2.3 i think it was...ubuntu wont work on it?
11:54fbifido has quit IRC
11:55sbalneav has quit IRC
11:55
<petre>
hmm, I've got the edubuntu live cd for ppc; think it will work with 32MB RAM, just to get to command prompt/no gui?
11:55King`Nothing has joined #ltsp
11:56
<cliebow_>
Balls!probably not
11:56
but ydl wont either..
11:57
<King`Nothing>
hi:) I want to ask you how to use usplash or other bootsplash loader in ltsp 5?
11:57
<petre>
the CD spun up, but then it just started os 9 from the hard disk; nuts
11:57
<cliebow_>
even holding down c?
11:59
<petre>
yep, even holding down c
12:00
it's got vnc installed on the hard disk, and I just got that to connect to the ltsp server--not perfect, but it might do
12:00
<cliebow_>
i dont think even nx will work
12:00
<petre>
how do I set that to load automatically at boot?
12:01
<cliebow_>
lordy .in os9..it has been to lonng..
12:10vagrantc has quit IRC
12:22
<Lumiere>
lol
12:22
I rule XD
12:25
<cliebow_>
i got my very first knucklehead out of it!
12:25* Lumiere strips cliebow_ of his _...
12:26
<cliebow_>
!
12:27Shingoshi has quit IRC
12:31pavka has joined #ltsp
12:42
<cliebow_>
ltspbot forget j
12:42
<ltspbot>
cliebow_: Error: 3 factoids have that key. Please specify which one to remove, or use * to designate all of them.
12:42
<cliebow_>
ltspbot forget j*
12:42
<ltspbot>
cliebow_: Error: There is no such factoid.
12:45
<jammcq>
ltspbot forget j(*)
12:45
<ltspbot>
jammcq: Error: There is no such factoid.
12:45
<jammcq>
ltspbot forget j[*]
12:45
<ltspbot>
jammcq: Error: "*" is not a valid command.
12:45
<jammcq>
ltspbot is a jerk
12:45
<ltspbot>
jammcq: Error: "is" is not a valid command.
12:46
<pavka>
hello everybody
12:46
<jammcq>
hello
12:47
<pavka>
can someone help me? Ive installed ltsp-5 on my ubuntu
12:47
<jammcq>
and.... ?
12:47
<pavka>
and Ive problem with Xserver detection
12:47
<jammcq>
what kind of video card?
12:47
<pavka>
Is posible to configure clients S3 as VESA_
12:47
?
12:48
<jammcq>
yeah, in lts.conf, set XSERVER = vesa
12:48
in /opt/ltsp/i386/etc
12:48
I dunno how well 'vesa' works with s3. you might also try: XSERVER = s3
12:48
<pavka>
It works in ltsp-4, but in ltsp5?
12:48
<jammcq>
try in ltsp-5
12:49
<pavka>
no, in thin client is right configured Xorg as S3, but it doesnt works. In ltsp4 ive configured vesa, it works fine
12:49
<jammcq>
ok, so then try XSERVER = vesa
12:49
<pavka>
i think, in ltsp5 is another configuration scheme
12:50
<jammcq>
XSERVER = vesa should still work
12:50
<pavka>
Ill try it
12:50
<jammcq>
ok
12:53
<pavka>
no, in xorg.conf is still generated s3 driver
12:54
<jammcq>
show me your lts.conf file. paste it to http://pastebot.ltsp.org
12:54
<pavka>
only your line
12:54
I dont have another option this time
12:54
<jammcq>
did you put [Default] ?
12:54
<pavka>
no :D
12:54
<jammcq>
well
12:55
Perhaps you should look at this page:
12:55
http://wiki.ltsp.org/twiki/bin/view/Ltsp/LtsConf
12:57
<pavka>
I know this configuration, but its for ltsp4. My old configuration stops work after upgrade to ltsp5
12:57
<jammcq>
ok, but the format of the file is the same
12:57
you need:
12:57
[Default]
12:57
<pavka>
so I began with empty configuration
12:57
<jammcq>
XSERVER = vesa
12:57
empty? or just a '[Default]' ?
12:57
if you show me your file, I'll know EXACTLY what you have
12:58
<pavka>
yeah, Xorg works
12:58
but only X
12:58
<jammcq>
dunno what that means
12:58
<pavka>
Id like use -query, its posible in 5 too?
12:59
<jammcq>
umm, you can set: SCREEN_07 = startx
12:59
<pavka>
no Xorg --query x.x.x.x?
12:59
<jammcq>
startx already does a query
13:00
you could probably do:
13:00
SCREEN_07 = startx -query x.x.x.x
13:00Avatara has quit IRC
13:01Gadi has joined #ltsp
13:02
<pavka>
great
13:02
I see login screen
13:02
and now last problem
13:02
mouse doesnt work in X
13:03
<jammcq>
what kind of mouse?
13:03
<pavka>
X_DEVICE_OPTION_01?
13:03
ps2
13:03
<jammcq>
hmm, that should just automatically work
13:03
<pavka>
maybe here isnt kernel module
13:03
I dont know
13:03
<jammcq>
for what, ps2 mouse?
13:03
heh
13:04
we'd all be in big trouble if there wasn't
13:04yhan has joined #ltsp
13:05
<pavka>
Ill find solution later. No time this time. Tnx a lot
13:05
<jammcq>
no prob
13:05
<yhan>
hi, is there a documentation somewhere for pxelinux.cfg ?
13:05
I'm trying to setup a term visara tn3270
13:06
it's booting the kernel, but it tries to mount the nfs share on the dhcp server
13:06
<jammcq>
using LTSP ?
13:06
<yhan>
the nfs server is not on the same machine
13:06
yes
13:06
<jammcq>
what distro?
13:06
<yhan>
ubuntu
13:06
<jammcq>
ogra_: did you add that ability yet?
13:06
<yhan>
it's working great with a standard pc as term
13:06
<jammcq>
ltsp-4.2 could do that just fine
13:06Gadi has quit IRC
13:06
<yhan>
but not with the term visara
13:07
<jammcq>
but I don't know anything about the visara
13:07
it's not up to pxelinux.cfg tho
13:07
it's a dhcp issue
13:07gigabytes has joined #ltsp
13:07
<yhan>
my dhcp config has option root-path "/opt/ltsp/i386";
13:07
next-server 192.168.0.100;
13:07Gadi has joined #ltsp
13:08
<jammcq>
'next-server' is for tftp
13:08
<yhan>
192.168.0.100 is my tftp and nfs server
13:08
I also have server-name "galinea.yhan.ath.cx";
13:08
galinea is 192.168.0.100
13:09
I've installed the tftp server on the same machine as the dhcp server to give it a try
13:09
it's was not booting at all
13:10
the only missing piece is the nfs server
13:10
<jammcq>
i'm not sure if that's been fixed in ltsp-5
13:10
ogra was thinking about doing that
13:20
<yhan>
ok when the term boots; at a moment it says ip=192.168.0.155:192.168.0.100:192.168.0.150
13:21
is it possible that the last line would be the nfs server ?
13:21
<jammcq>
i'm not sure if that's been fixed in ltsp-5
13:21
ogra was thinking about doing that
13:28
<yhan>
term says ready after booting the kernel
13:28
even if the dhcp server is on the same machine as the nfs server
13:29Shingoshi has joined #ltsp
13:30
<mistik1>
Hey jammcq
13:39sep__ has joined #ltsp
13:39sep__ is now known as sepski
13:41bricode has quit IRC
13:55blinky_ghost has joined #ltsp
13:56
<blinky_ghost>
hello can anybody help me or point me directions to setup a bootsplash on ltsp-4.2?
13:59gigabytes has quit IRC
14:01sepski has quit IRC
14:09sh3mh4mf0r4sh has quit IRC
14:19
<plamengr>
Hi, all :)
14:19
Have you already configured Local printers or scanners in LTSP-5?
14:22Tegel has quit IRC
14:22Tegel has joined #ltsp
14:25
<plamengr>
...or any success in configuring Floppy as a Local Dev?
14:25sbalneav has joined #ltsp
14:25
<jammcq>
!sbalneav
14:25
<ltspbot>
jammcq: "sbalneav" is Scotty !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
14:26
<sbalneav>
Hey hey!
14:28
<plamengr>
sbalneav: sorry again for the bothering.... Is there something new for Floppy as a Local Dev?
14:29
<agliodbs>
hey sbalneav
14:29
sbalneav: doing FISL?
14:32sh3mh4mf0r4sh has joined #ltsp
14:35
<sbalneav>
Yes I am!
14:36pavka has quit IRC
14:40
<yhan>
how can I debug the boot of the kernel on a terminal ?
14:41plamengr has quit IRC
14:44plamengr has joined #ltsp
14:46
<cliebow_>
ltspbot factoids
14:46
<ltspbot>
cliebow_: Error: "factoids" is not a valid command.
15:08pavka has joined #ltsp
15:09bobby_C has joined #ltsp
15:09
<pavka>
jammcq: so, my problem with mouse isnt solved
15:10
jammcq: I tried all posible devices, all posible protocols, and mouse dont move :(
15:11blinky_ghost has quit IRC
15:13
<agliodbs>
sbalneav: look forward to it. chacuscarria!
15:13
and you *must* go to the pizza place
15:16
<jammcq>
agliodbs: I thought you were a vegetarian
15:17
<agliodbs>
jammcq: the salad bars at those places are huge
15:17
and they sometimes have fish too
15:18
at one the owner was afraid I'd be hungry so he gave me a whole filet of salmon, grilled
15:20cliebow_ has quit IRC
15:22King`Nothing has quit IRC
15:31
<yhan>
how can I force a term to use a video driver in xorg ?
15:31
with lts.conf ?
15:33
<sbalneav>
XSERVER = whatever
15:35
<yhan>
thks
15:36
almost done to setup my terms
15:36
video driver glitch
15:36
it's a cyrix video board and it's not detected automaticly
15:37
an another problem to solve later on, is to make it boot faster
15:38
btw how can I disable acpi ? a kernel option ?
15:46
what is the variable name in lts.conf for the color depth ?
15:47primeministerp has quit IRC
15:48jammcq has quit IRC
15:48
<yhan>
found it X_COLOR_DEPTH
15:50tiagovaz has quit IRC
15:52Arauto has quit IRC
15:54pavka has left #ltsp
16:38plamengr has left #ltsp
16:43Arnoldtje has joined #ltsp
16:44
<Arnoldtje>
Hi there?
16:46
after installing LTSP and setting runlevel 5 the terminal says "unable to open /etc/inittab: no such file or directory at /usr/sbin/ltspcfg line 142, <STDIN> line4."
16:47Arnoldtje has quit IRC
17:05n4r0z4 has joined #ltsp
17:26
<gonzaloaf_work>
hello I'm using ltsp 4.2, if I use a xorg.conf file for eah client like ws00x.xorg.conf, do I have use a complete xorg.conf file? I just want my clients to load some more modules
17:29
<cliebow>
well you could use a specialize XF86CONFIg-FILE
17:29
hel
17:29
well you could use a specialize XF86CONFIG_FILE
17:30mistik1 has quit IRC
17:30
<gonzaloaf_work>
cliebow, I'm not doing that?
17:31
<cliebow>
http://wiki.ltsp.org/twiki/bin/view/Ltsp/LtsConf
17:33
<gonzaloaf_work>
cliebow, what I want is just to add some more lines to the default xorg.conf that ltsp use for my clients, not a complete xorg.conf
17:35
<cliebow>
X4_MODULE_01 through X4_MODULE_10..will that suit you..otherwise might have to ping someone else
17:36
4.2 it seems is passe..though i think iti s greatest thing since sliced bread
17:37n4r0z4 has quit IRC
17:37bobby_C has quit IRC
17:41mistik1 has joined #ltsp
17:50Dorphalsig has quit IRC
18:06edgarin has joined #ltsp
18:06
<edgarin>
Hi!
18:08
<cliebow>
ho!
18:08
<edgarin>
cliebow, how are u?
18:15
<cliebow>
oh putting dinner together..
18:27yhan has quit IRC
18:30petre has quit IRC
18:50jammcq has joined #ltsp
18:54edgarin has quit IRC
19:13ogra has quit IRC
19:22ogra has joined #ltsp
19:22ogra_ has quit IRC
19:22
<dan__t>
Ok, so... where does my /opt/ltsp/i386/ root pull its files from?
19:23
A specified copy of stuff required from / ?
19:23
<jammcq>
what distro>
19:23
?
19:23ogra_ has joined #ltsp
19:23
<dan__t>
FC6
19:23
I don't "see" it
19:23
<jammcq>
it pulls the files from the LTSP download mirror
19:23
<dan__t>
word.
19:24
Should I expect to find modules for specific devices off of said download mirror?
19:24
<jammcq>
no
19:24
everything that ltsp supports will get installed when you run ltspadmin, and select all
19:24
<dan__t>
thanks.
19:24
I'm tinkering with sound today.
19:25
<jammcq>
all devices supported by ltsp are in the ltsp-modules package
19:25
<dan__t>
Very cool, thank you.
19:26
Looks like sound support can be a daunting task.
19:27
<jammcq>
it can be, but if you have a pci sound card, it shouldn't be too bad
19:27
<dan__t>
Alright.
19:27
It's onboard, a Yamaha, which is assumed to be PCI.
19:28
I was not able to find what the normal "procedure" is, for updating LTSP. Is there one?
19:28
I'm using 4.2 under, again, FC6.
19:29
<jammcq>
just run ltspadmin, if there's any updates, it'll tell you
19:29
<dan__t>
awesome.
19:29
<jammcq>
there hasn't been any updates in quite a while. we're putting most of our efforts into ltsp-5
19:29
<dan__t>
Excellent.
19:29
Will that be upgrade-able?
19:29
Or... guess it doesn't matter huh.
19:30
<jammcq>
not upgradable
19:30
but you can install it alongside 4.2
19:30
<dan__t>
Awesome.
19:30
Sorry for all the questions - still learning a bit.
19:41sbalneav has left #ltsp
19:43
<cliebow>
4.2 still rocks in my book!
19:44
<dan__t>
word.
19:44
Does 4.2 update at all, or is it like a frozen tree
19:46
er, sorry, that was a dumb question.
19:47
<cliebow>
not much being done with it rightnow...
19:48
<dan__t>
yep.
19:49
<cliebow>
dan-_T:personaly i'd like to see some of the ideas incorporated back..but i'm not the one with savvy enough to do it..
19:52
<dan__t>
Such as what?
19:53efra has quit IRC
20:12
<dan__t>
Ok, so, I must have changed my LTSP installation path when I first installed.
20:12
How does LTSP know which packages should be marked for update/upgrade etc etc?
20:16
<jammcq>
when you run ltspadmin, it grabs a file from the ltsp download site called packages.list
20:17
that contains all the versions of the latest programs
20:17
it compares that with the packages currently installed
20:33
<dan__t>
Oh yeah, forgot, sorry.
20:34
Where is that local package list kept?
20:35ogra_ has quit IRC
20:36ogra has quit IRC
20:36
<jammcq>
it's in /opt/ltsp/data/package.db
20:36ogra has joined #ltsp
20:36ogra_ has joined #ltsp
20:42adam_ has joined #ltsp
20:43adam_ is now known as agike
20:44PMantis has joined #ltsp
20:44
<PMantis>
hi guys
20:44
Anyone have a couple minutes to talk Perl?
20:45
<jammcq>
heh
20:46
<PMantis>
forecch $problem as ($steve-dont-understand) { $jammcq->fix($problem); }
20:46
:-)
20:47
<jammcq>
ah, the object oriented approach
20:47
<PMantis>
And you're the object. :
20:47
:)
20:48
If you have a minute... you remember this code: http://superb-east.dl.sourceforge.net/sourceforge/hours2ledger/sql-ledger-hours-email
20:48
Line 78= foreach $line (split(/\n/, $procheaders))
20:48
<jammcq>
lets' take this out of #ltsp
20:48
<PMantis>
ok
21:04ChinaForge has joined #ltsp
21:05
<ChinaForge>
hello
21:05
Can you help me?
21:06
I install ltsp-5 in ubuntu 6.10,
21:06
<dan__t>
If a question is asked, I'm sure an answer will be provided.
21:06vagrantc has joined #ltsp
21:06
<ChinaForge>
but ia can't find rdesktop screen script.
21:07
<jammcq>
I don't think that ltsp-5 supports rdesktop yet
21:07
<ChinaForge>
why?
21:08
<jammcq>
not enough hours in the day
21:09agike has quit IRC
21:09adam_ has joined #ltsp
21:09
<vagrantc>
it shouldn't be hard to adapt the rdesktop scripts from ltsp 4.x for ltsp5
21:09
<jammcq>
installing the rdesktop binary should be real easy
21:10
<vagrantc>
not that i know *anything* about rdesktop
21:10
other than what it is and what it does
21:10
<jammcq>
I don't have any windows servers to test it against
21:11
<ChinaForge>
4.2 is support.
21:12
I english no good,so slow.
21:13
<jammcq>
ChinaForge: LTSP-5 doesn't support rdesktop
21:14
<ChinaForge>
4.2 support,5 doesn't,why?
21:14
<vagrantc>
ChinaForge: because you didn
21:14
't get it to work! :P
21:14
<jammcq>
because LTSP-5 is VERY different from LTSP-4.2
21:14
<ChinaForge>
o
21:14
<vagrantc>
it's 0.8 more LTSP!
21:15
<jammcq>
heh
21:15
very funny
21:16
<ChinaForge>
i can't display all our talk message,why?
21:16
setting?
21:16
font?
21:17agike has joined #ltsp
21:17
<ChinaForge>
now ok.
21:20
i can install 4.2 and 5 in one system?
21:20
<jammcq>
yes
21:20
install it to /opt/ltsp-4.2
21:20
instead of /opt/ltsp
21:21
<ChinaForge>
i try,thank you.
21:24
i use startx screen script no good too,
21:24
i use Thinkpad,
21:25
<jammcq>
startx should be fine. BUT, use SCREEN_07, instead of SCREEN_01
21:25
<ChinaForge>
in login window i can't input username and password.
21:26
must use SCREEN_07?
21:26sbalneav has joined #ltsp
21:26
<jammcq>
!sbalneav
21:26
<ltspbot>
jammcq: "sbalneav" is Scotty !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
21:26
<sbalneav>
hey hey
21:26
<jammcq>
now all I gotta do is setup a shortcut key, to do the '!sbalneav' thing
21:26
ltspbot s is sbalneav
21:26
<ltspbot>
jammcq: Error: "s" is not a valid command.
21:27
<jammcq>
ltspbot help
21:27
<ltspbot>
jammcq: (help [<plugin>] [<command>]) -- This command gives a useful description of what <command> does. <plugin> is only necessary if the command is in more than one plugin.
21:28
<jammcq>
!s
21:28
<ltspbot>
jammcq: "s" is sbalneav
21:28
<jammcq>
hmm
21:28
maybe later
21:28
<sbalneav>
ltspbot: forget s
21:28
<ltspbot>
sbalneav: The operation succeeded.
21:29
<jammcq>
!s
21:29
<sbalneav>
ltspbot: learn s as Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
21:29
<ltspbot>
jammcq: Error: "s" is not a valid command.
21:29
sbalneav: The operation succeeded.
21:29
<sbalneav>
!s
21:29
<ltspbot>
sbalneav: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
21:29
<sbalneav>
Howzzat?
21:29
<jammcq>
heh
21:30
<agike>
!s
21:30
<ltspbot>
agike: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
21:30
<sbalneav>
What we need is a bot that looks for joins, and then issues a greeting.
21:30
<agike>
heh
21:30
<sbalneav>
We could call it "normbot"
21:30
<ChinaForge>
jammcq,Thank you.
21:30
<agike>
Yeah, but will it walk the dog .. ?
21:31
<jammcq>
dunn
21:31
o
21:32
<ChinaForge>
exit
21:32ChinaForge has quit IRC
21:35ChinaForge has joined #ltsp
21:35
<ChinaForge>
startx screen script on SCREEN_07 is OK.
21:40pscheie has quit IRC
21:40agike has quit IRC
21:45
<vagrantc>
we should probably start making a list of the features not yet implemented in ltsp5
21:45
that can turn into a TODO list
21:45
presuming we want it all.
21:49adrianorg has joined #ltsp
21:49
<sbalneav>
We want it all
21:49
We want it all
21:49
We want it all
21:49
And we want it now
21:50
(apologies to Freddie Mercury)
21:52
<jammcq>
we are the champions
21:52RiXtEr has joined #ltsp
21:54
<sbalneav>
aaand weeeeeeeeell keep on fiiiiiiiiighting, till the eeeeeeeeeeeend!!
21:54
<whiprush>
sbalneav: don't quit your day job! :)
21:54* sbalneav goes to check whiprush.org
21:55
<sbalneav>
Firefox can't find the server at www.whiprush.org.
21:55
<whiprush>
that's a bummer.
21:55ccherret1 has joined #ltsp
21:55
<sbalneav>
I'll say
21:55ccherrett has quit IRC
21:55
<whiprush>
sbalneav: jam been telling you how awesome ltsp has been for us this past month?
21:56
<sbalneav>
He's mentioned that you've had a certain degree of success
21:56
Liking it?
21:56
<whiprush>
rocking and rolling.
21:56
expanding our deployment
21:56
<sbalneav>
Enjoying the taste of the kool-aid? :)
21:58
What programs are you mainly running? Student stuff like web + OO.o?
21:58
<whiprush>
no, a bunch of engineering apps
21:58
close sourced stuff
21:59
<sbalneav>
Ah. Like what? Linux apps, or under wine?
21:59
<whiprush>
linux apps, but like cad stuff
21:59
and others
21:59
matlab, marc mentat, unigraphics, comsol.
22:00
<sbalneav>
Nice.
22:00
<whiprush>
I make custom icons on their desktop, they just execute.
22:00
<sbalneav>
Using Sabayon?
22:00
<whiprush>
the platform stuff (ubuntu, ltsp, gnome, etc) just generally needs to be out of the way, which it does wonderfully.
22:00
I have sabayon with centralized profiles on a dev server, but not in production.
22:01
<sbalneav>
Sabayon's quite spiffy.
22:01
<whiprush>
indeed.
22:01
I have a new ltsp-dev environment with three servers, which I am managing with a tool called puppet.
22:02
once I get the kinks out I need to show this to you.
22:02
I have a PXE + preseed + puppet all tied together, so I can go from bare metal to full blown ltsp server in about ... 20 minutes.
22:03
with all the site specific goodies and everything
22:04
<sbalneav>
Coolio
22:04
Sounds like it'd make a good blog entry. Go on, Bruce has faded back into obscurity :)
22:05adrianorg has quit IRC
22:20gonzaloaf_laptop has joined #ltsp
22:24ChinaForge has quit IRC
22:25adam_ is now known as agike
23:00Bhaskar has joined #ltsp
23:02
<Bhaskar>
I have Xserver failed, how can i solve ? please any one can help me?
23:05
ogra, I have Xserver failed, how can i solve ? p
23:07
<sbalneav>
Bhaskar: Which version of LTSP are you using, and on what distro?
23:08
<Bhaskar>
sbalneav, ltsp4.2
23:08
k12ltsp
23:08
i have FC5
23:08
<sbalneav>
What does your lts.conf file look like?
23:08
Paste it to the pastebot
23:08
!pastebot
23:08
<ltspbot>
sbalneav: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
23:09japerry has joined #ltsp
23:10
<japerry>
heya, I've been working on trying to get LTSP 4.2 to work with sound all day, but the documentation on it is fairly sparce, anyone here know more about setting it up?
23:14
<sbalneav>
Have you checked the wiki?
23:14
<japerry>
yup
23:14
I keep seeing references to /etc/profile.d/ltsp-esound.sh (or ltsp_sound.sh)
23:14
<sbalneav>
Everything you need's in there
23:14
<japerry>
but I cannot find where to d/l that
23:15
<sbalneav>
Should be a link to it on that page, I beleive
23:15
<japerry>
ohh wait I might have found something
23:15
it'd be nice if old references could be changed to indicate what version of LTSP it goes it
23:16
s/it/to
23:16
<ltsppbot>
"Bhaskar" pasted "Xserver problem" (10 lines) at http://pastebot.ltsp.org/76
23:16
<sbalneav>
It's a wiki, anyone can update it.
23:17
Bhaskar: That's not your lts.conf file.
23:17
<japerry>
well, for example: http://wiki.ltsp.org/twiki/bin/view/Ltsp/Sound#NASD_ESD_and_ALSA
23:18
<sbalneav>
From /opt/ltsp/i386/etc/lts.conf
23:18
<japerry>
doesn't indicate that it works for 4.2, the download is for 4.1
23:18
<sbalneav>
Guess no-one's updated it.
23:18
We're working fairly hard on ltsp5
23:18
<vagrantc>
maybe someone should test that it works and update the wiki.
23:20
<sbalneav>
vagrantc: is pulseaudio packaged for Debian?
23:21
Bhaskar: You need to paste your /opt/ltsp/i386/etc/lts.conf file.
23:22ChinaForge has joined #ltsp
23:24
<ChinaForge>
ltsp 4.2 and ltsp 5 in one system,work is good.
23:25
<ltsppbot>
"Bhaskar" pasted "Xserver problem" (209 lines) at http://pastebot.ltsp.org/77
23:25
<vagrantc>
sbalneav: yes. support for it in ltsp isn't.
23:26
<Bhaskar>
sbalneav, check it
23:26
<vagrantc>
sbalneav: no idea how well the pulseaudio in debian works ... i tried it once ... don't remember if i suceeded or not.
23:27
<sbalneav>
Bhaskar: ok, so it's set to auto as a default, so the video card you have in there isn't autodetecting. What kind of video card do you have in the terminal?
23:29
<ChinaForge>
hello,how can in ldm use chinese?
23:29
<Bhaskar>
sbalneav, i forget, how can i check video card?
23:32
<sbalneav>
On the terminal, you can do an lspci
23:33
ChinaForge: Good question. Don't know if LDM has the right input support.
23:33RiXtEr has quit IRC
23:34
<ChinaForge>
i hope display only
23:34
<sbalneav>
Bhaskar: Alternatively, you could try setting the XSERVER from "auto" to something like "vesa"
23:35
ChinaForge: Once you log in, do you get the chinese characters?
23:35
<ChinaForge>
how to get the chinese characters?
23:36
<sbalneav>
What linux distribution are you using?
23:36
<ChinaForge>
ubuntu 6.10
23:36
<sbalneav>
Have you installed the right language pack?
23:37
<ChinaForge>
i think right.
23:38
<sbalneav>
Can you do a "dpkg -l | grep language-pack" for me?
23:38
<ChinaForge>
ok
23:39
senhua@ubuntu610-server:~$ dpkg -l | grep language-pack
23:39
ii language-pack-en 6.10+20070311 translation updates for language English
23:39
ii language-pack-en-base 6.10+20061019 translations for language English
23:39
ii language-pack-gnome-en 6.10+20070311 GNOME translation updates for language Engli
23:39
ii language-pack-gnome-en-base 6.10+20061019 GNOME translations for language English
23:39
ii language-pack-gnome-zh 6.10+20070311 GNOME translation updates for language Chine
23:39
ii language-pack-gnome-zh-base 6.10+20061019 GNOME translations for language Chinese
23:39
ii language-pack-zh 6.10+20070311 translation updates for language Chinese
23:39
ii language-pack-zh-base 6.10+20061019 translations for language Chinese
23:40
<sbalneav>
ok, so you've got the chinese language loaded.
23:40
Can you see the chinese characters on the console?
23:40
<ChinaForge>
yes
23:40
<sbalneav>
Can you see them on a terminal?
23:41
<ChinaForge>
yes
23:41
can't ldm only.
23:41
<sbalneav>
Then I'd expect that LDM itself simply hasn't been localized.
23:41
<ChinaForge>
in select language,no chinese.
23:42
<sbalneav>
Someone who speaks chinese will have to provide translations, so that the right strings can be printed for ldm/
23:42
<Bhaskar>
sbalneav, i change auto into vesa , in terminal one graphics containing Hz ? is moving, what is the problem
23:43
<sbalneav>
Bhaskar: You're monitor is probably not syncing. What kind of monitor is it?
23:43
<ChinaForge>
sbalneav,thank you.
23:43ChinaForge has quit IRC
23:43
<Bhaskar>
sbalneav, samsung
23:43
<sbalneav>
That tells me nothing.
23:44
<Bhaskar>
sbalneav, samsung 591s
23:44
<sbalneav>
Is it a flatpanel or a crt?
23:44
<Bhaskar>
crt
23:45
<sbalneav>
What kind of resolution is it capable of displaying?
23:45
1024x768?
23:45
800x600?
23:45
etc.
23:45tsw_ is now known as tsw
23:45
<Bhaskar>
sbalneav, 800x600 and 640x480
23:46
<sbalneav>
ok, then you'll probably need to add a line like X_MODE_0 = 800x600
23:50
That help at all?
23:51
<Bhaskar>
sbalneav, i addedbut not solved
23:53
<sbalneav>
So, what does it say now?
23:53
<Bhaskar>
sbalneav, same problem
23:54
sbalneav, Hz ? moving on terminal
23:54
<sbalneav>
What happens if you hit control-alt-keypad-+
23:55
i.e. the + on the numeric keypad of your computer.
23:55
<Bhaskar>
sbalneav, i uncoment line 85 hz resolution and X_MODE_0=800x600
23:56
thanks
23:56
sbalneav, i got success
23:56
<sbalneav>
ok, so what resolution does it look like?