IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 30 November 2010   (all times are UTC)

00:06Naruni has joined #ltsp
00:16sweetpi has joined #ltsp
00:20litlebuda has quit IRC
01:29Uzzi has joined #ltsp
01:39bobby_C has joined #ltsp
02:13hahlo has quit IRC
02:13hahlo has joined #ltsp
02:13gnunux has joined #ltsp
02:15
<gnunux>
hi
02:15dlezcano has joined #ltsp
02:27dobber has joined #ltsp
03:13MephistoM has left #ltsp
03:18sweetpi has quit IRC
03:27
<Uzzi>
grrr I can't log all users, it goes in timeout
03:33jimjimovich has joined #ltsp
03:33
<jimjimovich>
hi all
03:34
I was wondering, does anyone have experience with printing from Windows XP to a printer that is connected to an ltsp thin client?
03:51Trixboxer has joined #ltsp
04:00Axachi has joined #ltsp
04:01
<Axachi>
Appiah. I filed a bug report on Launchpad. about the $* "$@" bug in maverick 10.10.
04:02
<alkisg>
Axachi: actually that was me, not Appiah... :)
04:02
(about the "$@" etc)
04:02
<Appiah>
:)
04:02bobby_C has quit IRC
04:02
<alkisg>
But no problem, Appiah can help you too, he's a good LTSPer ;)
04:06
<Axachi>
oh sorry alkisg :)
04:06
you rock alkisg. I have a teflon brain.. :P
04:07
<alkisg>
:D
04:07
So anyway about the bug report, I guess someone of the devs that uses rdesktop will see + fix it...
04:07
<Axachi>
I need help on an other matter.
04:08
I needto get some printers going they are connectedlocally on the thin clients..
04:08
Hope they will.
04:09
https://bugs.launchpad.net/ltsp/+bug/682706
04:11
So annyone good on PRINTER_0_DEVICE?
04:13
<Appiah>
whats the prob?
04:15
<Axachi>
I tried putting this in lts.conf and I can not telnet to the ip and port 9100 on the thin client
04:16bobby_C has joined #ltsp
04:17
<Axachi>
I made print connection in Microsoft print serve.. added a port using HP jetdirect. and put in the ip of the thin client.
04:18
What was the link to put in the conf file that I have?
04:19
[00:23:7D:10:7F:BE]
04:19
PRINTER_0_NAME="HP LaserJet Series II"
04:19
PRINTER_0_DEVICE=dev/usb/lp0
04:19
PRINTER_0_TYPE=U
04:22
anyone?
04:23
!help
04:23
<ltspbot>
Axachi: (help [<plugin>] [<command>]) -- This command gives a useful description of what <command> does. <plugin> is only necessary if the command is in more than one plugin.
04:23
<Axachi>
!
04:26
Do I need to install anything into the chroot for this to work.. like I did with the ltspfs?
04:27
<Appiah>
cups
04:32
<Axachi>
?
04:33
apt-get install cups?
04:45
<ogra_ac_>
Axachi, no, dont install cups
04:45
find out why jetpipe doesnt start on the client instead
04:45
have you tried a different printer device ?
04:45
(/dev/usblp0 is a common one)
04:46mrcarrot has joined #ltsp
04:46
<mrcarrot>
i have been forgetting how to change a ltsp system away from squashfs to nfs... can somebody help. i have tried to google for documentation and last time it also took really long time to find
04:47
<alkisg>
ogra_ac_: is this only for HP printers? Or do all printers support jetpipe?
04:47
<ogra_ac_>
alkisg, heh, i got a dejavu :)
04:47
<alkisg>
ogra_ac_: right I forgot to ask this one though :D
04:47
<ogra_ac_>
you asked me that two weeks ago, no ?
04:47
<alkisg>
mrcarrot: https://help.ubuntu.com/community/UbuntuLTSP/LTSPWithoutNFS
04:47
ogra_ac_: not exactly, but similar
04:48
<ogra_ac_>
alkisg, jetpipe is a dumb port forwarder, as long as the device exists it will work
04:48
*some* HP printers need additional USB driver stuff which is in hplip or so
04:49
<mrcarrot>
thanks alkisg
04:49
<alkisg>
thanks ogra_ac_ :)
04:49ogra_ac_ is now known as ogra_ac
04:50
<ogra_ac>
(or in hpijs, not sure)
04:53
<mrcarrot>
alkisg: this is not working with debian lenny :(... i need to run backport version of ltsp because of some requirements from the customers and the latest backport is making the clients to not boot through squashfs
04:54
that is why i need old good nfs
04:58dlezcano has quit IRC
04:58alkisg has quit IRC
05:02alexqwesa has quit IRC
05:04alexqwesa has joined #ltsp
05:09
<Axachi>
urg sorry was on lunch her.. :)
05:10
How do I test jetpip.. on the client
05:10
<ogra_ac>
run an xterm as localapp and check the processlist and logs
05:12
<Axachi>
If I run jetpipe it pops an error.. IndexError: list indesx out of range
05:12
line 123 in <module>
05:13
<ogra_ac>
sounds like a bug in jetpipe
05:13
<Axachi>
opps how do I run a localapp? (Microsoft Consultant her :P be gental)
05:14
<ogra_ac>
!localapp
05:14
<ltspbot>
ogra_ac: Error: "localapp" is not a valid command.
05:14
<ogra_ac>
!localapps
05:14
<ltspbot>
ogra_ac: "localapps" :: to access a tutorial on setting up localapps on jaunty, see https://help.ubuntu.com/community/UbuntuLTSP/LTSPLocalAppsJaunty
05:14
<Axachi>
wow cool
05:15
<ogra_ac>
i guess you can ignore that its for jaunty
05:16
<Axachi>
oki
05:16
but should I be able to telnet the client on its ip and port 9100
05:16
?
05:17
<ogra_ac>
if jetpipe runs this port should be available
05:17
your prob seems to be that it doesnt start at all
05:17
<Axachi>
oki
05:18
so can i do a ps -ef | grep jetpipe ?
05:19
it comes up with a line
05:19
<ogra_ac>
sounds good, where did you see the index out of range error then ?
05:19
<Axachi>
if I only run jetpipe in shell
05:20
<ogra_ac>
on the server ?
05:20
<Axachi>
no on client
05:20
<ogra_ac>
with the right options ?
05:20
<Axachi>
no
05:20
<ogra_ac>
(see the line from ps)
05:20
<Axachi>
only jetpipe :)
05:20
<ogra_ac>
right, it wont have the right options that way
05:21
<Axachi>
how can I test
05:21
what command must I type ?
05:21
<ogra_ac>
well, if jetpipe already runs for that port you first need to kill it
05:22
then run the same command you saw in your ps output
05:24
<Axachi>
well taht only states jetpipe and notin behind?
05:25
I killed it no there is noting from ps
05:25
well it started right up agian
05:26chupacabra has quit IRC
05:27
<Axachi>
hmmm I can not see jetpipe if I do top..
05:31alkisg has joined #ltsp
05:44bobby_C has quit IRC
05:45mrcarrot has left #ltsp
05:48
<Axachi>
Well I got it working starting i manually..
05:48
it
05:49
I did jetpipe /dev/usblp0 9100 and out came my test page :)
05:50
but wy wont it start with printer_0_device /dev/usblp0 in lts.conf?
05:51
<ogra_ac>
are you sure thats your device in lts.conf ?
05:53
<Axachi>
what do you mean? [mac] and under I have printer_0_device /dev/usblp0.
05:57
<Uzzi>
I've problems with autentication. login screen works, but after typing password, no authentication and X doesn't start and login screen compare again
05:57
<Axachi>
well is password strong enough? Like Password10 ?
05:59
<Hyperbyte>
Uzzi, have you looked at logfiles? Have you tried to manually log in from the client to the server (like via SSH), to see if that works?
06:00
<Uzzi>
now I'm loging into the server by ssh
06:00
<Hyperbyte>
There is also an lts.conf option (LDM_DEBUG if memory serves) which instructs LDM (the login manager) to write a logfile in /var/log/ on the client, might also contain some useful information.
06:01
<Uzzi>
Hyperbyte, I've not ldm dir in /var/log
06:01
<Hyperbyte>
Take a look at the lts.conf documentation and turn on LDM debugging
06:01
<Uzzi>
k
06:01
<Hyperbyte>
Then after a client reboot there should be an ldm logfile
06:02
<ogra_ac>
Axachi, your lts.conf paste further above showed /dev/usb/lp0
06:02
Axachi, and no slash in front of /dev
06:02
<Axachi>
ah will check :)
06:16
no change.. :(
06:17
I changed the line to PRINTER_0_DEVICE=/dev/usblp0 and PRINTER_0_PORT=9100 but it is not starting..
06:18
but port should be set default to 9100 right..
06:18
<ogra_ac>
dont set the port
06:18
<Axachi>
k
06:18
<ogra_ac>
PRINTER_0_DEVICE=/dev/usblp0 is the only line you need
06:19
and dont forget you need to reboot the client after changing
06:19
<Axachi>
yea I know :P
06:26
nope wont start..
06:27
what script is starting it. as there where errors in the rdesktop screen script on maverick ther might be one for this as well :)
06:29
hmm if I do getltscfg -a I get no PRINTER_0_DEVICE...
06:29
<ogra_ac>
aha
06:31
smells like your lts.conf is either broken or lives in the wrong place
06:31
<Axachi>
well everything els works in it :P
06:32bobby_C has joined #ltsp
06:32
<Axachi>
hmm exept the thing I put under the MAC address ... I will try somting else..
06:32
<ogra_ac>
mac address should be fine
06:32
how about you put your lts.conf to a pastebin ;)
06:33
<Axachi>
!pastebin
06:33
<ltspbot>
Axachi: "pastebin" :: the LTSP pastebin is at http://ltsp.pastebin.com. Please paste all text longer than a line or two to the pastebin, as it helps to reduce traffic in the channel. Don't forget to paste the URL of the text here.
06:35
<Axachi>
http://ltsp.pastebin.com/CJCdmi7n
06:35
and as you scan thru it. is there a way to set a password on the menu item ?
06:41
<ogra_ac>
line 25 is broken
06:41
unless you have usblp01 on your thin client ;)
06:41
<Axachi>
i do
06:42
<ogra_ac>
01 ??
06:42
did you hack the kernel ?
06:42
<Axachi>
that is what I type when I do it manualy as well
06:42
?
06:42
no
06:42
<ogra_ac>
there is definitely no usblp01
06:42
should be usblp0
06:42
or if you have a second printer usblp1
06:42
but surely not 01
06:44
<Axachi>
thx changed it..
06:49mrcarrot has joined #ltsp
06:50
<mrcarrot>
after an upgrade of ltsp i get the thumbdrives mounted under /tmp/.username instead of under /media/username
06:50
in what file do i change this back?
06:55bobby_C has quit IRC
07:01
<Axachi>
what is the format on PRINTER_0 in lts.conf?
07:02
I trid PRINTER_0_DEVICE= /dev/usblp0 or is it only PRINTER_0_DEVICE /dev/usblp0 ?
07:05
I get syntax error.. on the PRINTER_0_DEVICE line..
07:20mrcarrot has left #ltsp
07:34jimjimovich has left #ltsp
07:34
<Axachi>
the lts.conf file was corupt. works now :)
07:34
thx for all the help
07:35
Now is there a way to set a login for when using menu?
07:42
<Appiah>
set login? as in autologon?
07:45vmlintu has quit IRC
08:00dlezcano has joined #ltsp
08:14Uzzi has quit IRC
08:14Uzzi has joined #ltsp
08:39Appiah has quit IRC
08:41muppis has quit IRC
08:42muppis has joined #ltsp
08:44whatch has joined #ltsp
08:45
<whatch>
Going to give skolelinux a try. I already have a dhcp server on my Windows Server 2008 domain. Where can I find clear instructions on how to use my current dhcp server. Thanks
08:48mikkel has joined #ltsp
08:52
<whatch>
where can I find good instructions on how to use my current windows dhcp server?
08:56eghie has joined #ltsp
08:58eghie has quit IRC
09:07gorkhaan has quit IRC
09:14
<alkisg>
whatch: skolelinux? That's not related to LTSP, is it?
09:14zz_evil_root is now known as evil_root
09:14
<alkisg>
Here are the docs for using a windows dhcp server with LTSP: https://help.ubuntu.com/community/UbuntuLTSP/LTSPWindowsDHCP
09:15evil_root is now known as zz_evil_root
09:18komunista has joined #ltsp
09:19
<whatch>
looking for as little configuring as possible. Skolelinux comes with it out of box. thanks for the help
09:20
<Axachi>
Appiah:no not autologin.. If I use the SCREEN_10 menu MENU_ITEM_01="Linux Shell" MENU_COMMAND_01="shell" is what I mean
09:20
I use windows 2008 dhcp
09:21
no prob on ubuntu distro. one nic as well
09:21gorkhaan has joined #ltsp
09:21
<Axachi>
install with apt-get install ltsp-server only not -standalone
09:23
It pops up. with a menu. but I don't want users to see it if they are not authenticated... :)
09:23
the menu that is :P
09:30whatch has quit IRC
09:43dlezcano has quit IRC
10:00Gadi has joined #ltsp
10:03artista_frustrad has quit IRC
10:03gnunux has quit IRC
10:09Axachi has quit IRC
10:12Uzzi has quit IRC
10:13Uzzi has joined #ltsp
10:14litlebuda has joined #ltsp
10:20staffencasa has joined #ltsp
10:31Uzzi has quit IRC
10:52[GuS] has joined #ltsp
10:52[GuS] has joined #ltsp
11:06dobber has quit IRC
11:12itcharlie has joined #ltsp
11:28litlebuda has quit IRC
11:30litlebuda has joined #ltsp
12:18dlezcano has joined #ltsp
12:39[GuS] has quit IRC
12:48Trixboxer has quit IRC
12:53shogunx has quit IRC
12:55shogunx has joined #ltsp
13:26toscalix has joined #ltsp
13:33blahal-rix has joined #ltsp
13:36RiXtEr has quit IRC
13:41toscalix has quit IRC
14:15vagrantc has joined #ltsp
14:19litlebuda has quit IRC
14:20litlebuda has joined #ltsp
14:26chupacabra has joined #ltsp
15:09Gadi has left #ltsp
15:32sidartha has joined #ltsp
15:33
<sidartha>
is anyone familiar with how to change the umask setting in karmic? I want to allow my students to be able to share editing of certain files.
15:39
<alkisg>
sidartha: https://wiki.ubuntu.com/MultiUserManagement and https://help.ubuntu.com/community/UbuntuLTSP/ACLSupport
15:49komunista has quit IRC
15:53sidartha has quit IRC
15:54dgroos has joined #ltsp
16:04bobby_C has joined #ltsp
16:16dgroos has left #ltsp
16:27robbie72 has joined #ltsp
16:36mikkel has quit IRC
16:38itcharlie has left #ltsp
16:57alkisg has quit IRC
17:00vagrantc has quit IRC
17:16johnny has left #ltsp
17:32ogra_ac_ has joined #ltsp
17:35ogra_ac has quit IRC
17:36johnny has joined #ltsp
17:40robbie72 has quit IRC
17:46blahal-rix has quit IRC
17:52bobby_C has quit IRC
18:14sweetpi has joined #ltsp
18:19RiXtEr has joined #ltsp
18:39staffencasa has quit IRC
19:02mistik1_ has joined #ltsp
19:05mistik1 has quit IRC
19:05mistik1_ is now known as mistik1
20:29ogra has quit IRC
20:32RiXtEr has quit IRC
20:32RiXtEr has joined #ltsp
20:37zz_evil_root is now known as evil_root
20:42ogra has joined #ltsp
20:55MorningSon has joined #ltsp
21:04alexqwesa has quit IRC
21:04alexqwesa has joined #ltsp
21:23ltspbot` has joined #ltsp
21:24ltspbot has quit IRC
21:38Appiah has joined #ltsp
22:06litlebuda has quit IRC
22:10johnny has left #ltsp
22:11Mip5 has joined #ltsp
22:16
<Mip5>
Evening folks - I'm at the initramfs prompt after a system update dist-upgrade. I'm at 10.04. Any ideas?
22:20MorningSon has quit IRC
22:40
<Mip5>
Okay - I'll check back in the morning. G'night.
22:41Mip5 has left #ltsp
22:41johnny has joined #ltsp
22:51alkisg has joined #ltsp
22:52
<johnny>
alkisg, is there anything to make the connect to server dialog sane? i can't believe this atrocity is still default
22:52
it doesn't even remember what you've typed in before
22:52
<alkisg>
Good morning
22:52
What dialog?
22:54
<evil_root>
morning alkisg
22:55
i also got a question for ya alkisg if you have played with the ltsp-cluster
22:55
<alkisg>
Nope, sorry, never seen it working
22:55
<evil_root>
dam
22:56
i got it all working but there is this stupid harware inventory screen that loads on the thin client before the login
22:56
i just want to disable that inventory
22:56
but other then that the thing runs like a champ
22:59
<johnny>
connect to server..
22:59
Places | Connect to Server
23:01
<evil_root>
johnny connect to server... for what? is this ltsp?
23:06
<alkisg>
johnny: you can make bookmarks for most of the things you put in that dialog
23:06
<johnny>
alkisg, i know, buti don't want to bookmark them
23:06
that implies i want to connect to them at some other point and time other than the current session
23:06
seems like it could at least save what you've typed in previously.. like in a web browser
23:06
<alkisg>
Well, that's about all the alternatives I know. The next one is submitting patches to the upstream code and hoping they'll accept it. :)
23:07
<johnny>
i've seen some replacements actually, i was just hoping you had one to recommend, guess not
23:37sweetpi has quit IRC