IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 24 January 2008   (all times are UTC)

00:05chupa has joined #ltsp
00:07chup has quit IRC
00:45misui has quit IRC
00:49zodma1 is now known as zodmna
00:49zodmna is now known as zodma1
00:49zodma1 is now known as zodman
00:50chup has joined #ltsp
00:52chupa has quit IRC
01:38sep has joined #ltsp
01:42chupa has joined #ltsp
01:44chup has quit IRC
02:21yanu has quit IRC
02:23Q-FUNK has joined #ltsp
02:32chup has joined #ltsp
02:34chupa has quit IRC
02:47Patina has joined #ltsp
02:48tux_440volt has joined #ltsp
03:00tux_440volt has quit IRC
03:01floppybaer has joined #ltsp
03:02bobby_C has joined #ltsp
03:22yanu has joined #ltsp
03:23ogra has joined #ltsp
03:29chupa has joined #ltsp
03:33chupa has quit IRC
03:33bobby_C has quit IRC
03:33chup has quit IRC
03:33zodman has quit IRC
03:33Egyptian[Home] has quit IRC
03:33BadMagic has quit IRC
03:33topslakr_ has quit IRC
03:33monteslu has quit IRC
03:33gu has quit IRC
03:33jim`` has quit IRC
03:33johnny has quit IRC
03:33F-GT has quit IRC
03:33gentgeen__ has quit IRC
03:33oh207 has quit IRC
03:33abadger1999 has quit IRC
03:33loather-work has quit IRC
03:33ninkendo has quit IRC
03:33Topslakr has quit IRC
03:33rcy has quit IRC
03:34BadMagic has joined #ltsp
03:34chupa has joined #ltsp
03:34bobby_C has joined #ltsp
03:34zodman has joined #ltsp
03:34Egyptian[Home] has joined #ltsp
03:34topslakr_ has joined #ltsp
03:34monteslu has joined #ltsp
03:34gentgeen__ has joined #ltsp
03:34johnny has joined #ltsp
03:34abadger1999 has joined #ltsp
03:34oh207 has joined #ltsp
03:34rcy has joined #ltsp
03:34jim`` has joined #ltsp
03:34F-GT has joined #ltsp
03:34Topslakr has joined #ltsp
03:34loather-work has joined #ltsp
03:34gu has joined #ltsp
03:34ninkendo has joined #ltsp
03:41yanu has quit IRC
03:42mikkel_ has joined #ltsp
04:11chupa has quit IRC
04:14yanu has joined #ltsp
04:23ace_suares has quit IRC
04:23ace_suares has joined #ltsp
04:38abadger1999 has quit IRC
04:40abadger1999 has joined #ltsp
04:42ogra has quit IRC
04:42floppybaer has quit IRC
04:42Q-FUNK has quit IRC
04:42sep has quit IRC
04:42jbrett has quit IRC
04:42elisboa has quit IRC
04:42sutula has quit IRC
04:42vernier__ has quit IRC
04:42cyberorg has quit IRC
04:42rjune_ has quit IRC
04:42moquist has quit IRC
04:42GiantPickle has quit IRC
04:42dberkholz has quit IRC
04:42mistik1 has quit IRC
04:42vagrantc has quit IRC
04:42Joris has quit IRC
04:43vagrantc has joined #ltsp
04:43Joris has joined #ltsp
04:44dberkholz has joined #ltsp
04:44mistik1 has joined #ltsp
04:44GiantPickle has joined #ltsp
04:44moquist has joined #ltsp
04:44ogra has joined #ltsp
04:44floppybaer has joined #ltsp
04:44Q-FUNK has joined #ltsp
04:44sep has joined #ltsp
04:44jbrett has joined #ltsp
04:44elisboa has joined #ltsp
04:44sutula has joined #ltsp
04:44cyberorg has joined #ltsp
04:44rjune_ has joined #ltsp
04:44vernier__ has joined #ltsp
04:45iMacGyve1 has joined #ltsp
04:55iMacGyver has quit IRC
04:58Guaraldo has joined #ltsp
05:00elisboa has quit IRC
05:11moquist has quit IRC
05:24vagrantc has quit IRC
05:50floppybaer has quit IRC
06:39elisboa has joined #ltsp
06:48bobby_C has quit IRC
06:54bobby_C has joined #ltsp
07:08cliebow_ has joined #ltsp
08:20joebaker has joined #ltsp
08:26exodos has joined #ltsp
08:32DonSilver has joined #ltsp
08:32
<cliebow_>
!seen sbalneav
08:32
<ltspbot>
cliebow_: sbalneav was last seen in #ltsp 3 days, 21 hours, 53 minutes, and 39 seconds ago: <sbalneav> I've been hellishly busy
08:32
<cliebow_>
He's ALIVE!
08:51DonSilver has quit IRC
08:54Gadi has joined #ltsp
09:00DonSilver has joined #ltsp
09:00floppybaer has joined #ltsp
09:14cdealer__ has joined #ltsp
09:14
<cdealer__>
hi all ...
09:14cyberorg has quit IRC
09:15
<cdealer__>
how can I change the default language from the ltsp client to soemthing else then english ?
09:18spectra has joined #ltsp
09:43DonSilver_ has joined #ltsp
09:43DonSilver_ has joined #ltsp
09:44primeministerp has joined #ltsp
09:50DonSilver has quit IRC
09:54elisboa has quit IRC
09:54elisboa has joined #ltsp
10:05bobby_C has quit IRC
10:10DonSilver_ has quit IRC
10:15misui has joined #ltsp
10:36rasmuson has joined #ltsp
10:44cdealer__ has quit IRC
10:50exodos has quit IRC
10:52sepski has joined #ltsp
10:55DonSilver has joined #ltsp
11:17DonSilver has quit IRC
11:26K_O-Gnom has joined #ltsp
11:33indradg has joined #ltsp
11:38lns has quit IRC
11:56indradg has quit IRC
12:04BadMagic has quit IRC
12:08BadMagic has joined #ltsp
12:27misui has left #ltsp
12:27K_O-Gnom has quit IRC
12:28artista-frustrad has joined #ltsp
12:29artista-frustrad has quit IRC
12:30artista_frustrad has joined #ltsp
12:32cdealer__ has joined #ltsp
12:35
<BadMagic>
compiz is getting better... Not sure what I just changed (that helped compiz overall), but now mplayer doesn't want to render xv. It will work if I -vo x11. What is the problem with compiz / nvidia / xv?
12:35rasmuson has quit IRC
12:35
<cdealer__>
Gadi: its possible to make a local printer to be seen by the server ?
12:37
<johnny>
you can always pretend it's remote
12:37
when you add it
12:37
use IPP
12:37
that should work
12:40
<cdealer__>
johnny: but the local printer is connected to a ltsp client ...
12:40
<johnny>
hmm.. that's odd
12:40
why?
12:41
<cdealer__>
johnny: a ltspclient have a printer (some deskjet) connected to his computer... and want to use it...
13:04
...
13:06
the major problem Im having is the fact of the clients having no sound... this problem I dont know how to workaround... any problem or tip on how to make sound to work on the clients?
13:06
<johnny>
i don't have speakers on my clients.. so i haven't tried out sound
13:11
<cdealer__>
sound is something that must have here...
13:11
=/
13:12
well... tomorrow we give a look on that
13:12cdealer__ has left #ltsp
13:20
<cliebow_>
any one have a logrotate scheme to snapshot rsynced homedirs
13:20
?
13:23dniel has joined #ltsp
13:48dniel has quit IRC
13:53Guaraldo has left #ltsp
13:59fprimex_ has joined #ltsp
14:04fprimex has joined #ltsp
14:05fprimex has left #ltsp
14:05fprimex has joined #ltsp
14:06
<fprimex>
Hi all. I have successfully set up ltsp using ubuntu, and would like to make it so that the client has access to all local hard disk drives and usb when booted. I have read a few things on how to enable support for CDROMs and USB, but can't find info on hard disks. can someone help me with this configuration?
14:09
err, think I found the answer.. brb if doesn't work...
14:13EDinNy has joined #ltsp
14:15sepski has quit IRC
14:15fprimex has quit IRC
14:16EDinNy has quit IRC
14:23zodman has quit IRC
14:35kyron has left #ltsp
14:39fprimex has joined #ltsp
14:40
<fprimex>
ok back... I installed ltspfs and that caused the floppy drive to show up, but still no hard disk drive (it has an NTFS partition on it)
14:44
tried it on another computer and it sees the dell utility partition (which is a type of FAT) - so I assume that it has something to do with the HD being NTFS
14:45
<johnny>
ntfs should be readable out of the box, unless the kernel in the chroot is purposefully built without it
14:46
do you have ntfs3g ? you need that if you want to write
14:46
maybe that has to be installed in the chroot
14:51
<fprimex>
yep, I can read / write USB NTFS hard drives
14:51
on the main computer, that is
14:51
how could I check the chroot for NTFS support?
14:53
<johnny>
i'd suggest installing ntfs3g in the chroot
14:53
<fprimex>
ok
14:55
<Gadi>
fprimex: easier than that - make a root password for the chroot and log in on tty1
14:56
then, on the client cat /proc/filesystems
14:56
<fprimex>
err, I'm already sudo ltsp-update-image'ing
14:57
<Gadi>
seems ntfs module is in just not loaded by default
14:57
see if: MODULE_01 = ntfs
14:57
works in lts.conf
14:57
<fprimex>
will have to wait for this to complete, but I will check those things in a client as soon as I can
14:58
<Gadi>
okey dokey
14:58Gadi has quit IRC
15:02Gadi has joined #ltsp
15:04
<fprimex>
Gadi: I did a sudo su - to get root, and while fuse and fuseblk are in the list of /proc/filesystems, there is nothing about ntfs
15:05vagrantc has joined #ltsp
15:05
<Gadi>
fprimex: on the client console?
15:05
<fprimex>
does MODULE_01 = ntfs need to be under a section?
15:05
<Gadi>
ctrl-alt-f1?
15:05
<fprimex>
Gadi: yes
15:05
oh, no
15:05
<Gadi>
why do you need sudo?
15:05
did you not login as root?
15:06
<fprimex>
no, because it's ubuntu, but sudo su - gives root on ubuntu
15:06
<Gadi>
dont confuse the client and server :)
15:06
only on the server
15:06
not on your thin client
15:06
<fprimex>
ah
15:06
<Gadi>
I dont think ur looking on the thin client
15:06
<johnny>
ntfs is only write
15:06
err
15:06
ntfs module is only read
15:06
you have to have fuse loaded to write
15:07
and ntfs3g installed
15:07
<Gadi>
right - the kernel mod is only read
15:07
the fuse-based mod is both
15:07
<fprimex>
fuse, fuseblk, and fusectl appear on both
15:07
<johnny>
and you should already have fuse if you have ltspfs
15:07
<Gadi>
but, for that, you need to load fuse
15:07
<johnny>
right?
15:07
<Gadi>
not on the client
15:07
<johnny>
oh ok
15:07
<Gadi>
the *thin client* needs fuse
15:07
now, it is probably in there
15:07
you could try: MODULE_01 = fuse
15:08
and then see if it will mount
15:08
<fprimex>
does that need to be under a section like [Default] or anything?
15:08
<Gadi>
yes
15:08
<fprimex>
ok
15:08
<Gadi>
it should be in: /var/lib/tftpboot/ltsp/i386/lts.conf
15:08
you should have a [default]
15:08
section
15:08
and then a series of param=value
15:08
lines
15:09
you do NOT need to reroll the image
15:09
just edit that file and reboot
15:09
<fprimex>
Ubuntu says to put it in /var/lib/tftpboot/ltsp/i386/lts.conf, which didn't exist
15:09
<Gadi>
create it
15:09
it doesnt exist by default
15:09
ltsp does not *need* a conf file
15:10
unless you change from the defaults
15:11
<fprimex>
ok, booting up again :)
15:11
<Gadi>
if you set SCREEN_07=ldm and SCREEN_02=shell , you can ctrl-alt-f2 to get to the thin client shell
15:12
from there, you can play and figure things out
15:12* vagrantc suspects if you're using ltspfs, that it will use the kernel ntfs support rather than the ntfs3g fuse stuff
15:12
<Gadi>
like modprobe fuse, etc
15:12
vagrantc: the thin client does not load the ntfs module by default
15:12
so, it wont use either
15:13K_O-Gnom has joined #ltsp
15:13
<vagrantc>
sure, but you're going to have to hack up the udev rules and/or udev hooks to support the fuse-based ntfs support
15:14bobby_C has joined #ltsp
15:14
<Gadi>
ah, that may be true - I suppose the fuse based one doesnt honor the ntfs filesystem type?
15:14* vagrantc thinks about getting gphotofs support, which is also fuse based
15:14
<fprimex>
Gadi: no luck, and now the desktop is not coming all the way up. I get my panel though
15:15
<vagrantc>
my guess is it will look at the filesystem and see that it's ntfs, and try the in kernel ntfs if present
15:16
hacking the client's /lib/udev/add_fstab_entry may be the place to check the filesystem type ...
15:16
i remember there were differences at one point in how ubuntu and debian handled that stuff ...
15:16
<fprimex>
yeah, I think ubuntu defaults to 3g now
15:17
<Gadi>
right - but udev will report ntfs - the question is whether the fuse-based ntfs support honors that
15:17
<vagrantc>
i.e. weather to put "auto" for filesystem type, or actually specify the filesystem type from the udev rules
15:17
<Gadi>
or if you need to specify it as some other type
15:17* vagrantc suspects it will require some hacking
15:24
<fprimex>
how would I request to have ltpfs mount a local hard disk drive?
15:24
from df, I cannot tell what the device for the mounted DellUtility partition is
15:25
ltspfs, I mean
15:27cliebow_ has quit IRC
15:30
<vagrantc>
fprimex: look at all the devices in /media/username and see if any have the stuff you're looking for
15:30
<fprimex>
nope, just DellUtility, nothing else
15:30
<vagrantc>
on debian, i recently disabled the mounting of non-removable media
15:31
but i suspect ubuntu still mounts it
15:31
Gadi: i even used the patch you provided to the udev rules and credited you in the debian changelog :P)
15:32* vagrantc doesn't have any idea what that emoticon is
15:33
<vagrantc>
Gadi: see, you're famous: http://packages.qa.debian.org/l/ltspfs/news/20080114T173207Z.html
15:35K_O-Gnom has quit IRC
15:36mikkel_ has quit IRC
15:38
<fprimex>
I'm up for udev editing suggestions :)
15:38
<vagrantc>
fprimex: so is the device mounted, just not showing anything ?
15:38
<fprimex>
no, DellUtility is of type FAT and mounted fine. the actual Windows installation is nowhere to be found
15:38
that's the NTFS partition
15:39
<vagrantc>
ok, so you want to mount the NTFS partition?
15:39
<fprimex>
yep
15:39
<vagrantc>
ah, mentioning the DellUtility confused me- i thought that's what you wanted to mount ...
15:39
!localdev
15:39
<ltspbot>
vagrantc: "localdev" is (#1) Information regarding using pluggable devices and cdroms with LTSP can be found at http://wiki.ltsp.org/twiki/bin/view/Ltsp/LTSP-42-LocalDev, or (#2) for ubuntu: https://wiki.ubuntu.com/EnableLTSP5LocalDevices, or (#3) for debian-edu: http://wiki.debian.org/DebianEdu/HowTo/LocalDeviceLtspfs, or (#4) http://wiki.ubuntu.com/DebugLocalDev
15:40
<fprimex>
nope, that worked great after installing ltspfs
15:40
<vagrantc>
fprimex: take a look at the DebugLocalDev instructions ... you'll want to see if it's added in /var/run/ltspfs_fstab or /etc/fstab
15:40
<fprimex>
ok
15:41
<Gadi>
YaY - I love being famous
15:45
<fprimex>
I wonder if there is any difference between a USB ntfs partition and an internal ntfs partition
15:48
yes - external ntfs showed up when plugged in, but the window is empty
15:49
<Q-FUNK>
hehehe
15:50
<vagrantc>
otavio: so, i posted to pkg-ltsp-devel about getting different lintian results when built on a buildd and built locally ... any ideas on that?
16:06Egyptian[Home] has quit IRC
16:11Egyptian[Home] has joined #ltsp
16:11mistik1_ has joined #ltsp
16:11mistik1 has quit IRC
16:11mistik1_ is now known as mistik1
16:20fprimex has left #ltsp
16:22
<otavio>
vagrantc: yes ...
16:22
vagrantc: will take a bath and then we chat about it...
16:29
<vagrantc>
otavio: i might have to go soon ... need to get outside :)
16:30
otavio: i you miss me, please respond a bit on the pkg-ltsp-devel thread
16:31vagrantc has quit IRC
16:40Q-FUNK has quit IRC
17:21bobby_C has quit IRC
17:23mischko has joined #ltsp
17:36Gadi has left #ltsp
17:39Egyptian[Home] has quit IRC
17:50vagrantc has joined #ltsp
17:51
<vagrantc>
otavio: you back yet?
18:09haz___ has joined #ltsp
18:10
<haz___>
hi, i need to change the DPI on a particular client and was hoping there was would be a way of doing it from lts.conf, but it looks like there isn't. can anyone suggest the easiest way of doing this?
18:17* vagrantc notes that popularity-contest scores for ltsp-server in debian jumped about 50% in the last week ...
18:18
<johnny>
that's cuz vagrantc == popular
18:18
duh
18:18
<vagrantc>
hmmm... not according to the graph ... maybe i just forgot the numbers
18:18
http://people.debian.org/~igloo/popcon-graphs/index.php?packages=ltsp-server
18:19
<haz___>
umm, surely someone else has set custom DPI workstation settings?
18:19
should i use a custom XF86Config for that ws?
18:24moquist has joined #ltsp
18:35mischko has quit IRC
18:43haz___ has quit IRC
19:05vagrantc has quit IRC
20:13ari_stres1 has joined #ltsp
20:20J45p3r has joined #ltsp
21:01tracerout has joined #ltsp
21:03J45p3r has quit IRC
21:52subir has joined #ltsp
22:08vagrantc has joined #ltsp
22:12tracerout has quit IRC
22:35ari_stres1 has quit IRC
22:46zodman has joined #ltsp
23:38moquist has quit IRC