IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 26 December 2009   (all times are UTC)

01:33Kicer86 has joined #ltsp
01:41alkisg has quit IRC
02:15Kicer86 has quit IRC
02:25Kicer86 has joined #ltsp
02:43Kicer86 has quit IRC
02:51alkisg has joined #ltsp
03:04Faithful has quit IRC
03:06Faithful has joined #ltsp
03:24Kicer86 has joined #ltsp
03:32Faithful has quit IRC
03:33Faithful has joined #ltsp
04:15Faithful has quit IRC
04:16Faithful has joined #ltsp
04:21Kicer86 has quit IRC
04:27Kicer86 has joined #ltsp
04:44ogra has quit IRC
04:46ogra has joined #ltsp
05:28alkisg has quit IRC
05:44osjoberg_ has joined #ltsp
05:47johnny has left #ltsp
05:47johnny has joined #ltsp
05:47
<osjoberg_>
hi, i have a development machine and i want to be able to display windows on a ltsp-client, i want to do this on the development machine's initiative
05:48
i can't get it to work using xhost
05:49
i tried putting the xhost command in an S-runlevel script of ldm
05:50
but that doesn't work neither
05:50
does anybody know how to do it?
05:58
satan
06:13osjoberg_ has quit IRC
06:45Selveste1 has quit IRC
07:21Sarten-X2 has joined #ltsp
07:27Sarten-X has quit IRC
08:08Kicer86 has quit IRC
09:08Selveste1 has joined #ltsp
09:43alkisg has joined #ltsp
09:55Ahmuck-Jr_ has joined #ltsp
10:01Ahmuck-Jr_ has quit IRC
10:02Ahmuck-Jr has quit IRC
10:08GiantPic1le has joined #ltsp
10:09GiantPickle has quit IRC
10:43pmatulis has joined #ltsp
10:53Ahmuck has quit IRC
10:57Ahmuck has joined #ltsp
11:10Ahmuck has quit IRC
11:11Ahmuck has joined #ltsp
11:17Ahmuck has quit IRC
11:19Ahmuck has joined #ltsp
11:26alkisg has quit IRC
11:30Ahmuck has quit IRC
11:34Ahmuck has joined #ltsp
12:37Kicer86 has joined #ltsp
12:44scottmaccal has joined #ltsp
12:48alkisg has joined #ltsp
12:56scottmaccal has quit IRC
13:00alkisg has quit IRC
14:00alkisg has joined #ltsp
14:02scottmaccal has joined #ltsp
14:12yanu has quit IRC
14:20yanu has joined #ltsp
14:26Selveste1 has quit IRC
14:26nobios has joined #ltsp
14:29barbosa_ has joined #ltsp
14:30Barbosa has quit IRC
14:37
<alexqwesa_>
i try to connect to ltsp-client via ssh, but get a message: Permission denied (publickey,keyboard-interactive).
14:38
( ssh root@192.168.1.15 )
14:38
if use ssh linux@192.168.1.15 - it work
14:39
how to get root access in ltsp-client?
14:39
(need to restart pulseaudio)
14:40Sarten-X has joined #ltsp
14:41alexqwesa_ is now known as alexqwesa
14:43Sarten-X2 has quit IRC
14:44Kicer86 has quit IRC
14:47
<alkisg>
alexqwesa: distro/version?
14:58
<sbalneav>
Afternoon all
15:11
<alexqwesa>
alkisg: opensuse11.2
15:13nobios has quit IRC
15:19scottmaccal has quit IRC
15:33
<alexqwesa>
ok, i try send /etc/ssh/sshd_config to lts-client via tftp (in KIWI/config.default) - i think should work
15:39
now it request password, but: Permission denied, please try again.
15:39
cat /etc/pam.d/sshd
15:40
auth requisite pam_nologin.so
15:40
O_O
15:42
i think problem in pam, but user linux can login - it's ok?, I think it strange..
15:43
http://pastebin.ca/1727821
15:45Selveste1 has joined #ltsp
15:45lucascoala has quit IRC
15:45alkisg has quit IRC
16:53
<alexqwesa>
ok, i can login with public key ^__^
18:18litlebuda has joined #ltsp
18:40litlebuda has quit IRC
19:11Sarten-X has quit IRC
19:15zamba has quit IRC
19:32zamba has joined #ltsp
19:36Ahmuck-Jr has joined #ltsp
19:55zamba has quit IRC
19:59noob2 has joined #ltsp
19:59
<noob2>
hi!
20:00
i am wondering if i want to use oss sound? does it mean i have to change it in the ltsp/i386?
20:05
anyone back from their xmas parties?
20:06pmatulis has quit IRC
20:10zamba has joined #ltsp
20:11
<johnny>
why would you want oss sound?
20:11
oss is not even in the kernel anymore in newer versions.. i wouldn't try
20:15Patina has quit IRC
20:15jhutchins_lt has quit IRC
20:15Wastrel_ has quit IRC
20:15Appiah has quit IRC
20:15primeministerp has quit IRC
20:15sep has quit IRC
20:15jbrett has quit IRC
20:18Appiah has joined #ltsp
20:18Wastrel_ has joined #ltsp
20:18jhutchins_lt has joined #ltsp
20:18sep has joined #ltsp
20:18primeministerp has joined #ltsp
20:18Patina has joined #ltsp
20:18jbrett has joined #ltsp
20:25
<sbalneav>
The only reason I can think of to use oss sound is if you've got some really old hardware that was supported by oss, but isn't supported by the newer sound architechrue
20:25
And for the amount of trouble you'll go through to get oss to work, you'd be better off to turf the old hardware.
20:26
either that, or just SOUND = N
20:29
<noob2>
oh
20:29
becoz when i do play sound on my thin client using rdesktop to a windows
20:29
<johnny>
rdesktop doesn't require oss
20:29
<noob2>
a get a bunch of "fooo!"
20:29
and the sound stutters
20:30
online documentations give me the impression that I should change it to OSS
20:30
<sbalneav>
I don't know much about rdesktop.
20:30
<noob2>
which i did on my server i installed OSS 4.x
20:31
the sound on the server works but i got no sound on my thin clients
20:31
<sbalneav>
oss on the server wouldn't fix sound on the thin clients
20:31
<noob2>
so i am wondering if i have to tweak the i386
20:31
instead..
20:31
<sbalneav>
probably
20:31
you'd be on your own for that, though.
20:32
<noob2>
anyways
20:32
lets do an anlogy though
20:32
so if i wanted say, a new program on my thin clients, how do i do that?
20:32
do i login to the administrator account on a thin client?
20:33
or do i somewhat change the chroot?
20:33
as i am still new to ltsp istill need a direction
20:34
<sbalneav>
!docs
20:34
<ltspbot`>
sbalneav: "docs" :: For the most current documentation, see https://sourceforge.net/apps/mediawiki/ltsp/index.php?title=Ltsp_LtspDocumentationUpstream
20:35
<sbalneav>
Are you running localapps, or all programs on the server?
20:35
if you're running them from the server, just install them on the server as you normally would.
20:35
<johnny>
i would suggest against this noob2 ..
20:36
<noob2>
so u mean i just do a normal install in the server?
20:36
<johnny>
if something doesn't work with alsa..
20:36
<noob2>
why?
20:36
<johnny>
then getthem to fix the program
20:36
or talk to the authors and find out if you're reading obsolete docs
20:36
nobody here who uses rdesktop has ever mentioned oss
20:36
i'd suggest trying back in a few hours
20:36
as in.. the next day for usa..
20:37
talk to other folks who use it before mucking with something you don't understand
20:37
<noob2>
oh
20:37
i already changed the OSS sound in the server...
20:37
<johnny>
change it back?
20:37
<noob2>
i supposedly have already changed it ...
20:37
<johnny>
alsa already comes with an oss emulation module
20:38
so you shouldn't have had to do anything at all to use apps that did'nt work with alsa
20:38
<noob2>
let me see if i can find the webpage that told me to change it../
20:38
it does??
20:38
<johnny>
yes
20:38
<noob2>
that is wonderful news.......
20:38
<johnny>
i wouldn't trust any docs related to sound that are greater than 2 years old
20:38loathsome has quit IRC
20:38loather-work has quit IRC
20:38leio has quit IRC
20:38
<johnny>
or really much of anything related to linux..
20:39
things change so quickly..
20:41
<noob2>
so there are pple here using rdesktop to windows>
20:41
<johnny>
yes
20:41
using it from the chroot tho..
20:41
as in.. booting directy to rdesktop
20:42
without going into gnome
20:42
<noob2>
https://bugs.launchpad.net/ubuntu/+source/rdesktop/+bug/379636
20:43
oh, last time i posted a question... did not think there were pple doing that... maybe my question was too dumb....
20:43
<johnny>
you can't do anything of that
20:44
you need pulseaudio for ltsp to work
20:44
oh wait.. perhaps they do it another way..
20:44
since rdesktop is installed in the chroot?
20:44
that's my guess.. i've never used it
20:44
but you should already have /dev/dsp is alsa-oss is loaded
20:45
noob2, can you post on ltsp-discuss list?
20:45
<noob2>
it givves me an error if i recall correctly
20:45
<johnny>
other people can help
20:45
just say you're having an issue and point t that ticket
20:45
don't describe how you think you might need to fix the problem.. just describe the problem
20:45
<noob2>
anywyas, the thing is, when i was playing sound... everytime it stutters i get a fooo!
20:45
<johnny>
that way you won't have to wait for somebodoy to show up here
20:45
yes.. i know
20:45
<noob2>
where is this list?
20:45
<johnny>
just post that
20:45
to ltsp-discuss
20:45
<noob2>
that's a webpage?
20:45
<johnny>
it's on sourceforge.. that's all i know..
20:46
no.. it's a mailing list that you have to subscribe to
20:46loather-work has joined #ltsp
20:46
<noob2>
oh...
20:46
<johnny>
just search for ltsp-discuss on a search engine.. i'm not sure..
20:46
<noob2>
lol, i never joined a mailing list...
20:46
<sbalneav>
noob2: This isn't an LTSP issue
20:46
it's an rdesktop issue.
20:46loathsome has joined #ltsp
20:46leio has joined #ltsp
20:46
<johnny>
sbalneav, sure.. buti bet our folks know how to get around this issue
20:47
i've never heard anybody who uses rdesktop here mention the problem
20:47
<noob2>
hmm... maybe does not exist when rdesktop from shell...
20:48
<johnny>
well that's how most people run it
20:48
i think
20:48
they make it so some clients boot directly into rdesktop
20:48
<sbalneav>
I'd personally say you'd get better help by talking to the rdesktop people, but that's just me.
20:50
<noob2>
sigh... all that OSS work for nothing...
20:50
at least i did not break my box, last time i followed some guide...my box died...
20:50
<sbalneav>
Don't let me stop you
20:51
do whatever you'd like. All I'm doing is pointing out that this is clearly a problem with rdesktop.
20:51
<noob2>
oh
20:51
<sbalneav>
ultimately, to get the problem solved, you don't deal with the project that simply uses rdesktop
20:51
you deal with the project that WRITES rdesktop.
20:51
<noob2>
yeah, but becoz i am still not sure how ltsp is set up
20:52
the structure of ltsp
20:52
<sbalneav>
If you're unsure how to drive, you don't contact ford for driving instructions.
20:52
<noob2>
since i know there's a main directory then a ltsp/i386
20:53
<sbalneav>
and I have pointed you to the docs
20:53
!
20:53
!docs
20:53
<ltspbot`>
sbalneav: "docs" :: For the most current documentation, see https://sourceforge.net/apps/mediawiki/ltsp/index.php?title=Ltsp_LtspDocumentationUpstream
20:53
<sbalneav>
have you read them all the way through?
20:54
<noob2>
oh.. sorry.. did not know the docs is for me... =P
20:54
<sbalneav>
There was nobody else we were talking to in here :)
20:55
Someone may know a workaround on the mailing list, but it will only be a workaround.
20:55
If you want a FIX, you'll need to talk to the rdesktop people.
20:57
<noob2>
okay
20:57
will do that later
21:02
<sbalneav>
From the rdesktop source
21:02
<noob2>
have to go to the doctors...i've been such a bad boy, santa decided to make me ill for xmas....sob*
21:02
<sbalneav>
rdpsnd_alsa.c
21:02
if ((len = snd_pcm_writei(out_handle, out->p, ((MAX_FRAMES < len) ? MAX_FRAMES : len))) < 0)
21:02
{
21:02
printf("Fooo!\n");
21:02
snd_pcm_prepare(out_handle);
21:02
len = 0;
21:02
}
21:02
So, the snd_pcm_writei is returning probably a -1
21:02
Return values: -EBADFD PCM is not in the right state (SND_PCM_STATE_PREPARED or SND_PCM_STATE_RUNNING) -EPIPE an underrun occurred -ESTRPIPE a suspend event occurred (stream is suspended and waiting for an application recovery)
21:03
Seems like something's not prepared.
21:03
1) they're not actually checking the result code to determine if the retcode's EBADFD, EPIPE or ESTRPIPE
21:04
2) if they're doing a snd_pcm_prepare AFTER the writei's failed, looks like they're closing the barn door after the horse has already gotten out.
21:04
3) Whoever thinks "Fooo!
21:04
is a good error message needs their head examined.
21:20
<Ahmuck-Jr>
lol, Foo for an error code
21:20
my kind of programmer
21:54Ahmuck-Jr has quit IRC
22:05dfwlinuxguy has joined #ltsp
22:35dfwlinuxguy has quit IRC
23:36Egyptian[Home] has joined #ltsp
23:42cyberorg has joined #ltsp