IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 11 April 2007   (all times are UTC)

00:24Egyptian[Home] has joined #ltsp
00:43BlueRaid has quit IRC
01:40MoL0ToV has joined #ltsp
01:50plamengr has joined #ltsp
01:56plamengr has quit IRC
01:59plamengr has joined #ltsp
01:59plamengr has left #ltsp
02:01gonzaloaf_laptop has joined #ltsp
02:11MoL0ToV has quit IRC
02:37MoL0ToV has joined #ltsp
02:38plamengr has joined #ltsp
02:51MoL0ToV has quit IRC
02:58vanya has joined #ltsp
02:59MoL0ToV has joined #ltsp
02:59lzap_ has joined #ltsp
02:59
<lzap_>
hi all
02:59
!localdev
02:59
<ltspbot`>
lzap_: "localdev" is Information regarding using pluggable devices and cdroms with LTSP can be found at http://wiki.ltsp.org/twiki/bin/view/Ltsp/LTSP-42-LocalDev
03:02
<lzap_>
when I insert a floppy in the terminal what should I do then? does it automatically recognize floppy in the drive,
03:02
?
03:04Bhaskar1 has joined #ltsp
03:04
<Bhaskar1>
I have downloaded ltsp5 for debian , but how can i install ?
03:06
dem, hello
03:31Bhaskar1 has quit IRC
03:43muh2000_ has joined #ltsp
03:43zzaza has quit IRC
03:49Bhaskar has joined #ltsp
03:59muh2000 has quit IRC
04:09zzaza has joined #ltsp
04:10
<lzap_>
where can I get ltspfs sources (the 4.2 version) ?
04:10
I was told to search the WIKI but I didnt find it
04:11
I need to compile a debug version
04:16
anyone?
04:19
http://ltsp.mirrors.tds.net/pub/ltsp/utils/ -- contains binaries only
04:23gonzaloaf_laptop has quit IRC
04:27Fosforo has left #ltsp
04:32BlueRaid has joined #ltsp
04:33plamengr has left #ltsp
04:43muh2000_ is now known as muh2000
04:56Bhaskar has quit IRC
05:24Avatara has joined #ltsp
05:30Egyptian[Home] has quit IRC
05:37killsalad has joined #ltsp
05:37
<killsalad>
hi all
05:37
<BlueRaid>
hi
05:40
<killsalad>
i've got problem with ATI rage and LTSP-5, when i set XSERVER = ati there is a small black square in the top left corner of the screen
05:40
<BlueRaid>
why you don't use auto?
05:40
<killsalad>
any ideas how to get rid of this?
05:41
well auto sets it to ati
05:41rjune has quit IRC
05:42
<killsalad>
curious it's disapered
05:44
hm it seams that it is some kind of video memory issue, because when i change resolution it appears for a while and then disapperars
05:48killsalad has quit IRC
05:49
<ogra>
killsalad, set the HWCursor option
05:49
gah, he's gone
05:50killsalad has joined #ltsp
05:52
<killsalad>
one more thing how can i configure printer in LTSP-5 (xubuntu)
05:52
<lzap_>
what package I need to install when configure of ltspfs says: Perhaps you should add the directory containing `x11.pc'
05:53
checking for LTSPFSD... configure: error: Package requirements (x11) were not met
05:54
<ogra>
killsalad, set the HWCursor option for yxour yti problem ... since ubuntus Xserver autoconfig doesnt accept that as an option you should go with a static xorg.conf that contains this parameter
05:55
killsalad, /opt/ltsp/i386/usr/share/doc/ltsp-client/examples/lts-parameters.txt.gz hasd all options listed ltsp5 accepts ... for a printer it should sufice to set PRINTER_DEVICE_0 in lts.conf
05:55
s/yti/ati
05:57muh2000 has quit IRC
06:05antgel has joined #ltsp
06:06
<antgel>
hi, in muekow (ltsp5), if i want to make more fonts available for users, i don't install them in the ltsp chroot, do i? should i just install them on the server without going into the chroot?
06:06
<ogra>
right
06:06
<antgel>
thanks
06:07
i know i could have tried it before asking, but this deployment is very precarious and i need to look authoratitive :)
06:07
<ogra>
:)
06:07killsalad has quit IRC
06:19
<lzap_>
is v5 stable?
06:21killsalad has joined #ltsp
06:22
<killsalad>
back again :)
06:24
one last problem, when somebody (me) plugs a usbstick in the server's port every ltsp users can see contents of my pendrive, and what's more there are able to modify data on the stick
06:25
xubuntu 7.04 + LTSP-5
06:30muh2000 has joined #ltsp
06:36Leo has joined #ltsp
06:38
<Leo>
alguem?
06:43
Alguem jah teve problema no LTSP-4.2 com a montagem cd CDROM nas estações?
06:44BlueRaid has quit IRC
06:48project9 has joined #ltsp
06:53project9 has left #ltsp
06:56muh2000 has quit IRC
06:57* lzap_ gave up LocalDev support in 4.2 on Madriva 2006 and trying to install LTSP-5 on that old distro...
06:57
<lzap_>
does LTSP-5 have LocalDev support?
07:03muh2000 has joined #ltsp
07:06killsalad has quit IRC
07:17Avatara has quit IRC
07:18cliebow__ has joined #ltsp
07:21Avatara has joined #ltsp
07:23
<ogra>
lzap_, yes
07:24kaminski-FISL has joined #ltsp
07:25
<antgel>
i'm using jetpipe with debian ltsp5, but it seems to lock up from time to time, often with large files. any way i can debug this?
07:27
<ogra>
antgel, hmm ... how much mem does the client have ?
07:28
jetpipe doesnt have any cache meachanism or something, it just pipes through ... so if the printer isnt fast enough, the kernel will start caching the data somehow in memory ...
07:28
i'd suggest to enable NBD_SWAP in lts.conf ;)
07:28
<antgel>
ogra: also, sometimes it's printing gibberish
07:29
ogra: client has 128MB
07:29
<ogra>
can also be a out of mem problem ... try if adding swap helps
07:29
<antgel>
will do
07:30
ogra: NBD_SWAP not USE_NFS_SWAP?
07:30
<ogra>
jetpipe is still very young ... sadly the licensing of lp_server is broken else we could have kept it ...
07:31plamengr has joined #ltsp
07:31kaminski-FISL has quit IRC
07:50bb_et has joined #ltsp
07:50
<antgel>
ogra: how do i control swapfile size with USE_NBD_SWAP? SWAPFILE_SIZE = 128m doesn't work
07:56zzaza has quit IRC
08:01
<cliebow_>
ogra: you come across an fsck at every boot ..saying it hasnt been checked for 11998 days?
08:01
in ppc?
08:02
<ogra>
seems your HW clock is off
08:03Leo has left #ltsp
08:03sahil has quit IRC
08:04ltspbot has joined #ltsp
08:05ltspbot` has quit IRC
08:08* lzap_ suggest to use "mktemp" command instead "tempfile" in ltsp-update-sshkeys
08:08
<lzap_>
tempfile is not present in older distros
08:11
<ogra>
how old would that be ?
08:11antgel has quit IRC
08:13
<ogra>
(we surely wont care about stuff like FC4, but if you send a bzr branch url with a sane fix i'll happily merge it ;) )
08:18sam__ has quit IRC
08:18ccjoe has quit IRC
08:18sam__ has joined #ltsp
08:19antgel has joined #ltsp
08:20
<antgel>
did anyone answer me ^^ re nbd swapfile size? my laptop battery ran out :/
08:21Fosforo has joined #ltsp
08:21
<ogra>
antgel, grep SIZE /usr/sbin/nbdswapd ;)
08:22ccjoe has joined #ltsp
08:22
<ogra>
and see /opt/ltsp/i386/usr/share/doc/ltsp-client/examples/lts-parameters.txt.gz ... use NBD_SWAP=True
08:24
<antgel>
ogra: grr, only file in there is /opt/ltsp/i386/usr/share/doc/ltsp-client/examples/lts.conf
08:25
<cliebow_>
lemme look
08:27
antgel..no gz in there?
08:28
<lzap_>
haha ubuntu LTSP-5 kernel does not fit in memory when loading...
08:28
<antgel>
ogra: no :(
08:29edgarin has joined #ltsp
08:29
<lzap_>
whats wrong? the terminal has 256MB RAM
08:29
I am getting: segment [xxxxx] does not fit in any memory region
08:34ltspbot has joined #ltsp
08:35
<antgel>
cliebow_: would be ever so grateful
08:35
<cliebow_>
what is the client??
08:35
shall do
08:36
<ltsppbot>
"cliebow" pasted "lts params" (155 lines) at http://pastebot.ltsp.org/93
08:36
<lzap_>
whats wrong with the kernel size?
08:37
<antgel>
so there's no way to set swapsize via lts.conf in muekow?
08:37
cliebow_: thank you btw
08:38
<cliebow_>
8~)
09:00MoL0ToV has quit IRC
09:16cliebowx has joined #ltsp
09:18
<lzap_>
LTSP-5 Ubuntu now boots on Mandriva 2006 server, but booting process hangs
09:19
I can see 2% progress, the screen is frozen /Ubuntu logo/
09:19
how could I boot without this framebuffer?
09:21
<cliebowx>
lzap_:pxelinus?
09:21
lzap_:pxelinux/
09:21
Balls!
09:26
<lzap_>
wow pxelinux works
09:26
but it cant mount the root
09:27
I am getting "bad file descriptor"
09:27
<cliebowx>
so nfs is ok? portma?
09:27pc01 has joined #ltsp
09:27
<cliebowx>
perhaps showmount -e will verify that nfs is ok?
09:27
<lzap_>
192.168.47.128:/opt/ltsp/ubuntu_6.10_i3
09:27
<pc01>
hi
09:28
<lzap_>
it seems it doesnt read full path
09:28
is it limited or something?
09:28
the path ends with "i386"
09:28
and thats what I have in my DHCP conf
09:28
<cliebowx>
lzap_:in dhcp.conf do you have the server ip in the root-path statenment?
09:28
<pc01>
Hi i've got local printer when i add one in kde he prints nothing, but kde find the printer
09:28blinky_ghost has joined #ltsp
09:28
<lzap_>
yup: option root-path "192.168.47.128:/opt/ltsp/ubuntu_6.10_i386";
09:29
<cliebowx>
you need only /opt/ltsp/i386
09:30
<pc01>
can i see in a log that the pc became a file to print?
09:31
<ogra>
lzap_, drop the ip
09:32
<lzap_>
really?
09:32
ok
09:32
<cliebowx>
hmm..guess i shoulderloooked a little closer
09:33
so you have a fhen..older /opt/ltsp/ubuntu--> then..not /opt/ltsp/i386?
09:33
Good Grief!
09:33
so you have a folder /opt/ltsp/ubuntu*
09:34SBNet has joined #ltsp
09:35
<lzap_>
yes i have
09:35
I am installint v5
09:35
installing...
09:35
it mounts now but the boot process ends after several lines, the last message is "eth0 link is up"
09:37
hmmm bad
09:38
it seems its trying to load from .254 address
09:38
my tftp server is .128 (the same as the DHCP server)
09:38
<cliebowx>
tftp only loads the kernel
09:39
your nfs is on sam machine as dhcp server/
09:40muh2000_ has joined #ltsp
09:40
<lzap_>
yes
09:40
sorry, nfs is on the same machine
09:41
after the message link is up it halts for several minutes and then tries to load from 192.168.47.254...
09:42
I am there!
09:42
ldm shows!
09:42sepski has joined #ltsp
09:42
<lzap_>
oh I have clicked on "languages" and the window doesnt want to close :-D
09:43
ah theres a close button, I had to scroll down
09:43
I login but the screen is blank for 2 seconds and then ldm appears. how to configure ldm?
09:44
<ogra>
run ltsp-update-sshkeys on the server
09:44
<pc01>
How can i see , that or that a print job not came to the client? In a log?
09:44
<ogra>
your ssh keys on the client are not up to date
09:48
<lzap_>
I did run it
09:48muh2000 has quit IRC
09:48
<lzap_>
result: Setting up ssh_known_hosts in: /opt/ltsp/ubuntu_6.10_i386
09:48
<ogra>
right
09:49
and adding your server
09:49
so ldm knows it if it wants to connect
09:49
next release of ldm will have more clear error handling to tell you whats wrong
09:49cberlo has joined #ltsp
09:50
<lzap_>
still cannot login
09:50
[16:48] <ogra> and adding your server -- what you mean exactly?
09:50
<ogra>
ltsp-update-sshkeys should generate keys for your server and add them to ssh_known_hosts in the client environment
09:51
at least thats what it does on ubuntu and debian :)
09:51
<lzap_>
the keys are there
09:51
ll try to reboot
09:51
<ogra>
also make sure that your ssh server is running on the server and allows X forwarding
09:52
... should be enabled on all recent distros by default ...
09:54
<cberlo>
ogra: What are the odds of getting your thoughts on Active Directory? :)
09:55
<ogra>
i have had no microsoft software near me since ages, so i'm likely not the right person for a tech review :) but i heard the auth stuff shall work fine, whie the directoy mounting is tricky
09:56
<cberlo>
I knew there was a reason I liked you... ;)
09:56
Okay, I'll bug someone else. I know my server isn't in the "standard" shape you Ubuntu folk support....
09:57
<ogra>
actually there is no kind of network authentcation we officially support yet afaik
09:57
<cberlo>
Yeah, that's a feisty+1 kinda thing, isn't it?
09:58
<ogra>
yep, even though i dont know about the server side that might even be a +2 or later thing
09:58
we wont support anything half breeded and developing a proper solution takes time
09:59
<cberlo>
Okay. I'm sure you guys will get it. I'm patient! Just need to work around the issue for now with my existing setup. I'll get a complete rebuild with Proper Ubuntu going when you guys have it ready.
09:59
<lzap_>
reboot didnt help
09:59
<cberlo>
ttyl
09:59cberlo has left #ltsp
09:59
<lzap_>
ogra: aaah forwarding...
09:59
<cliebowx>
cberlo:dont suppose you can isolate your time issue to pam or samba?
10:00
<lzap_>
ogra: lemme se
10:00
<cliebowx>
heh
10:00
<lzap_>
well its running and it has: X11Forwarding yes
10:00
<ogra>
X11Forwarding yes is the option in your sshd_config
10:00
<lzap_>
:-(
10:01
<ogra>
hmm, then check yur users .xsession-errors
10:01
<lzap_>
ldm does not let me in
10:01
ok
10:01
<ogra>
the server is not ubuntu/debian, right ?
10:02
<lzap_>
server is Mandriva 2006 ;-)
10:02
<ogra>
ah
10:02
<lzap_>
not my choice...
10:02
_X11TransSocketINETConnect() can't get address for localhost:6010: Name or service not known
10:02
many times in the .xsessin-errors
10:03
I use KDE, not GNOME... maybe a problem with that?
10:04
<ogra>
no
10:04
a system problem
10:04
<lzap_>
xsetroot: unable to open display 'localhost:10.0'
10:04
<ogra>
debian based systems have a default X session in /etc/X11/Xsession
10:04
its likely you dont have that
10:04
<lzap_>
/usr/X11R6/bin/xauth: (argv):1: bad display name "localhost:10.0" in "list" command
10:04
<ogra>
the _X11TransSocketINETConnect is unrelated to ltsp
10:05
<lzap_>
I have got the file
10:05
<ogra>
at least there is nothing usinng port 6010
10:06
try setting LDM_REMOTECMD=/usr/bin/startkde ... or however the default kde session is called
10:06
in your lts.conf in the client environment
10:07edgarin has quit IRC
10:08
<lzap_>
okay I will continue tomorrow, thanks for help. I will try that...
10:08
<ogra>
you will be the first person running ltsp5 on mandriva btw :)
10:09
would probably be nice to take notes so you could put some documentation up for others
10:09
<lzap_>
of course, I will do. see ya tomorrow.
10:10
<ogra>
ciao
10:10
<lzap_>
our client need to run local devices
10:10
and I must enable it
10:10lzap_ has quit IRC
10:10
<ogra>
check the lts.conf file, if the tarball was recent it should be enabled by default
10:10
heh ... gone
10:18efra has joined #ltsp
10:23antgel has quit IRC
10:24vanya has quit IRC
10:26
<SBNet>
anyone available to help?
10:27
<cliebowx>
available yes..to help..not so sure
10:28
<SBNet>
lol
10:28
ok, i got my new ltsp server up and running, woohooo!
10:28
<cliebowx>
Woohoo!
10:28
<SBNet>
problem is that tftp isn't working right, but it's setup the same as the vmware machine that is currently running ltsp
10:29
if i tftp to it from itself, i get files fine. if i try it from another computer, i get a timeout
10:29
firewall is off and selinux is off
10:29
server is running
10:30
<cliebowx>
for the hell of it.why not post results of netstat -anp|grep ":69"
10:32
<SBNet>
ok
10:32
just a sec
10:32
<cliebowx>
unfortunately jim and scottie are travelling today..
10:33
<SBNet>
http://www.pastebin.ca/434694
10:34
<Lumiere>
a
10:34Lumiere has quit IRC
10:35
<cliebowx>
that looks great!..what else could be borking it? hosts.allow..hosts.deny/
10:36
<SBNet>
used ltspcfg to set those up
10:36
but i'll post to pastebin
10:37Lumiere has joined #ltsp
10:38
<SBNet>
www.pastebin.ca/434703 is hosts
10:39
www.pastebin.ca/434707 is hosts.allow
10:40oh207 has joined #LTSP
10:40
<cliebowx>
Whoa...this is 4.2/
10:40
?
10:41
<SBNet>
yeah, everyone said to use 4.2 so i use 4.2
10:41
would it be better to use 5?
10:41
<cliebowx>
i Love 4.2..whish tftp server..i know you said before..
10:41
!tftp
10:41
<ltspbot>
cliebowx: Error: "tftp" is not a valid command.
10:42
<SBNet>
the only difference between my vmware machine and my true server is vmware uses fc5 and server uses fc6
10:42
the default tftp server in fc6, package is tftp-server
10:42
lol
10:42
should i try another server?
10:42
see if it works then
10:42
<cliebowx>
http://wiki.ltsp.org/twiki/bin/view/Ltsp/TFTP
10:42
i think you need to switch
10:43
<SBNet>
so why would it work in fc5 but not in fc6?
10:43
that's a good question i think!!!
10:43
:)
10:43
<cliebowx>
hmm.
10:44
i am using tftp-server-0.39-1
10:45pc01 has quit IRC
10:46
<ltsppbot>
"cliebow" pasted "/etc/xinetd.d/tftp" (19 lines) at http://pastebot.ltsp.org/94
10:47
<SBNet>
ok, i get in my log for tftp no route to host from the tftp server to my remote host
10:48
<cliebowx>
fwiw..you can pastebot your dhcpd.conf
10:49
<SBNet>
can't pastebot the dhcpd.conf, it's hosted on a windows 2003 server and it's setup right, cause the clients are booting from the vmware box,not this server so i should be able to change them out
10:49
once i get this tftp issue fixed
10:50
<cliebowx>
ahhh...
10:51irule has joined #ltsp
10:53
<cliebowx>
so youve used options 17 66 and 67 in windows dhcp
10:54
<SBNet>
yep all that is right, just can't tftp, it's something in the server. i'm trying tftp from my laptop on the terminal and i connect, but can't get anything
10:55
<cliebowx>
laptop to server you mean..
10:56
<SBNet>
yeah, my laptop typing tftp 10.40.0.29 and then trying get test.txt
10:56
and the log keeps reporting no route to host
10:58McDutchie has quit IRC
10:58vagrantc has joined #ltsp
11:04
<cliebowx>
boot-server host name in option 66 is by ip?
11:05
<SBNet>
all is by ip, so i can swap servers and clients won't know
11:07
<cliebowx>
sure there is just one dhcp-server..
11:07
<SBNet>
yes
11:07* cliebowx cliebow grasps at straws
11:07
<SBNet>
if there wasn't we would have all kinds of havok
11:08
i'm trying to figure out why i can ssh to the box from any of my computers but tftp won't get anything
11:08
let me try a send
11:08
or put rather
11:10
that didn't work either
11:10
WHY CAN'T YOU ROUTE TO MY LAPTOP!!!!!
11:11
or my desktop for that matter
11:11antgel has joined #ltsp
11:12
<cliebowx>
steady..man
11:12
8~)
11:13
<SBNet>
it doesn't make any sense that the sam config of two machines doesn't work. i can ssh, i can http i can https i can even telnet and ftp but tftp ohhhhh no
11:14
brb
11:14
what about this mtu setting under ehternet device? could it change something?
11:15
<vagrantc>
is it different?
11:15
<SBNet>
it just has a thing that says set mtu to then a box to change the mtu number you can enable or disable it
11:17* vagrantc was just asking if there was a difference in the mtu settings between the two servers
11:18
<SBNet>
i don't think so, brb this time for real
11:21
<ltsppbot>
"cliebow" pasted "syslog" (7248 lines) at http://pastebot.ltsp.org/95
11:21dmorar has joined #ltsp
11:21
<ogra>
cliebow, you are crazy ... 7k to a pastebot :)
11:22
<dmorar>
hi, i would like to know if there is a way to limit my users to have only one active session, i'm having problems, because they forget to log out and then they go into another machine and log in, so they can't open firefox, openoffice... because its already openned
11:23
<cliebow__>
ok.point taken...what would you like done with it..
11:24
never looked for size 8~)
11:26
<ogra>
cliebow__, see #edubuntu
11:26
<cliebow__>
roger
11:27
<ogra>
heh, and we should stop cross posting on IRC *g*
11:27
<cliebow__>
8~)
11:34cliebowx has quit IRC
11:39
<SBNet>
cliebow: i think i'll try moving my vmware box over and seeing if that works
11:49bb_et has quit IRC
11:54
<blinky_ghost>
hi can anybody tell me how do I remote control a terminal on ltsp5? I installed x11vnc but it doesn't work
12:00
<ogra>
blinky_ghost, x11vnc doesnt have an initscript ... you need to write one and as well make sure to connect the vnc server to the right display (in ltsp5 usually :6)
12:00
<blinky_ghost>
ok, thanks
12:00
<ogra>
for testing just set a rootpw in the client chroot and log in on the console on the terminal
12:01
<vagrantc>
"With x11vnc you can export your currently running X11 session to any VNC client.
12:01bjohnson has joined #ltsp
12:01
<ogra>
right
12:02
<vagrantc>
so, wouldn't you log in and run x11vnc, rather than running an init script?
12:02
<ogra>
but x11vnc has a horrible amount of manual options you need to set to make it run properly
12:02
<vagrantc>
ah.
12:02
<ogra>
well, you can make it run from an initscript and conncet to the ldm display
12:02
that should work just fine ...
12:04
<vagrantc>
it's been a while since i messed with this stuff
12:05
<cliebow__>
vagrantc: login via ssh is what i do with it..from Teach2.py which is a python gui
12:05
at least with 4.2
12:06
Karl Runge wrote it..He is a real nice guy if anything needs tweaking
12:06
<ogra>
vagrantc, i plan to have a proper initscript in the thin-client-manager package for feisty+1
12:06
so just installing the x11vnc package should suffice then ...
12:07
(and thats even something i can let update-managet handle directly from the TCM gui with a button or something ... it got so easy to make apps instal packages in ubuntu :) )
12:08
apt and aptitude so last century :)
12:08
+are
12:08
vagrantc, btw, will we meet in spain or not ?
12:09
<vagrantc>
ogra: looks promising :)
12:09
<ogra>
rich didnt tell me anything what you guys talked about
12:09
he just told me he was talking to you
12:09
<vagrantc>
ogra: got the official invite this morning
12:09
<ogra>
YAY
12:10
did you tell jammcq and sbalneav ? we can have a big ltsp tapas session :)
12:10
even though i suspect its not enough meat in tapas for jammcq
12:10
<vagrantc>
"tapas" ?
12:11
well, jammcq can have all the meat i would've eaten.
12:11
<ogra>
http://en.wikipedia.org/wiki/Tapas
12:12
the best you can eat in spain :)
12:12bjohnson has quit IRC
12:13
<vagrantc>
sounds good, minus the squid
12:13
<ogra>
you arent even vegaquarian ?
12:13
i thougt you eat fish
12:13
<vagrantc>
oh, i guess i was focusing on the olives.
12:13
<ogra>
heh
12:13
<vagrantc>
if it swam, flew or walked, i don't generally eat it
12:14
actually, if it locomoted, i don't generally eat it
12:15
mmmmmm... aioli
12:15* ogra cant help to think of the simpsons "i'm a fourth leevel vegan, i dont eat anything that drops a shadow" :)
12:15
<blinky_ghost>
don't forget to try the paella :P
12:15
<Lumiere>
so you eat eggs and milk?
12:15
<ogra>
blinky_ghost, bad idea for vegetarians :)
12:15
<Lumiere>
yea
12:15
paella almost always has meat
12:15
lots of meat
12:16
<ogra>
and fish
12:16
and often chicken
12:16
<blinky_ghost>
paella with sea food it's best thing you eat in spain ;-)
12:17
<vagrantc>
i eat eggs and milk products, but i sometimes avoid even those.
12:17
all this food talk makes me want to skip work. :)
12:17* vagrantc waves
12:17vagrantc has quit IRC
12:17
<Lumiere>
lol
12:20
<ogra>
heh
12:35antgel has quit IRC
12:43Avatara has quit IRC
12:44blinky_ghost has quit IRC
12:45J45p3r_ has joined #ltsp
12:59J45p3r_ has quit IRC
13:05dmorar has quit IRC
13:15Lumiere is now known as Lumiere|Airport
13:17EMPER0R has quit IRC
13:17greg_g has quit IRC
13:18
<SBNet>
what is the recommended tftp server? tftp-hp or something like that
13:19EMPER0R has joined #ltsp
13:20
<sepski>
i use atftpd
13:20
<ogra>
ubuntu/debian use tftpd-hpa by default
13:26
<SBNet>
where can i get it for fedora? cause i think the tftp server that comes with fedora 6 is broken, twice i've tried and it doesn't work, but fedora 5 works fine so it must be in fedora 6
13:27freet15 has quit IRC
13:29jammcq has joined #ltsp
13:29kaminski-ltsp-br has quit IRC
13:29
<jammcq>
hey kids
13:34
<ogra>
jammcq, !
13:34
jammcq, we'll have tapas with vagrant :)
13:38
<twinprism>
SBNet: You may try looking how K12LTSP does it on fedora 6 for a clue.
13:38
<cliebow__>
jamcq!!
13:38
jammcq!!
13:38sbalneav has joined #ltsp
13:38
<ogra>
!s
13:38
<ltspbot>
ogra: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
13:38
<sbalneav>
Afternoon all!
13:39
Hey Ogra!
13:39
<cliebow__>
!
13:39
<sbalneav>
Greetings from Porto Alegre!
13:39
<cliebow__>
Cool! you got there!!
13:39
<ogra>
unlike jono
13:39
<sbalneav>
Yes, we did.
13:41
<cliebow__>
remember:jammcq promised to eat foe me too!
13:43
<sbalneav>
Jono not make it yet?
13:43* sbalneav checks planet
13:44
<ogra>
seems there was something weird with his flight ...
13:44
i have no details though
13:44
<jammcq>
hey
13:44
!s
13:44
<ltspbot>
jammcq: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
13:47fernando1 has joined #ltsp
13:53
<sbalneav>
Hey jammc
13:59ogra has quit IRC
14:10Egyptian[Home] has joined #ltsp
14:16sbalneav has quit IRC
14:16EMPER0R has quit IRC
14:17cliebow__ has quit IRC
14:23
<SBNet>
ok here's a questions for you guys
14:24
my new server is working and my client gets an ip and boots the image, but when it goes to mount the nfs it gets permission denied, why?
14:43sepski has quit IRC
14:43
<jammcq>
SBNet: check your /etc/exports file
14:44
and do this: showmount -e
14:45
<cliebow_>
SBNet: you get tftp squared up then ???
14:47
<SBNet>
yep, tftp is working now
14:48
<cliebow_>
what was the deal?
14:48
<SBNet>
don't know, uninstalled it then reinstalled it and it started working fine
14:49
<cliebow_>
just being bitchyu
14:49
<SBNet>
i did showmount -e and it said can't get address for einsteind <- my server name but in dhcp it is all done using ips
14:49
yep
14:49
<cliebow_>
your /etc/exports file governs what is nfs shared..give that a peek..or is that fixed too
14:50knitoperu has joined #ltsp
14:50
<SBNet>
would the nfs mount be an issue if my server is on 10.40.0.* and my client ip is 10.40.1.* but my subnet is 255.255.254.0 so all can talk, but the hosts doesn't have 10.40.1.* addresses only 10.40.0.*
14:50
<knitoperu>
Hi eveybody
14:51
<SBNet>
ok heres' the exports lines
14:51
/opt/ltsp 10.40.0.0/255.255.254.0(ro,no_root_squash,sync)
14:52
<knitoperu>
do you know how can I allow access from the internet to my ltsp server, only for some users?
14:52
<cliebow_>
take their browser away??
14:52
<SBNet>
/var/opt/ltsp/swapfiles 10.40.0.0/255.255.254.0(rw,no_root_squash,async)
14:52
<jammcq>
"FROM" or "TO" the internet ?
14:53
SBNet: what's your broadasts set to ?
14:53
<knitoperu>
FROM the internet
14:53
(via VNC)
14:53
<SBNet>
10.40.1.255
14:53
<cliebow_>
SBNet life depends on a good broadcast addrss..
14:54
<jammcq>
that seems correct fora 254.0 mask
14:54
<SBNet>
it is
14:54
if it was 255.255.255.0 it would just be 10.40.0.255
14:54
<jammcq>
SBNet: and 'showmount -e' didn't work?
14:54
<SBNet>
if it was 255.255.252.0 it would be 10.40.3.255
14:54
nope said it couldn't get an address
14:55
<jammcq>
SBNet: too many people don't have a clue about that broadcast/netmask stuff
14:55
<SBNet>
can't get address for einstein
14:55
<jammcq>
what is 'einstein' ?
14:55
<SBNet>
well, luckly i'm cisco certified and the network admin
14:55
my server
14:56
<cliebow_>
is einstein entered wierd in /etc/hosts??
14:56
<SBNet>
nope
14:57
<jammcq>
i'm guessing einstein isn't even in /etc/hosts
14:57
<SBNet>
my line for einstein is
14:57
::1 einstein localhost.localdomain localhost
14:57
<jammcq>
hmm, ipv6 stuff
14:57
<SBNet>
ipv6 is off
14:57
<cliebow_>
SBNEt:You're scasring your partner
14:57
<SBNet>
i don't use it but fc6 for some reason adds it in there
14:58
<cliebow_>
yeah it did that in netstat for m
14:58
me
14:58
do netstat -anp|grep ":2049"
14:58
<SBNet>
i'm booting my vmware server to check it out and see if there is a diff
14:58
<cliebow_>
have bunch of dots therte too?
14:59
i post4ed on this ipv6 stuff
14:59
<SBNet>
nope it's right
15:00
<ltsppbot>
"SBNet" pasted "tcp 0 0 0.0.0.0:2049 0.0.0.0:*" (2 lines) at http://pastebot.ltsp.org/96
15:00
<cliebow_>
so like 0.0.0.0:2049?
15:01
tcp 0 0 0.0.0.0:2049 0.0.0.0:* LISTEN -
15:01
<SBNet>
!sbnet
15:01
<ltspbot>
SBNet: "sbnet" is great!
15:02* cliebow_ cliebow is goink home
15:02
<SBNet>
why?
15:02
<cliebow_>
let thge dogs out..ill be in from there..
15:02
<SBNet>
well, i might try a restart of the server and see if that does any good
15:03
<jammcq>
what is your root-path set to?
15:03
<cliebow_>
hasta la vista...get that showmount command to work ..8~)\
15:03
<SBNet>
depends, which option is that?
15:03
<cliebow_>
17
15:03
<SBNet>
i have a 2003 windows dhcp
15:03
ohh ohhh i know this one
15:04
i think /opt/ltsp
15:04
<str4nd>
/opt/ltsp/i386 maybe
15:04
<SBNet>
i don't now right now, haven't looked at it in a day or so
15:04
mostlikely
15:04
<cliebow_>
just remember windows pads that
15:04
<jammcq>
well, it has to match, or be a subdir of whatever you are exporting in /etc/exports
15:04
<SBNet>
according to my laptop it is /opt/ltsp/i386
15:04
<str4nd>
SBNet: I have Win Server 2003 too.. (dhcp)
15:04
<SBNet>
line from laptop trying to boot ltsp
15:05
<cliebow_>
so if you put /opt/ltsp/i386 windows will translate that to look for /opt/ltsp/i386000
15:05
<str4nd>
SBNet: I can get configs to you at thursday
15:05
<SBNet>
mounting root filesystem: /opt/ltsp/i386 from 10.40.0.10
15:05
<cliebow_>
hmm maybe 2003 is fixed
15:05
<SBNet>
well, ltsp works with my vmware machine, just switching it over to a dedicated server
15:05
<str4nd>
good night ->
15:05cliebow_ has quit IRC
15:06
<SBNet>
2003 doesn't pad
15:07
<knitoperu>
I use to access my server from my home via Internet. login with my name and with root
15:07
I have a very strong password for me and for root
15:07
but others users have not strong passwords
15:08
I want to limit acces from the internet for them
15:09
I have fount in /opt/ltsp/i386/etc/security some files that seems to manage that kind os security
15:09
<jammcq>
hmm, no, I don't think that's what you need to change
15:10
knitoperu: do you know their IP address from where they are coming?
15:10
<knitoperu>
I want to make my server safer from Internet's attacks
15:11
if my users have weak passwords... And it's difficult to control the strongest of my users passordw
15:12
I can Deny all the trafic from the internet (via iptables) but I will deny my access too
15:12
Can I limit some users login?
15:12
<jammcq>
I really don't know
15:13
<knitoperu>
or allow some users login via some rth?
15:13
<jammcq>
this is a vnc issue, not an LTSP issue
15:13
<knitoperu>
via some eth?
15:13
ok
15:13
I will search vnc documentation
15:14
but I think that it could be an usual backdoor for ltsp servers
15:14
<jammcq>
only if you use vnc
15:14
LTSP has nothing to do with vnc
15:14
<knitoperu>
I have not an vnc server installed!!!
15:14
<jammcq>
it's a backdoor for "Linux" servers
15:15
not necessarily LTSP servers
15:15
<knitoperu>
I access my ltsp server from port 5900, that i think is installed by ltsp
15:15
<jammcq>
no
15:15
it might be installed by 'k12ltsp', but not by 'ltsp
15:15
'
15:15
<SBNet>
5900 is the vnc port
15:15
<knitoperu>
(I use k12ltsp... could be a k12ltsp issue?)
15:15
<SBNet>
default prot
15:16
<jammcq>
it's the "k12" part of k12ltsp
15:16
<knitoperu>
ahhhhh, ok
15:16
that I will search in k12ltsp documentation
15:16
<jammcq>
and you should NEVER put a k12ltsp server directly on the internet
15:16
<SBNet>
hey, guess what, a restart fixed it
15:16
<jammcq>
there should always be a firewall between the server and the internet, that would filter out (or allow) connections
15:16
<SBNet>
no idea what the hell that was about but it fixed it
15:16
<jammcq>
SBNet: I was gonna suggest you do: exportfs -ra
15:17
to re-export the exports
15:17
<knitoperu>
SBNet: That's a windows method!!!! the reboot
15:17
<SBNet>
still waiting on a desktop, just got a grey screen with an x or a cursor
15:17
well i had to reboot to update the kernel so it was kinda nessesary
15:17
<knitoperu>
lol
15:18
<SBNet>
windows has to restart if it updates a text file
15:18
<jammcq>
windows has to restart if you move the mouse
15:18
<SBNet>
linux only restarts if there is a kernel update
15:19
lol
15:19
<knitoperu>
jammcq: If I find a way to limit access for some users? Do you think that It would remain unsafe to connect my k12 to internet?
15:19
<jammcq>
knitoperu: yes
15:19
there's other services that you shouldn't be exposing to the internet, like mountd
15:19
knitoperu: if you really know what you are doing, you can configure iptables to make your system MUCh more safe
15:20gigabytes has joined #ltsp
15:20
<knitoperu>
jammcq: I have a shorewall in my k12, denyng all but some services (I allow VNC)
15:21
jammcq: I can allow VNC only for my home's IP
15:21
<SBNet>
maybe it's just me but this is taking way tooo long
15:21
it ran faster on my vmware server
15:22
<jammcq>
SBNet: what's your 'SERVER' parameter set to in lts.conf ?
15:22
<SBNet>
who knows, maybe it will work after an full update only 551mb
15:22
umm just a sec, should be right, but i did have a problem once cause of changing ips, forgot to check that
15:23
yep, set to another ip that i haven't ever used on this server
15:23
figure that out
15:23michael has joined #ltsp
15:23
<SBNet>
i always forget about that server option
15:24
definately gotta change that xdmcp login screen tooo plain and ugly
15:24bobby_C has joined #ltsp
15:25greg_g has joined #ltsp
15:25
<SBNet>
now if i can just get it to authenticate using ldap against my active directory server, i'll be set
15:25
<michael>
Hello, I have a local device problem
15:26Fosforo has quit IRC
15:26
<michael>
is there an local dev expert on the list
15:26
Jim :-)) ?
15:26
<jammcq>
scotty is the local app guy, and he's taking a nap right now, after about 24 hours of travelling
15:27
<michael>
puh, no good time
15:28
he asked me to send some trouble shooting data, but he did not resp for a week
15:28
this might be the reason ?
15:28
Guess I wait.
15:28
<jammcq>
could be. he's a very busy guy
15:28
<SBNet>
what's the issue with local device support?
15:28
<michael>
I got the impression
15:29
<jammcq>
what's the problem?
15:29
<michael>
you all do a great job!
15:29
the prob is simple... I get not icons for local devs
15:29
<jammcq>
what distro?
15:29
<michael>
but... all test are positive
15:29
openSUSE 10.2
15:29petenutz has joined #ltsp
15:29
<jammcq>
ugh
15:29
<michael>
agree
15:29
<jammcq>
i'm really not familiar with suse
15:30
is it 64-bit too?
15:30
making it even trickier
15:30
<michael>
32
15:30
<jammcq>
we've been inviting Novell in, to become active in LTSP. They've chosen to go their own route
15:31
<michael>
I am kind of in the loop, but I am far away from been Novel or SuSE
15:31
<SBNet>
by default though you should be getting a folder icon for local devices
15:31
<michael>
there is absolutely nothing
15:32
I can fire of the eventhandler manually this works
15:34
<SBNet>
got me, last time i messed with suse was in like 9.2 i think
15:34
<michael>
Jim, Daniel do you think we can follow this up or should we wait for Scott an I will post a solution on the mailing list
15:34
<SBNet>
and that was just for a few weeks then off to fedora
15:35
<michael>
well 9.2 was not too bad
15:35pscheie has quit IRC
15:35
<michael>
the last real SuSE version
15:35
how ever SuSE was and is different
15:36antgel has joined #ltsp
15:36
<SBNet>
i would let scott know. he would be able to handle it the best as he worked on that part fo the system
15:36
<michael>
I plan on moving to wards ubuntu
15:37
<SBNet>
i would check out Fedora Core 6 and at the end of this month Fedora 7 is released so it's going great
15:37
<michael>
thanks, I will be online for a wihle -- but since he was travelling a lot I may better let him sleep :-)
15:37
<SBNet>
last thing i heard about ubuntu was that they were in talks with microsoft about stuff
15:37
that would be best
15:38
<michael>
stuff as in MS employees work for / with canonical ?
15:39
<SBNet>
i mean like ms looking at maybe buy or investing heavily in ubuntu and related software, just a rumor though
15:40
<michael>
well Novell is going toward MS, cooperation is ok and better that confrontation but
15:40
every medal as two sides...
15:42
<SBNet>
well, i guess i'm off. gonna go home and relax. i might be on later guys. bye
15:42SBNet has quit IRC
15:45jammcq has quit IRC
15:50TheGuy has joined #ltsp
15:50BadMagic has quit IRC
15:50
<TheGuy>
is anyone here using or have tried using LTSP 5 on any SuSE distro?
15:51akazia has joined #ltsp
15:51BadMagic has joined #ltsp
15:52
<akazia>
Last thing I read is that Novell did show interest to ltsp..
15:53
<TheGuy>
Yeah, but has anyone tried just installing the tarballs from the downloads section?
15:55
<akazia>
I ran in lot of probs and choose to use 4.2u4 but I have not really worked on the problems
15:56
as soon as it was under the impression that this is more than a little massage to the distro I stopped
15:56gigabytes has quit IRC
16:01
<akazia>
Guess I get some sleep... bye
16:01akazia has left #ltsp
16:01michael has quit IRC
16:08TheGuy has quit IRC
16:43knitoperu has quit IRC
16:58plamengr has left #ltsp
17:12IRCzito_home has left #ltsp
17:17irule has quit IRC
17:23efra has quit IRC
17:26fernando1 has quit IRC
17:39fernando1 has joined #ltsp
17:40mistik1 has quit IRC
17:40Egyptian[Home] has quit IRC
17:46ogra has joined #ltsp
17:51twinprism has quit IRC
17:56bobby_C has quit IRC
17:59twinprism has joined #ltsp
18:06ogra has quit IRC
18:06ogra has joined #ltsp
18:10
<cliebow>
ogra:thanks for the help today..got ldap/samba and everything ready to go bacjk to Otis..
18:11
<ogra>
cool
18:21mistik1 has joined #ltsp
18:24gonzaloaf_laptop has joined #ltsp
18:58muh2000_ has quit IRC
19:21freet15 has joined #ltsp
19:37freet15_ has joined #ltsp
19:44paavum has joined #ltsp
19:45
<paavum>
Hello, hello
19:46
hey... ummm I need to run a really old dos program in ltsp
19:46
which emulator would you guys recommend?
19:51antgel has quit IRC
19:52freet15 has quit IRC
20:17paavum has quit IRC
20:22nicoAMG has joined #ltsp
20:24twinprism_ has joined #ltsp
20:30twinprism_ has quit IRC
20:35vagrantc has joined #ltsp
20:49muh2000 has joined #ltsp
20:53shogunx has quit IRC
20:55shogunx has joined #ltsp
20:57ogra has quit IRC
21:32nicoAMG has quit IRC
22:09gonzaloaf_laptop has quit IRC
22:41Bhaskar has joined #ltsp
23:03
<Bhaskar>
i have download ltsp5 143MB, now how can install , there is no doc to install in this bundle?
23:03
<vagrantc>
!tarball
23:03
<ltspbot>
vagrantc: "tarball" is http://wiki.ltsp.org/twiki/bin/view/Ltsp/Ltsp5TarballInstructions
23:03
<vagrantc>
that's the instructios
23:08greg_g has quit IRC
23:19Bhaskar has quit IRC
23:37mistik1 has quit IRC
23:39mistik1 has joined #ltsp
23:53vagrantc has quit IRC