IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 29 May 2007   (all times are UTC)

00:12klausade has quit IRC
00:14PMantis has left #LTSP
00:24klausade has joined #ltsp
00:26kaos01 has quit IRC
00:33spectra has quit IRC
00:55cyberorg has joined #ltsp
01:15MoL0ToV has joined #ltsp
01:38marek82 has joined #ltsp
02:13Jenna has quit IRC
02:29vagrantc has joined #ltsp
02:48Q-FUNK has joined #ltsp
03:02vanya has joined #ltsp
03:47fernando1 has quit IRC
03:52Paul_UK has joined #ltsp
03:53
<Paul_UK>
hey there, is there an how-to to get things up and running with ltsp and ubuntu 7?
03:54
<vagrantc>
!quickinstall
03:54
<ltspbot`>
vagrantc: Error: "quickinstall" is not a valid command.
03:54
<Paul_UK>
https://help.ubuntu.com/community/UbuntuLTSP/LTSPQuickInstall
03:54
<vagrantc>
ltspbot`: factoids search --values
03:54
<ltspbot`>
vagrantc: 'ltsp', 'sbalneav', 'icewm', 'frappr', 'wiki', 'debian', 'edubuntu', 'dhcpd', 'greyscreen', 'ltsp42', 'localdev', 'localdev', 'localdev', 'checklist', 'muekow', 'bestltspdistro', 'serversize', 'wireless', 'sound', 'topics', 'integration', 'lts.conf', 'pastebot', 'bootfloppy', 'ltsp5', 'tarball', 'download', 'monkeys', 'ogra', 'nfs', 'nfsnotresp', 'js', 's', 'troubleshooting', 'sbnet', (1 more message)
03:54
<vagrantc>
Paul_UK: yeah, that.
03:55
<Paul_UK>
lol, my beef is, on the ubuntu server page, it looks to me, its saying its already installed. im guessing its not.
03:55
<vagrantc>
"ubuntu server page" ?
03:55
<Paul_UK>
http://www.ubuntu.com/products/WhatIsUbuntu/serveredition
03:56
Hmm, maybe they should have offered LTSP as part of the installing process, as they have DNS and LAMP. oh well.
03:57fernando1 has joined #ltsp
03:58
<vagrantc>
well, just a couple weeks ago, we were talking about how to integrate LTSP into ubuntu server at the ubuntu developer summit ...
03:58
<Paul_UK>
oh crap, now its saying starting dhcp server, i already have one heh
03:58
<vagrantc>
but as i understand it, it's currently no more integrated into ubuntu server than plain ol ubuntu
03:58
<Paul_UK>
right
04:01* vagrantc notes that the ubuntu server edition tries to capitalize on debian's reputation for stability while ubuntu desktop doesn't even mention debian
04:02
<Paul_UK>
well i just think there is no current centos distribution. its one that im using here.
04:02
<vagrantc>
centos distrubution of what?
04:03
<Paul_UK>
ltsp
04:03
or status or whatever lol, sorry need more coffee. not really wake
04:03
<vagrantc>
ah yes. thus far only ubuntu and debian for LTSP 5 ... so far
04:04
always looking for folks from other distros to fix that, of course :)
04:04
<Paul_UK>
well, if i can get it working and the pilot seems to go well. i will give it a go. i'll be rolling out 50 thin clients in a call center environment.
04:07pere_away is now known as pere
04:16envite has joined #ltsp
04:17
<envite>
Hello all from Spain
04:17
Hola a todos desde España
04:17
<vagrantc>
buenos dias
04:18
<envite>
buenos días vagrantc
04:18
<dberkholz>
i wish i spent all day working on ltsp5
04:18
instead i got to fix a totally broken build system in a scientific program, and unbundle another one
04:18
<vagrantc>
yo no tengo teclado de í :(
04:19
<dberkholz>
but on the bright side, the unbundling clears up licensing issues so we can GPL it later
04:20
<vagrantc>
good good
04:21
<envite>
bueno, vagrantc, no es tan grave ;)
04:22
I used to have a knote or a text file in my desktop with all spanish special characters, to copy-paste with the mouse, when I worked on american computers
04:22
<vagrantc>
heh
04:23
yeah, i need that
04:23
<dberkholz>
compose key..
04:23
<vagrantc>
?
04:24
i know there's some way to configure key combinations...
04:24
<dberkholz>
compose, i + `
04:24
where compose key is controlled by xorg.conf something like Option "XkbOptions" "compose:menu" in the keyboard section
04:25
probably setxkbmap -option "compose:menu" if you want to change without restarting X
04:26
then hit menu, i, ` to get an i with grave
04:26* vagrantc has no "menu" key
04:26
<dberkholz>
there are other options
04:26
<f3ew>
meta
04:26
<dberkholz>
compose:rwin compose:rctrl compose:ralt etc
04:28* vagrantc has no luck
04:29
<vagrantc>
`
04:29
<dberkholz>
oh you've gotta have utf8 properly set up all the way through too
04:29
<vagrantc>
well, i've got that
04:29
<dberkholz>
readline-5, screen, irssi is what i need
04:29
<vagrantc>
well ... i don't know what "all the way is"
04:30
<dberkholz>
all with their own bits
04:30
well, readline you just need >=5, no config needed.
04:31* vagrantc suspects something amiss with the setxkbmap
04:32
<dberkholz>
try setxkbmap -print and see if it shows up
04:32
<vagrantc>
didn't show up, no
04:32
<dberkholz>
guess it didn't get in there, then.
04:33* vagrantc can't read
04:34
<vagrantc>
so, it was in there.
04:34
but now it's really screwed up
04:34
xkb_symbols { include "pc(pc105)+us+compose(menu)+compose(rctrl)"};
04:34
<dberkholz>
heh, you've got 2 compose keys. nice.
04:34
<vagrantc>
one of which i don't even have
04:35
though at one point, it was just ... xkb_symbols { include "pc(pc105)+us+compose(rctrl)"};
04:35
but it still didn't work
04:35
<dberkholz>
shouldn't affect your ability to use the other one
04:35
how about a different combo, like rctrl, o, /
04:35
should give that norse o with a slash through it
04:36
note those are not pressed at the same time but in sequence
04:36
<vagrantc>
no dice.
04:36
<envite>
¿how do you use compose?
04:36
<dberkholz>
Ãdoes it work in a terminal outside of irc?
04:36
<envite>
because it's not supossed to be pressed while you press the letter, but before
04:37
<vagrantc>
dberkholz: i'm trying in rxvt-unicode
04:37
<dberkholz>
one would hope that could handle it without too much effort
04:38
i'm just using gnome-terminal
04:38
<vagrantc>
the interesting thing is ... it doesn't print any character when i do it ... so it's obviously trying to do something
04:38
<dberkholz>
that sounds like you might not have utf8 working properly for it
04:38
<vagrantc>
hrm.
04:39
utf8 works for everything else...
04:39
<dberkholz>
another option is you have a font missing those chars
04:39
<vagrantc>
or at least, i have no trouble reading utf8 characters
04:39
<dberkholz>
more likely with bitmap fonts than ttf/type1
04:39
can you see e.g. ø
04:39
<vagrantc>
dberkholz: looks like an A with a ~ on top
04:40
<dberkholz>
one of us must be in iso8859-1 instead of utf8
04:40
er, 8559-1, whatever
04:40
<envite>
well
04:40
<vagrantc>
locale spits out en_US.UTF-8
04:40
<Q-FUNK>
ÃĀ
04:41
<envite>
I am in UTF-8
04:41
and this ? is a inverted question mark
04:41
sorry
04:41
this ¿
04:41
<Q-FUNK>
¿
04:41
<dberkholz>
heh, looks like it's probably my irc that's screwy.
04:41
<envite>
dberkholz: can be
04:42
<dberkholz>
brb
04:42dberkholz has quit IRC
04:42
<envite>
most irc clients are codechar configurable independently of the locale
04:42dberkholz has joined #ltsp
04:42
<envite>
because you must cope not with user, but with peers
04:42
so, i tipically use utf-8 in freenode but 8859-15 in Irc-Hispano
04:42
<Q-FUNK>
Я тебя хочу
04:43
<envite>
cool russian lettes :)
04:43
Я тебя хочу
04:43
<vagrantc>
ok, back to LTSP hacking... :)
04:43
<vanya>
:))
04:43
<dberkholz>
ø
04:43
<envite>
hehehehehehhe
04:43
<dberkholz>
is that a norse o-slash?
04:43
<envite>
i see that
04:44
<Q-FUNK>
yup
04:44
<dberkholz>
good. screen -U for the win
04:44
<Q-FUNK>
äöüæøœå
04:44
<dberkholz>
anyhow, i highly recommend getting compose keys working, it's a lot more logical than the somewhat arbitrary other way of typing special chars
04:44
<vanya>
ну тоді і з України привіт :)
04:44
<dberkholz>
with level3 shifts
04:45
<Q-FUNK>
добро
04:45
amazing how southern slavic ended up with real i, compared to russian and bulgarian
04:45
<vagrantc>
ah, tasty screen -U
04:46
i can use screen on the console again
04:47
<dberkholz>
weird, i need to pass -U even when reconnecting
04:53plamengr has joined #ltsp
04:53plamengr has left #ltsp
04:53defile has joined #ltsp
05:03defile has quit IRC
05:04defile has joined #ltsp
05:05defile has quit IRC
05:26
<envite>
going out to meet a cliente (¡ajcoooooo!)
05:27envite has quit IRC
05:32vagrantc_ has joined #ltsp
05:33
<vagrantc_>
in case it didn't make it to the channel the first time ... i wonder if that person who couldn't get floppies and CDs to work with ltspfs on debian was being bitten by missing lsof
05:37Q-FUNK has quit IRC
05:45vagrantc has quit IRC
05:47Avatara has joined #ltsp
05:51Q-FUNK has joined #ltsp
06:13vanya_y has joined #ltsp
06:13vanya has quit IRC
06:14vanya_y is now known as vanya
06:36Paul_UK has quit IRC
06:50jammcq has quit IRC
07:03ufo has joined #ltsp
07:14ogra-classmate has joined #ltsp
07:20jammcq has joined #ltsp
07:20jsgotangco has joined #ltsp
07:22a5benwillis has joined #ltsp
07:25Guaraldo has joined #ltsp
07:29jsgotangco has quit IRC
07:45cliebow has joined #ltsp
07:46
<Guaraldo>
jammcq: good morning... How do you do?
07:47
<jammcq>
hey Guaraldo
07:47
<cliebow>
jammcq!!!
07:48
<Guaraldo>
jammcq: I'm having some trouble with keyboard change on clients... Let me explain:
07:51ufo has quit IRC
07:51ufo has joined #ltsp
07:51
<Guaraldo>
clients have 3 kind of keyboard: us(intl), br(intl) and abnt2.
07:51
but, as keyboads get broken very often, it can change for each client...
07:52
so, jammcq, we made an script to change the keyboad, and it used to work very well on LTSP 4.1...
07:53
<vagrantc_>
change the keyboard on boot?
07:54
<Guaraldo>
vagrantc_: No... after login...
07:54
<vagrantc_>
ah
07:54
doesn't work anymore?
07:54
<Guaraldo>
it's a little command: setxkbmap -model abnt2 -layout br -print | xkbcomp - $DISPLAY
07:55
vagrantc_: that's the problem... after upgrading to LTSP 4.2, the xkbcomp drop client X...
07:56
<vagrantc_>
oh, upgrading *to* 4.2 ...
07:56
<Guaraldo>
vagrantc_: It was LTSP 4.1
07:56
<vagrantc_>
got it
07:56
i was thinking it was a 4.2 -> 5 issue ... i'm off the hook :)
07:57
<Guaraldo>
Ok... thanks, vagrantc_...
07:57
<vagrantc_>
thanks for passing the buck? :)
07:58
<Guaraldo>
vagrantc_: Thanks to listen... :-D
07:58
<vagrantc_>
hopefully it works when you get around to upgrading to LTSP 5 :)
07:59
Guaraldo: what distro are your servers running?
07:59* vagrantc_ wonders if it's an XFree86 / X.org incompatibility
07:59
<Guaraldo>
vagrantc_: Ubuntu...
07:59
<vagrantc_>
probably not, then.
08:03
<Guaraldo>
vagrantc_: Not only drop client's X, but you can't type anything else... You must reboot client to get back to control...
08:03
<vagrantc_>
a significant useability issue, yes.
08:06
<Guaraldo>
jammcq: any idea?
08:07* Guaraldo is a kind of lost...
08:09
<Guaraldo>
I thought could be the xkbcomp binary... changed it by the LTSP version... It was a bad idea... it locked the client at all...
08:09
got back to the ubuntu version...
08:10Guaraldo has quit IRC
08:11Guaraldo has joined #ltsp
08:11
<Guaraldo>
Ops... I was dopped!
08:16fxrsliberty has joined #LTSP
08:34irule has joined #ltsp
08:34Gadi has joined #ltsp
08:35rjune-isis has joined #ltsp
08:38Alexandre has joined #ltsp
08:41Alexandre has quit IRC
08:57vanya has quit IRC
08:58vanya has joined #ltsp
08:59highvoltage has quit IRC
08:59highvoltage has joined #ltsp
09:02sbalneav has joined #ltsp
09:02
<sbalneav>
Morning all.
09:03
<ogra>
!s
09:03
<ltspbot`>
ogra: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
09:03
<cliebow>
sbalneav, !!!
09:03
<sbalneav>
Morning ogra!
09:04MoL0ToV has quit IRC
09:04jsgotangco has joined #ltsp
09:05SBNet has joined #ltsp
09:21
<vagrantc_>
sbalneav: heya
09:21
<sbalneav>
Hey there!
09:21
How's it going?
09:22
Man, that Jan Kunder's been keeping me busy in the mailing list :)
09:23
He sorta forgot to mention a vital piece of info right at the beginning: that his chroot was installed in /opt/ltsp-500-blah-blah, and not /opt/ltsp
09:24
the ltsp-build-chroot script uses export BASE=${BASE:-/opt/ltsp}
09:24
<rjune-isis>
doh
09:24
<sbalneav>
We should probably do the same thing for ltsp-update-sshkeys, and ltsp-update-kernels as well.
09:24
<vagrantc_>
i really need to start preparing for my LTSP talk at debconf7
09:25
<sbalneav>
Then we could tell people: if you want to maintain/install other than /opt/ltsp, BASE=/opt/ltsp-blah-blah ltsp-update-sshkeys, etc.
09:25
<vagrantc_>
yes.
09:26
<sbalneav>
5 minutes for some slides, that's all you need :)
09:26
<vagrantc_>
i slowly worked some of those hooks in, but it's been a slow process of variabalizing hard-coded values
09:26
<sbalneav>
I could take a look at some of those.
09:26
<vagrantc_>
please do! :)
09:27
maybe we should drop commandline options for that stuff entirely, and require a configuration file instead, as the configuration needs to stay even after you've run the command.
09:28
sbalneav: now the talk is coming closer ... i don't even know what to say exactly.
09:28
:)
09:29
<sbalneav>
"Things are progressing nicely"
09:29
"All is well, citizen"
09:29
:)
09:30
<vagrantc_>
GAH! i am so sick of my messages not getting to pkg-ltsp-devel.
09:30
<jammcq>
!s
09:30
<ltspbot`>
jammcq: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
09:30
<sbalneav>
Morning jammcq!
09:31
<jammcq>
what's up homie
09:32
<sbalneav>
Coding coding coding!
09:32
Hey, should we get RW tickets this week?
09:32vanya has quit IRC
09:33vanya has joined #ltsp
09:33
<jammcq>
sbalneav: yeah, that, and Portland travel arrangements need to be made
09:34
<sbalneav>
yep
09:36
<ogra>
mumble, i still cant get the e2300 faster than 113 secs
09:37
the last thng that gained me 10 secs (and got me usplash back) is forcing the sisfb modul to load
09:40
<jammcq>
ogra: have you tried the different scheduler yet?
09:40* ogra wonders why it loads the pci htplug modules
09:40
<ogra>
*hotplug
09:41
jammcq, yes, the anticipatory scheduler is only minimally faster 3-5 secs
09:41
<jammcq>
bummer
09:41* jammcq was hoping for a magic bullet
09:41
<ogra>
the boost i saw on the classmate seems not to happen on the e2300
09:42
<vagrantc_>
probably network is not as big of a deal as on a USB device
09:42
<ogra>
yeah, indeed
09:43
<ogra-classmate>
http://www.phys.ethz.ch/~abe/MicroClientJr/ he seems to be quite happy with it booting from a local disk
09:43
and etchs kernel
09:44
i could build a squashfs from the chroot, but that will have other speed issues so its not really comparable
09:45jsgotangco has quit IRC
09:47sepski has joined #ltsp
09:50vanya has quit IRC
09:53
<Guaraldo>
sbalneav: H, Scotty...
09:53
<sbalneav>
Hey Guaraldo
09:53
<Guaraldo>
sbalneav: How do you do, man?
09:54
<sbalneav>
Delving into the mysteries of select(2) :)
09:54
<Guaraldo>
sbalneav: I'm having some trouble with keybord selection after login on LTSP 4.2 over Ubuntu dapper...
09:55
<jammcq>
select(2) is a wonderful system call. /me has done LOTS of select() programming
09:55
<sbalneav>
Yep, lots of fun.
09:56
Guaraldo: I think, if I remember correctly, ltsp 4.2 had some problems with the keyboard files it shipped with.
09:56
jammcq: You remember something about this?
09:56
There was something we had to do. Hmmmm....
09:56* sbalneav thinks
09:57
<Guaraldo>
sbalneav: On LTSP4.1 we used this command line to change: setxkbmap -model abnt2 -layout br -print | xkbcomp - $DISPLAY
09:58
It used to work very well... on LTSP4.2 it gives me many warning messages then drop client's X and block keyboard...
09:59
<sbalneav>
Yeah, hmm
09:59
ummm, check the ltsp-discuss mailing list archives, I think someone solved this.
09:59
Crumb, can't for the life of me remember what it was.
10:00* Guaraldo is searching...
10:07
<sbalneav>
Hm
10:24efra has joined #ltsp
10:33vagrantc_ has quit IRC
10:35fxrsliberty has quit IRC
10:37
<jammcq>
sbalneav: i really don't remember that problem
10:39
<sbalneav>
There was something with the compiled keymaps
10:39
had something to do with xkbcomp
10:39
<jammcq>
i'm thinking that was long before 4.2
10:39
like 4.0
10:39
<sbalneav>
hmm
10:39
<jammcq>
when we switched from XFree86 to Xorg
10:54lambda_ has joined #ltsp
10:58powernet has joined #ltsp
10:59
<powernet>
hi all, anyone may help me in a ltsp configuration ?
11:01f3ew has quit IRC
11:01f3ew has joined #ltsp
11:03
<powernet>
anyone there ?
11:04
<cliebow>
powernet spit er out..maybe someone can help
11:05
<powernet>
local usb stick on lts any idea
11:05
?
11:05
no way to view ?
11:05
<cliebow>
what version..
11:05
<powernet>
5
11:05
on ubuntu 7.04
11:05
standard installation
11:06
the rest seem's to be ok
11:06
<cliebow>
ogra is prob the one to snag..
11:06
<powernet>
i've read someting about sbalneaves
11:07
<cliebow>
sbalneav rocks!!!
11:07
<powernet>
:)
11:08
in 4.2 there is a way to do it, in 5.0 not ?
11:09
<cliebow>
this is on a terminal?
11:09
<powernet>
usb stick on terminal and mounted in some way on server for use it on client
11:10
<sbalneav>
powernet: Should work on both 4.2 and 5
11:10
<powernet>
(sorry for my bad english)
11:10
<cliebow>
have you tried the ten step..THERE he si
11:10
<sbalneav>
I have to pop out to a meeting right at the moment, should be back in an hour or so.
11:10
<powernet>
wow
11:10
ok np i'm here
11:10
<cliebow>
use the ten step,scottie?
11:10
<powernet>
thank a lot
11:12spectra has joined #ltsp
11:19
<powernet>
what's the 'ten step procedure?'
11:20
<cliebow>
sec
11:21
http://wiki.ltsp.org/twiki/bin/view/Ltsp/LTSP-42-LocalDev#Troubleshooting
11:21
<powernet>
i'll check ... thanks
11:21
<cliebow>
sure
11:27cyberorg has left #ltsp
11:37monteslu has joined #ltsp
11:41
<powernet>
cliebow: i've made some conf in the document .. i try to restart both server and client
11:42
i cross my finger
11:43tiagovaz has joined #ltsp
11:45nf1 has quit IRC
11:45nf1 has joined #ltsp
11:46Avatara has quit IRC
11:46plamengr has joined #ltsp
11:46plamengr has left #ltsp
12:01Q-FUNK has quit IRC
12:10
<Gadi>
sbalneav: ping
12:13plamengr has joined #ltsp
12:15
<sbalneav>
Gadi: ICMP ECHO REPLY
12:15
<Gadi>
ack
12:15
so...
12:16
is this a true statement: if the USB stick is plugged in on boot, feistyLTSP won't see it until it is unplugged and replugged to generate the udev event?
12:16
<sbalneav>
Well,
12:17
it SHOULDN'T be a true statement
12:17
when udev starts, it should enumerate everything that's in the box.
12:17
so if it's NOT doing that, I'd expect it's a bug.
12:18
<Gadi>
does it get covered under the delayted_mount code you have?
12:18
<sbalneav>
Now, is UDEV not seeing it, or is it that the LTSP scripts are being fired when things aren't plumbed enough to work.
12:18
It should, yeah
12:18
<Gadi>
ok
12:18
I havent investigated too much, just playing with some things and wanted to know what to expect
12:18
<sbalneav>
I mean, it works for IDE cdroms which is pretty much the same thing.
12:18
so if it's not working for usb sticks, that's a problem.
12:19powernet has quit IRC
12:19
<Gadi>
ok
12:19
no complaints, I take it yet
12:19
<sbalneav>
Not that I've heard.
12:19
Are you complaining? :)
12:19
<Gadi>
nope
12:19
<sbalneav>
Then no, I've heard nothing :)
12:19
<Gadi>
:)
12:19
youve tested with USB cdroms, right?
12:20* sbalneav wipes brow
12:20
<sbalneav>
whew
12:20
<Gadi>
so that should be the same
12:20
<sbalneav>
yep
12:20
we did.
12:20
yeah
12:20
<Gadi>
because you prolly had a cd in the cdrom on boot
12:20
tho, I suppose that has the whole cdpinger thing
12:20
i dunno
12:20
<sbalneav>
yeh
12:20
<Gadi>
i guess i'll jump over that bridge when I get to it ;)
12:21* Gadi wishes if he knew if he won yesterday's bet
12:22* Gadi also wishes he could type whats in his head
12:22
<Gadi>
;)
12:22
<sbalneav>
What was the bet yesterday?
12:22plamengr has quit IRC
12:22powernet has joined #ltsp
12:22
<Gadi>
someone had the ole I get bounced to the login screen when I try to login on a fresh install
12:23
my bet was that he did not have ltspfs installed
12:23
which he did not
12:23
but, I didnt see the resolution
12:23
<powernet>
hi, i've problem with local devices
12:23
<Gadi>
on Feisty, the ssh keys are usually taken care of
12:24
but, it also sets localdev by default, even if the server has no ltspfs
12:24
which can cause the login to barf
12:24
in my experience
12:24
powernet: what version of LTSP? and what problem?
12:24
<powernet>
5
12:24Blinny has joined #ltsp
12:24
<powernet>
no remote view of a local usb stick
12:25
<Gadi>
do you have ltspfs installed on the server?
12:25
dpkg -l ltspfs
12:25
<powernet>
1st time on ltsp
12:25
i'll check
12:26
mmm may not
12:27
<Blinny>
jammcq: ping
12:27
<Gadi>
powernet: install ltspfs
12:27
<powernet>
done
12:27
<Gadi>
you may be illustrating a point I was just making :)
12:27
restart the terminal
12:27
<powernet>
ok
12:27
<Gadi>
and log back in
12:28
<powernet>
switch on another machine
12:28powernet has quit IRC
12:28
<Gadi>
weird - I promise I didn't plant him in the audience
12:29Q-FUNK has joined #ltsp
12:29pere is now known as pere_away
12:30powernet has joined #ltsp
12:31
<powernet>
system restarted
12:32
mmm nothing change ... server devices on desktop
12:34
Gadi:any idea ?
12:34
<Gadi>
are the users part of the "fuse" group?
12:34
<powernet>
yse
12:35
yes
12:35
wich daemon take care of the usbstik in local thin client ?
12:36
<Gadi>
its a combination of things, but before you check daemons: do you have LOCALDEV=True in lts.conf?
12:36
<powernet>
yes LOCALDEV = Y
12:37
sorry =True
12:37
and LOCAL_STORAGE=Y
12:38
<Gadi>
you should only need LOCALDEV=True
12:38
for LTSP5
12:38
<powernet>
ok i remove LOCAL_STORAGE
12:39
<Gadi>
on the server, try: lsmod|grep fuse
12:40
<powernet>
done
12:40
<Gadi>
make sure the module is loaded
12:40
<sbalneav>
powernet: Before we go any further, what distro are you using?
12:40
<powernet>
yes it's loaded
12:40
ubuntu 7.04
12:42
both the server and the client have same name (hostname) it's normal ?
12:47
<sbalneav>
Yes, should be normal
12:47
Could you paste the lts.conf file you're using to the pastebot?
12:47
!pastebot
12:47
<ltspbot`>
sbalneav: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
12:48
<powernet>
mmm i try
12:48
!pastebot [default]
12:48
SOUND=True
12:48
LOCALDEV=True
12:48
NBD_SWAP=True
12:48
SYSLOG=server
12:48
<ltspbot`>
powernet: Error: "pastebot" is not a valid command.
12:49
<powernet>
i'm a dumb
12:49
so the file is more or less this
12:50
fresh ubuntu 7.04 installation
12:50
<ltsppbot>
"powernet" pasted "[default] SOUND=True LOCALDEV=" (5 lines) at http://pastebot.ltsp.org/149
12:55
<powernet>
but username on client environment (/opt/ltsp/i386/passwd) should exist ?
13:00
...
13:00
<Guaraldo>
sbalneav: I can't see the ltsp-discuss... Error 500 (Internal Server Error)... :-/
13:01
<powernet>
:(
13:02
<Gadi>
powernet: what device exactly are you using?
13:02
for removable media
13:02
<powernet>
usbstick
13:02
but same for cdrom or floppy
13:02
<Gadi>
do you know if it is partitioned?
13:02
ah
13:02
<powernet>
if i mount it it's ok on local
13:03
<Gadi>
should be fine
13:03
<powernet>
on desktop i've icon of server devices only
13:06
what process need to be up in server and client ?
13:06
(for remote mounting)
13:07
<Gadi>
if you add: SCREEN_07=ldm and SCREEN_02=shell to lts.conf and reboot the terminal, you can switch to the shell on ctrl-alt-f2
13:07
that can help troubleshoot
13:07
<powernet>
i can switch now with ctrl-alt-f1
13:08
working
13:08lambda_ has left #ltsp
13:08
<Gadi>
but you have no login on the client
13:08
there are no users on the client
13:08
<powernet>
i've root login
13:08
<Gadi>
you shouldnt
13:08
unless you added it
13:08
<powernet>
i've add sudo passwd
13:08
:)
13:08
<Gadi>
ah, ok
13:09
check for ltspfsd
13:09
on the client
13:09
<powernet>
on client ?
13:09
ok
13:09
<Gadi>
also check that on the client, you have folders created in /var/run/drives/
13:09
<Blinny>
Of the thin-clients at disklessworkstations.com, which ones use an accelerated server and don't require the install of any special settings/software?
13:11
<powernet>
ltspfsd is up with -a param and in /var/run/driver have floppy cdrom and usbfloppy-sda1
13:11
sorry floppy0
13:13
all the dir are empty
13:13
<Gadi>
thats correct
13:13
<powernet>
good
13:14
<Gadi>
ok, after you login through ldm and are at your desktop, open a terminal window and type: ls /media
13:14
<powernet>
gdm is the same ?
13:14
(gnome env)
13:14
<Gadi>
you're not using gdm - the login screen is called "ldm" and is running locally (just looks like gdm)
13:14
;)
13:16
<powernet>
:) ok the /media have cdrom0 floppy0 sdb1 and ubuntu7.04 (server devices i think)
13:17
<Gadi>
hmm
13:18
no subdirectories under /media?
13:18
what is your username?
13:18
<powernet>
yes all this are subdirectory
13:18
alex
13:19
.hal-mtab is referred to ubuntu cdrom
13:20
<Gadi>
ls -a /tmp/.alex*
13:21
on the server
13:21
<powernet>
are floppy0 and usbfloppy-sda1 dir
13:22
may be client devices this
13:22
<Gadi>
those should be
13:22
yes
13:23
<powernet>
mmm good
13:23
<Gadi>
but, you should also have a /media/alex folder
13:23
<powernet>
check
13:23
no
13:23
<cliebow>
yeas?
13:24
<powernet>
no
13:24
nothing
13:24
who create this ?
13:24
<Gadi>
when you login through ldm, a script called ltspfsmounter is called
13:25
<powernet>
ok i check if it is
13:25
<Gadi>
which creates the dirs in /tmp, in media, and connects everything back to the client
13:25gentgeen__ has joined #ltsp
13:25
<Gadi>
try: cat /proc/mounts|grep ltspfs
13:25
<powernet>
in server ?
13:25
<Gadi>
you should have an ltspfs mount
13:25
on the server
13:25
if not, then the ltspfs mount failed for some reason
13:26
<powernet>
aren't
13:26
<Gadi>
powernet: can you reboot the server?
13:26
try starting with a fresh reboot all around
13:27
<powernet>
yes i do
13:27
done -- rebooting
13:29
this is the second time i install the server, the first i've doing someting wrong because i've use this also for serving an sunray 100 thin client
13:30fernando1 has quit IRC
13:30muh2000 has quit IRC
13:34
<powernet>
arrghh started live ubuntu... going on the other room
13:35
ok ready
13:37
:)))) work
13:38
floppy and usb icons on desktop
13:39
i can read both
13:40
:( what is wrong before ?? i hate this
13:40
<Gadi>
:)
13:40
prolly the server just wasnt ready for you :)
13:41
<powernet>
no may be not restarted upon ltspfs installation
13:41
<Gadi>
enjoy
13:42
<powernet>
i'm very happy for your help
13:42
where are you from ?
13:43
<Gadi>
New York
13:43
<cliebow>
maine
13:43
<Gadi>
I would say USA, but we're really our own country
13:43
;)
13:43
<cliebow>
so are we
13:44
<Gadi>
yeah, we go to war all the time
13:44
with Maine
13:44
<powernet>
wow, i'm gone in 99 an 2000, i'm italian and if you went i'm offer a fresh beer... thank's a lot
13:44
<cliebow>
theirt insurgents drive cars with ny plates 8~)
13:44
<Gadi>
mangia!
13:44
<powernet>
ahah
13:44
<Gadi>
which part of italia?
13:45
<powernet>
tuscany middle of
13:45
near florence and siena
13:45
<cliebow>
is ther good beer?
13:45
<Gadi>
ooh... I LOVE Siena
13:46
<powernet>
not as north of europe
13:46
you now?
13:46
you know?
13:46
<Gadi>
one of my favorite vacations...
13:46
:)
13:46
<powernet>
when ?
13:46
<Gadi>
hmm... 2001
13:46
was last
13:46
<powernet>
wow
13:46
<Gadi>
we spent 3 weeks
13:47
<powernet>
when i'm on NY
13:47
8-)
13:47
<Gadi>
excelente!
13:47
<powernet>
you know Montepulciano?
13:47
<Gadi>
is that near San Gimingiano?
13:47
<powernet>
70km
13:48
near Pienza
13:48
<Gadi>
ah
13:48fernando1 has joined #ltsp
13:48
<powernet>
i wos born in Montepulciano and live there
13:48
<Gadi>
nice. pretty. :) ok, basta! Back to work... ;)
13:49
<cliebow>
sounds like a great place for and ltsp dev conf
13:49
<powernet>
ok
13:49
if you need something from Italy this is my email
13:49
alessandro.frati@gmail.com
13:49
ops ...public
13:50
<Gadi>
heh, grazie!
13:50sahil has joined #ltsp
13:50
<powernet>
i hope no need more help and dont' disturd more
13:50
grazie a te
13:50
and sorry for my bad english
13:50
!!
13:50
<ltspbot`>
powernet: Error: "!" is not a valid command.
13:50
<cliebow>
weare here to please
13:50
<sahil>
is there anyway to check what specific xorg.conf the clients are using also checks the logs?
13:51
<powernet>
if you have a user in it switch in console and check in /etc/X11/xorg.conf
13:52
<sahil>
thats not the xorg.conf on the server?
13:52
<powernet>
no
13:52
<sahil>
and tmp/xorg.log is also the client one?
13:52
<powernet>
dinamically created i suppose
13:54
but i'm a newbie
13:56
so i have dinner ... thank a lot to all specially Gadi,cliebow and sbalneav
13:56
bye
13:56
<sahil>
i keep loading vesa for some reason
13:56
<powernet>
you can force a specific driver in ltsp.conf
13:56
lts.conf
14:10bill_c has quit IRC
14:32muh2000 has joined #ltsp
14:38stillflame has quit IRC
14:39powernet has quit IRC
14:42Lambda] has joined #ltsp
14:46tiagovaz has quit IRC
14:49rjune-isis has quit IRC
14:57Blinny has left #ltsp
15:06vagrantc has joined #ltsp
15:23Burgundavia has joined #ltsp
15:23a5benwillis has quit IRC
15:24Lambda] has quit IRC
15:42Egyptian[Home] has joined #ltsp
15:42SBNet has quit IRC
16:00Guaraldo has left #ltsp
16:00vagrantc has quit IRC
16:17sepski has quit IRC
16:19KeepW has joined #ltsp
16:20
<KeepW>
hi, how can i pass 2 parameters to kernel via option-129 on dhcpd.conf?
16:22
<jammcq>
KeepW: put them both in the option-129 parameter
16:22
option option-129 "NIC=3c509 vga=773";
16:22
take a look at the following wiki page for more examples:
16:22
http://wiki.ltsp.org/twiki/bin/view/Ltsp/KernelOptions
16:24Egyptian[Home] has quit IRC
16:29maximi89 has joined #ltsp
16:29
<maximi89>
hi
16:29
why can be the terminals can't download vmlinuz
16:32
http://pastebin.ca/520198
16:32
that is the /etc/exports
16:33maximi89 has quit IRC
16:35
<str4nd>
wooooot....
16:36bronze has quit IRC
16:37
<str4nd>
weird
16:39sbalneav has quit IRC
16:42freyley has joined #ltsp
16:43fernando1 has quit IRC
16:45muh2000 has quit IRC
16:49bobby_C has joined #ltsp
16:53fernando1 has joined #ltsp
16:56highvoltage has quit IRC
16:56highvoltage has joined #ltsp
17:24GodFather has joined #ltsp
17:25
<GodFather>
ping jammcq
17:27lambda_ has joined #ltsp
17:28Q-FUNK has quit IRC
17:29lambda_ has quit IRC
17:33muh2000 has joined #ltsp
17:38muh2000 has quit IRC
17:39muh2000 has joined #ltsp
17:41V3rM3 has joined #ltsp
17:41V3rM3 has left #ltsp
17:44bobby_C has quit IRC
17:46
<pablo_>
hi how do i uninstall ltsp5 and install ltsp 4.2?
17:46
or they can live toghether?
17:47
<Burgundavia>
why would you want to do that?
17:47
<jammcq>
yes, they can live together
17:47
<pablo_>
because ltsp5 is so much slow. ltsp4.2 was much faster in terms of speed.
17:47
<jammcq>
when you go to install ltsp-4.2, just tell it to install in a different location, like /opt/ltsp-4.2
17:47
<pablo_>
booting clients in 4.2 took 22 secs
17:47
in ltsp5 takes more than a minute
17:48
jammcq: and after that i only have to edit dhcp.conf? is that ok??
17:49
or do i need to make any other changes?
17:49irule has quit IRC
17:50
<jammcq>
pablo_: you'll need to also have entries for both in your /etc/exports file
17:52
<pablo_>
the install/configure process of 4.2 will do that for me or ill have to edit it myself?
17:53
<jammcq>
it will, but when it's done, you'll want to make sure you still have the path for the ltsp-5 directory
18:01fuhvio has joined #ltsp
18:02pablo_ has quit IRC
18:08jammcq has quit IRC
18:12J45p3r has joined #ltsp
18:21GodFather has quit IRC
18:30fuhvio has quit IRC
18:35monteslu has quit IRC
18:42jsgotangco has joined #ltsp
18:43
<KeepW>
how to open por 177? its closed and gdm not start in clients
18:52
<sahil>
keepW:use the gdmc configuration tool
18:53
*gdm
18:58pablo_ has joined #ltsp
18:59
<pablo_>
ive added X_MODE_0=1024x768 in lts.conf but my clients still show a 800x600 screnn config (using ltsp5) what else can i try?
19:00
also: i have LOCALDEV=True in lts.conf but when trying to acces floppy from clients says it can mount the drive
19:03
<sahil>
is there any way to have a splash screen for boot?
19:03jammcq has joined #ltsp
19:04
<sahil>
jammcq! the best person in the world
19:04
<jammcq>
heh
19:04
what's up my friend?
19:04
<sahil>
not much just trying to figure out how to make my sis graphics work
19:04
<jammcq>
hmm
19:04
<sahil>
and actually is there a way to have a bootsplash screen?
19:05
<jammcq>
which version of LTSP ?
19:05KeepW has quit IRC
19:05
<sahil>
4.2
19:05
<jammcq>
well, bootsplash is very easy with ltsp-5.0, but very difficult with ltsp-4.2
19:07KeepW has joined #ltsp
19:07
<sahil>
i can't do 5 cause of gentoo
19:07
<jammcq>
bummer
19:07
<sahil>
the sis issue is my priority right now though
19:08
<jammcq>
i've got to go eat dinner. I'll be back in a little bit
19:08
<sahil>
kk
19:10KeepW has quit IRC
19:46jsgotangco has quit IRC
20:12efra has quit IRC
20:57adrianorg has joined #ltsp
21:00muh2000 has quit IRC
21:04J45p3r has quit IRC
21:14ogra has quit IRC
21:23ogra has joined #ltsp
21:24ogra-classmate has quit IRC
21:30gentgeen__ has quit IRC
21:30nf1 has quit IRC
21:30ufo has quit IRC
21:30dem has quit IRC
21:30whiprush has quit IRC
21:30pere_away has quit IRC
21:30jbrett has quit IRC
21:30MM2_ has quit IRC
21:32ufo has joined #ltsp
21:33MM2 has joined #ltsp
21:38gentgeen__ has joined #ltsp
21:38nf1 has joined #ltsp
21:38dem has joined #ltsp
21:38MM2_ has joined #ltsp
21:38pere_away has joined #ltsp
21:38jbrett has joined #ltsp
21:38whiprush has joined #ltsp
21:38dem has quit IRC
21:40MM2_ has quit IRC
21:40whiprush has joined #ltsp
21:41dem has joined #ltsp
21:44kaos01 has joined #ltsp
21:49pere_away has quit IRC
21:49jbrett has quit IRC
21:49gentgeen__ has quit IRC
21:49nf1 has quit IRC
21:49gentgeen__ has joined #ltsp
21:49nf1 has joined #ltsp
21:49pere_away has joined #ltsp
21:49jbrett has joined #ltsp
21:56pere_away has quit IRC
21:56jbrett has quit IRC
21:56gentgeen__ has quit IRC
21:56nf1 has quit IRC
21:57adrianorg has quit IRC
21:59nf1 has joined #ltsp
21:59jbrett has joined #ltsp
21:59gentgeen__ has joined #ltsp
21:59pere has joined #ltsp
22:43muh2000 has joined #ltsp
22:45cyberorg has joined #ltsp
23:04sahil has quit IRC
23:09bill_c has joined #ltsp
23:21sahil has joined #ltsp
23:29
<sahil>
jammcq: are you around?
23:50f3ew has quit IRC