IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 16 June 2007   (all times are UTC)

00:07sbalneav has quit IRC
00:33muh2000_ has joined #ltsp
00:49Egyptian[Home] has joined #ltsp
00:50muh2000 has quit IRC
01:19jsgotangco has joined #ltsp
02:09cliebow has quit IRC
02:12cliebow has joined #ltsp
02:37jsgotangco has quit IRC
02:52nsar has joined #ltsp
02:58nsar has quit IRC
02:58nsar has joined #ltsp
02:59Burgundavia has quit IRC
02:59nsar has quit IRC
02:59nsar has joined #ltsp
03:00nsar has left #ltsp
03:01nsar has joined #ltsp
03:02
<nsar>
hello
03:02
<str4nd>
hei
03:02
*hi :)
03:02
<nsar>
hi
03:06nsar has quit IRC
03:17ogra_ has joined #ltsp
03:18fernando1 has quit IRC
03:18ogra has quit IRC
03:18ogra_ is now known as ogra
03:22fernando1 has joined #ltsp
03:36vagrantc has joined #ltsp
03:41otavio has joined #ltsp
04:26muh2000__ has joined #ltsp
04:26muh2000_ has quit IRC
04:40Q-FUNK has joined #ltsp
04:48sahil has quit IRC
04:55yigal has joined #ltsp
04:56
<yigal>
hi guys, I am back with a secondary netwrok card
04:57
i just dont know how to find it's location in rom-o-matic, since there are several entries with same chipset
04:57
with hexa numbers. Any idea how to chose the right hexa entry?
04:59
this pc has not ethernet boot option, so I must prpare a diskette, to make it a thin client
05:02vagrantc has quit IRC
05:12Avatara has joined #ltsp
05:13
<yigal>
any one with rom-o-matic knowledge?
05:16
<dan__t>
lspci?
05:35yigal has quit IRC
05:35yigal has joined #ltsp
05:38yigal_ has joined #ltsp
05:39
<yigal_>
hi guys - need help with ROM-O-Matic for a network card. Any help would be appreciated
06:07
<cliebow>
yigal_, :whata card?
06:09
can you run a live cd...do lspci -vv and get the busid..then do lspci -n and get the device id..
06:09
use that to see if there is an etherboot image for it
06:22gonzaloaf has joined #ltsp
06:39bronze has joined #ltsp
06:40jammcq has quit IRC
06:40Q-FUNK has quit IRC
06:41muh2000__ has quit IRC
06:41muh2000__ has joined #ltsp
06:46Q-FUNK has joined #ltsp
06:53
<yigal_>
the chip is RTL8139D
06:53
there are several entries in romatic. how can i tell which one?
06:54muh2000_ has joined #ltsp
06:54muh2000__ has quit IRC
06:59
<yigal_>
i may have solved the problem... i have chosen one entry and i have some activity when I power up
07:01
now i need help to configure the server
07:01
how do i tell the server to use the 2nd NIC and to boot the client?
07:02vagrantc has joined #ltsp
07:10
<cliebow>
turn off thed onbord in the bios?
07:11
you have a default dhcpd.conf? we dont even know what distro you have..
07:13
<yigal_>
ok... here it is:
07:13
<cliebow>
dont paste long
07:13
<vagrantc>
yigal_: pastebot please
07:13
!pastebot
07:13
<ltspbot>
vagrantc: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
07:13
<cliebow>
use the past...heh
07:14muh2000_ has quit IRC
07:15
<cliebow>
reminds me of a sailboat race i watched..
07:16
<ltsppbot>
"yigal" pasted "Client server status" (7 lines) at http://pastebot.ltsp.org/178
07:17
<cliebow>
ok..what network is your internal card? 192.168.0?
07:18
<yigal_>
how can i tell that?
07:18
<cliebow>
ifconfig:im guessing you are new so we'll try to be patient
07:19
lets just see if dhcp is running with netstat -anp|grep ":67"
07:20
<yigal_>
bash:ipconfig: command npt found
07:21
oops, hold
07:21
<cliebow>
heh
07:21
<vagrantc>
ifconfig
07:22ogra has quit IRC
07:23
<yigal_>
ifconfig returns many lines, cant copy them all. ifconfig:im returns command not found
07:23
<vagrantc>
ifconfig | egrep ^eth
07:23ogra has joined #ltsp
07:24
<vagrantc>
ifconfig | egrep -A 1 ^eth
07:26
<cliebow>
sorry about that
07:28
yigal_, that is a "pipe" symbol between ifconfig and egrep
07:41
<ltsppbot>
"Yigal" pasted "set up server" (4 lines) at http://pastebot.ltsp.org/179
07:53
"yigal" pasted "set up server" (40 lines) at http://pastebot.ltsp.org/180
07:54
<yigal_>
all info in pastebot
07:57nf1 has joined #ltsp
08:05
<ltsppbot>
"yigal" pasted "now with nstat as well" (49 lines) at http://pastebot.ltsp.org/181
08:18Lumiere is now known as Lumiere|Sarcasm
08:45plamengr has joined #ltsp
08:45plamengr has left #ltsp
08:50edgarin has joined #ltsp
08:53nf1 has quit IRC
08:59lambda has joined #ltsp
09:05obelin23 has joined #ltsp
09:05sbalneav has joined #ltsp
09:06
<sbalneav>
Morning all
09:07
<yigal_>
morning
09:08* vagrantc does the new ltsp and ltspfs packages in debian/unstable dance
09:09
<sbalneav>
hey vagrantc, here's a conundrum for you
09:10
ever seen this one before? With the new LDM, I log into X,everything looks fine, but when I start typing, it's OK until I hit the enter key...
09:10
Then the enter key "sticks", and keeps being presses.
09:10
pressed sorry.
09:11
If I ctl-alt-f1 to a text console, it;s ok, and if I ctl-alt back to X, it's stopped.
09:11
Wierd, huh?
09:12
<vagrantc>
ouch
09:12
this is with your ldm c rewrite ?
09:12
<sbalneav>
yeah.
09:13
Now, I should try it with a stock chroot.
09:13
<vagrantc>
this brings some really old hazy memories back ...
09:13
<sbalneav>
since Xorgs been updated, it may be an xorg thing.
09:13
<vagrantc>
but not really in clarity
09:13
<sbalneav>
I vaguely remember some other people complaining of this before too.
09:18
<kaminski-ltsp-br>
sbalneav: hi
09:18
<sbalneav>
hello kaminski-ltsp-br
09:24Lumiere|Sarcasm is now known as Lumiere
09:28cottima has joined #ltsp
09:31
<cottima>
I might miss understand how ltsp works, but it sends gui over network. does it send X?
09:31
<sbalneav>
cottima: yes
09:33
<cottima>
(I have 10 mostly 225MHz+ 128MBram 2GBhdd machines) and if the machine has enough power, is there a way to have some of the resources on the client used to relieve the server a little?
09:34
<sbalneav>
You asked this the other day.
09:34
I answered it.
09:34
<vagrantc>
cottima: there is no way out of the box. it is certainly possible, but a lot of work.
09:34
<cottima>
I did I am tired. Sorry!
09:36
I am nervous. Never have done anything worth while with Linux and am think of all the things the system needs like a content filter and locking down a user. I have only been using Linux as a desktop. I am sorry and always thankful for help.
09:39
Have a nice day everyone. I will see you later and next time after reading several docs.
09:39
bye
09:39cottima has left #ltsp
09:39obelin23 has quit IRC
09:51
<sbalneav>
Back on later
09:51sbalneav has quit IRC
09:52vagrantc has quit IRC
09:52vagrantc has joined #ltsp
09:57cliebow has quit IRC
09:58Lossie has joined #ltsp
09:58cliebow has joined #ltsp
09:59
<Lossie>
local drives howto anyone?
10:09Avatara has quit IRC
10:20cliebow has quit IRC
10:20cliebow has joined #ltsp
10:21
<vagrantc>
Lossie: what linux distro?
10:31
<yigal_>
hi guys, I need more help to define the server in Ubuntu. I have two NICs installed, and you can see the results in: http://pastebot.ltsp.org/180
10:39
<Lossie>
ubuntu
10:40
vagrantc: Ubuntu Feisty
10:41
this is what i have so far
10:41
LOCAL_STORAGE=Y
10:41
LOCAL_DEVICE_01=/dev/sda:usb
10:41
HOTPLUG=Y
10:41
in lts.conf
10:42
what needs to be done on the server side
10:42
how do i get it automounted?
10:45
<ogra>
Lossie, you wont gain anything with these ltsp 4 settings :) try https://wiki.ubuntu.com/EnableLTSP5LocalDevices
10:48
drop all that stuff from your lts.conf
10:48wpgmb_ has joined #ltsp
10:51
<Lossie>
ogra, it's these kind of manuals need that i cound't find wile googling, thx
10:52
Going for reboot *crossing fingers*
10:52Lossie has quit IRC
10:58Lossie has joined #ltsp
10:58
<Lossie>
well what do you know it works
10:58
thx
10:59
<ogra>
:)
11:00
<wpgmb_>
hi.. I'm about to install edubuntu and was wondering.. Will there be an option to use lvm in the drive partitioning setup so I can use multiple drives for /home?
11:00
<ogra>
there should be, yes
11:01
<wpgmb_>
and that doesn't cause any known issues with assigning clients their own piece of the pie?
11:01
<ogra>
??
11:01
clients boot from a readonly exported chroot from /opt/ltsp
11:02
thats the only connection to any disk they have
11:03
so no, you dont assign any pieces to any clients, so there are no issues :)
11:03
<wpgmb_>
sorry. my bad.. what I meant was, if I run out of space later on /home, can I add / exchange drives for /home without any issues?
11:03
<ogra>
i'm not an lvm user, but isnt that the prupose of it ?
11:04
so i'd guess so
11:04
<vagrantc>
wpgmb_: if you leave some space free, it's easy to add space. it's harder to shrink filesystems
11:04Q-FUNK has quit IRC
11:04
<vagrantc>
wpgmb_: if you make a bigger than you need swap on lvm, it's easy to resize swap
11:05* ogra doesnt manage to get sbalnevs ldm working :(
11:05
<wpgmb_>
It is. I just wanted to know if there are any know issues with using lvm in combination with edubuntu server. You've answered my question - and like everything else, try and learn, right?
11:06
I have two 9G Scsi's lying around I'd like to use for /, /var /tmp etc and use two 80G IDE drives for /home using lvm - that's why I asked
11:09
<yigal_>
hi... i need help with configuring Server-thin client, with Ubuntu 7.04.
11:16
<wpgmb_>
yigal: I may not be the one able to help you, but I suggest you post your question :o)
11:22
<yigal_>
thanks. I did post, made some progress today, but again I am at a dead end. I keep reading documents, but I guess I am a too dummy to use them.
11:25
<ogra>
!ubuntu
11:25
<ltspbot>
ogra: "ubuntu" is a Debian based GNU/Linux distrubution that includes a Ubuntu specific version of LTSP. It can be found at http://www.ubuntulinux.org. to install ltsp on ubuntu: https://help.ubuntu.com/community/UbuntuLTSP/LTSPQuickInstall
11:25
<ogra>
yigal_, just follow the wuick install guide
11:25
*quick
11:30
<yigal_>
i wish it was as simple as that. I followed different guides. None is going the simple way: what do I have to do with a Ubuntu 7.04 in order to set it up at the server. Most guides are for older versions. I know I am doing something wrong, but after 3 days of reading the "go rtfm" material I need help or to abort the story. I still wonder if thin client is a rocket science.
11:32
<ogra>
if you folow the guide step by step on a clean ubuntu it will work out of the box
11:34
<yigal_>
I was thinking the same, but it didn't. Thanks any way.
11:34
<ogra>
make sure to have one static interface with the ip 192.168.0.1, install ltsp-server-standalone and openssh-server ... run sudo ltsp-build-client, boot your clients ...
11:35
<yigal_>
I did all the above
11:35sbalneav has joined #ltsp
11:35
<ogra>
on a clean ubuntu ?
11:35
i.e. you didnt fiddle with other ltsp implementations that tweak settings ?
11:35
<sbalneav>
hey, ogra!
11:35
<ogra>
!s
11:36
<ltspbot>
ogra: "s" is Scotty!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
11:36
<sbalneav>
Got a second?
11:36
<ogra>
sbalneav, i cant get your ldm to work at all
11:36
:(
11:36
<sbalneav>
No?
11:36
<ogra>
no
11:36
<sbalneav>
does it call up the greeter?
11:36
<ogra>
your quoting of the command seems very strange as well
11:36
yes
11:36
but it doesnt let me in
11:36
and apparently something breaks ssh completely, i cant ssh from commandline either
11:37
<sbalneav>
hmm
11:37
Well, when I ssh in, you see I set the "LANG=C"
11:37
<ogra>
also fgets commands wont get through the security review, we'll need proper forking
11:38
<sbalneav>
fgets, or popen?
11:38
<yigal_>
it was an ubuntu upgrade from 6.04 to 6.10 and then 7.04. I just today added the 2nd NIC.
11:38
<ogra>
both
11:38
<sbalneav>
yeah, that's just a quicky
11:38
<ogra>
forking and reading from raw fd's ...
11:38
just a side comment ...
11:38
<sbalneav>
I'll do that once we get it working :)
11:38
<ogra>
i know its a prototype ;)
11:39
<sbalneav>
hmm, wonder what you're seeing on the ssh fd.
11:39
<ogra>
i'm not near ay cient atm :/
11:39
*client
11:40
<sbalneav>
I'll add some code to dump the expect strings to tty2
11:40
<ogra>
i see it complaining abut ssh-askpass on the X screen though
11:40
<sbalneav>
that way you can control-alt-f2, and see what the program thinks it's seeing
11:40
<ogra>
(if the greeter diesd)
11:40
<sbalneav>
Never seen that.
11:41
<ogra>
yeah, you dropped ldm.log :) that made debugging somewhat reasier :)
11:41
*easier
11:41
<sbalneav>
well, the idea was to log to syslog, but for me, the syslog is REALLY slow
11:41
it only posts one line per second from the client.
11:41
<ogra>
if i install ssh-askpass-gnome i get a second passphrase question after the greeter and then a dbus error in the session
11:42
yeah, something is not right wih syslog, i noticed that as well
11:42
<sbalneav>
You shouldn't need ssh-askpass
11:42
<ogra>
right
11:42
<sbalneav>
here's the problem I'm having
11:42
<ogra>
i see the sentinel message
11:42
btw ...
11:43
<sbalneav>
oh, so when you're logged in on the server, if you do a ps -ef you see the echo LTSPROCKS ; bash -?
11:43
<ogra>
no it doesnt get there
11:43
<sbalneav>
oh, ok
11:43
<ogra>
the connection dies earlier
11:44
<sbalneav>
Once I get logged in, things work fine.
11:44
except the keyboard
11:44
<ogra>
check accessibility options
11:44
<sbalneav>
wwwwhhhhhhiiiiiccccchhhhhhhhh reeeepeeeeeaaaattssssss keeeeyyyysss liiiikkeee craaazyyyy
11:44
<ogra>
and the gnome keyboard settings
11:44
<sbalneav>
oh, is that it?
11:44
<ogra>
it might be caused by not using an xorg.conf
11:45
<sbalneav>
That was what I was wondering. But I'll check the accessibility options.
11:45
Where do we want the ldm.log?
11:45
<ogra>
set CONFIGURE_X=True in lts.conf to force X detection
11:45
we had it on the client in /var/log before
11:45
<sbalneav>
in /tmp, or /var/run?
11:46
ah, duh
11:46* sbalneav slaps forhead
11:46
<sbalneav>
gimme 15 minutes, I'll hack in some logging
11:46
<ogra>
well, using syslog would be better indeed
11:46
<sbalneav>
right.
11:46
<ogra>
but as it is it will only slow down i guess
11:46
<sbalneav>
But until we get that fixed, this is workable.
11:46
<ogra>
i'll have to dig into that
11:46
<sbalneav>
meh, l8ter :)
11:47
I wanna see you get logged in.
11:47
<ogra>
yep
11:47
well, im not near a client atm ... and susie started cleaning the house throwing angry looks ...
11:47
i guess i should soon start helping :)
11:47
<sbalneav>
heh
11:47
I gotta do some housework soon too.
11:48
But, I'll get this in first, and push it. Have a look at it later today if you can.
11:48
But help Suzie first. :)
11:48
<ogra>
we might have guests the next 100 days :)
11:48
<sbalneav>
Tell her your Canadian Friend says hi :)
11:48
<ogra>
http://documenta.de/geschichte0.html?&L=1
11:49
<sbalneav>
Whassat?
11:49
<wpgmb_>
sbalneav: it's (all about) art - or is it art? :o)
11:49
<ogra>
one of the biggest art exhibitions worldwide ...
11:49
<sbalneav>
Cool
11:50
<ogra>
using the whole city for sculptures etc for 100 days
11:50
the only intresting thing this boring city has :)
11:51yigal_ has left #ltsp
11:52
<wpgmb_>
ogra: so - you inviting us all Canucks, sending free airline tix and all?
11:52
<ogra>
haha
11:52
<wpgmb_>
(I tried..)
11:52
<ogra>
i wish i'd be so rich :)
11:52
(i would though :) )
11:53
<wpgmb_>
It's been faaaar too long since I enjoyed a cool, European beer... *snif*
11:55
Q for all... I have two SCSI's - a 9G and a 2G, and then two 80G IDE's... Would the 9 + 2 be sufficient to hold the / and swap for Edubuntu, if I want to dedicate the two 80G's for /home (using LVM)?
11:56
addendum: I have 1G RAM, was thinking to use the 2G SCSI for swap.. is that overkill?
12:04
ok... let me ask a different way.. is the amount of /var space dependent on the number of clients?
12:05
<sbalneav>
No
12:06
ogra: ok, logging added
12:06
pushing
12:07
Off for a bit to do some housework.
12:07sbalneav is now known as sbalneav|AFK
12:08
<wpgmb_>
sbalneav: thx. back to my earlier question: will 9G be sufficient for a complete Edubuntu w/ LTSP install?
12:09Q-FUNK has joined #ltsp
12:09Santo_pendorchoo has joined #ltsp
12:10
<Santo_pendorchoo>
buenas
12:10
alguien de habla hispana
12:16
quiero montar un cybercafe , con 20 pc un entre 120 y 233 mhz con 32 ram y disco de 300 mb, y como servidor un athlon 2000 con 1 gb de ram
12:18
<wpgmb_>
I don't speak Spanish, but so far, I understand what you said
12:21
<Santo_pendorchoo>
ok im not speak english, but so far, i understand you said
12:22
i need create ltsp server for cybercoffee
12:22
<wpgmb_>
comprende
12:22
<Santo_pendorchoo>
i have 12 old pc and 1 pc with server
12:23ogra has quit IRC
12:23
<wpgmb_>
yes
12:24
<Santo_pendorchoo>
i have cable modem conect to router , conect to switch
12:24
for internet
12:24
<wpgmb_>
ok
12:24
<Santo_pendorchoo>
and switch conect all pc
12:24
<wpgmb_>
ok
12:25
<Santo_pendorchoo>
no need dhcp-server
12:25
<wpgmb_>
how do the client pc's get their IP address?
12:25
<Santo_pendorchoo>
router work dhcp
12:25
<wpgmb_>
ok
12:26
which linux for ltsp?
12:26
<Santo_pendorchoo>
i use ubuntu 7.04 como server
12:26
<wpgmb_>
ok
12:26
server has static IP?
12:27
<Santo_pendorchoo>
yes
12:27
<wpgmb_>
what is the problem?
12:27
<Santo_pendorchoo>
equal to the client
12:27
<wpgmb_>
clients also have static IP's - ok
12:27
what is the problem??
12:27
<Santo_pendorchoo>
yes
12:28
what need config ltsp server
12:28
have apt-get install ltsp-server
12:28
<wpgmb_>
Edubuntu has the option to install LTSP right from the start
12:29
no need to install later
12:29
<Santo_pendorchoo>
si ya se
12:29
but install ubuntu
12:29
installed
12:30
<wpgmb_>
So - you have Ubuntu installed, and would like to add LTSP?
12:30
<Santo_pendorchoo>
yes
12:31
<wpgmb_>
what is the problem?
12:31
<Santo_pendorchoo>
installed ltsp a traves de apt-get instal ltsp-server packages debian
12:32
<wpgmb_>
which version of LTSP did you get?
12:32
<Santo_pendorchoo>
my problem is config ltps server
12:32yigal_ has joined #ltsp
12:32
<Santo_pendorchoo>
5.07
12:32
<wpgmb_>
ok
12:32
<Santo_pendorchoo>
so?
12:33
<wpgmb_>
I'm not sure about the options when LTSP is installed later.. but I do know that if you install Edubuntu, LTSP has basic configuration files already, that might be useful
12:34
see if you can find sample config files on the Internet.
12:35
<Santo_pendorchoo>
yes but host.allows and other files config not understand
12:35
step by step
12:36
<wpgmb_>
I can't help you there. Sorry.
12:36
<Santo_pendorchoo>
ok
12:36
so you think you can tell Heaven from Hell,
12:36
blue skies from pain
12:37
thank wpgmb_
12:37
<wpgmb_>
http://www.geocities.com/hammerjw/ltsp-basic_security.html go down to No. 4
12:37
<Santo_pendorchoo>
handshake from argentina
12:38ogra has joined #ltsp
12:45Santo_pendorchoo has quit IRC
12:53yigal_ has left #ltsp
12:56ogra has quit IRC
13:00ogra has joined #ltsp
13:02
<vagrantc>
ogra: so, we got ltsp packages out of the NEW queue today ... but jvw wanted us to improve the package descriptions...
13:17ogra has quit IRC
13:17ogra has joined #ltsp
13:19yigal_ has joined #ltsp
13:20
<yigal_>
hi Cliebow, have time to continue ramping up my server?
13:23
<lambda>
vagrantc, it appears ltsp_5.0.8debian2/debian/doc is rather slim
13:24* lambda wonder why writting doc is so fastidious ...
13:24
<wpgmb_>
I'm attempting to install Edubuntu 7 as an LTSP server. Do I need to add special parameters to the kernel for it to see scsi drives? Only the IDE drives in the system are seen in the partioner
13:24
<vagrantc>
lambda: well, please write some :P
13:25
lambda: if you ask me questions, and turn it into documentation, i would be thrilled.
13:28petre has joined #ltsp
13:30
<lambda>
vagrantc, I'm accustomed to ltsp-4.1 and have already participate to the french translation ( http://ltsp.mirrors.tds.net/pub/ltsp/docs/ltsp-4.1-fr.html )
13:30
My LUG is fond of ltsp technology
13:32
<vagrantc>
lambda: well, start adding content to http://wiki.debian.org/LTSP ... or wiki.ltsp.org ... and we'll pull content into the package
13:35petre has quit IRC
13:37* lambda planed to install the freshly upgraded debian-edu-amd64-i386-powerpc-DVD-1.iso this evening ...
13:37
<vagrantc>
lambda: there's also a lot of relevent content on ubuntu's wiki ... though some of it is a bit different
13:37
lambda: debian-edu is using an older ltsp version, mind you.
13:38
lambda: it should work with the newer packages, but i'm not certain
13:46sepski has joined #ltsp
13:47yanu has quit IRC
13:55
<lambda>
vagrantc, Do I write it in hurry ?
13:57
<vagrantc>
lambda: write it whenever you want :)
13:57
<wpgmb_>
Question: when using the guided partioner using LVM, the system hangs at 60% during "computing the new partitions..." Am I doing someting wrong?
13:58
oh no... wait.. it's just veeeeeery slooooow...
14:00
<lambda>
vagrantc, from 18 monday evening will I have more time to dedicate ; be sure I will do my best :)
14:15Burgundavia has joined #ltsp
14:17
<vagrantc>
Burgundavia: how's things goin in canananadia ?
14:17
<Burgundavia>
not bad
14:17
the unemployment thing sucks though
14:28* kaminski-ltsp-br is back
14:34
<vagrantc>
Burgundavia: yeah, i'm acquanted with unemployment myself :)
14:35
<Burgundavia>
vagrantc: when does your job start?
14:36
<vagrantc>
Burgundavia: good question
14:43jammcq has joined #ltsp
14:43
<jammcq>
hello
14:44
<vagrantc>
http://packages.qa.debian.org/l/ltsp/news/20070616T135048Z.html
14:44
yay!
14:45
and http://packages.qa.debian.org/l/ltspfs/news/20070615T213208Z.html
14:47Yigal has joined #ltsp
14:47yigal_ has quit IRC
14:56jasonrsmit1 has joined #ltsp
14:58
<Yigal>
Hi Guys. I need help to ramp up Server-thin clinet based on Ubuntu 7.04. This computer I am using now will be the server. It has 2 NICs - one to the internet, and one to a client, which tries to get IP for some hours now. Can someone help me to config the server? I read many documents, nothing helped. My deadline is Monday.
15:00
<jasonrsmit1>
Yigal, did you run the apt-get install ltsp-server-standalone command to install ltsp?
15:00
<Yigal>
yes
15:01
<jasonrsmit1>
did you change the IP address from the default on eth1?
15:02
<Yigal>
and also the yes, but I am not sure I did it correctly. eth1 is theone connected to the client, I gave it 192.168.0.254, no gateway
15:02
yes, but I am not sure I did it correctly. eth1 is theone connected to the client, I gave it 192.168.0.254, no gateway
15:03
<jasonrsmit1>
ok, then you need to check /etc/ltsp/dhcpd.conf and make sure it's set up for the right IP address
15:03
there's a good howto at https://help.ubuntu.com/community/ThinClientHowto
15:03
<vagrantc>
Yigal: use 192.168.0.1 for the server
15:03
ubuntu, right ?
15:04
<Yigal>
yes, ubuntu 7.04
15:04
<vagrantc>
192.168.0.1
15:04
<jasonrsmit1>
yes, but which address do you have eth1 set to: 192.168.0.1 or 192.168.0.254 ?
15:05
<Yigal>
now i changed it to 192.168.0.1 as advised. it was 254 before
15:06
<vagrantc>
try again
15:06
<wpgmb_>
Question: If I choose to implement LVM - at what point will the installer let me assign a mountpoint to the LV's? I think this is broken in the installer -unless I'm missing something
15:07
<vagrantc>
wpgmb_: if this is edubuntu, you should probably ask in the #edubuntu channel
15:07
it really doesn't have anything to do with LTSP ...
15:07
<wpgmb_>
'k
15:08
<Yigal>
still "NO IP address"
15:09
<vagrantc>
Yigal: could you post /etc/ltsp/dhcpd.conf to the pastebot ?
15:09
<Yigal>
i work on it now
15:09
<jasonrsmit1>
yigal, how do you have the client hooked up? direct with a crossover cable or with a hub/switch
15:10
<ltsppbot>
"Yigal" pasted "thin client" (17 lines) at http://pastebot.ltsp.org/182
15:11
<Yigal>
switch
15:11
<vagrantc>
Yigal: egrep -i dhcp /var/log/syslog
15:11
Yigal: paste it to the pastebot please
15:12
Yigal: egrep -i dhcpd /var/log/syslog
15:12Q-FUNK has quit IRC
15:14
<ltsppbot>
"Yigal" pasted "thin client" (294 lines) at http://pastebot.ltsp.org/183
15:15
<vagrantc>
Yigal: looks like you might have troubles with eth2
15:16
<Yigal>
you mean with the hardware?
15:16
<vagrantc>
something ...
15:16
ah
15:16
network manager
15:16
maybe that's causing problems ...
15:17
<Burgundavia>
networkmanager cannot have two active network cards
15:17
that is your problem
15:17
<vagrantc>
Yigal: it looks like you have eth0, eth1 and eth2 ... how many cards do you think you have ?
15:17
<Yigal>
only two
15:17
eth0 and eth2
15:18
<vagrantc>
i see a lot of: Jun 16 07:57:47 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
15:18
<Yigal>
I see only eth0 and eth2 in the network controller software
15:18
<vagrantc>
but sounds like network-manager will be a big problem
15:19ogra_ has joined #ltsp
15:19
<Yigal>
but this is why we have nework manager for, right?
15:19* vagrantc does the network-manager should conflict with ltsp dance
15:19ogra has quit IRC
15:20
<vagrantc>
well, network-manager is for automatically managing your network settings ... and not currently smart enough to handle LTSP environments by default
15:20* vagrantc leaves it up to others what to do from here
15:21
<Yigal>
hmmm, who are the others? since if this like in "lost" ........
15:22
<Burgundavia>
network manager cannot currently support have more than 1 active network interface
15:22
you need to remove NM and then manually configure the interfaces via /etc/network/interfaces
15:23
<Yigal>
are you 100% sure? 2 NICs is not suppose to be an issue with a mature OS. It's even described in the manuals as recommended way with Server
15:23
<Burgundavia>
yes, completely certain
15:24
the issue is not the base Ubuntu, it is NetworkManager
15:24
Ubuntu, sans NM, can handle as many nics as you want. NM cannot (yet)
15:25
<Yigal>
i see. So if I need to have two NICs, and I know their IPs, can you guide me with removing NM and setting it up?
15:25
<Burgundavia>
yep
15:26
sudo apt-get remove network-manager
15:26
<Yigal>
will it kill the networking? this is the same machine I use now to yype
15:26
type
15:27
<Burgundavia>
yes, it will
15:27
before you do that, lets make certain you can get back online
15:27
ok
15:28
for the network card that is connected to the outside, you need the following:
15:28
<Yigal>
ok, let me first rampup the other Ubuntu machine (on vmware, will take a sec
15:28
<Burgundavia>
auto eth0
15:28
<Yigal>
wait please
15:28
<Burgundavia>
iface eth0 inet dhcp
15:30yigal_ has joined #ltsp
15:30
<yigal_>
ok... i am set here. please lead me
15:31
<Burgundavia>
ok
15:31
which nic faces the internet and which faces the thin client?
15:32
<Lossie>
is beryl possible in ltsp or shouldn't i even try?
15:32
<yigal_>
removing NM now. Eth0 - internet. Eth1 or 2 goes to the client
15:33
NM removed
15:33
<Burgundavia>
okl
15:33
so in /etc/network/interfaces
15:33
eth0 should be the following:
15:34
auto eth0
15:34
iface eth0 inet dhcp
15:35
<yigal_>
it is so
15:35
no.. wait .... mistake
15:36
3rd line ends with "static" because I wanted the router to know that pc
15:36
ip given: 192.168.2. 109
15:37
<Burgundavia>
ahh, op
15:37
ok
15:37
then set it as:
15:37
iface eth0 inet static
15:37Lossie has quit IRC
15:37
<Burgundavia>
address XX.XXX.XXX.XXX
15:37
netmask XXX.XXXX.XXX.XXX
15:37
gateway XXX.XXX.XXX.XXX
15:38
<yigal_>
with real numbers? it is.
15:39
<Burgundavia>
yes
15:40
ok
15:40
ok, for the next one, duplicate that, but with eth1
15:40
<ltsppbot>
"Yigal" pasted "/etc...." (23 lines) at http://pastebot.ltsp.org/184
15:41
<yigal_>
here is the content of that file
15:43
I think i see were Eth2 comes from..... that's a bug, right?
15:44
<Burgundavia>
yep
15:44
<yigal_>
what next? delete eth2 line?
15:46
<Burgundavia>
yep, delete that
15:46
then try and bring up eth1
15:46
<yigal_>
How do I comment a line? with a #?
15:47
and how to "bring up"? just by saving the file?
15:48
<Burgundavia>
sudo ifup eth1
15:50
<ltsppbot>
"Yigal" pasted "/etc...." (8 lines) at http://pastebot.ltsp.org/185
15:50
<yigal_>
failed
15:51
<Burgundavia>
ok
15:51
it is not finding your second network card
15:52ogra_ has quit IRC
15:52ogra_ has joined #ltsp
15:53
<yigal_>
i see. the leds are lighting there, and so in the switch side, so I think the hardware is oK, I can replace the NIC tomorow if no other option left
15:54jasonrsmit1 has left #ltsp
15:55
<ogra_>
Burgundavia, ???
15:55
why did you remove him NM ?
15:56
<yigal_>
because I have two NICs, and he said Ubuntu can handle only one with NM
15:56
<ogra_>
no
15:56
thats wrong
15:56
did you follow my advise from some hours ago ?
15:56
<yigal_>
i think so, remind me what was it
15:57
<ogra_>
told you the ip you have to use, the packages you have to install and the one command you need to run
15:57
did you do all of this ?
15:57
<yigal_>
yes
15:58
<ogra_>
ok, paste the output of ifconfig -a and your /etc/ltsp/dhcpd.conf to the pastebot
15:58
!pastebot
15:58
<ltspbot>
ogra_: "pastebot" is The LTSP pastebot is at http://pastebot.ltsp.org. Please paste all text longer than a line or two to the pastebot, as it helps to reduce traffic in the channel. A link to the content will be pasted in the channel.
15:59sbalneav|AFK is now known as sbalneav
15:59
<ltsppbot>
"Yigal" pasted "thin client" (31 lines) at http://pastebot.ltsp.org/186
15:59
<sbalneav>
Hey
15:59
Back
16:00
<ogra_>
Yigal, ok, that looks fine so far, show me your /etc/ltsp/dhcpd.conf
16:01
<ltsppbot>
"Yigal" pasted "thin client" (18 lines) at http://pastebot.ltsp.org/187
16:01
<ogra_>
do you have a working internet connection on the server ?
16:01
<yigal_>
yes, so far I do
16:02
<ogra_>
the networks are separated ? i.e. you dont have both NICs connected to the same switch or so
16:02
<yigal_>
eth0 ic connected to the home router and to the world. Eth1 is connected to a switch, and the client is also connected to that switch.
16:03
so yes - they are separated
16:03
<ogra_>
you mean eth2 :)
16:03
(at least according to what your kernel thinks :) )
16:03
ok, the dhcp and interface stuff looks good
16:03
is your dhcpd running ?
16:04
<yigal_>
i think so. how can i tell?
16:04
<ogra_>
ps ax|grep dhcpd
16:04
shoudl give you someathing like:
16:04
/usr/sbin/dhcpd3 -q -pf /var/run/dhcp3-server/dhcpd.pid -cf /etc/ltsp/dhcpd.conf
16:04
*something
16:05
<ltsppbot>
"Yigal" pasted "dhcpd" (5 lines) at http://pastebot.ltsp.org/188
16:06
<ogra_>
ok, fine
16:06
so how far does your boot get ?
16:06
if you start a client ...
16:07
<yigal_>
the client? it search for IP and doesnt find any
16:07
<vagrantc>
when yigal_ posted parts of syslog, it looked like the server gave DHCPOFFERs but the client didn't see them
16:08
<ogra_>
sounds like a HW issue ...
16:08
what kind of switch is that ?
16:08
manageable ?
16:09
<yigal_>
i dont know.. its a 24 port switching hub,,, large one
16:09
<sbalneav>
yigal_: Got a crossover cable?
16:09
<yigal_>
not here, i wish
16:10
but i have another idea before we blame the switch
16:11
the NIC in the client is RTL, and when I used ROMATIC i chosed one RTL entry out of few. Could it be it's the wrong one? how can i tell the right one?
16:11
<ogra_>
oh, indeed
16:11
<sbalneav>
yigal_: You have to know what kind of card you have.
16:11
<ogra_>
next time tell first that you use etherboot :)
16:12
<vagrantc>
!bootfloppy
16:12
<ltspbot>
vagrantc: "bootfloppy" is http://etherboot.anadex.de or ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/Universal_boot_floppy
16:12
<yigal_>
the chipset had RTL8139D on it
16:12
<vagrantc>
that floppy should be able to figure out which image to use
16:12* ogra_ was asuming PXE
16:13
<sbalneav>
ogra_: I fixed up a couple more things on ldm2
16:13
<ogra_>
oh, cool
16:13
i wont do much anymore today
16:13
<sbalneav>
Did you try it after I gave you the logging patch?
16:13
<ogra_>
during house cleaning i came to nearto one of my crappy playaround servers ...
16:13
<vagrantc>
ogra_: debian has newer ltspfs packages than ubuntu :P
16:13
<ogra_>
one of thse things with open case and more Hds than they use ...
16:14
one of the HDs has a loose power plug .. i wanted to look why and indeed didnt switch off the pc ...
16:14
was a nice spark :)
16:14
<sbalneav>
zap
16:14
<ogra_>
sadly it seems i grounded half my network ... only one of three WLAN routes survived
16:15
<vagrantc>
ouch
16:15
<ogra_>
and only two of five switches
16:15
at least the calbles arent fried :)
16:16* ogra_ looks forward to go shopping on monday :D new hardware ! :)
16:16
<Burgundavia>
ogra_: what are you going to be getting?
16:16
<sbalneav>
Did you try the patched ldm2 I uploaded? I'm interested to know if the reason why you can't log in is because something's igoring the LANG=C and giving you german prompts.
16:16
<ogra_>
new switches and wlan routers
16:17
sbalneav, unlikely
16:17
i see a "wrong password" message in auth log
16:17
so it attempts to send something
16:17
<Burgundavia>
very cool
16:18
<Yigal>
ok guys, i will generate new diskette and hope it will work out. Thanks so far.
16:18
<sbalneav>
ogra_: btw, must have been something with gnome keyboard.
16:18
I blew away my .gnome settings, and now the keyboard's fine
16:19
localdev works
16:19
sound works
16:19
it honours the DIRECTX lts.conf parm
16:20
and, plus, with an Idea that I've come up with, we'll eliminate the delayed-mounter daemon.
16:20
so I'm pretty happy with how this is working out.
16:20
next, I need to start hacking the greeter to handle a conversation.
16:21
but at this point, I think it's fairly close to being a drop-in replacement for ldm
16:21
so phase 2 will be adding the cool stuff we want.
16:22lambda has quit IRC
16:22
<sbalneav>
whoops
16:22
spoke too soon on the keyboard
16:22
crumb
16:25
Hm, gonna try it with CONFIGURE_X = True
16:31
<ogra_>
yeah
16:31
<sbalneav>
Hmm
16:31
<ogra_>
i'm pondering to write my own X detetor
16:31
<sbalneav>
still mucks up
16:31
<ogra_>
*detector
16:31
<sbalneav>
Man, this is annoying.
16:31
<ogra_>
are you sure its not the keyboard ?
16:32
<sbalneav>
Positive,
16:32
I've tried 3 known good ones.
16:32
Plus, it DOESN'T do it on one of the ttys
16:32
only in X
16:32
<ogra_>
weird
16:32
<sbalneav>
You're not kidding.
16:32
<ogra_>
not even with X config ?
16:32
<sbalneav>
still does it.
16:33
it's been a couple of days since I updated my chroot.
16:33
Maybe it's an X bug
16:33
there's bugs for it in launchpad.
16:34
<vagrantc>
night all
16:34vagrantc has quit IRC
16:38Egyptian[Home] has quit IRC
16:38otavio has quit IRC
16:40
<ogra_>
ah, indeed tha could be
16:40
<sbalneav>
hmm, well, a libc6 update
16:40
nothing major
16:41
<ogra_>
night all
16:42
sbalneav, i'll test the laest canges tomorrow .. if i get it working here, we'll have it as default on monday ;)
16:42* ogra_ waves
16:42
<sbalneav>
k
16:50wpgmb_ has quit IRC
17:10Q-FUNK has joined #ltsp
17:28yanu has joined #ltsp
17:32yanu has quit IRC
17:33yanu has joined #ltsp
17:36yanu has quit IRC
17:36yanu has joined #ltsp
17:41yanu has quit IRC
17:45sepski has quit IRC
18:07Q-FUNK has quit IRC
18:27jamie has joined #ltsp
18:28
<jamie>
any on help trying to make each of my clients auto log into a different user account?
18:31Burgundavia has quit IRC
18:36edgarin has quit IRC
18:44
<jamie>
any on help trying to make each of my clients auto log into a different user account?
18:45obelin23 has joined #ltsp
18:47edgarin has joined #ltsp
18:49J45p3r has joined #ltsp
19:04
<jamie>
ok any any on know how to make different clients use a different gdm.conf?
19:16jamie has quit IRC
19:20obelin23 has quit IRC
19:55muh2000 has joined #ltsp
19:59sbalneav has quit IRC
20:26andresmujica has joined #ltsp
20:27pck has joined #ltsp
20:31sbalneav has joined #ltsp
20:47andresmujica has left #ltsp
21:13muh2000 has quit IRC
21:13muh2000 has joined #ltsp
21:28sahil has joined #ltsp
21:44J45p3r has quit IRC
21:49pck has quit IRC
22:02muh2000 has quit IRC
22:13oh207 has quit IRC
22:21oh207 has joined #ltsp
22:43Burgundavia has joined #ltsp
22:56bronze has quit IRC
23:09gonzaloaf has quit IRC
23:20subir has joined #ltsp
23:20Egyptian[Home] has joined #ltsp
23:36edgarin has quit IRC
23:57jasonrsmith has joined #ltsp
23:59muh2000 has joined #ltsp