IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 1 March 2007   (all times are UTC)

00:28
<mathesis>
vagrantc: instale ltsp 4.2 en ubuntu edgy y todo perfecto
00:28
debian me da problemas ltsp
00:29
<vagrantc>
lo siento ...
00:30
<mathesis>
vagrantc: estoy pensando en migrar a ltsp5 con debian etch
00:31
<vagrantc>
mathesis: que problemas tiene con ltsp y debian etch ?
00:32
<mathesis>
ltsp 4.2 nfs and tftp en debian etch
00:32
cuando tienes tiempo para ayudarme a configurar ltsp5 en debian etch?
00:33
<vagrantc>
no se. no mucho ... quisas a domingo o sabado en la noche
00:33
<mathesis>
sabado en la noche
00:33
ok
00:34
vagrantc: necesito un counter time para ltsp5
00:34
<vagrantc>
pero, tiene otro proyectos quiero tarbahar ...
00:35
<mathesis>
you have busy sunday?
00:36
<vagrantc>
nothing specific ... i might actually work on new ltsp packages for debian, there are a couple remaining bugs i'd like to fix.
00:37
i've also started playing with debian-live's network boot ... its very cool.
00:38
<mathesis>
debian-live ltsp5?
00:39
<vagrantc>
debian-live can be used as an alternative to ltsp
00:50
<astroboy>
vagrantc: speaking of bugs .. I'm still getting msgs from ltsp-build-client that various mirrors are corrupt due to "E: Couldn't find these debs: locales
00:50
error: LTSP client installation ended abnormally
00:50
".
00:51
What is debian-live ?
00:51
<vagrantc>
and i'm still clueless
00:51
i don't tend to get those kinds of errors ...
00:51
<astroboy>
It's not personal ..
00:51
<vagrantc>
all i can say is "it works for me" which i know isn't particularly helpful ... i'm perplexed that you would continue to get those errors ...
00:52
<astroboy>
It seems to be a consistent error across at least five NZ, Aus, & US mirrors ..
00:52
<vagrantc>
debian-live was originally started to make live CDs based on debian (derived from ubuntu live cd code), but has been extended to also support network boot
00:53
astroboy: and you've removed /opt/ltsp after each time ?
00:53
<astroboy>
Umm .. no
00:53
<vagrantc>
you said you did the other day, after i said to do that :P
00:53
<astroboy>
Hmm ..
00:54
Right now, I can't remember what I did ..
00:55
<vagrantc>
at any rate .. removing the /opt/ltsp/* directories usually helped me in the rare cases where i got those kinds of problems
00:55
<astroboy>
I'll try that. 'rm /opt/ltsp*' and ltsp-build-client ..
00:56
<vagrantc>
astroboy: well, that will also remove your ltsp-4.2 installs , if you have them ...
00:56
astroboy: all you need to do is "rm -rf /opt/ltsp/*"
00:57
though if you don't care about the other ltsp installs, that's fine too ... just didn't want you obliterating anything needlessly
00:57
<astroboy>
At the mo I've got *both* ltsp-4.2 & ltsp versions. Your'e right - it's confusing the issue.
00:58
<vagrantc>
as long as they're in separate directories, it shouldn't be a problem
01:07
<astroboy>
I have a lot of doc's refusing to delete as "Read-only fs" but no /opt/ltsp/i386/etc/lts.conf .. but I do have one for ltsp-4.2
01:07
.. so I'll run ltsp-build-client again
01:08
<vagrantc>
you only create an lts.conf if you need it in ltsp5
01:08
i.e. if you need to change the default autodetected settings
01:08mathesis has quit IRC
01:08
<astroboy>
It's an *option* ? That's a good idea.
01:08
Cool ..
01:17
I hate to be a downer, but it looks like this ..
01:17
NOTE: adding default dist and components to security mirror:
01:17
http://security.debian.org/ etch/updates main
01:17
/usr/sbin/debootstrap: line 328: /opt/ltsp/i386/debootstrap/debootstrap.log: Read-only file system
01:17
error: LTSP client installation ended abnormally
01:17g333k_laptop has quit IRC
01:17* vagrantc suspects this has nothing to do with ltsp
01:19
<vagrantc>
astroboy: so ... is /opt/ltsp/i386 a read-only filesystem?
01:21sepski has joined #ltsp
01:22
<astroboy>
drwxr-xr-x 4 root root 4096 2007-03-01 19:55 ltsp
01:22
<vagrantc>
touch /opt/ltsp/foo
01:23
as root ...
01:23
<astroboy>
C'est vrai .. touch: cannot touch `/opt/ltsp/foo': Read-only file system
01:23
Hrm ..
01:24
<vagrantc>
you maybe have filesystem or hardware errors and linux decided best not attempt to write anything anymore
01:24
is /opt/ltsp on it's own partition, or the same as / ?
01:25
<astroboy>
Yeah .. I got a lot of strange messages along those lines after < rm -rf /opt/ltsp/* > .. I don't like forcing things.
01:26
opt is on /
01:27
Should I change permissions on ltsp .. ?
01:28
It's a new Etch install & I'm just finding my around the system.
01:29
<vagrantc>
you have some serious problems- quite possibly a failing hard drive, or if you're lucky, just a freak corrupted filesystem.
01:34
<astroboy>
I might try rebooting .. if I don't get in, I'll reinstall.
01:34
vim /etc/apt/sources.list
01:34
Error detected while processing /usr/share/vim/vim70/debian.vim:
01:34
line 55:
01:34
E483: Can't get temp file name
01:34
.. and so on.
01:35
It's now a recurring error .. previously did not happen. There are worse things ..
01:35
Tomorrow .. I'll sleep on it.
01:44
No Vim ..
01:44nf1_ has quit IRC
01:45
<vagrantc>
astroboy: powerbutton, then sleep, eh? :)
01:47
<astroboy>
Shortly .. I'll try getting some use out of the net while I'm up.
01:48
<vagrantc>
astroboy: i guess, i'm just saying that because continuing to run in that state could cause hardware damage ...
01:49vagrantc has quit IRC
01:49
<astroboy>
I'm not getting any strange noises from the box. OTOH, / is on the oldest drive ..
01:49
Cheers.
01:49astroboy has quit IRC
01:58
<`Kiliko>
How can i get my usb stick working? i have install ltspfsd on my server and
01:58
How can i get my usb stick working? i have install ltspfs on my server and __ltspfsd__ on the client
02:05
<sepski>
have you done all of these ? http://wiki.debian.org/DebianEdu/HowTo/LocalDeviceLtspfs or https://wiki.ubuntu.com/EnableLTSP5LocalDevices
02:10meduxa has joined #ltsp
02:12MoL0ToV has joined #ltsp
02:18Bhaskar has quit IRC
02:32MoL0ToV has quit IRC
02:39vanya has joined #ltsp
02:42astroboy has joined #ltsp
02:45
<astroboy>
Heh, heh .. I'm back ..
02:47
I wiped out 'etc' in /opt/ltsp/i386 ..
02:48
.. but that's what vagrantc wanted ..
02:53
I'm running ltsp-build-client
02:58
.. so far its working and seems to be retrieving a lot of base files
02:59
.. such as adduser, base-passwd, bash .. alphabetical
03:02
<`Kiliko>
sepski, Yes i have dont it, but it wont showup for me. there must be somting more todo to get it working.
03:16
<astroboy>
.. huge number of libs ..
03:17MoL0ToV has joined #ltsp
03:20
<astroboy>
Hola, Mol0ToV .. !
03:21
<MoL0ToV>
hola astroboy
03:21
?
03:21
:)
03:21
<astroboy>
You've missed all the fun ..
03:21
<MoL0ToV>
whats appening?
03:21
:)
03:23
<astroboy>
My system seems to be rebuilding itself after 'rm -rf /opt/ltsp/i386*' .. at one stage I thought I'd have to reinstall
03:24
I'm running 'ltsp-build-client' & its retrieving & validating base pkgs .. at one stage before reboot I had lost vim [holds breath] ..
03:26Avatara has quit IRC
03:29
<astroboy>
Aaaaargh .. [again] .. W: Failure while installing base packages. This will be re-attempted up to five times.
03:29
I
03:30
error: LTSP client installation ended abnormally
03:30
Good night folks.
03:30astroboy has quit IRC
03:32
<MoL0ToV>
:)
03:32
here is 10:29am
03:32
lool
03:32
:)
03:34
someone has experience with etherboot?
03:34
i have a problem, tracing the net, a udp dhcp request e reply are sent and received
03:35
but etherboot still print "No IP address"
03:38spectra has joined #ltsp
03:54bobby_C has joined #ltsp
05:15* kaminski-away is back
05:15kaminski-away is now known as kaminski-ltsp-br
05:15
<kaminski-ltsp-br>
hola
05:46Avatara has joined #ltsp
05:50tiagovaz has joined #ltsp
06:14Faithful1 has joined #ltsp
06:27ogra_ibook has joined #ltsp
06:27ogra_ibook is now known as ogra_
06:32a5benwillis has quit IRC
06:35FernandoMM has joined #ltsp
06:36ogra has quit IRC
06:41
<MoL0ToV>
boys, someone know if exist a specific chan for ethereal?
06:41
etherboot, sorry
06:43jammcq has quit IRC
06:44MoL0ToV has quit IRC
06:47Egyptian[Home] has quit IRC
06:50Egyptian[Home] has joined #ltsp
06:53osl has joined #ltsp
06:56
<osl>
hello, i have 3 ltsp servers, but two of them are not running gdm on remote clients!, both gdm and kdm tried, and listinig to port 177, im running debian etch on all of them, any idea how to debug this?
06:56a5benwillis has joined #ltsp
07:00
<osl>
im getting Xlib: connection to "192.168.0.88:1.0" refused by server, Xlib: Invalid MIT-MAGIC-COOKIE-1 key in /var/log/kdm.log
07:02
and im using X load balancing
07:06Blinny has joined #ltsp
07:06
<osl>
please ...
07:07
<a5benwillis>
osl
07:08
<osl>
i dont have xhost on the client to do something like xhost + or similar
07:08
yes a5benwillis
07:08
<a5benwillis>
I dontknow anything about your error but I wanted to tell you to stick around. Its still early. Someone will see your question and have some ideas.
07:08
<osl>
:) thank you a5benwillis :) i hope ill be able to
07:09* osl has to do a demonstration ... pretty soon, sorry for being pushy
07:11
<a5benwillis>
does your client exist in /etc/X).hosts?
07:11
does your client exist in /etc/X0.hosts
07:12MoL0ToV has joined #ltsp
07:13
<osl>
um
07:13
one minute
07:13
<a5benwillis>
may not exist in your distro
07:13
<osl>
on which machine? the master server?
07:13
<a5benwillis>
yes
07:13
<osl>
or all of them
07:14
dont have such a file
07:14
<a5benwillis>
ok
07:16
<sepski>
osl, with debian etch, and ltsp muekow you should run ldm on the thinclients
07:16
not gdm or kdm
07:16
<osl>
hmmm
07:16
<sepski>
osl, did you make the ltsp chroot using the debian etch ltsp packages ?
07:16erdinc has joined #ltsp
07:17
<sepski>
if yes, you can install ldm inside the chroot.
07:17
<ogra_>
it will be installed
07:17
<erdinc>
hi everyone
07:17
<osl>
sepski, no, i used the 4.2 packages from ltsp.org
07:17
<ogra_>
if he used ltsp-build-client
07:17
thats different then
07:17
<sepski>
osl, oh then you can forget everything i said
07:18
osl, the ltsp in etch is based on ltsp5
07:18
<a5benwillis>
osl: I tried to help until the others got here. Itold you they would know what to do :-)
07:18
<osl>
hehe :) thanks a5benwillis
07:34osl has quit IRC
07:34osl has joined #ltsp
07:38erdinc has quit IRC
07:43shesse has joined #ltsp
07:48
<a5benwillis>
ping ogra
07:52
does a user need to be a membor ofa special group to log into ltsp(edubuntu)?
07:54jammcq has joined #ltsp
07:55Blinny has quit IRC
07:56Jenna has joined #ltsp
08:01
<a5benwillis>
cliebow: Are you here this morning?
08:04erdinc has joined #ltsp
08:05
<erdinc>
hi everyone
08:05Jenna has quit IRC
08:07
<a5benwillis>
erdinc: Hi
08:09
<ogra_>
a5benwillis, no
08:10
<erdinc>
hi ogra_ whats up
08:10
<a5benwillis>
ogra_: I finally got ssh andNCP authentivationto work!!
08:10
now Im tryingto get a client to login.
08:11
<ogra_>
make sure your ssh keys are up to date ....
08:11
<a5benwillis>
I thought the "enable access to fuse fylesystem" had to be checked.
08:11
<ogra_>
if in doubt just runn sudo ltsp-update-sshkeys
08:11
no, thats for local devicde access
08:12
nothing you need for a plain login
08:12
<a5benwillis>
I did that. User stillgets to a black screen with the little rotating circle and hangs
08:12
in student control panel I even see the user listed.
08:12
<ogra_>
check .xsession-errors of that user
08:13
likely something in the session cant run
08:13
if it doesnt return immediately to the login screen, the ltsp and ldm sides are fine ... must be the users session
08:15
<a5benwillis>
error
08:16
"Theapplication 'x-session-manager'lost its ocnnection to the display localhost:11.0; most likely the X server was shut down or you killed/destroyed the application.
08:16
<ogra_>
did you hit ctrl-alt-backspace at some point =
08:16
?
08:16
<a5benwillis>
no
08:16
<ogra_>
hmm
08:17
the homedir of that user is ok and writeable for all apps he starts ?=
08:17shesse has quit IRC
08:17
<a5benwillis>
well. once the black screen sits there for 5 mins Ive beenkilling the connection
08:17
<ogra_>
ah
08:17
that the message then
08:17
*that's
08:18
<a5benwillis>
cd bl
08:18
oops wrong window....
08:18
<ogra_>
what about the users home ? if you log in as that directly on the server it all works ?
08:18
<a5benwillis>
let me try
08:19
<ogra_>
it rather looks like either something with the account is wrong or gnome-session doesnt work right
08:19
<a5benwillis>
users home gets mapped to there novell home directory
08:19
but its writable because the xsession logs were there
08:19
<ogra_>
and they have full write access to them ?
08:19
including no probs with dotfiles ?
08:20
<a5benwillis>
.bash_history
08:20
.Xauthority-c
08:20
.xsession-errors
08:21
<ogra_>
ok
08:21
<a5benwillis>
those are the files that are there
08:22
<ogra_>
its weird that you dont see more errors there
08:25
<a5benwillis>
trying local login now
08:25lapinmalin has quit IRC
08:28
<osl>
hello
08:29
demo done... with 1/3 clients :(
08:29
and i still cant figure out what the problem is
08:31Gadi has joined #ltsp
08:34
<osl>
im watching the kdm and gdm logs, it seems they are not even trying to connect to the servers
08:35cliebow_ has joined #ltsp
08:36lapinmalin has joined #ltsp
08:36
<lapinmalin>
Hello everybody
08:38intengu has joined #LTSP
08:40vanya has quit IRC
08:41
<intengu>
using intergrated ltsp on xubuntu - how do you config ltsp-build-client to use cdrom then fetch missing packages from the internet
08:42
any ideas ladies & gentlemen
08:43
<a5benwillis>
intengu: Haveyou configured your repositories?
08:44FernandoMM is now known as fernando[fora]
08:45
<intengu>
e5benwillis: yes this is what I type ltsp-build-client file:///media/cdrom (do not know what else to type to say fetch extra packages from the net)
08:45
<a5benwillis>
it may be differentin xubuntu
08:46
Start by clicking on Applications-> System-> Synaptic Pacake Manager and enter your password.
08:47
Then click Settings-> Repositories and from here you can add or edit Installation Media
08:48
<intengu>
a5benwillis: but in building ltsp chroot you use ltsp-build-client, but do not know what option to use to say fetch extra from the net
08:48
<Gadi>
intengu: try editing: /etc/ltsp/ltsp-build-client.conf
08:49
<a5benwillis>
Ah, I understand the question now. Soorry
08:49
<intengu>
Gadi: what do I enter
08:50
<Gadi>
I think you can add a line like: MIRROR="file:///media/cdrom" or EXTRA_MIRROR="file:///media/cdrom"
08:51
something along those lines
08:51
ogra or vagrantc would know best
08:52
<intengu>
Gadi: are they here
08:52
<Gadi>
!seen ogra_
08:52
<ltspbot>
Gadi: ogra_ was last seen in #ltsp 30 minutes and 17 seconds ago: <ogra_> its weird that you dont see more errors there
08:53
<Gadi>
intengu: does that file exist?
08:53
also, is there a "man ltsp-build-client"?
08:53
perhaps there are more clues
08:53
I dont have an install handy atm
08:55
<intengu>
Gadi: there is a man, but cannot figure howto do it (able to install from cdrom)
08:56
ogra_: any ideas on ltsp-build-client problem?
08:56
<Gadi>
intengu: actually, copy the URL from the cdrom line in your /etc/apt/sources.list (assuming its the ubuntu cdrom)
08:56
and use that for MIRROR
08:57
in ltsp-build-client.conf
08:57
that might work
08:57
(ie. cdrom:)
08:57
<a5benwillis>
Does "Unable to lock the ICE authority files" mean anything to you guys?
08:57
Error in~/.xsession-errors file
08:59
<Gadi>
a5benwillis: there is a /tmp/.ICE-unix/ file that the session manager uses
08:59
if you had trouble with auth as I know you have,...
08:59
<intengu>
Gadi: will try that, btw if i mention cdrom, then url will they be executed in that fashion
08:59
<a5benwillis>
Gadi: Its looking for a file thats in the user home directoruy
09:00
<Gadi>
ah, there's also an ~/.ICEauthority
09:00
file
09:00
<a5benwillis>
thats the one it cant lock
09:01
<Gadi>
perhaps the same user is already running a session?
09:01
I would start clean and pkill -u <user>
09:02
intengu: perhaps if you make the CDROM the mirror and http the extra_mirror
09:03
<intengu>
Gadi: thanks
09:10jammcq has quit IRC
09:11gentgeen__ has joined #ltsp
09:16
<erdinc>
is there anyone who speaks malay here?
09:17intengu has quit IRC
09:17fernando[fora] has quit IRC
09:18One has joined #ltsp
09:19
<lapinmalin>
gadi : hello, have you found my lts.conf in pastin.com ?
09:20
<Gadi>
lapinmalin: can you post the link to it again (sorry)
09:22tiagovaz has quit IRC
09:24
<lapinmalin>
It's OK. Here is the link : http://pastebin.com/890705
09:26* Gadi waits as slow pastebin.com loads
09:26
<a5benwillis>
We need a new pastebin. It sucks
09:27
<Gadi>
heh, ah ok, lapinmalin this is how I usually do it....
09:27
SCREEN_02          = "rdesktop -a 16 -k fr -f -d GLOBAL -r sound:local -r disk:USB=/tmp/drives -r disk:drives=/Drives"
09:28
comment out RDP_OPTIONS
09:28
comment out HOTPLUG = Y
09:28
(not needed for 4.2)
09:29
comment out MODULE_01 = "usb_storage"
09:29
(udev should handle that)
09:29
I dont know what "ALLOW_UNKNOWN_USB" is...
09:30
oops - add the RDP_SERVER ip to the end of that SCREEN_02 line
09:30bengoa has joined #ltsp
09:30
<Gadi>
and comment out RDP_SERVER
09:30bengoa has left #ltsp
09:30* Gadi HATES RDP_OPTIONS and RDP_SERVER
09:30
<Gadi>
what if you want to rdp connections on ur thin client?
09:30
so non-versatile
09:31
so: SCREEN_02 = "rdesktop -a 16 -k fr -f -d GLOBAL -r sound:local -r disk:USB=/tmp/drives -r disk:drives=/Drives 192.168.178.206"
09:31
<lapinmalin>
I don't understand your question : what if you want to rdp connections on ur thin client?
09:32
<a5benwillis>
ping Ogra
09:32
<Gadi>
yeah - say you had 2 WTS and you wanted screen_01 to go to 1 and screen_02 to go to the other
09:32
the best way to do that is put all the parameters on the SCREEN_0X = lines
09:33
not with the RDP_X parameters
09:33
thats why RDP_X parameters are ugly imho
09:34
<cliebow_>
Gadi:if xorg log shows no devices detected is that a BusID prob or a driver prob?
09:34
<lapinmalin>
OK, i understand !
09:35
<Gadi>
cliebow_: no "input devices"? or no "devices"?
09:35
<cliebow_>
no devices
09:35
detected
09:35
<Gadi>
most likely a config under the device section
09:35
try not specifying busid
09:35
you shouldnt need to
09:36
<cliebow_>
should i randomly try other drivers..or randomly try other BusID?
09:36
ok
09:36
<Gadi>
vesa should always work
09:36
with always in quotes ;)
09:36
<cliebow_>
actually i did..this seems to be sunffb
09:36
<Gadi>
this is ur sun box?
09:37
<cliebow_>
heh..yes "No hardware left behind"
09:37
<Gadi>
welcome to the wonderful world of proprietary hardware
09:37
Sun's hardware is another beast
09:37
from a console, you should be able to run: X :1 -pciscan
09:37
<cliebow_>
seems all i do is proprietary...netvista apple this pos
09:37
<Gadi>
or some such
09:37
<lapinmalin>
i've modify my lts.conf with the new line SCREEN_02 and commented out the other. It's exactly the same problem. I see the name of my usb as a directory and this directory is empty
09:38
<Gadi>
but, maybe its not pci
09:38
<cliebow_>
scanpci
09:38
<Gadi>
lapinmalin: you should only be redirect /Drives
09:38
not /tmp/drives
09:38
/tmp/drives will always only show the directory
09:39
<cliebow_>
Heh Psycho PCI Bus Module
09:39
<Gadi>
lapinmalin: whats supposed to happen is this:
09:39
<cliebow_>
unknown card 0x1227/0006 3d labs Permedia 2d+3d
09:40
trying glint driver
09:40
<Gadi>
you plug in the drive -> udev on the client informs lbuscd and creates an empty dir in /tmp/drives -> lbuscd informs lbussd -> lbussd mount /Drives/<mntpnt> to /tmp/drives/<mntpnt> using ltspfsd
09:43
<lapinmalin>
OK, i understand.
09:46efra has joined #ltsp
09:47
<cliebow_>
unknown card 0x1227/0006 3d labs Permedia 2d+3d
09:48
unknown card 0x1227/0006 3d labs Permedia 2d+3d
09:48
whoops
09:49
im progressed to "domainoutofrange
09:51
<lapinmalin>
but the pb is nothing is mounted /Drives/<mntpnt>
09:52osl has quit IRC
09:52
<Gadi>
right. which means that lbuscd is not talking to lbussd
09:52
what happens if you drop into a shell on the thin client,
09:52
kill all lbussd instances
09:52
and run /etc/rc.d/lbussd_bg
09:53
<lapinmalin>
i'll try
09:53
<Gadi>
then, try reinserting the USB
10:00
<lapinmalin>
i kill all processes lbussd. Then i run /etc/rc.d/lbussd_bg, the result is : shell-init:could not get current directory: getcwd: cannot access parent directories: no such file ou directory
10:03
<Gadi>
thats odd
10:03ogra has joined #ltsp
10:03
<Gadi>
do: cd /
10:03
then run the command
10:05
<a5benwillis>
For anyone thats been following my NCP authentication trials.
10:05
I can log in and have the user authenticated, their account is created automatically and their netware home directory is mounted.
10:05
But
10:06
The last issue I have is thatit takes two log ins for the user to get a session.
10:06
On the first log in the useris created and .xauthority and two other "." files are created
10:07
<lapinmalin>
ok, the command run.
10:07ogra has quit IRC
10:07
<lapinmalin>
But nothing in /Drives
10:07
<a5benwillis>
The user gets sent back to the login screen (LDM)
10:07
<lapinmalin>
and the script is a daemond as : /usr/bin/perl -w /usr/sbin/lbussd
10:08
<a5benwillis>
On the second log in all of the .gconf, .gnome etc ate created and the user logs all the way in properly.
10:08
Anyone havea clue as to why that happens?
10:08J45p3r_ has joined #ltsp
10:13
<cliebow_>
if X:1 -scanpci gives 128:1:0 for a video card shouldnt that be usable as a BusID in xorg.conf
10:19MoL0ToV has quit IRC
10:20
<lapinmalin>
no more idea ?
10:20
<Gadi>
lapinmalin: so, now if you unplug/plug the usb, and do ls /Drives its still empty?
10:21
<lapinmalin>
YES
10:21
<Gadi>
and lbuscd is running, too, right?
10:22
<lapinmalin>
YES
10:22
yes : /usr/bin/perl - w /usr/sbin/lbussd
10:22
<Gadi>
how about ls /dev/fuse
10:25
<lapinmalin>
nothing in ls /dev/fuse
10:26* erdinc bye aLL..
10:26erdinc has quit IRC
10:26
<lapinmalin>
because /dev/fuse is a file !
10:35sam_ has quit IRC
10:37
<Gadi>
lapinmalin: right - it should be - just making sure it exists
10:37
because that means that fuse loaded properly
10:38
Im not sure what the issue is
10:38
it should work
10:45
<cliebow_>
xf86DomainIo:domain out of range..any one care to explain?
10:53
<lapinmalin>
pfff. Do i have miss something ?
11:03
i have to leave. i will come back tomorrow... BONSOIR
11:03
11:03lapinmalin has quit IRC
11:05
<sh3mh4mf0r4sh>
hi.. have a question with this problem post here yesterday but i guess all yours were aways... he.. so read again here.. http://pastebin.ca/377126
11:23Avatara has quit IRC
11:27bricode has joined #ltsp
11:34tiagovaz has joined #ltsp
11:42irule has joined #ltsp
12:00FernandoMM has joined #ltsp
12:06ogra_ has quit IRC
12:06ogra has joined #ltsp
12:06
<a5benwillis>
I need to set the "UserAuthDir in gdm.conf totemp. This file doeasnt exist under the ltsp chroot does it?
12:06
Changing it in /etc/X11/gdm/gdm.conf wont effect the LDM clients will it?
12:08
<mistik1>
no
12:09
<a5benwillis>
How can I make a similar change to the ldm clients? The problem is that all of the files are created in their network home directories now.
12:09
By changing that path I can store itin a temp directory on the server, this works great at the console login with gdm.
12:10
<mistik1>
I dont know
12:10
<a5benwillis>
maybe orga will see the question.
12:10One has quit IRC
12:12
<a5benwillis>
mistik1: Im still cleaningup some final issues with my ncp/nds logins
12:12
<mistik1>
cool
12:14
<cliebow_>
mistik1:any good commands to enumerate scsi devices on a system?
12:15
<mistik1>
umm
12:15
donno
12:15
what do you mean by enumerate anyway?
12:15
<a5benwillis>
will the real mistik1 please stand up!
12:15
lol
12:15
<mistik1>
hehe
12:16
cliebow_: what exactly are you trying to do?
12:16
<cliebow_>
i have abox with 4 drives and a scsi cable which hooks to this ssun box running ubuntu..but haavnt a clue if that is a raid array
12:17
or seperate drives or what
12:17
<mistik1>
well what are the device names?
12:18
<cliebow_>
i dont know...is htere a way to contact the scsi controller and have it say what is hooked to it
12:18
lspci shows 4 scsi controllers
12:18
<mistik1>
dmesg should give you a good idea
12:19
You said the system is running ubuntu, therefore there must be an /etc/fstab
12:19
I would prolly dump dmesg to a file and get to reading
12:20
<cliebow_>
hmm..makes sense..fstab "looks " all commented out except for cdrom
12:21juxed has joined #ltsp
12:25
<sh3mh4mf0r4sh>
hey
12:25
<cliebow_>
i don think it sees the secondary drive box at all...so i keep on experimenting
12:25
<sh3mh4mf0r4sh>
http://pastebin.ca/377126
12:25
what i do with that?
12:30`Kiliko has left #ltsp
12:34CaPRiCorN^80 has joined #ltsp
12:35CaPRiCorN^80 has quit IRC
12:48
<sh3mh4mf0r4sh>
cliebow_: r u there?
12:49
<a5benwillis>
Does anyone know what the chroots equivilent of /etc/X11/gdm/gdm.conf is
12:50
<cliebow_>
hmmm'
12:51
<a5benwillis>
was that hmm for me?
12:51
<cliebow_>
yeah...
12:51
<sh3mh4mf0r4sh>
http://pastebin.ca/377126
12:51
<cliebow_>
well ldm runs in the chroot
12:51
<sh3mh4mf0r4sh>
please.. any suggestion?
12:51
<cliebow_>
looking..
12:51
<a5benwillis>
Surely there has to be one or something similar
12:52KeepWalking_ has joined #ltsp
12:58
<cliebow_>
doesnt look like it..
12:59
<sh3mh4mf0r4sh>
cliebow_: can u help me with my pastebin?
13:00
<cliebow_>
ill look..prob not 8~)
13:00
<sh3mh4mf0r4sh>
can't help?
13:00
<cliebow_>
i can look..but prob wont be any help
13:01
<sh3mh4mf0r4sh>
ahh
13:01
wel. :| somebody here can help?
13:01
or know what happen ..
13:01
i gueess is trouble to share devices by nfs
13:01
:|
13:02
<cliebow_>
nfs?
13:02
<sh3mh4mf0r4sh>
i guess..
13:03
<cliebow_>
i think you are talking about usinfg a floppy via local devices in ltsp 4.2?
13:03
<sh3mh4mf0r4sh>
yes
13:03
my 1st cliente start ok
13:03
my 2nd
13:03
start ok with floppy dev
13:03
but show at desktop
13:03
<cliebow_>
and the floppy icon shows on the desktop
13:03
<sh3mh4mf0r4sh>
floppy(1) from client 1
13:03
yes
13:04
and client3 boot ok and have floopy (1) from 2dn client
13:04
and 1st client have
13:04
floppy(1) from 2 and floppy(2) from 3 client
13:04
and.. etc etc
13:04
to client (n)
13:04
so.. I try to umount
13:04
said error
13:04
because only root can use fstab
13:04
:S
13:04
to umount floppy
13:05
and fstab have
13:05
biblioteca:~# cat /etc/fstab | grep fd0
13:05
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
13:05
flash drives(pendrives) and CD(s) .. mount and umount ok
13:05
not show all thats of icons...
13:07
<cliebow_>
is it the boot floppy that shows? or is it floppies inserted after bootup..
13:08
<sh3mh4mf0r4sh>
no..
13:09
just will be appears. when clients is inn in to gdm system
13:09
when login to gnome
13:10KeepWalking_ has quit IRC
13:13
<sh3mh4mf0r4sh>
so?
13:13
no idea?
13:13
:|
13:14
<cliebow_>
i dont..i am having a hard time translating..
13:15
<sh3mh4mf0r4sh>
uff
13:15
my english is bad :|
13:15
<str4nd>
my london lankuake is pad too!
13:17
<sh3mh4mf0r4sh>
if someone of dev of ltsp speak spanish my life would be better O:)
13:21
<cliebow_>
i understand
13:29
<a5benwillis>
Ping Ogra
13:29
<sh3mh4mf0r4sh>
cliebow_: can i see your fstab of fd0?
13:29
<str4nd>
< ogra> pong
13:30
<a5benwillis>
Ahathere you are.
13:30
Im trying to do something similar to changing the UserAuthDir in gdm.conf. Can this be done in LDM?
13:31
.
13:31
ok, maybe that wasnt him lol
13:37juxed has quit IRC
13:37Faithful1 has quit IRC
13:40* kaminski-ltsp-br is away: home
13:44Gadi has quit IRC
13:47
<sh3mh4mf0r4sh>
hey
13:47
why /opt/ltsp-4.2/i386/etc/fstab -> /tmp/fstab and that file is empty inside?
13:51
cliebow_:
13:59Egyptian[Home] has quit IRC
14:01Egyptian[Home] has joined #ltsp
14:07Gadi has joined #ltsp
14:09
<sh3mh4mf0r4sh>
Gadi: can u help with some problem?
14:09
Gadi: have 15 clients and all show 15 floppys icons
14:11
<Gadi>
sh3mh4mf0r4sh: try this: sudo gconf-editor
14:11
go to: apps > nautilus > desktop
14:11
<sh3mh4mf0r4sh>
Gadi: i'm by remote shell
14:11
<Gadi>
uncheck volumes_visible
14:12
<sh3mh4mf0r4sh>
uhmmmmm
14:12
<Gadi>
then have the users logout and log back in
14:12
so, do: ssh -X ;)
14:12
<sh3mh4mf0r4sh>
-X ?
14:12
<Gadi>
are you on a linux box locally?
14:13
<sh3mh4mf0r4sh>
no
14:13
<Gadi>
how do you get the remote shell?
14:13
<sh3mh4mf0r4sh>
i have to pass 1st of Layer3 router :)
14:13
<Gadi>
putty?
14:13
<sh3mh4mf0r4sh>
from L3
14:13
ssh directly
14:13
i login into L3
14:13
then
14:13
login into server ltsp
14:14
<Gadi>
ah, I see
14:15
so, the router can do ssh?
14:15
<sh3mh4mf0r4sh>
yes
14:15
but don't think to make -X
14:15
<Gadi>
how do you log into the router? web browser?
14:16
<sh3mh4mf0r4sh>
by telnet
14:16
<Gadi>
thats an interesting and insecure setup ;)
14:16
<sh3mh4mf0r4sh>
why insecure?
14:17
<Gadi>
telnet transfers your password in cleartext
14:17
<sh3mh4mf0r4sh>
ahh
14:18
i c :)
14:18
well..
14:18
my problem
14:18
<Gadi>
there's a command line tool called gconftool-2 to make the changes I suggested, but I dont usually do it that way, so I would need the syntax
14:18
<sh3mh4mf0r4sh>
when i logged into ltsp-server
14:18
what i do?
14:18
<Gadi>
well, there's a program to configure Gnome called gconf-editor
14:19
it's a bit like a group policy editor in the Windows world
14:19
you can modify most of the way Gnome and Gnome apps behave there
14:19
<sh3mh4mf0r4sh>
uhmm
14:19
i see now in my box
14:19
<Gadi>
and, if you run it as root (sudo) you can make changes and set them to be global for all users
14:20
so, one of the things is a setting that makes volumes visibile on the nautilus desktop
14:20
<sh3mh4mf0r4sh>
that place not show nothing
14:20
<Gadi>
go to: apps > nautilus > desktop
14:21
<sh3mh4mf0r4sh>
i'm there
14:21
<Gadi>
then scroll down on the right side
14:21
at the bootom, you should see a checkbox with volumes_visible
14:21
<sh3mh4mf0r4sh>
nothing!
14:21
<Gadi>
you have nothing on the right side?
14:21
<sh3mh4mf0r4sh>
nope
14:22
<Gadi>
thats strange
14:22
what distro are you on?
14:22
<sh3mh4mf0r4sh>
let me explain better
14:22
debian etch ltsp-4.2
14:22
look
14:22
yesterday i forgot to clients
14:22
can use devices local
14:22
so i made adduser(1 to 15) fuse
14:22
so NOW works fine
14:23
BUT when in the morning start navigation room
14:23
start server ok
14:23
start all client
14:23
and when i logging into gnomed
14:23
1st client start ok
14:23
and show floppy devices icon
14:23
ok
14:23
when i logging 2nd client
14:23
appears 2 floopys devices icons in both
14:23
when i logging again to 15 client
14:23
so have 15 floppys devices icons
14:24
thats my problem now
14:24
so appears.. floppy floppy(1) floppy(2) ... floppy(15)
14:24
and .. works.. because all use floppy
14:24
whe u click onlsy floppy works fine
14:25
<Gadi>
ah, i found a discussion about this problem: http://marc.theaimsgroup.com/?t=115221913400003&r=1&w=2
14:25
maybe it helps
14:25
?
14:25
<sh3mh4mf0r4sh>
fine. let me check
14:27
<a5benwillis>
Anyone know what would cause a thin client to hang when logging out? I can hit ctl-alt-back and it resets tot he login screen.
14:32meduxa has quit IRC
14:34
<sh3mh4mf0r4sh>
Gadi: if i set volume visibility = off
14:35
what happen with the orig device floppy each client
14:35
this no disappear right?
14:35
just go away floppy(n)
14:35
but floppy no?
14:36
<Gadi>
right
14:37
<sh3mh4mf0r4sh>
nice.. so
14:37
have to walk 2 blocks to try then
14:37
remote can't see gconf
14:37
<Gadi>
:)
14:37
<sh3mh4mf0r4sh>
i try to fix with this
14:37
LOCAL_DEVICE_01 = /dev/fd0:floppy
14:37
LOCAL_DEVICE_02 = /dev/sda1:usb
14:37
to strict use but not works :)
14:37
ok .brb
14:50J45p3r_ has left #ltsp
14:55bjohnson has joined #ltsp
14:56FernandoMM has quit IRC
14:57sepski has quit IRC
15:04bjohnson has quit IRC
15:10Egyptian[Home] has quit IRC
15:10andresmujica has joined #ltsp
15:14Egyptian[Home] has joined #ltsp
15:16
<Egyptian[Home]>
3333322222241000000000000000000000000003.....00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000......................................................................................................1.0.22224..211111111111111
15:17
uh .. woops ..sorry about that .. i was cleaning my keyboard
15:17
so .. hello all
15:18
i have a question .. i have an app ..that connects to its server. the server checks to see what ip the app is connecting from .. and if it isnt the correct ip (in the db) it wont allow the app to connect. how do i solve this problem with ltsp?
15:19
<a5benwillis>
the connectionwil always come from a single ip address
15:21
<sh3mh4mf0r4sh>
Gadi:
15:21
works cool
15:22
but works by client
15:22
when i type sudo gconf-edit
15:22
i set unmark volumes visibility but
15:22
not works
15:22
and i relogin again
15:22
and nothing
15:22
<a5benwillis>
Can anyone tell me how to modify the default desktop thats used when new users log into the chroot?
15:22
<sh3mh4mf0r4sh>
so i stay there un mark
15:22
and any way i un mark client by client
15:22
in mode global not works
15:23
<Gadi>
ah, you can do this:
15:23
right-click on the value field and do: Set as Mandatory
15:23
that should force it on all users
15:23
(sorry - forgot that part)
15:23
<sh3mh4mf0r4sh>
ahhhh
15:23
jajaja
15:23
well.. i'm back
15:24
so i roght that now for my notes. to present in flisolf..this part for FAQ is VERY IMPORTANT ;)
15:24
*i'm right*
15:28a5benwillis has quit IRC
15:35
<sh3mh4mf0r4sh>
Gadi: r u there?
15:35
<Gadi>
kind of
15:35
<sh3mh4mf0r4sh>
uff this part to my presentation will be fine but can't go again to walk that 2 blocks
15:36
u can screenshot that part when u clic that mandatory with gconf-editor open and send me by email?
15:36
<Gadi>
sure
15:36
<sh3mh4mf0r4sh>
thanxs
15:36
Gadi: emperor@infomed.sld.cu
15:36cliebow_ has quit IRC
15:41
<Gadi>
sh3mh4mf0r4sh: on its way
15:41
<sh3mh4mf0r4sh>
thanxs Gadi
15:42
Gadi: have to set to my clients can't change the wallpaper of desktop.. where can i set read-only some file importat to can't do this?
15:43
<Gadi>
sh3mh4mf0r4sh: you can make that change in gconf-editor too
15:43
and Set as Mandatory
15:43
<sh3mh4mf0r4sh>
wow.. what is the /path/to/that/
15:44
<Gadi>
apps > desktop > gnome > background
15:44
<sh3mh4mf0r4sh>
and the right side said?
15:45
<Gadi>
you can set the path to the picture_filename, and other options
15:45
<sh3mh4mf0r4sh>
yeah yea but users can't change it
15:45
<Gadi>
not if you make it mandatory, I think
15:46tiagovaz has quit IRC
15:46
<sh3mh4mf0r4sh>
ahh nice
15:46
<Gadi>
there's another gui tool for gnome desktop profiles....
15:46
whats it called....
15:47
sabayon
15:47
i think
15:47
<sh3mh4mf0r4sh>
uhm
15:48
like alakarte
15:48
to edit gnome menu :)
15:48
<Gadi>
http://www.gnome.org/projects/sabayon/
15:49
i think its supposed to make making gconf changes easier
15:49* Gadi has never used it
15:49
<sh3mh4mf0r4sh>
maybe i said same to you
15:50
i talk about it but not ahve experience :D
16:00* sh3mh4mf0r4sh is away
16:00
<sh3mh4mf0r4sh>
c'u tomorrow
16:01nf1 has joined #ltsp
16:04msinhore has quit IRC
16:07a5benwillis has joined #ltsp
16:09ipl has joined #ltsp
16:10
<ipl>
i am having a problem booting an asus a7n8x system
16:10
pxe works and it boots up to rc.sysinit and then hangs
16:11
everything looks good up until that point
16:48efra has quit IRC
17:06Gadi has left #ltsp
17:12bobby_C has quit IRC
17:35astroboy has joined #ltsp
17:42
<a5benwillis>
can anyone help me with customizing the LDM login? What files do I edit?
17:42
Not the login screen but the desktop for all new users who log in.
18:15ogra has quit IRC
18:16ogra has joined #ltsp
18:17GodFather has joined #ltsp
18:22Stevecar has joined #ltsp
18:32bricode has quit IRC
19:21bricode has joined #ltsp
19:30andresmujica has left #ltsp
19:50danrez has joined #ltsp
20:03mathesis has joined #ltsp
20:14jammcq has joined #ltsp
20:14
<jammcq>
hey kids
20:15
<a5benwillis>
hola
20:15sbalneav has joined #ltsp
20:15
<jammcq>
Scotty !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
20:15
<sbalneav>
Evening all
20:15
Hey jammcq
20:15
<jammcq>
how's it goin, eh?
20:15
<sbalneav>
Goin good. How you doin?
20:15
<jammcq>
doing fine
20:16
just wondering where I could get a cookie
20:16
<sbalneav>
Hmmm
20:17
<mathesis>
Invito a #cctime a todos los que hablen español para desarrollar una control de cyber para ltsp5
20:18FernandoMM has joined #ltsp
20:18
<jammcq>
hmm
20:19
<a5benwillis>
can either of you help me with customizing the LDM login? What files do I edit? I just cant find any info online about it.
20:19
not the actual login screen but the desktop, icons etc.
20:21
<jammcq>
no clue
20:21
i'm not up to speed on ldm yet
20:21
that's one of the goals for this weekend
20:21
<a5benwillis>
thanks for looking. I did email the ltsp mailing list. Maybe someone there will know.
20:22
<jammcq>
ogra is the guy you want to talk to
20:25
<mathesis>
Try #cctime. The channel born for control cyber with ltsp5
20:27sbalneav has quit IRC
20:33bricode has quit IRC
20:33
<danrez>
alguem aqui tb acessa a brasnet ?
20:35irule has quit IRC
20:43sbalneav has joined #ltsp
20:43
<sbalneav>
I'm baaaaack
20:50
a5benwillis: Was that you asking about modifying desktop defaults?
20:57
<a5benwillis>
yes
20:59
sbalneav: It was me
21:05spectra has quit IRC
21:05
<sbalneav>
a5benwillis: You're using the gnome desktop?
21:08
<a5benwillis>
yes
21:09
<sbalneav>
Then you'll want to look into both sabayon, and setting up defaults in the gconf-editor.
21:09
<a5benwillis>
I want to add a 'window' to the desktop if possible with shortcuts to the programs. This will mimic the Novell Application window that my users are used to seeing.
21:11
<jammcq>
a5benwillis: you using Gnome?
21:11
go into the Desktop folder, and create a new directory
21:11
<a5benwillis>
yes gnome. Thats the default with LDM tight
21:11
<jammcq>
it should show up as a folder on your desktop
21:12
<sbalneav>
ldm doesn't set the default
21:12
<jammcq>
then, double click the folder to open it, nautilus should display it like a window
21:13
<a5benwillis>
will that show up on all users desktop? I guess I need to be able to make sure it cant be deleted as well.
21:13
<jammcq>
well, you'd need to add it to each users Desktop folder
21:14
<a5benwillis>
can it be a sym link?
21:14
<jammcq>
dunno, give it a try
21:14
<a5benwillis>
that way I can modify it and have it show up everywhere
21:16
<jammcq>
well, give it a try, see if it works
21:17
<a5benwillis>
will do
21:22ipl has quit IRC
21:33danrez has quit IRC
22:01Stevecar has left #ltsp
22:03sbalneav has quit IRC
22:20FernandoMM has quit IRC
22:22GodFather has quit IRC
22:26mistik1 has quit IRC
22:31mistik1 has joined #ltsp
22:34mathesis has quit IRC
22:41mistik1 has quit IRC
22:45mistik1 has joined #ltsp
22:48
<jammcq>
/quit
22:48jammcq has quit IRC
22:56vagrantc has joined #ltsp
23:13Bhaskar has joined #ltsp
23:29vagrantc has quit IRC
23:51rookie has joined #ltsp
23:53
<rookie>
I am setting up a ltsp for the first time using K12LTSP, my client is receiving DHCP but no TFTP, I've checked the services on the server and they appear to be there, the client is using Intel UNDI, PXE 2.0
23:54
all my clients are the same and i did a local install on one to make sure the hardware was all supported