IRC chat logs for #ltsp on irc.freenode.net (webchat)


Channel log from 3 August 2016   (all times are UTC)

00:12Phantomas has left IRC (Phantomas!~ftsamis@ubuntu/member/phantomas, Quit: Leaving.)
03:18vagrantc has joined IRC (vagrantc!~vagrant@unaffiliated/vagrantc)
04:14vagrantc has left IRC (vagrantc!~vagrant@unaffiliated/vagrantc, Quit: leaving)
04:22reality_collagis has joined IRC (reality_collagis!46aa2736@gateway/web/freenode/ip.70.170.39.54)
04:23reality_collagis has left IRC (reality_collagis!46aa2736@gateway/web/freenode/ip.70.170.39.54)
04:38highvoltage has left IRC (highvoltage!~highvolta@ubuntu/member/highvoltage, Quit: bbl)
04:46highvoltage has joined IRC (highvoltage!~highvolta@ubuntu/member/highvoltage)
04:55highvoltage has left IRC (highvoltage!~highvolta@ubuntu/member/highvoltage, Remote host closed the connection)
05:18ricotz has joined IRC (ricotz!~ricotz@ubuntu/member/ricotz)
06:18kjackal has joined IRC (kjackal!~quassel@2a02:582:cde:6e00:60d3:dbdf:4aea:36df)
06:48highvoltage has joined IRC (highvoltage!~highvolta@ubuntu/member/highvoltage)
07:11kjackal has left IRC (kjackal!~quassel@2a02:582:cde:6e00:60d3:dbdf:4aea:36df, Ping timeout: 264 seconds)
07:32mikkel has joined IRC (mikkel!~mikkel@mail.dlvs.dk)
07:36
<alkisg>
bennabiy: compare the output of `env` in thin and fat clients, then try to run the menu from the command line so that you see its output in both cases, then try to set the same environment vars, if they are different, and run the menu again etc
07:37
Debugging programs is an ad-hoc procedure, it cannot be described too well (and without great amounts of time) in IRC
07:37
If it runs with x2go, it should be runnable in ltsp as well
07:38
Or, if it runs locally with ssh -X localhost
08:29highvoltage has left IRC (highvoltage!~highvolta@ubuntu/member/highvoltage, Remote host closed the connection)
08:35kjackal has joined IRC (kjackal!~quassel@2a02:582:cde:6e00:60d3:dbdf:4aea:36df)
08:40highvoltage has joined IRC (highvoltage!~highvolta@ubuntu/member/highvoltage)
10:33Phantomas has joined IRC (Phantomas!~ftsamis@ubuntu/member/phantomas)
11:11kjackal has left IRC (kjackal!~quassel@2a02:582:cde:6e00:60d3:dbdf:4aea:36df, Ping timeout: 264 seconds)
11:11kjackal has joined IRC (kjackal!~quassel@2a02:582:cde:6e00:881f:e20:6201:d66f)
12:44TatankaT has joined IRC (TatankaT!~tim@193.190.253.114)
13:04
<bennabiy>
alkisg: thank you.. I will try that
13:05mikkel has left IRC (mikkel!~mikkel@mail.dlvs.dk, Quit: Leaving)
13:36Softeisbieger has joined IRC (Softeisbieger!~Softeisbi@ip-62-143-13-166.hsi01.unitymediagroup.de)
13:57ben_roose has joined IRC (ben_roose!~roose@roose.cs.wichita.edu)
14:03
<bennabiy>
alkisg: here is a diff of env variables from both environments (the first being the environment which works (with the user virtualm ) and the second with name typist which does not work (thin client)
14:03
alkisg: https://pastebin.mozilla.org/?diff=8889162
14:13alkisg has left IRC (alkisg!~alkisg@ubuntu/member/alkisg, Read error: Connection reset by peer)
14:25
<bennabiy>
Hmm, interesting. If I set LDM_DIRECTX=FALSE then the menu works... so it seems related to XForwarding
14:35Softeisbieger has left IRC (Softeisbieger!~Softeisbi@ip-62-143-13-166.hsi01.unitymediagroup.de, Ping timeout: 276 seconds)
15:29wim1 has joined IRC (wim1!~Icedove@88-117-19-153.adsl.highway.telekom.at)
15:29alkisg has joined IRC (alkisg!~alkisg@ubuntu/member/alkisg)
15:32wim1 has left IRC (wim1!~Icedove@88-117-19-153.adsl.highway.telekom.at, Client Quit)
15:33forum has joined IRC (forum!~Icedove@88-117-19-153.adsl.highway.telekom.at)
15:40forum has left IRC (forum!~Icedove@88-117-19-153.adsl.highway.telekom.at, Ping timeout: 244 seconds)
16:22K0HAX has left IRC (K0HAX!~michael@shellhost.home.englehorn.com, Quit: ZNC 1.7.x-git-631-88a8675 - http://znc.in)
16:26K0HAX has joined IRC (K0HAX!~michael@shellhost.home.englehorn.com)
16:28
<bennabiy>
alkisg: so the menu works if it is forwarded over SSH, but not DIRECT X
16:32
alkisg: here is a diff of the working vs non working on thin client. https://pastebin.mozilla.org/?diff=8889192 this is with the same user, same client, just one is directx and the other ssh
16:43forum has joined IRC (forum!~Icedove@88-117-19-153.adsl.highway.telekom.at)
18:14julienfayad has joined IRC (julienfayad!~julienfay@194.126.137.38)
18:15
<julienfayad>
Hello there, did anyone face issue with pulseaudio under a fat client ?
18:15
because now sound on my fat clients isn’t working as it should and it seems that the issue comes from pulseaudio (but I might be wrong)
18:24
<bennabiy>
julienfayad: do you have proper group permissions for pulse? also, do you have lts.conf disabling audio for some reason?
18:24forum has left IRC (forum!~Icedove@88-117-19-153.adsl.highway.telekom.at, Quit: forum)
18:24
<julienfayad>
1. group permission: I guess so, I left this as it is out of the box
18:25
2. lts.conf have been checked and sound is enabled
18:25
I actually have sound if I run aplay -D plughw:1,0 /path/to/file
18:25
Device1,0 being my usb headseat
18:26
but the default sound device is not connected and so no sound can be heard out of it
18:26
for some reason, if I select the output device in the Sound preferences and then close the sound preferences, when I open it back, the output device is back to the default one (HDA Intel PCH)
18:27
so I tried to follow this solution: http://askubuntu.com/questions/14077/how-can-i-change-the-default-audio-device-from-command-line
18:27
but pacmd keeps on returning me errors (not able to connect)
18:27
after I checked it seemed pulseaudio wasn’t running
18:28
if I try to run it as the fat client user (in terminal) I get a “Failed to create secure directory (/home/{username}/.config/pulse)
18:29
yet I can run pulseaudio as root (using epoptes) but after some seconds I get an error with a procotole-native.c: connection died. error
18:30
voila, that’s all I have so far and I’m not really sure where to start bennabiy, any idea ?
18:32
<bennabiy>
julienfayad: What distribution are you running?
18:32
<julienfayad>
ubuntu mate 16.04
18:32
and it’s ltsp pnp
18:33
<bennabiy>
Are you using NBD for your home directory?
18:33
<julienfayad>
as I said, the sound works… (for instance, if an application gives me the option to configure sound devices, I can configure it to use my usb headset. But the general sound for the whole station doesn’t work, so youtube videos won’t output any sound)
18:33
<bennabiy>
or NFS?
18:34
<julienfayad>
it defaults to NBD I think and I left it like that
18:34
how can double check though ?
18:34
<bennabiy>
If you defaulted, it would be NBD
18:34
<julienfayad>
yup defaulted
18:37
<bennabiy>
And the issue is that general system sound is not being heard, but if you select your headset, it will give you sound. What if you just change the default sound device in "Control Center / Sound"
18:38
alkisg might have more wisdom on the matter, as I do not use fat clients much
18:38
<julienfayad>
well in the sound preference I can see my second device, selecting it as the output device doesn’t do much though…
18:39
and as I wrote earlier, when I close and open the sound preference window back, the settings are back to default
18:47julienfayad has left IRC (julienfayad!~julienfay@194.126.137.38, Quit: julienfayad)
18:48julienfayad has joined IRC (julienfayad!~julienfay@194.126.137.38)
18:57
<bennabiy>
It sounds like perhaps root might have accidentally taken permissions from your sound folder and now your user cannot write to the folder... I would check all permissions on your home folder and if need be (and if you consider it wise) do a sudo chown -R $USER /home/$USER (replacing $USER with your username obviously)
18:57
<julienfayad> if I try to run it as the fat client user (in terminal) I get a “Failed to create secure directory (/home/{username}/.config/pulse)
18:58
<julienfayad>
well that’s the first thing I checked
18:58
and the user is the owner of both the home/{username} and home/{username}/.config folders
18:58
so couldn’t find anything wrong with the permissions there
19:02julienfayad has left IRC (julienfayad!~julienfay@194.126.137.38, Quit: julienfayad)
19:04julienfayad has joined IRC (julienfayad!~julienfay@194.126.137.38)
19:05
<bennabiy>
Can you verify that your user can write to those directories?
19:08
<julienfayad>
well these are not empty
19:08
the .config directory contains many folder for apps
19:08
tand they are all owned by the user
19:09
for instance, one directory for chrome, one for pluma, one for slack etc...
19:15* alkisg waves
19:17
<julienfayad>
hello alkisg!
19:17
bennabiy suggested that you might have an opinion about the issue I’m facing with sound ?
19:18
<alkisg>
julienfayad: can you try with an ubuntu live cd and verify that it's not related to ltsp at all?
19:18
...or an external usb disk
19:19
<bennabiy>
alkisg: did you see my pastebin?
19:19
<bennabiy> alkisg: here is a diff of the working vs non working on thin client. https://pastebin.mozilla.org/?diff=8889192 this is with the same user, same client, just one is directx and the other ssh
19:19
<julienfayad>
alkisg, I did better, one of the laptop have ubuntu installed on its Hard disk and when booting from the HD all works well
19:19
<alkisg>
bennabiy: yup, only DISPLAY is different there, so there must be something wrong in the mate menu code, that breaks
19:19
julienfayad: is it the same ubuntu version?
19:19
and kernel and all?
19:20
<bennabiy>
I pulled the code, so I am going to look through it
19:20
<julienfayad>
same version 16.04 but not same distro though, the other is Ubuntu Desktop (the one you get here: ubuntu.com/download)
19:21
the ltsp runs on mate
19:21
<alkisg>
julienfayad: ok, please try with the same distro and version and flavor and kernel
19:21
We're not doing anything wrt sound on fat clients
19:21
So it shouldn't be related to ltsp, but it can be related to flavor
19:21
<bennabiy>
alkisg: there are also these entries which are on the direct X which are not on the SSH GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/mate-tweak.desktop
19:22
A couple GIO entries
19:22
<alkisg>
bennabiy: if the mate menu breaks because of them, then it's an issue with mate menu, not ltsp...
19:22
<bennabiy>
alkisg: fair enough
19:22
<alkisg>
I don't think it's related to the environment though, except of course for the remote display part
19:23
<bennabiy>
Is there a way to test it outside of ltsp (say I have a different computer outside the network which could test remote X connection)
19:24
<alkisg>
Sure, it's just networked xorg
19:24
There are many ways to set that up, from xauth to X -query
19:24
<julienfayad>
well noted, yet I can’t manage to find a Live CD iso for ubuntu mate 16.04
19:24
<alkisg>
julienfayad: how did you install ltsp-pnp with mate then?
19:24
<julienfayad>
well regular iso to install the OS
19:25
but wasn’t a Live CD
19:26
<alkisg>
Regular iso to install the OS is a live cd
19:26
It gives an option, "install ubuntu" or "try before installing"
19:27
<julienfayad>
ohhh, never paid attention to that detail! I’ll try this out, thanks!
19:29julienfayad has left IRC (julienfayad!~julienfay@194.126.137.38, Quit: julienfayad)
19:56julienfayad has joined IRC (julienfayad!~julienfay@77.42.226.41)
20:20vagrantc has joined IRC (vagrantc!~vagrant@unaffiliated/vagrantc)
21:05julienfayad_ has joined IRC (julienfayad_!~julienfay@94.187.69.22)
21:05julienfayad has left IRC (julienfayad!~julienfay@77.42.226.41, Ping timeout: 252 seconds)
21:05julienfayad_ is now known as julienfayad
21:06julienfayad has left IRC (julienfayad!~julienfay@94.187.69.22, Client Quit)
21:14gp has left IRC (gp!~gp@104-14-168-137.lightspeed.rcsntx.sbcglobal.net, Quit: Leaving)
21:57ricotz has left IRC (ricotz!~ricotz@ubuntu/member/ricotz, Quit: Leaving)
22:43ben_roose has left IRC (ben_roose!~roose@roose.cs.wichita.edu, Remote host closed the connection)
23:33vagrantc has left IRC (vagrantc!~vagrant@unaffiliated/vagrantc, Quit: leaving)